make VFolderMenu::loadDoc KDebug instead of KWarning
This commit is contained in:
parent
b370918161
commit
e9f546bf1f
12
kdelibs-4.14-14-vfolder_spam.patch
Normal file
12
kdelibs-4.14-14-vfolder_spam.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up kdelibs-4.14.14/kded/vfolder_menu.cpp.vfolder_spam kdelibs-4.14.14/kded/vfolder_menu.cpp
|
||||
--- kdelibs-4.14.14/kded/vfolder_menu.cpp.vfolder_spam 2015-11-04 16:29:10.000000000 -0600
|
||||
+++ kdelibs-4.14.14/kded/vfolder_menu.cpp 2015-12-09 08:45:49.861988284 -0600
|
||||
@@ -487,7 +487,7 @@ VFolderMenu::loadDoc()
|
||||
int errorRow;
|
||||
int errorCol;
|
||||
if ( !doc.setContent( &file, &errorMsg, &errorRow, &errorCol ) ) {
|
||||
- kWarning(7021) << "Parse error in " << m_docInfo.path << ", line " << errorRow << ", col " << errorCol << ": " << errorMsg;
|
||||
+ kDebug(7021) << "Parse error in " << m_docInfo.path << ", line " << errorRow << ", col " << errorCol << ": " << errorMsg;
|
||||
file.close();
|
||||
return doc;
|
||||
}
|
11
kdelibs.spec
11
kdelibs.spec
@ -52,7 +52,7 @@ Summary: KDE Libraries
|
||||
# shipped with kde applications, version...
|
||||
%global apps_version 15.08.3
|
||||
Version: 4.14.14
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
|
||||
Name: kdelibs
|
||||
Epoch: 6
|
||||
@ -145,6 +145,11 @@ Patch41: 0002-Trigger-installation-of-missing-components-when-inst.patch
|
||||
# https://git.reviewboard.kde.org/r/102350/
|
||||
Patch42: 0003-Implement-automatic-scanning-of-source-code-for-requ.patch
|
||||
|
||||
# kbuildsycoca4 VFolderMenu::loadDoc spam, always complains about
|
||||
# ~/.config/menus/applications-merged/xdg-desktop-menu-dummy.menu
|
||||
# unexpected EOF
|
||||
Patch48: kdelibs-4.14-14-vfolder_spam.patch
|
||||
|
||||
# limit solid qDebug spam
|
||||
# http://bugzilla.redhat.com/882731
|
||||
# TODO: could make uptreamable and conditional only on Release-type builds
|
||||
@ -450,6 +455,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
%patch41 -p1 -b .libplasma-pk-0002
|
||||
%patch42 -p1 -b .libplasma-pk-0003
|
||||
|
||||
%patch48 -p1 -b .vfolder_spam
|
||||
%if "%{?udisks}" == "udisks2"
|
||||
%patch49 -p1 -b .solid_qt_no_debug_output
|
||||
%endif
|
||||
@ -838,6 +844,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 09 2015 Rex Dieter <rdieter@fedoraproject.org> 6:4.14.14-4
|
||||
- make VFolderMenu::loadDoc KDebug instead of KWarning
|
||||
|
||||
* Sat Dec 05 2015 Rex Dieter <rdieter@fedoraproject.org> 6:4.14.14-3
|
||||
- revert upstream commit causing kopete crashes for now (kde#355275)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user