Sync from devel:
* Tue Feb 24 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.0-15 - fix crash in ~KMainWindow triggered by sending messages in KNode (kde#182322) * Mon Feb 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-14 - (Build)Req: soprano(-devel) >= 2.2 - devel: drop Req: zlib-devel libutempter-devel * Wed Feb 18 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.0-13 - disable strict aliasing in kjs/dtoa.cpp (GCC 4.4 x86_64 crash) (#485968) * Thu Feb 12 2009 Than Ngo <than@redhat.com> - 4.2.0-11 - make plasma work better with Qt 4.5 (when built against Qt 4.5) - add gcc44-workaround
This commit is contained in:
parent
e25144ca36
commit
e941411d71
14
kdelibs-4.2.0-gcc44-workaround.patch
Normal file
14
kdelibs-4.2.0-gcc44-workaround.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -up kdelibs-4.2.0/cmake/modules/CheckPrototypeExists.cmake.orig kdelibs-4.2.0/cmake/modules/CheckPrototypeExists.cmake
|
||||
diff -up kdelibs-4.2.0/ConfigureChecks.cmake.orig kdelibs-4.2.0/ConfigureChecks.cmake
|
||||
diff -up kdelibs-4.2.0/kdecore/kdefakes.h.cmake.orig kdelibs-4.2.0/kdecore/kdefakes.h.cmake
|
||||
--- kdelibs-4.2.0/kdecore/kdefakes.h.cmake.orig 2009-02-16 14:41:16.000000000 +0100
|
||||
+++ kdelibs-4.2.0/kdecore/kdefakes.h.cmake 2009-02-16 14:41:47.000000000 +0100
|
||||
@@ -57,7 +57,7 @@ unsigned long strlcpy(char*, const char*
|
||||
#endif
|
||||
#endif
|
||||
|
||||
-#cmakedefine HAVE_STRCASESTR_PROTO 1
|
||||
+#define HAVE_STRCASESTR_PROTO 1
|
||||
#if !defined(HAVE_STRCASESTR_PROTO)
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
12
kdelibs-4.2.0-kjs-gcc44-crash.patch
Normal file
12
kdelibs-4.2.0-kjs-gcc44-crash.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ur kdelibs-4.2.0/kjs/CMakeLists.txt kdelibs-4.2.0-kjs-gcc44-crash/kjs/CMakeLists.txt
|
||||
--- kdelibs-4.2.0/kjs/CMakeLists.txt 2008-11-19 11:20:10.000000000 +0100
|
||||
+++ kdelibs-4.2.0-kjs-gcc44-crash/kjs/CMakeLists.txt 2009-02-18 19:43:20.000000000 +0100
|
||||
@@ -183,6 +183,8 @@
|
||||
CompileState.cpp
|
||||
)
|
||||
|
||||
+set_source_files_properties(dtoa.cpp PROPERTIES COMPILE_FLAGS -fno-strict-aliasing)
|
||||
+
|
||||
if (NOT DEFINED QT_ONLY)
|
||||
set(KJSLIBNAME kjs)
|
||||
else (NOT DEFINED QT_ONLY)
|
12
kdelibs-4.2.0-kmainwindow-crash.patch
Normal file
12
kdelibs-4.2.0-kmainwindow-crash.patch
Normal file
@ -0,0 +1,12 @@
|
||||
Index: kdeui/widgets/kmainwindow.cpp
|
||||
===================================================================
|
||||
--- kdeui/widgets/kmainwindow.cpp (Revision 918168)
|
||||
+++ kdeui/widgets/kmainwindow.cpp (Revision 918169)
|
||||
@@ -461,6 +461,7 @@
|
||||
KMainWindow::~KMainWindow()
|
||||
{
|
||||
sMemberList->removeAll( this );
|
||||
+ delete k_ptr->dockResizeListener; //so we don't get anymore events after k_ptr is destroyed
|
||||
delete k_ptr;
|
||||
KGlobal::deref();
|
||||
}
|
13
kdelibs-4.2.0-plasma-qt45.patch
Normal file
13
kdelibs-4.2.0-plasma-qt45.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up kdelibs-4.2.0/plasma/extender.cpp.orig kdelibs-4.2.0/plasma/extender.cpp
|
||||
--- kdelibs-4.2.0/plasma/extender.cpp.orig 2009-02-12 21:55:46.000000000 +0100
|
||||
+++ kdelibs-4.2.0/plasma/extender.cpp 2009-02-12 21:56:54.000000000 +0100
|
||||
@@ -467,6 +467,9 @@ void ExtenderPrivate::updateBorders()
|
||||
|
||||
void ExtenderPrivate::adjustSizeHints()
|
||||
{
|
||||
+#if (QT_VERSION >= QT_VERSION_CHECK(4, 90, 0))
|
||||
+ return;
|
||||
+#endif
|
||||
//FIXME: what happens in this function are some nasty workarounds for a bug in qt4.4's QGL.
|
||||
//Alexis has told me they are working on a fix for qt4.5, so this can be removed once the bug
|
||||
//has been fixed in Qt.
|
38
kdelibs.spec
38
kdelibs.spec
@ -1,6 +1,6 @@
|
||||
Summary: K Desktop Environment 4 - Libraries
|
||||
Version: 4.2.0
|
||||
Release: 10%{?dist}
|
||||
Release: 15%{?dist}
|
||||
|
||||
%if 0%{?fedora} > 8
|
||||
Name: kdelibs
|
||||
@ -45,7 +45,7 @@ Requires: kdelibs-common
|
||||
Requires: hunspell
|
||||
%endif
|
||||
Requires: phonon%{?_isa} >= 4.3.0
|
||||
Requires: soprano%{?_isa} >= 2.1.64
|
||||
Requires: soprano%{?_isa} >= 2.2
|
||||
Requires: strigi-libs%{?_isa} >= 0.6.3
|
||||
|
||||
Source1: kde4.sh
|
||||
@ -78,6 +78,9 @@ Patch14: kdelibs-4.0.85-libexecdir.patch
|
||||
Patch18: kdelibs-4.1.72-kstandarddirs.patch
|
||||
Patch20: kdelibs-4.1.70-cmake.patch
|
||||
Patch22: kdelibs-4.1.96-cmake.patch
|
||||
Patch23: kdelibs-4.2.0-gcc44-workaround.patch
|
||||
# disable strict aliasing in kjs/dtoa.cpp (GCC 4.4 x86_64 crash) (#485968)
|
||||
Patch24: kdelibs-4.2.0-kjs-gcc44-crash.patch
|
||||
|
||||
# upstream
|
||||
# 4.3 branch
|
||||
@ -91,6 +94,10 @@ Patch113: kdelibs-4.2.0-kded-kdirwatch.patch
|
||||
# http://bugs.kde.org/179934
|
||||
Patch114: kdelibs-4.2.0-ssl_proxy.patch
|
||||
Patch115: kdelibs-4.2.0-kded.patch
|
||||
Patch116: kdelibs-4.2.0-plasma-qt45.patch
|
||||
# fix crash in ~KMainWindow triggered by sending messages in KNode (kde#182322)
|
||||
# http://websvn.kde.org/?view=rev&revision=918169
|
||||
Patch117: kdelibs-4.2.0-kmainwindow-crash.patch
|
||||
|
||||
BuildRequires: qt4-devel >= 4.4.0
|
||||
# qt4%{_?_isa} isn't provided yet -- Rex
|
||||
@ -128,7 +135,7 @@ BuildRequires: openssl-devel
|
||||
BuildRequires: pcre-devel
|
||||
BuildRequires: phonon-devel >= 4.3.0
|
||||
BuildRequires: shared-mime-info
|
||||
BuildRequires: soprano-devel >= 2.1.64
|
||||
BuildRequires: soprano-devel >= 2.2
|
||||
BuildRequires: strigi-devel >= 0.6.3
|
||||
BuildRequires: zlib-devel
|
||||
BuildRequires: libutempter-devel
|
||||
@ -169,8 +176,9 @@ Requires: automoc4 >= 0.9.88
|
||||
Requires: qt4-devel
|
||||
Requires: openssl-devel
|
||||
Requires: phonon-devel
|
||||
# do we really still need all these below? -- Rex
|
||||
Requires: strigi-devel
|
||||
Requires: bzip2-devel gamin-devel libacl-devel zlib-devel libutempter-devel
|
||||
Requires: bzip2-devel gamin-devel libacl-devel
|
||||
%{?x_deps:Requires: %{x_deps}}
|
||||
%description devel
|
||||
This package includes the header files you will need to compile
|
||||
@ -217,6 +225,8 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
%patch18 -p1 -b .kstandarddirs
|
||||
%patch20 -p1 -b .xxcmake
|
||||
%patch22 -p1 -b .kdepimlibs-cmake
|
||||
%patch23 -p1 -b .gcc44
|
||||
%patch24 -p1 -b .kjs-gcc44-crash
|
||||
|
||||
# upstream patches
|
||||
%patch101 -p1 -b .AllowExternalPaths
|
||||
@ -226,6 +236,8 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
%patch113 -p4 -b .kde#182472
|
||||
%patch114 -p3 -b .kde#179934
|
||||
%patch115 -p0 -b .kded
|
||||
%patch116 -p1 -b .qt45
|
||||
%patch117 -p0 -b .kmainwindow-crash
|
||||
|
||||
%build
|
||||
|
||||
@ -391,6 +403,20 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Feb 24 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.0-15
|
||||
- fix crash in ~KMainWindow triggered by sending messages in KNode (kde#182322)
|
||||
|
||||
* Mon Feb 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.2.0-14
|
||||
- (Build)Req: soprano(-devel) >= 2.2
|
||||
- devel: drop Req: zlib-devel libutempter-devel
|
||||
|
||||
* Wed Feb 18 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.0-13
|
||||
- disable strict aliasing in kjs/dtoa.cpp (GCC 4.4 x86_64 crash) (#485968)
|
||||
|
||||
* Thu Feb 12 2009 Than Ngo <than@redhat.com> - 4.2.0-11
|
||||
- make plasma work better with Qt 4.5 (when built against Qt 4.5)
|
||||
- add gcc44-workaround
|
||||
|
||||
* Fri Feb 06 2009 Than Ngo <than@redhat.com> - 4.2.0-10
|
||||
- Fix duplicated applications in the K menu and in keditfiletype
|
||||
|
||||
@ -451,7 +477,7 @@ rm -rf %{buildroot}
|
||||
|
||||
* Fri Jan 09 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.1.96-4
|
||||
- bump min deps (cmake, kde-filesystem, phonon)
|
||||
- kde.(sh|csh): cleanup QT_PLUGIN_PATH handling
|
||||
- kde.(sh|csh): cleanup QT_PLUGIN_PATH handling (#477095)
|
||||
- Requires: coreutils grep
|
||||
|
||||
* Fri Jan 09 2009 Than Ngo <than@redhat.com> - 4.1.96-3
|
||||
@ -609,7 +635,7 @@ rm -rf %{buildroot}
|
||||
|
||||
* Thu Jul 24 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.0-2
|
||||
- move Sonnet documentation back to the main package
|
||||
- fix #453063 (Sonnet documentation multilib conflict) properly
|
||||
- fix #341751 (Sonnet documentation multilib conflict) properly
|
||||
|
||||
* Wed Jul 23 2008 Than Ngo <than@redhat.com> 4.1.0-1
|
||||
- 4.1.0
|
||||
|
Loading…
Reference in New Issue
Block a user