4.9.90 (4.10beta2)

This commit is contained in:
Rex Dieter 2012-12-03 11:39:46 -06:00
parent 3966b2d0bd
commit e326136c9b
10 changed files with 41 additions and 4400 deletions

2
.gitignore vendored
View File

@ -1,3 +1,3 @@
/kdelibs-4.8.5.tar.xz
/kdelibs-4.9.3.tar.xz
/kdelibs-4.9.4.tar.xz
/kdelibs-4.9.90.tar.xz

View File

@ -1,110 +0,0 @@
diff --git a/kio/misc/mms.protocol b/kio/misc/mms.protocol
index 286ccd8..e8afbdb 100644
--- a/kio/misc/mms.protocol
+++ b/kio/misc/mms.protocol
@@ -1,7 +1,7 @@
[Protocol]
helper=true
exec=
-defaultMimetype=uri/mms
+defaultMimetype=x-scheme-handler/mms
protocol=mms
input=none
output=none
diff --git a/kio/misc/mmst.protocol b/kio/misc/mmst.protocol
index 1f0f763..455694a 100644
--- a/kio/misc/mmst.protocol
+++ b/kio/misc/mmst.protocol
@@ -1,5 +1,5 @@
[Protocol]
-defaultMimetype=uri/mmst
+defaultMimetype=x-scheme-handler/mmst
exec=
protocol=mmst
input=none
diff --git a/kio/misc/mmsu.protocol b/kio/misc/mmsu.protocol
index deda935..1c1a7f6 100644
--- a/kio/misc/mmsu.protocol
+++ b/kio/misc/mmsu.protocol
@@ -1,5 +1,5 @@
[Protocol]
-defaultMimetype=uri/mmsu
+defaultMimetype=x-scheme-handler/mmsu
exec=
protocol=mmsu
input=none
diff --git a/kio/misc/pnm.protocol b/kio/misc/pnm.protocol
index 3ca3a7d..fe44c37 100644
--- a/kio/misc/pnm.protocol
+++ b/kio/misc/pnm.protocol
@@ -1,5 +1,5 @@
[Protocol]
-defaultMimetype=uri/pnm
+defaultMimetype=x-scheme-handler/pnm
exec=
protocol=pnm
input=none
diff --git a/kio/misc/rtspt.protocol b/kio/misc/rtspt.protocol
index 9e4fe96..4d86282 100644
--- a/kio/misc/rtspt.protocol
+++ b/kio/misc/rtspt.protocol
@@ -1,5 +1,5 @@
[Protocol]
-defaultMimetype=uri/rtspt
+defaultMimetype=x-scheme-handler/rtspt
exec=
protocol=rtspt
input=none
diff --git a/kio/misc/rtspu.protocol b/kio/misc/rtspu.protocol
index 9cc9299..5fc9d6b 100644
--- a/kio/misc/rtspu.protocol
+++ b/kio/misc/rtspu.protocol
@@ -1,5 +1,5 @@
[Protocol]
-defaultMimetype=uri/rtspu
+defaultMimetype=x-scheme-handler/rtspu
exec=
protocol=rtspu
input=none
diff --git a/mimetypes/kde.xml b/mimetypes/kde.xml
index 2810b5b..8de16f6 100644
--- a/mimetypes/kde.xml
+++ b/mimetypes/kde.xml
@@ -187,24 +187,30 @@ Notes:
<comment>all files</comment>
</mime-type>
- <!-- uri/ fake mime types -->
- <mime-type type="uri/mms">
+ <!-- x-scheme-handler/ fake(ish) mime types -->
+ <mime-type type="x-scheme-handler/mms">
<comment>mms: URIs</comment>
+ <alias type="uri/mms"/>
</mime-type>
- <mime-type type="uri/mmst">
+ <mime-type type="x-scheme-handler/mmst">
<comment>mmst: URIs</comment>
+ <alias type="uri/mmst"/>
</mime-type>
- <mime-type type="uri/mmsu">
+ <mime-type type="x-scheme-handler/mmsu">
<comment>mmsu: URIs</comment>
+ <alias type="uri/mmsu"/>
</mime-type>
- <mime-type type="uri/pnm">
+ <mime-type type="x-scheme-handler/pnm">
<comment>pnm: URIs</comment>
+ <alias type="uri/pnm"/>
</mime-type>
- <mime-type type="uri/rtspt">
+ <mime-type type="x-scheme-handler/rtspt">
<comment>rtspt: URIs</comment>
+ <alias type="uri/rtspt"/>
</mime-type>
- <mime-type type="uri/rtspu">
+ <mime-type type="x-scheme-handler/rtspu">
<comment>rtspu: URIs</comment>
+ <alias type="uri/rtspu"/>
</mime-type>
<mime-type type="application/vnd.kde.fontspackage">

View File

@ -1,104 +0,0 @@
diff -up kdelibs-4.7.3/solid/solid/CMakeLists.txt.halectomy kdelibs-4.7.3/solid/solid/CMakeLists.txt
--- kdelibs-4.7.3/solid/solid/CMakeLists.txt.halectomy 2011-05-20 15:24:54.000000000 -0500
+++ kdelibs-4.7.3/solid/solid/CMakeLists.txt 2011-11-16 17:12:05.439596850 -0600
@@ -39,7 +39,6 @@ configure_file(config-processor.h.cmake
file(MAKE_DIRECTORY
${CMAKE_CURRENT_BINARY_DIR}/backends/fakehw
- ${CMAKE_CURRENT_BINARY_DIR}/backends/hal
${CMAKE_CURRENT_BINARY_DIR}/backends/udev
${CMAKE_CURRENT_BINARY_DIR}/backends/wmi
)
@@ -199,33 +198,6 @@ if(NOT WIN32 AND NOT APPLE)
endif( UDEV_FOUND )
- message(STATUS "Building Solid HAL backend." )
- set(solid_LIB_SRCS ${solid_LIB_SRCS}
- backends/hal/halacadapter.cpp
- backends/hal/halaudiointerface.cpp
- backends/hal/halbattery.cpp
- backends/hal/halblock.cpp
- backends/hal/halbutton.cpp
- backends/hal/halcamera.cpp
- backends/hal/halcdrom.cpp
- backends/hal/haldeviceinterface.cpp
- backends/hal/haldvbinterface.cpp
- backends/hal/halfstabhandling.cpp
- backends/hal/halgenericinterface.cpp
- backends/hal/haldevice.cpp
- backends/hal/halmanager.cpp
- backends/hal/halnetworkinterface.cpp
- backends/hal/halserialinterface.cpp
- backends/hal/halopticaldisc.cpp
- backends/hal/halportablemediaplayer.cpp
- backends/hal/halprocessor.cpp
- backends/hal/halstorageaccess.cpp
- backends/hal/halstorage.cpp
- backends/hal/halvideo.cpp
- backends/hal/halvolume.cpp
- backends/hal/halsmartcardreader.cpp
- )
-
message(STATUS "Building Solid UPower backend." )
set(solid_LIB_SRCS ${solid_LIB_SRCS}
backends/upower/upowermanager.cpp
diff -up kdelibs-4.7.3/solid/solid/managerbase.cpp.halectomy kdelibs-4.7.3/solid/solid/managerbase.cpp
--- kdelibs-4.7.3/solid/solid/managerbase.cpp.halectomy 2011-05-20 15:24:54.000000000 -0500
+++ kdelibs-4.7.3/solid/solid/managerbase.cpp 2011-11-16 17:14:45.193599658 -0600
@@ -30,7 +30,6 @@
#if defined (Q_OS_MAC)
#include "backends/iokit/iokitmanager.h"
#elif defined (Q_OS_UNIX)
-#include "backends/hal/halmanager.h"
#include "backends/udisks/udisksmanager.h"
#include "backends/upower/upowermanager.h"
@@ -71,22 +70,13 @@ void Solid::ManagerBasePrivate::loadBack
# elif defined(Q_WS_WIN) && defined(HAVE_WBEM) && !defined(_WIN32_WCE)
m_backends << new Solid::Backends::Wmi::WmiManager(0);
-# elif defined(Q_OS_UNIX) && !defined(Q_OS_LINUX)
- m_backends << new Solid::Backends::Hal::HalManager(0);
-
# elif defined(Q_OS_LINUX)
- bool solidHalLegacyEnabled
- = QString::fromLocal8Bit(qgetenv("SOLID_HAL_LEGACY")).toInt()==1;
- if (solidHalLegacyEnabled) {
- m_backends << new Solid::Backends::Hal::HalManager(0);
- } else {
# if defined(UDEV_FOUND)
m_backends << new Solid::Backends::UDev::UDevManager(0);
# endif
m_backends << new Solid::Backends::UDisks::UDisksManager(0)
<< new Solid::Backends::UPower::UPowerManager(0)
<< new Solid::Backends::Fstab::FstabManager(0);
- }
# endif
# if defined (HUPNP_FOUND)
diff -up kdelibs-4.7.3/solid/tests/CMakeLists.txt.halectomy kdelibs-4.7.3/solid/tests/CMakeLists.txt
--- kdelibs-4.7.3/solid/tests/CMakeLists.txt.halectomy 2011-10-28 02:41:29.000000000 -0500
+++ kdelibs-4.7.3/solid/tests/CMakeLists.txt 2011-11-16 17:12:05.440596838 -0600
@@ -15,21 +15,6 @@ endif(WIN32)
target_link_libraries(fakehardwaretest solid_static ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTTEST_LIBRARY} )
add_definitions(-DTEST_DATA="\\"${CMAKE_CURRENT_SOURCE_DIR}/../solid/backends/fakehw/fakecomputer.xml\\"")
-
-########### halbasictest ###############
-
-if(NOT WIN32 AND NOT APPLE)
-set(halbasictest_SRCS halbasictest.cpp )
-
-kde4_add_executable(halbasictest ${halbasictest_SRCS})
-
-if(WIN32)
- set_target_properties(halbasictest PROPERTIES COMPILE_FLAGS -DSOLID_EXPORT=)
-endif(WIN32)
-
-target_link_libraries(halbasictest solid_static ${KDEWIN_LIBRARIES} ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTTEST_LIBRARY} )
-endif(NOT WIN32 AND NOT APPLE)
-
########### solidhwtest ###############
set(solidhwtest_SRCS

View File

@ -1,28 +0,0 @@
diff -up kdelibs-4.9.2/cmake/modules/FindSamba.cmake.samba4 kdelibs-4.9.2/cmake/modules/FindSamba.cmake
--- kdelibs-4.9.2/cmake/modules/FindSamba.cmake.samba4 2012-09-27 19:09:04.000000000 -0500
+++ kdelibs-4.9.2/cmake/modules/FindSamba.cmake 2012-10-02 07:11:38.137381941 -0500
@@ -17,10 +17,22 @@ if(SAMBA_INCLUDE_DIR AND SAMBA_LIBRARIES
set(Samba_FIND_QUIETLY TRUE)
endif(SAMBA_INCLUDE_DIR AND SAMBA_LIBRARIES)
-find_path(SAMBA_INCLUDE_DIR NAMES libsmbclient.h )
+IF (NOT WIN32)
+ # use pkg-config to get the directories and then use these values
+ # in the FIND_PATH() and FIND_LIBRARY() calls
+ find_package(PkgConfig)
+ pkg_check_modules(PC_LIBSMBCLIENT QUIET smbclient)
+ENDIF (NOT WIN32)
-find_library(SAMBA_LIBRARIES NAMES smbclient )
+find_path(SAMBA_INCLUDE_DIR NAMES libsmbclient.h
+ PATHS
+ ${PC_LIBSMBCLIENT_INCLUDEDIR}
+ ${PC_LIBSMBCLIENT_INCLUDE_DIRS})
+find_library(SAMBA_LIBRARIES NAMES smbclient
+ PATHS
+ ${PC_LIBSMBCLIENT_LIBDIR}
+ ${PC_LIBSMBCLIENT_LIB_DIRS})
if(SAMBA_INCLUDE_DIR AND SAMBA_LIBRARIES)
set(SAMBA_FOUND TRUE)

View File

@ -1,10 +0,0 @@
--- kdelibs-4.9.3/plasma/private/packages.cpp 2012-10-19 12:26:32.000000000 +0200
+++ kdelibs-4.9.3/plasma/private/packages.cpp_new 2012-11-23 13:19:25.757302077 +0100
@@ -109,6 +109,7 @@ void PlasmoidPackage::createNewWidgetBro
m_knsDialog = knsDialog = new KNS3::DownloadDialog("plasmoids.knsrc", parent);
knsDialog->setProperty("DoNotCloseController", true);
connect(knsDialog, SIGNAL(accepted()), this, SIGNAL(newWidgetBrowserFinished()));
+ connect(knsDialog, SIGNAL(accepted()), knsDialog, SLOT(deleteLater()));
}
knsDialog->show();

View File

@ -0,0 +1,26 @@
diff -up kdelibs-4.9.90/cmake/modules/FindSamba.cmake.FindSamba-samba4 kdelibs-4.9.90/cmake/modules/FindSamba.cmake
--- kdelibs-4.9.90/cmake/modules/FindSamba.cmake.FindSamba-samba4 2012-11-14 09:58:29.000000000 -0600
+++ kdelibs-4.9.90/cmake/modules/FindSamba.cmake 2012-12-03 07:29:54.103057454 -0600
@@ -17,10 +17,20 @@ if(SAMBA_INCLUDE_DIR AND SAMBA_LIBRARIES
set(Samba_FIND_QUIETLY TRUE)
endif(SAMBA_INCLUDE_DIR AND SAMBA_LIBRARIES)
-find_path(SAMBA_INCLUDE_DIR NAMES libsmbclient.h )
+# use pkg-config to get the directories and then use these values
+# in the FIND_PATH() and FIND_LIBRARY() calls
+find_package(PkgConfig)
+pkg_check_modules(PC_LIBSMBCLIENT QUIET smbclient)
-find_library(SAMBA_LIBRARIES NAMES smbclient )
+find_path(SAMBA_INCLUDE_DIR NAMES libsmbclient.h
+ HINTS
+ ${PC_LIBSMBCLIENT_INCLUDEDIR}
+ ${PC_LIBSMBCLIENT_INCLUDE_DIRS})
+find_library(SAMBA_LIBRARIES NAMES smbclient
+ HINTS
+ ${PC_LIBSMBCLIENT_LIBDIR}
+ ${PC_LIBSMBCLIENT_LIB_DIRS})
if(SAMBA_INCLUDE_DIR AND SAMBA_LIBRARIES)
set(SAMBA_FOUND TRUE)

View File

@ -1,29 +0,0 @@
--- a/cmake/modules/FindLibPython.py 2011-07-27 13:34:31.000000000 -0500
+++ b/cmake/modules/FindLibPython.py 2012-07-24 14:57:17.259160400 -0500
@@ -11,3 +11,5 @@
print("long_version:%s" % sys.version.split()[0])
print("py_inc_dir:%s" % distutils.sysconfig.get_python_inc())
print("site_packages_dir:%s" % distutils.sysconfig.get_python_lib(plat_specific=1))
+if sys.version_info >= (3, 2):
+ print("abiflags:%s" % sys.abiflags)
--- a/cmake/modules/FindPythonLibrary.cmake 2011-07-27 13:34:31.000000000 -0500
+++ b/cmake/modules/FindPythonLibrary.cmake 2012-07-24 15:06:50.180929600 -0500
@@ -54,6 +54,9 @@
string(REGEX REPLACE ".*\npy_inc_dir:([^\n]+).*$" "\\1" _TMP_PYTHON_INCLUDE_PATH ${python_config})
string(REGEX REPLACE ".*\nsite_packages_dir:([^\n]+).*$" "\\1" _TMP_PYTHON_SITE_PACKAGES_DIR ${python_config})
+ if(PYTHON_SHORT_VERSION VERSION_GREATER "3.1")
+ string(REGEX REPLACE ".*\nabiflags:([^\n]+).*$" "\\1" _TMP_PYTHON_ABIFLAGS ${python_config})
+ endif(PYTHON_SHORT_VERSION VERSION_GREATER "3.1")
# Put these two variables in the cache so they are visible for the user, but read-only:
set(PYTHON_INCLUDE_PATH "${_TMP_PYTHON_INCLUDE_PATH}" CACHE PATH "The python include directory" FORCE)
@@ -63,7 +66,7 @@
set(PYTHON_SITE_PACKAGES_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}/python${PYTHON_SHORT_VERSION}/site-packages CACHE PATH "The directory where python modules will be installed to.")
string(REGEX REPLACE "([0-9]+).([0-9]+)" "\\1\\2" PYTHON_SHORT_VERSION_NO_DOT ${PYTHON_SHORT_VERSION})
- set(PYTHON_LIBRARY_NAMES python${PYTHON_SHORT_VERSION} python${PYTHON_SHORT_VERSION_NO_DOT})
+ set(PYTHON_LIBRARY_NAMES python${PYTHON_SHORT_VERSION}${_TMP_PYTHON_ABIFLAGS} python${PYTHON_SHORT_VERSION_NO_DOT})
if(WIN32)
string(REPLACE "\\" "/" PYTHON_SITE_PACKAGES_DIR ${PYTHON_SITE_PACKAGES_DIR})
endif(WIN32)

File diff suppressed because it is too large Load Diff

View File

@ -8,9 +8,6 @@
%define apidocs 1
# to build/include QCH apidocs or not (currently broken)
#define apidocs_qch 1
%if 0%{?fedora} && 0%{?fedora} > 16
%define libplasma_pk 1
%endif
%if 0%{?rhel} > 6 || 0%{?fedora} > 17
%define udisks udisks2
%else
@ -24,7 +21,7 @@
%global dbusmenu_qt_version %(pkg-config --modversion dbusmenu-qt 2>/dev/null || echo %{dbusmenu_qt_ver})
Summary: KDE Libraries
Version: 4.9.4
Version: 4.9.90
Release: 1%{?dist}
Name: kdelibs
@ -58,7 +55,6 @@ Requires: kde-settings
%{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
Requires: %{name}-common = %{epoch}:%{version}-%{release}
Requires: hunspell
# https://git.reviewboard.kde.org/r/103028/
Requires: media-player-info
# beware of possible bootstrapping problems
# moved back to kde-runtime
@ -72,7 +68,7 @@ Requires: strigi-libs%{?_isa} >= %{strigi_version}
# make kdelibs-devel parallel-installable with kdelibs3-devel
Patch0: kdelibs-4.5.80-parallel_devel.patch
# fix kde#149705
# fix http://bugs.kde.org/149705
Patch2: kdelibs-4.2.85-kde149705.patch
# install all .css files and Doxyfile.global in kdelibs-common to build
@ -118,12 +114,6 @@ Patch41: 0002-Trigger-installation-of-missing-components-when-inst.patch
# https://git.reviewboard.kde.org/r/102350/
Patch42: 0003-Implement-automatic-scanning-of-source-code-for-requ.patch
# make forcefully hal-free build
Patch45: kdelibs-4.7.3-halectomy.patch
# udisks2 Solid backend
Patch47: kdelibs-udisks2-backend.patch
# cache to improve performance of apps using Solid with udisks2 (#868530)
Patch48: kdelibs-udisks2-kfileplacesdevicecache.patch
@ -132,10 +122,6 @@ Patch48: kdelibs-udisks2-kfileplacesdevicecache.patch
# https://git.reviewboard.kde.org/r/102439/
Patch50: kdelibs-4.7.0-knewstuff2_gpg2.patch
# https://bugs.kde.org/show_bug.cgi?id=269045
# https://git.reviewboard.kde.org/r/101231/
Patch51: kdelibs-4.6.2-uri_mimetypes.patch
# Toggle solid upnp support at runtime via env var SOLID_UPNP=1 (disabled by default)
Patch52: kdelibs-4.7.4-SOLID_UPNP.patch
@ -147,22 +133,15 @@ Patch54: kdelibs-4.8.4-kjs-locale.patch
# patch FindSamba.cmake to find samba4 libs (using pkg-config hints)
# https://git.reviewboard.kde.org/r/106861/
Patch55: kdelibs-4.9.2-FindSamba_samba4.patch
Patch55: kdelibs-4.9.90-FindSamba_samba4.patch
# backport FindKipi.cmake from Digikam SC 3.0.0-beta1 for libkipi 2 (kde#307213)
Patch56: kdelibs-4.9.1-FindKipi-libkipi2.patch
# cmake/python3 love, see # https://bugs.kde.org/show_bug.cgi?id=275919
# see also http://git.reviewboard.kde.org/r/106707/
# reviewboard finished, double check if these remaining patches are still
# required or not -- rex
Patch58: kdelibs-cmake_python3.patch
# make filter working
# make filter working, TODO: upstream? -- rex
Patch59: kdelibs-4.9.3-kcm_ssl.patch
## upstream
Patch100: kdelibs-4.9.3-delete-downloadDialog.patch
## security fix
# Not Upstreamed? why not ? -- Rex
@ -198,6 +177,8 @@ BuildRequires: libacl-devel libattr-devel
BuildRequires: libjpeg-devel
BuildRequires: libpng-devel
BuildRequires: libutempter-devel
# strictly only a runtime dependency, but makes cmake happier at buildtime too -- rex
BuildRequires: media-player-info
BuildRequires: pkgconfig(alsa)
BuildRequires: pkgconfig(avahi-core)
BuildRequires: pkgconfig(dbusmenu-qt)
@ -312,32 +293,25 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch27 -p1 -b .no_rpath
# libplasma PackageKit integration
%if 0%{?libplasma_pk}
%patch40 -p1 -b .libplasma-pk-0001
## hrm, seems only 0001 is upstreamed so far, need to poke Kevin why that is. -- rex
#patch40 -p1 -b .libplasma-pk-0001
%patch41 -p1 -b .libplasma-pk-0002
%patch42 -p1 -b .libplasma-pk-0003
%endif
%if "%{?udisks}" == "udisks2"
%patch47 -p1 -b .udisks2backend
%patch48 -p1 -b .kfileplacesdevicescache
%else
%patch45 -p1 -b .halectomy
%endif
# upstreamable patches
%patch50 -p1 -b .knewstuff2_gpg2
%patch51 -p1 -b .uri_mimetypes
%patch52 -p1 -b .SOLID_UPNP
%patch53 -p1 -b .kjs-s390
%patch54 -p1 -b .kjs-locale
%patch55 -p1 -b .FindSamba-samba4
%patch56 -p1 -b .FindKipi-libkipi2
%patch58 -p1 -b .cmake_python3
%patch59 -p1 -b .filter
# upstream patches
%patch100 -p1 -b .delete-downloadDialog
# security fixes
%patch200 -p1 -b .CVE-2009-2702
@ -352,10 +326,9 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
mkdir -p %{_target_platform}
pushd %{_target_platform}
%{cmake_kde4} \
-DKAUTH_BACKEND:STRING="PolkitQt-1" \
-DKDE_DISTRIBUTION_TEXT="%{version}-%{release}%{?fedora: Fedora}%{?rhel: Red Hat Enterprise Linux}" \
%if 0%{?rhel} > 6 || 0%{?fedora} > 17
-DWITH_SOLID_UDISKS2:BOOL=ON \
%endif
%{?udisks2:-DWITH_SOLID_UDISKS2:BOOL=ON} \
..
popd
@ -391,10 +364,6 @@ ln -s %{_kde4_libexecdir}/kmailservice %{buildroot}%{_kde4_bindir}/kmailservice
# create/own stuff
# see http://bugzilla.redhat.com/483318
mkdir -p %{buildroot}%{_kde4_libdir}/kconf_update_bin
%if 0%{?fedora} && 0%{?fedora} < 15
# moved to kde-filesystem f15+
mkdir -p %{buildroot}%{_kde4_libdir}/kde4/plugins/{gui_platform,styles}
%endif
## use ca-certificates' ca-bundle.crt, symlink as what most other
## distros do these days (http://bugzilla.redhat.com/521902)
@ -466,11 +435,6 @@ update-desktop-database -q &> /dev/null
update-mime-database %{_kde4_datadir}/mime >& /dev/null
gtk-update-icon-cache %{_kde4_iconsdir}/hicolor &> /dev/null || :
%clean
rm -rf %{buildroot}
%files
%doc AUTHORS README TODO
%doc COPYING.LIB
@ -575,9 +539,7 @@ rm -rf %{buildroot}
%{_mandir}/man1/preparetips.1*
%{_kde4_bindir}/kconfig_compiler4
%{_kde4_bindir}/makekdewidgets4
%if 0%{?libplasma_pk}
%{_kde4_bindir}/plasma-dataengine-depextractor
%endif
%{_kde4_bindir}/kde4-doxygen.sh
%{_kde4_appsdir}/cmake/
%{_kde4_includedir}/*
@ -596,6 +558,9 @@ rm -rf %{buildroot}
%changelog
* Mon Dec 03 2012 Rex Dieter <rdieter@fedoraproject.org> 6:4.9.90-1
- 4.9.90 (4.10beta2)
* Mon Dec 03 2012 Than Ngo <than@redhat.com> - 6:4.9.4-1
- 4.9.4
- update udisks2 backend patch to fix ghost devices

View File

@ -1 +1 @@
ec4b28e42cdcb26ddba1c1075e02a166 kdelibs-4.9.4.tar.xz
94c892cbe5eaf180ad18cba7c6d225be kdelibs-4.9.90.tar.xz