Merge commit 'ebdb7525fa7f9095e6eb3e7c9369ca1b49de392a' into f14/master

Conflicts:
	kdelibs.spec
This commit is contained in:
Rex Dieter 2010-11-06 13:24:00 -05:00
commit df47543174
7 changed files with 6 additions and 80 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/kdelibs-4.5.2.tar.bz2
/kdelibs-4.5.3.tar.bz2

View File

@ -1,19 +0,0 @@
--- branches/KDE/4.5/kdelibs/plasma/tooltipmanager.cpp 2010/09/28 01:19:58 1180436
+++ branches/KDE/4.5/kdelibs/plasma/tooltipmanager.cpp 2010/10/08 11:35:52 1183776
@@ -236,10 +236,12 @@
}
}
- d->tipWidget->setContent(widget, data);
- d->tipWidget->prepareShowing();
- if (m_corona) {
- d->tipWidget->moveTo(m_corona->popupPosition(widget, d->tipWidget->size(), Qt::AlignCenter));
+ if (d->tipWidget) {
+ d->tipWidget->setContent(widget, data);
+ d->tipWidget->prepareShowing();
+ if (m_corona) {
+ d->tipWidget->moveTo(m_corona->popupPosition(widget, d->tipWidget->size(), Qt::AlignCenter));
+ }
}
}
}

View File

@ -1,14 +0,0 @@
--- branches/KDE/4.5/kdelibs/kio/kio/krun.cpp 2010/10/15 15:53:49 1186277
+++ branches/KDE/4.5/kdelibs/kio/kio/krun.cpp 2010/10/15 16:00:27 1186278
@@ -368,9 +368,9 @@
}
else {
if (supportedProtocols.isEmpty()) {
- // compat mode: assume KIO if not set and it's a KDE app
+ // compat mode: assume KIO if not set and it's a KDE app (or a KDE service)
const QStringList categories = _service.property("Categories").toStringList();
- if (categories.contains("KDE")) {
+ if (categories.contains("KDE") || !_service.isApplication()) {
supportedProtocols.append("KIO");
}
else { // if no KDE app, be a bit over-generic

View File

@ -1,10 +0,0 @@
--- kdelibs-4.5.2/kio/kio/krun.cpp.orig 2010/09/07 20:07:19 1172681
+++ kdelibs-4.5.2/kio/kio/krun.cpp 2010/10/06 22:33:23 1183317
@@ -375,6 +375,7 @@
}
else { // if no KDE app, be a bit over-generic
supportedProtocols.append("http");
+ supportedProtocols.append("https"); // #253294
supportedProtocols.append("ftp");
}
}

View File

@ -1,22 +0,0 @@
--- branches/KDE/4.5/kdelibs/kdecore/util/kshareddatacache.cpp 2010/09/29 02:49:40 1180816
+++ branches/KDE/4.5/kdelibs/kdecore/util/kshareddatacache.cpp 2010/10/21 00:17:48 1187999
@@ -1156,11 +1156,17 @@
IndexTableEntry *entriesIndex = indexTable();
// Update page table first
- uint firstPage = entriesIndex[index].firstPage;
- if ((qint32)index != pageTableEntries[firstPage].index) {
+ pageID firstPage = entriesIndex[index].firstPage;
+ if (firstPage < 0 || firstPage >= pageTableSize()) {
+ kError(264) << "Removing" << index << "which is already marked as empty!";
+ return;
+ }
+
+ if (index != static_cast<uint>(pageTableEntries[firstPage].index)) {
kError(264) << "Removing" << index << "will not work as it is assigned"
<< "to page" << firstPage << "which is itself assigned to"
<< "entry" << pageTableEntries[firstPage].index << "instead!";
+ return;
}
uint entriesToRemove = intCeil(entriesIndex[index].totalItemSize, cachePageSize());

View File

@ -11,8 +11,8 @@
#define apidocs_qch 1
Summary: KDE Libraries
Version: 4.5.2
Release: 8%{?dist}
Version: 4.5.3
Release: 1%{?dist}
Name: kdelibs
Epoch: 6
@ -90,14 +90,8 @@ Patch27: kdelibs-4.4.80-no_rpath.patch
Patch50: kdelibs-4.5.1-knewstuff_gpg2.patch
## 4.5 upstream
Patch100: kdelibs-4.5.2-comic_applet_kde253387.patch
# http://websvn.kde.org/?view=revision&revision=1186278
Patch101: kdelibs-4.5.2-kio_krun_services.patch
# http://websvn.kde.org/?revision=1187999&view=revision
Patch102: kdelibs-4.5.2-kshareddatecache_time.patch
## trunk upstream
Patch150: kdelibs-4.5.2-krun-kde#253294.patch
# http://websvn.kde.org/?view=revision&revision=1185912
Patch151: kdelibs-4.5.2-plasma_wallpaper_configchanged.patch
@ -266,10 +260,6 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch50 -p1 -b .knewstuff_gpg2
# upstream patches
%patch100 -p4 -b .comic_applet_kde253387
%patch101 -p4 -b .kio_krun_services
%patch102 -p4 -b .kshareddatecache_time
%patch150 -p1 -b .kde#253294
%patch151 -p3 -b .plasma_wallpaper_configchanged
# security fix
@ -515,8 +505,8 @@ rm -rf %{buildroot}
%changelog
* Tue Nov 02 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-8
- kshareddatacache fix for zime shifts, just in time for DST (kde#253795)
* Fri Oct 29 2010 Than Ngo <than@redhat.com> - 4.5.3-1
- 4.5.3
* Fri Oct 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-7
- backport configChanged() for wallpaper

View File

@ -1 +1 @@
9f2ad67a40f233a72d374800e1c2d2e2 kdelibs-4.5.2.tar.bz2
f412739c8e9bdb7b92487ee79ba3b5bd kdelibs-4.5.3.tar.bz2