more fixes from the 4.1 branch
This commit is contained in:
parent
1c9d7f419c
commit
de289b4a46
13
kdelibs-4.1.1-kde#858795-mimeassoc.patch
Normal file
13
kdelibs-4.1.1-kde#858795-mimeassoc.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: kded/kmimeassociations.cpp
|
||||||
|
===================================================================
|
||||||
|
--- kded/kmimeassociations.cpp (revision 858794)
|
||||||
|
+++ kded/kmimeassociations.cpp (revision 858795)
|
||||||
|
@@ -62,7 +62,7 @@
|
||||||
|
const QString mimeappsFile = mimeappsIter.previous();
|
||||||
|
kDebug(7021) << "Parsing" << mimeappsFile;
|
||||||
|
parseMimeAppsList(mimeappsFile, basePreference);
|
||||||
|
- basePreference -= 50;
|
||||||
|
+ basePreference += 50;
|
||||||
|
}
|
||||||
|
return true;
|
||||||
|
}
|
24
kdelibs-4.1.1-kde#860095-khtml-scroll-crash.patch
Normal file
24
kdelibs-4.1.1-kde#860095-khtml-scroll-crash.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
Index: khtml/rendering/render_layer.cpp
|
||||||
|
===================================================================
|
||||||
|
--- khtml/rendering/render_layer.cpp (revision 860094)
|
||||||
|
+++ khtml/rendering/render_layer.cpp (revision 860095)
|
||||||
|
@@ -715,9 +715,6 @@
|
||||||
|
for (RenderLayer* child = firstChild(); child; child = child->nextSibling())
|
||||||
|
child->updateLayerPositions(rootLayer);
|
||||||
|
|
||||||
|
- // Fire the scroll DOM event.
|
||||||
|
- m_object->element()->dispatchHTMLEvent(EventImpl::SCROLL_EVENT, true, false);
|
||||||
|
-
|
||||||
|
// Just schedule a full repaint of our object.
|
||||||
|
if (repaint)
|
||||||
|
m_object->repaint(RealtimePriority);
|
||||||
|
@@ -728,6 +725,9 @@
|
||||||
|
if (m_vBar)
|
||||||
|
m_vBar->setValue(m_scrollY);
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+ // Fire the scroll DOM event. Do this the very last thing, since the handler may kill us.
|
||||||
|
+ m_object->element()->dispatchHTMLEvent(EventImpl::SCROLL_EVENT, true, false);
|
||||||
|
}
|
||||||
|
|
||||||
|
void RenderLayer::updateScrollPositionFromScrollbars()
|
11
kdelibs.spec
11
kdelibs.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Summary: K Desktop Environment 4 - Libraries
|
Summary: K Desktop Environment 4 - Libraries
|
||||||
Version: 4.1.1
|
Version: 4.1.1
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
|
|
||||||
%if 0%{?fedora} > 8
|
%if 0%{?fedora} > 8
|
||||||
Name: kdelibs
|
Name: kdelibs
|
||||||
@ -88,6 +88,8 @@ Patch101: kdelibs-4.1.1-kde#856379-cookiejar.patch
|
|||||||
Patch102: kdelibs-4.1.1-kde#856403-urlnav.patch
|
Patch102: kdelibs-4.1.1-kde#856403-urlnav.patch
|
||||||
Patch103: kdelibs-4.1.1-kutils-fixes.patch
|
Patch103: kdelibs-4.1.1-kutils-fixes.patch
|
||||||
Patch104: kdelibs-4.1.1-kdeui-widgets-fixes.patch
|
Patch104: kdelibs-4.1.1-kdeui-widgets-fixes.patch
|
||||||
|
Patch105: kdelibs-4.1.1-kde#858795-mimeassoc.patch
|
||||||
|
Patch106: kdelibs-4.1.1-kde#860095-khtml-scroll-crash.patch
|
||||||
|
|
||||||
BuildRequires: qt4-devel >= 4.4.0
|
BuildRequires: qt4-devel >= 4.4.0
|
||||||
Requires: qt4 >= %{_qt4_version}
|
Requires: qt4 >= %{_qt4_version}
|
||||||
@ -221,6 +223,8 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
|||||||
%patch102 -p0 -b .kde#856403-urlnav
|
%patch102 -p0 -b .kde#856403-urlnav
|
||||||
%patch103 -p0 -b .kutils-fixes
|
%patch103 -p0 -b .kutils-fixes
|
||||||
%patch104 -p0 -b .kdeui-widgets-fixes
|
%patch104 -p0 -b .kdeui-widgets-fixes
|
||||||
|
%patch105 -p0 -b .kde#858795-mimeassoc
|
||||||
|
%patch106 -p0 -b .kde#860095-khtml-scroll-crash
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -381,6 +385,11 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 18 2008 Lukáš Tinkl <ltinkl@redhat.com> 4.1.1-10
|
||||||
|
- Fix file association bug, the global mimeapps.list file had priority
|
||||||
|
over the local one.
|
||||||
|
- khtml scroll crash fix (kdebug:170880)
|
||||||
|
|
||||||
* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-9
|
* Tue Sep 16 2008 Than Ngo <than@redhat.com> 4.1.1-9
|
||||||
- #461725, revert the patch to fix the regression
|
- #461725, revert the patch to fix the regression
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user