Merge branch 'master' into f16

This commit is contained in:
Rex Dieter 2012-04-30 13:07:09 -05:00
commit d595b76fa8
7 changed files with 3783 additions and 36 deletions

2
.gitignore vendored
View File

@ -1,2 +1,2 @@
/kdelibs-4.6.5.tar.bz2
/kdelibs-4.8.2.tar.xz
/kdelibs-4.8.3.tar.xz

View File

@ -1,22 +0,0 @@
diff --git a/cmake/modules/FindKDE4Internal.cmake b/cmake/modules/FindKDE4Internal.cmake
index 6d65e61..700d265 100644
--- a/cmake/modules/FindKDE4Internal.cmake
+++ b/cmake/modules/FindKDE4Internal.cmake
@@ -1036,12 +1036,13 @@ if (UNIX)
set(CMAKE_INSTALL_NAME_DIR ${LIB_INSTALL_DIR})
else (APPLE)
# add our LIB_INSTALL_DIR to the RPATH (but only when it is not one of the standard system link
- # directories listed in CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES) and use the RPATH figured out by cmake when compiling
+ # directories listed in CMAKE_{PLATFORM,CXX}_IMPLICIT_LINK_DIRECTORIES) and use the RPATH figured out by cmake when compiling
- list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemLibDir)
- if("${_isSystemLibDir}" STREQUAL "-1")
+ list(FIND CMAKE_PLATFORM_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemPlatformLibDir)
+ list(FIND CMAKE_CXX_IMPLICIT_LINK_DIRECTORIES "${LIB_INSTALL_DIR}" _isSystemCxxLibDir)
+ if("${_isSystemPlatformLibDir}" STREQUAL "-1" AND "${_isSystemCxxLibDir}" STREQUAL "-1")
set(CMAKE_INSTALL_RPATH "${LIB_INSTALL_DIR}")
- endif("${_isSystemLibDir}" STREQUAL "-1")
+ endif("${_isSystemPlatformLibDir}" STREQUAL "-1" AND "${_isSystemCxxLibDir}" STREQUAL "-1")
set(CMAKE_SKIP_BUILD_RPATH FALSE)
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)

View File

@ -0,0 +1,65 @@
diff -up kdelibs-4.8.2/solid/solid/CMakeLists.txt.udisks2_prep kdelibs-4.8.2/solid/solid/CMakeLists.txt
--- kdelibs-4.8.2/solid/solid/CMakeLists.txt.udisks2_prep 2011-07-27 13:34:38.000000000 -0500
+++ kdelibs-4.8.2/solid/solid/CMakeLists.txt 2012-04-17 16:02:06.153985974 -0500
@@ -1,6 +1,7 @@
set( EXECUTABLE_OUTPUT_PATH ${CMAKE_CURRENT_BINARY_DIR} )
add_subdirectory( ifaces )
include_directories( ${CMAKE_CURRENT_SOURCE_DIR} ${CMAKE_CURRENT_BINARY_DIR} )
+include_directories( ${QT_QTDBUS_INCLUDE_DIR} )
if(WIN32)
include_directories( ${KDEWIN_INCLUDES} )
diff -up kdelibs-4.8.2/solid/solid/managerbase.cpp.udisks2_prep kdelibs-4.8.2/solid/solid/managerbase.cpp
--- kdelibs-4.8.2/solid/solid/managerbase.cpp.udisks2_prep 2011-07-27 13:34:39.000000000 -0500
+++ kdelibs-4.8.2/solid/solid/managerbase.cpp 2012-04-17 16:02:06.154985961 -0500
@@ -21,7 +21,7 @@
#include "managerbase_p.h"
#include <stdlib.h>
-#if !defined (Q_WS_WIN) && !defined (Q_OS_MAC)
+#if !defined (Q_OS_WIN) && !defined (Q_OS_MAC)
#include <config-solid.h>
#endif
@@ -44,7 +44,7 @@
#include "backends/fstab/fstabmanager.h"
-#elif defined (Q_WS_WIN) && defined(HAVE_WBEM) && !defined(_WIN32_WCE)
+#elif defined (Q_OS_WIN) && defined(HAVE_WBEM) && !defined(_WIN32_WCE)
#include "backends/wmi/wmimanager.h"
#endif
@@ -68,7 +68,7 @@ void Solid::ManagerBasePrivate::loadBack
# if defined(Q_OS_MAC)
m_backends << new Solid::Backends::IOKit::IOKitManager(0);
-# elif defined(Q_WS_WIN) && defined(HAVE_WBEM) && !defined(_WIN32_WCE)
+# elif defined(Q_OS_WIN) && defined(HAVE_WBEM) && !defined(_WIN32_WCE)
m_backends << new Solid::Backends::Wmi::WmiManager(0);
# elif defined(Q_OS_UNIX) && !defined(Q_OS_LINUX)
diff -up kdelibs-4.8.2/solid/tests/CMakeLists.txt.udisks2_prep kdelibs-4.8.2/solid/tests/CMakeLists.txt
--- kdelibs-4.8.2/solid/tests/CMakeLists.txt.udisks2_prep 2011-10-20 15:52:04.000000000 -0500
+++ kdelibs-4.8.2/solid/tests/CMakeLists.txt 2012-04-17 16:02:44.584505527 -0500
@@ -16,20 +16,6 @@ target_link_libraries(fakehardwaretest s
add_definitions(-DTEST_DATA="\\"${CMAKE_CURRENT_SOURCE_DIR}/../solid/backends/fakehw/fakecomputer.xml\\"")
-########### halbasictest ###############
-
-if(NOT WIN32 AND NOT APPLE)
-set(halbasictest_SRCS halbasictest.cpp )
-
-kde4_add_executable(halbasictest ${halbasictest_SRCS})
-
-if(WIN32)
- set_target_properties(halbasictest PROPERTIES COMPILE_FLAGS -DSOLID_EXPORT=)
-endif(WIN32)
-
-target_link_libraries(halbasictest solid_static ${KDEWIN_LIBRARIES} ${QT_QTCORE_LIBRARY} ${QT_QTDBUS_LIBRARY} ${QT_QTXML_LIBRARY} ${QT_QTTEST_LIBRARY} )
-endif(NOT WIN32 AND NOT APPLE)
-
########### solidhwtest ###############
set(solidhwtest_SRCS

View File

@ -0,0 +1,13 @@
diff -up kdelibs-4.8.3/experimental/libkdeclarative/CMakeLists.txt.kdeclarative-install-location kdelibs-4.8.3/experimental/libkdeclarative/CMakeLists.txt
--- kdelibs-4.8.3/experimental/libkdeclarative/CMakeLists.txt.kdeclarative-install-location 2012-04-29 22:37:35.777207066 +0200
+++ kdelibs-4.8.3/experimental/libkdeclarative/CMakeLists.txt 2012-04-30 12:20:40.384393056 +0200
@@ -6,6 +6,9 @@ endif(KDE_PLATFORM_FEATURE_BINARY_COMPAT
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config-kdeclarative.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-kdeclarative.h)
+set (LIB_SUFFIX "" CACHE STRING "Define suffix of library directory name (eg. '64')")
+set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+
include_directories(
${CMAKE_SOURCE_DIR}
${CMAKE_BINARY_DIR}

File diff suppressed because it is too large Load Diff

View File

@ -11,6 +11,11 @@
%if 0%{?fedora} && 0%{?fedora} > 16
%define libplasma_pk 1
%endif
%if 0%{?rhel} > 6 || 0%{?fedora} > 17
%define udisks udisks2
%else
%define udisks udisks
%endif
%global phonon_version %(pkg-config --modversion phonon 2>/dev/null || echo %{phonon_ver})
%global shared_desktop_ontologies_version %(pkg-config --modversion shared-desktop-ontologies 2>/dev/null || echo %{shared_desktop_ontologies_ver})
@ -19,7 +24,7 @@
%global dbusmenu_qt_version %(pkg-config --modversion dbusmenu-qt 2>/dev/null || echo %{dbusmenu_qt_ver})
Summary: KDE Libraries
Version: 4.8.2
Version: 4.8.3
Release: 1%{?dist}
Name: kdelibs
@ -114,6 +119,13 @@ Patch41: 0002-Trigger-installation-of-missing-components-when-inst.patch
# https://git.reviewboard.kde.org/r/102350/
Patch42: 0003-Implement-automatic-scanning-of-source-code-for-requ.patch
# make forcefully hal-free build
Patch45: kdelibs-4.7.3-halectomy.patch
# udisks2 Solid backend, halectomy
Patch46: kdelibs-4.8.2-udisks2_prep.patch
Patch47: kdelibs-udisks2-backend.patch
## upstreamable
# knewstuff2 variant of:
# https://git.reviewboard.kde.org/r/102439/
@ -129,18 +141,14 @@ Patch52: kdelibs-4.7.4-SOLID_UPNP.patch
# add s390/s390x support in kjs
Patch53: kdelibs-4.7.2-kjs-s390.patch
## upstream
# don't set rpath on multiarch dirs, https://git.reviewboard.kde.org/r/103422
Patch101: kdelibs-4.8.0-cmake_cxx_implicit_link_directories.patch
## upstream
# fix kdeclarative install location (by wstephenson as found in kde-packager list)
Patch100: kdelibs-4.8.3-kdeclarative-install-location.patch
## security fix
# Not Upstreamed? why not ? -- Rex
Patch200: kdelibs-4.3.1-CVE-2009-2702.patch
## Fedora specific patches
# make forcefully hal-free build
Patch300: kdelibs-4.7.3-halectomy.patch
# force upgrade of apps using the discontinued KatePart Smart* interfaces to
# versions using the new Moving* interfaces instead
# conditionize these? how long to carry them? -- rex
@ -198,7 +206,7 @@ BuildRequires: zlib-devel
%define x_deps pkgconfig(sm) pkgconfig(xcomposite) pkgconfig(xdamage) pkgconfig(xkbfile) pkgconfig(xpm) pkgconfig(xscrnsaver) pkgconfig(xtst) pkgconfig(xv) pkgconfig(xxf86misc)
%{?x_deps:BuildRequires: %{x_deps}}
Requires: udisks upower
Requires: %{?udisks} upower
%if 0%{?apidocs}
BuildRequires: docbook-dtds
@ -314,6 +322,15 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch42 -p1 -b .libplasma-pk-0003
%endif
%if "%{?udisks}" == "udisks2"
pushd solid
%patch46 -p2 -b .udisks2_prep
%patch47 -p4 -b .udisks2backend
popd
%else
%patch45 -p1 -b .halectomy
%endif
# upstreamable patches
%patch50 -p1 -b .knewstuff2_gpg2
%patch51 -p1 -b .uri_mimetypes
@ -321,13 +338,10 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch53 -p1 -b .kjs-s390
# upstream patches
%patch101 -p1 -b .cmake_cxx_implicit_link_directories
# security fixes
%patch200 -p1 -b .CVE-2009-2702
# Fedora patches
%patch300 -p1 -b .halectomy
%build
@ -559,6 +573,7 @@ rm -rf %{buildroot}
%{_kde4_bindir}/kde4-doxygen.sh
%{_kde4_appsdir}/cmake/
%{_kde4_includedir}/*
%{_kde4_libdir}/cmake/KDeclarative/
%{_kde4_libdir}/kde4/devel/
%if 0%{?apidocs}
@ -575,6 +590,21 @@ rm -rf %{buildroot}
%changelog
* Mon Apr 30 2012 Jaroslav Reznik <jreznik@redhat.com> - 6:4.8.3-1
- 4.8.3
- remove cmake implicit link directories patch
- remove adblock filter patch
- add kdeclarative install location patch
* Mon Apr 16 2012 Rex Dieter <rdieter@fedoraproject.org> 6:4.8.2-4
- enable udisks2, +Requires: udisks2 on f18+ too
* Mon Apr 16 2012 Lukas Tinkl <ltinkl@redhat.com> - 6:4.8.2-3
- add udisks2 Solid backend plus RHEL conditional
* Thu Apr 12 2012 Than Ngo <than@redhat.com> - 6:4.8.2-2
- Load/Update filter lists only when AdBlock is enabled
* Fri Mar 30 2012 Jaroslav Reznik <jreznik@redhat.com> - 6:4.8.2-1
- 4.8.2

View File

@ -1 +1 @@
e9dc9a76a785045642fb3098692618d2 kdelibs-4.8.2.tar.xz
c4987c838164bd9ee2787e77243fe4a9 kdelibs-4.8.3.tar.xz