backport the recent kdelibs fixes
This commit is contained in:
parent
529dcc96af
commit
d2d4d20571
13
kdelibs-4.3.1-copyurls.patch
Normal file
13
kdelibs-4.3.1-copyurls.patch
Normal file
@ -0,0 +1,13 @@
|
||||
Index: kfile/kurlbutton.cpp
|
||||
===================================================================
|
||||
--- kfile/kurlbutton.cpp (revision 1006184)
|
||||
+++ kfile/kurlbutton.cpp (revision 1006185)
|
||||
@@ -123,7 +123,7 @@
|
||||
QAction* activatedAction = popup.exec(QCursor::pos());
|
||||
if (activatedAction == copyAction) {
|
||||
QMimeData* mimeData = new QMimeData();
|
||||
- mimeData->setText(m_urlNavigator->url().prettyUrl());
|
||||
+ mimeData->setText(m_urlNavigator->url().pathOrUrl());
|
||||
clipboard->setMimeData(mimeData);
|
||||
} else if (activatedAction == pasteAction) {
|
||||
m_urlNavigator->setUrl(KUrl(clipboard->text()));
|
26
kdelibs-4.3.1-unmountfix.patch
Normal file
26
kdelibs-4.3.1-unmountfix.patch
Normal file
@ -0,0 +1,26 @@
|
||||
Index: kioslave/file/file.cpp
|
||||
===================================================================
|
||||
--- kioslave/file/file.cpp (revision 1008903)
|
||||
+++ kioslave/file/file.cpp (revision 1008904)
|
||||
@@ -1146,7 +1146,7 @@
|
||||
error( KIO::ERR_COULD_NOT_UNMOUNT, i18n("Could not find program \"umount\""));
|
||||
return;
|
||||
}
|
||||
- buffer = umountProg + QFile::encodeName(KShell::quoteArg(_point)) + " 2>" + tmpFileName;
|
||||
+ buffer = umountProg + ' ' + QFile::encodeName(KShell::quoteArg(_point)) + " 2>" + tmpFileName;
|
||||
system( buffer.constData() );
|
||||
#endif /* HAVE_VOLMGT */
|
||||
|
||||
Index: kio/kio/kautomount.cpp
|
||||
===================================================================
|
||||
--- kio/kio/kautomount.cpp (revision 1008897)
|
||||
+++ kio/kio/kautomount.cpp (revision 1008898)
|
||||
@@ -108,7 +108,7 @@
|
||||
};
|
||||
|
||||
KAutoUnmount::KAutoUnmount( const QString & _mountpoint, const QString & _desktopFile )
|
||||
- : d( new KAutoUnmountPrivate(this, _desktopFile, _mountpoint) )
|
||||
+ : d( new KAutoUnmountPrivate(this, _mountpoint, _desktopFile) )
|
||||
{
|
||||
KIO::Job * job = KIO::unmount( d->m_mountpoint );
|
||||
connect( job, SIGNAL( result( KJob * ) ), this, SLOT( slotResult( KJob * ) ) );
|
15
kdelibs.spec
15
kdelibs.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Summary: K Desktop Environment 4 - Libraries
|
||||
Version: 4.3.0
|
||||
Release: 2%{?dist}
|
||||
Release: 4%{?dist}
|
||||
|
||||
%if 0%{?fedora} > 8
|
||||
Name: kdelibs
|
||||
@ -87,6 +87,9 @@ Patch20: kdelibs-4.1.70-cmake.patch
|
||||
Patch100: kdelibs-4.3.1-kdebug#202550.patch
|
||||
# http://bugs.kde.org/199557
|
||||
Patch101: kdelibs-4.3.1-kdebug#199557.patch
|
||||
Patch102: kdelibs-4.3.1-unmountfix.patch
|
||||
# http://bugs.kde.org/170608
|
||||
Patch103: kdelibs-4.3.1-copyurls.patch
|
||||
|
||||
BuildRequires: qt4-devel >= 4.5.0
|
||||
# qt4%{_?_isa} isn't provided yet -- Rex
|
||||
@ -223,7 +226,8 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
# 4.3
|
||||
%patch100 -p4 -b .kdebug#202550
|
||||
%patch101 -p4 -b .kdebug#199557
|
||||
|
||||
%patch102 -p0 -b .unmountfix
|
||||
%patch103 -p0 -b .copyurls
|
||||
|
||||
%build
|
||||
|
||||
@ -405,6 +409,13 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 17 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.0-4
|
||||
- fix unmounting devices
|
||||
- fix copying URLs to clipboard (kdebug:170608)
|
||||
|
||||
* Fri Aug 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.0-3
|
||||
- kde4.(sh|csh): drop KDE_IS_PRELINKED for now (workaround bug #515539)
|
||||
|
||||
* Wed Aug 05 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.0-2
|
||||
- microblog crashes plasma on show friends toggle (kdebug#202550)
|
||||
- khtml crasher (kdebug#199557)
|
||||
|
Loading…
Reference in New Issue
Block a user