* Mon Apr 20 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.2.2-8

- fix Plasma PopupApplet configuration interfering with weather applet (#495998)
This commit is contained in:
Kevin Kofler 2009-04-20 12:23:37 +00:00
parent 80dba827d5
commit c68eb5c6d1
3 changed files with 66 additions and 1 deletions

View File

@ -0,0 +1,26 @@
Index: plasma/popupapplet.cpp
===================================================================
--- plasma/popupapplet.cpp (revision 937997)
+++ plasma/popupapplet.cpp (revision 937998)
@@ -535,8 +535,8 @@
{
//Reposition the dialog
if (dialog) {
- KConfigGroup sizeGroup = q->config();
- sizeGroup = KConfigGroup(&sizeGroup, "PopupApplet");
+ KConfigGroup *mainGroup = static_cast<Applet*>(q)->d->mainConfigGroup();
+ KConfigGroup sizeGroup(mainGroup, "PopupApplet");
sizeGroup.writeEntry("DialogHeight", dialog->height());
sizeGroup.writeEntry("DialogWidth", dialog->width());
@@ -559,8 +559,8 @@
return;
}
- KConfigGroup sizeGroup = q->config();
- sizeGroup = KConfigGroup(&sizeGroup, "PopupApplet");
+ KConfigGroup *mainGroup = static_cast<Applet*>(q)->d->mainConfigGroup();
+ KConfigGroup sizeGroup(mainGroup, "PopupApplet");
Q_ASSERT(q->containment());
Q_ASSERT(q->containment()->corona());

View File

@ -0,0 +1,29 @@
diff -Nur kdelibs-4.2.2/plasma/CMakeLists.txt kdelibs-4.2.2-popupapplet-kconf_update/plasma/CMakeLists.txt
--- kdelibs-4.2.2/plasma/CMakeLists.txt 2009-01-06 18:27:56.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/CMakeLists.txt 2009-04-19 05:33:42.000000000 +0200
@@ -268,3 +268,5 @@
install(FILES scripting/plasmoids.knsrc DESTINATION ${CONFIG_INSTALL_DIR})
+install(FILES plasma_popupapplet_fix_groups.upd DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
+install(PROGRAMS plasma_popupapplet_fix_groups.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
diff -Nur kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.pl kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl
--- kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.pl 1970-01-01 01:00:00.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl 2009-04-19 05:24:00.000000000 +0200
@@ -0,0 +1,8 @@
+#!/usr/bin/perl
+
+while(<>) {
+ if ($_ =~ m/^\[.*\[Configuration\]\[PopupApplet\]$/) {
+ $_ =~ s/\[Configuration\]\[PopupApplet\]$/[PopupApplet]/;
+ }
+ print $_;
+}
diff -Nur kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.upd kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.upd
--- kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.upd 1970-01-01 01:00:00.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.upd 2009-04-19 05:31:20.000000000 +0200
@@ -0,0 +1,4 @@
+# Fix groups of the form ...[Configuration][PopupApplet] into ...[PopupApplet]
+Id=PlasmaPopupAppletFixGroups
+File=plasma-appletsrc,plasmarc,plasmoidviewer-appletsrc
+Script=plasma_popupapplet_fix_groups.pl,perl

View File

@ -1,6 +1,6 @@
Summary: K Desktop Environment 4 - Libraries
Version: 4.2.2
Release: 7%{?dist}
Release: 8%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs
@ -84,6 +84,8 @@ Patch23: kdelibs-4.2.0-gcc44-workaround.patch
Patch24: kdelibs-4.2.0-kjs-gcc44-crash.patch
Patch25: kdelibs-4.2.0-gcc44-misc.patch
Patch26: kdelibs-4.2.2-plasma-focus.patch
# kconf_update script for Patch201 - to be upstreamed
Patch27: kdelibs-4.2.2-popupapplet-kconf_update.patch
# upstream
# 4.2 branch
@ -95,6 +97,8 @@ Patch104: kdelibs-4.2.2-kde#180785-2.patch
# 4.3 branch
Patch200: kdelibs-4.1.96-AllowExternalPaths.patch
# fix Plasma PopupApplet configuration interfering with weather applet (#495998)
Patch201: kdelibs-4.2.2-popupapplet-kconf_update.patch
BuildRequires: qt4-devel >= 4.4.0
# qt4%{_?_isa} isn't provided yet -- Rex
@ -229,6 +233,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch24 -p1 -b .kjs-gcc44-crash
%patch25 -p1 -b .gcc44-misc
%patch26 -p1 -b .kickoff-focus
%patch27 -p1 -b .popupapplet-kconf_update
# upstream patches
# 4.2
@ -240,6 +245,8 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
# 4.3
%patch200 -p1 -b .AllowExternalPaths
%patch201 -p0 -b .popupapplet-config
%build
@ -421,6 +428,9 @@ rm -rf %{buildroot}
%changelog
* Mon Apr 20 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.2.2-8
- fix Plasma PopupApplet configuration interfering with weather applet (#495998)
* Sun Apr 19 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.2-7
- fix and simplify the child struct disposal (kde#180785)