Rex Dieter 2016-05-06 12:54:17 -05:00
parent 1f0798516b
commit b1fac5955e
2 changed files with 45 additions and 5 deletions

View File

@ -0,0 +1,30 @@
diff -up kdelibs-4.14.19/CMakeLists.txt.strigi_optional kdelibs-4.14.19/CMakeLists.txt
--- kdelibs-4.14.19/CMakeLists.txt.strigi_optional 2016-04-13 15:10:50.000000000 -0500
+++ kdelibs-4.14.19/CMakeLists.txt 2016-05-06 12:47:17.709456787 -0500
@@ -82,17 +82,17 @@ set_package_properties(ZLIB PROPERTIES D
)
find_package(Strigi 0.6.3)
-if (WIN32)
- set (STRIGI_TYPE "OPTIONAL")
- set (STRIGI_EXTRA_TEXT "")
-else (WIN32)
- set (STRIGI_TYPE "REQUIRED")
- set (STRIGI_EXTRA_TEXT "Required by some critical kioslaves")
-endif (WIN32)
+#if (WIN32)
+# set (STRIGI_TYPE "OPTIONAL")
+# set (STRIGI_EXTRA_TEXT "")
+#else (WIN32)
+# set (STRIGI_TYPE "REQUIRED")
+# set (STRIGI_EXTRA_TEXT "Required by some critical kioslaves")
+#endif (WIN32)
set_package_properties(Strigi PROPERTIES DESCRIPTION "Desktop indexing and search support"
URL "http://strigi.sourceforge.net"
- TYPE ${STRIGI_TYPE}
- PURPOSE ${STRIGI_EXTRA_TEXT}
+ TYPE OPTIONAL
+ PURPOSE "Required by some kioslaves for metadata support"
)
find_package(LibAttica 0.4.2)

View File

@ -6,7 +6,6 @@
%define dbusmenu_qt_ver 0.9.0
%define phonon_ver 4.6.0
%define qt4_ver 4.8.1
%define strigi_ver 0.7.0
%if ! 0%{?bootstrap}
%define apidocs 1
%endif
@ -19,6 +18,9 @@
%if 0%{?fedora} < 24
%define nepomuk 1
%endif
%if 0%{?fedora} < 25
%define strigi 1
%endif
# to build/include QCH apidocs or not (currently broken)
#define apidocs_qch 1
%if 0%{?rhel} > 6 || 0%{?fedora} > 17
@ -39,7 +41,6 @@
%global _hardened_build 1
%global phonon_version %(pkg-config --modversion phonon 2>/dev/null || echo %{phonon_ver})
%global strigi_version %(pkg-config --modversion libstreams 2>/dev/null || echo %{strigi_ver})
%global dbusmenu_qt_version %(pkg-config --modversion dbusmenu-qt 2>/dev/null || echo %{dbusmenu_qt_ver})
%global rpm_macros_dir %(d=%{_rpmconfigdir}/macros.d; [ -d $d ] || d=%{_sysconfdir}/rpm; echo $d)
@ -50,7 +51,7 @@ Summary: KDE Libraries
# shipped with kde applications, version...
%global apps_version 16.04.0
Version: 4.14.19
Release: 3%{?dist}
Release: 4%{?dist}
Name: kdelibs
Epoch: 6
@ -95,7 +96,6 @@ Requires: kde-l10n
%endif
Requires: phonon%{?_isa} >= %{phonon_version}
Requires: shared-mime-info
Requires: strigi-libs%{?_isa} >= %{strigi_version}
%if 0%{?fedora} > 22
# Rich deps are currently problematic
@ -173,6 +173,10 @@ Patch55: Drop-Nepomuk-from-KParts-LINK_INTERFACE_LIBRARIES.patch
# https://bugs.kde.org/show_bug.cgi?id=288410
Patch56: kdelibs-kdebug288410.patch
# make strigi dep optional
# see also http://reviewboard.kde.org/r/127823
Patch57: kdelibs-strigi_optional.patch
# make filter working, TODO: upstream? -- rex
Patch59: kdelibs-4.9.3-kcm_ssl.patch
@ -252,7 +256,9 @@ BuildRequires: pkgconfig(jasper)
BuildRequires: pkgconfig(libattica) >= %{attica_ver}
BuildRequires: pkgconfig(liblzma)
BuildRequires: pkgconfig(libpcre)
BuildRequires: pkgconfig(libstreams) >= %{strigi_ver}
%if 0%{?strigi}
BuildRequires: pkgconfig(libstreams)
%endif
BuildRequires: pkgconfig(libudev)
BuildRequires: pkgconfig(libxslt) pkgconfig(libxml-2.0)
BuildRequires: pkgconfig(OpenEXR)
@ -470,6 +476,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch54 -p1 -b .kjs-locale
%patch55 -p1 -b .Drop-Nepomuk-from-KParts-LINK_INTERFACE_LIBRARIES
%patch56 -p1 -b .kdebug288410
%patch57 -p1 -b .strigi_optional
%patch59 -p1 -b .filter
%patch61 -p1 -b .dot
%patch62 -p1 -b .arm-plasma
@ -861,6 +868,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%changelog
* Fri May 06 2016 Rex Dieter <rdieter@fedoraproject.org> - 6:4.14.19-4
- drop strigi support (f25+)
* Wed Apr 20 2016 Rex Dieter <rdieter@fedoraproject.org> - 6:4.14.19-3
- rebuild (qt)