sync w/devel branch for 4.4.2 goodness
This commit is contained in:
parent
a6384873ab
commit
a031fcc237
@ -1 +1 @@
|
|||||||
kdelibs-4.4.1.tar.bz2
|
kdelibs-4.4.2.tar.bz2
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -up kdelibs-4.4.1/cmake/modules/FindKDE4Internal.cmake.no_rpath kdelibs-4.4.1/cmake/modules/FindKDE4Internal.cmake
|
|
||||||
--- kdelibs-4.4.1/cmake/modules/FindKDE4Internal.cmake.no_rpath 2010-02-28 11:08:56.164016085 -0600
|
|
||||||
+++ kdelibs-4.4.1/cmake/modules/FindKDE4Internal.cmake 2010-02-28 11:10:20.126766912 -0600
|
|
||||||
@@ -947,7 +947,16 @@ if (UNIX)
|
|
||||||
set(CMAKE_INSTALL_NAME_DIR ${LIB_INSTALL_DIR})
|
|
||||||
else (APPLE)
|
|
||||||
# add our LIB_INSTALL_DIR to the RPATH and use the RPATH figured out by cmake when compiling
|
|
||||||
- set(CMAKE_INSTALL_RPATH ${LIB_INSTALL_DIR} )
|
|
||||||
+ # set(CMAKE_INSTALL_RPATH ${LIB_INSTALL_DIR} )
|
|
||||||
+ message(STATUS "CMAKE_SYSTEM_LIBRARY_PATH: ${CMAKE_SYSTEM_LIBRARY_PATH}")
|
|
||||||
+ message(STATUS "LIB_INSTALL_DIR: ${LIB_INSTALL_DIR}")
|
|
||||||
+ list(FIND CMAKE_SYSTEM_LIBRARY_PATH ${LIB_INSTALL_DIR} _LIB_INSTALL_DIR_INDEX_IN_CMAKE_SYSTEM_LIBRARY_PATH)
|
|
||||||
+ message(STATUS "_LIB_INSTALL_DIR_INDEX_IN_CMAKE_SYSTEM_LIBRARY_PATH: ${_LIB_INSTALL_DIR_INDEX_IN_CMAKE_SYSTEM_LIBRARY_PATH}")
|
|
||||||
+ if(${_LIB_INSTALL_DIR_INDEX_IN_CMAKE_SYSTEM_LIBRARY_PATH} EQUAL -1)
|
|
||||||
+ message(STATUS "appending to CMAKE_INSTALL_RPATH: ${LIB_INSTALL_DIR}")
|
|
||||||
+ list(APPEND CMAKE_INSTALL_RPATH ${LIB_INSTALL_DIR})
|
|
||||||
+ endif(${_LIB_INSTALL_DIR_INDEX_IN_CMAKE_SYSTEM_LIBRARY_PATH} EQUAL -1)
|
|
||||||
+
|
|
||||||
set(CMAKE_SKIP_BUILD_RPATH FALSE)
|
|
||||||
set(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
|
||||||
set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
|
|
@ -1,29 +0,0 @@
|
|||||||
--- branches/KDE/4.4/kdelibs/kdecore/io/kdebug.cpp 2010/01/06 22:46:33 1070858
|
|
||||||
+++ branches/KDE/4.4/kdelibs/kdecore/io/kdebug.cpp 2010/03/20 01:43:08 1105396
|
|
||||||
@@ -317,7 +317,7 @@
|
|
||||||
return groupName;
|
|
||||||
}
|
|
||||||
|
|
||||||
- OutputMode areaOutputMode(QtMsgType type, unsigned int area)
|
|
||||||
+ OutputMode areaOutputMode(QtMsgType type, unsigned int area, bool enableByDefault)
|
|
||||||
{
|
|
||||||
if (!config)
|
|
||||||
return QtOutput;
|
|
||||||
@@ -343,7 +343,7 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
const KConfigGroup cg(config, groupNameForArea(area));
|
|
||||||
- const int mode = cg.readEntry(key, int(DefaultOutput));
|
|
||||||
+ const int mode = cg.readEntry(key, int(enableByDefault ? DefaultOutput : NoOutput));
|
|
||||||
return OutputMode(mode);
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -418,7 +418,7 @@
|
|
||||||
const int lev = level(type);
|
|
||||||
//qDebug() << "in cache for" << num << ":" << it->mode[lev];
|
|
||||||
if (it->mode[lev] == Unknown)
|
|
||||||
- it->mode[lev] = areaOutputMode(type, num);
|
|
||||||
+ it->mode[lev] = areaOutputMode(type, num, enableByDefault);
|
|
||||||
if (it->mode[lev] == FileOutput && it->logFileName[lev].isEmpty())
|
|
||||||
it->logFileName[lev] = logFileName(type, num);
|
|
||||||
|
|
18
kdelibs.spec
18
kdelibs.spec
@ -7,8 +7,8 @@
|
|||||||
%define apidocs 1
|
%define apidocs 1
|
||||||
|
|
||||||
Summary: KDE Libraries
|
Summary: KDE Libraries
|
||||||
Version: 4.4.1
|
Version: 4.4.2
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
Name: kdelibs
|
Name: kdelibs
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
@ -83,14 +83,10 @@ Patch24: kdelibs-4.3.1-drkonq.patch
|
|||||||
# paths (like /usr/lib64) already! With this, we can drop
|
# paths (like /usr/lib64) already! With this, we can drop
|
||||||
# -DCMAKE_SKIP_RPATH:BOOL=ON (finally)
|
# -DCMAKE_SKIP_RPATH:BOOL=ON (finally)
|
||||||
Patch27: kdelibs-4.3.98-no_rpath.patch
|
Patch27: kdelibs-4.3.98-no_rpath.patch
|
||||||
# bug:568389 (crash in kpixmapcache)
|
|
||||||
Patch28: kdelibs-4.4.2-kpixmapcache.patch
|
|
||||||
|
|
||||||
# upstreamable
|
# upstreamable
|
||||||
|
|
||||||
## 4.4 upstream
|
## 4.4 upstream
|
||||||
# https://bugs.kde.org/show_bug.cgi?id=227089
|
|
||||||
Patch100: kdelibs-4.4.2-kdebug.patch
|
|
||||||
|
|
||||||
## trunk upstream
|
## trunk upstream
|
||||||
Patch110: kdelibs-4.4.1-k3passworddialog_qt47.patch
|
Patch110: kdelibs-4.4.1-k3passworddialog_qt47.patch
|
||||||
@ -144,8 +140,6 @@ BuildRequires: zlib-devel
|
|||||||
# extra X deps (seemingly needed and/or checked-for by most kde4 buildscripts)
|
# extra X deps (seemingly needed and/or checked-for by most kde4 buildscripts)
|
||||||
%define x_deps libSM-devel libXcomposite-devel libXdamage-devel libxkbfile-devel libXpm-devel libXScrnSaver-devel libXtst-devel libXv-devel libXxf86misc-devel
|
%define x_deps libSM-devel libXcomposite-devel libXdamage-devel libxkbfile-devel libXpm-devel libXScrnSaver-devel libXtst-devel libXv-devel libXxf86misc-devel
|
||||||
%{?x_deps:BuildRequires: %{x_deps}}
|
%{?x_deps:BuildRequires: %{x_deps}}
|
||||||
BuildRequires: openssh-clients
|
|
||||||
BuildRequires: subversion
|
|
||||||
|
|
||||||
%if 0%{?apidocs}
|
%if 0%{?apidocs}
|
||||||
BuildRequires: doxygen
|
BuildRequires: doxygen
|
||||||
@ -241,12 +235,10 @@ format for easy browsing.
|
|||||||
%patch24 -p1 -b .drkonq
|
%patch24 -p1 -b .drkonq
|
||||||
%endif
|
%endif
|
||||||
%patch27 -p1 -b .no_rpath
|
%patch27 -p1 -b .no_rpath
|
||||||
%patch28 -p4 -b .kpixmapcache
|
|
||||||
|
|
||||||
# upstreamable patches
|
# upstreamable patches
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p4 -b .kdebug
|
|
||||||
%{?_qt47:%patch110 -p1 -b .k3passworddialog_qt47}
|
%{?_qt47:%patch110 -p1 -b .k3passworddialog_qt47}
|
||||||
|
|
||||||
# security fix
|
# security fix
|
||||||
@ -439,6 +431,12 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 29 2010 Lukas Tinkl <ltinkl@redhat.com> - 6:4.4.2-1
|
||||||
|
- 4.4.2
|
||||||
|
|
||||||
|
* Thu Mar 25 2010 Rex Dieter <rdieter@fedoraproject.org> 6:4.4.1-10
|
||||||
|
- drop BR: openssh-clients subversion
|
||||||
|
|
||||||
* Thu Mar 25 2010 Rex Dieter <rdieter@fedoraproject.org> 6:4.4.1-9
|
* Thu Mar 25 2010 Rex Dieter <rdieter@fedoraproject.org> 6:4.4.1-9
|
||||||
- refresh kdelibs-4.4.2-kpixmapcache.patch
|
- refresh kdelibs-4.4.2-kpixmapcache.patch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user