Merge branch 'f20'

Conflicts:
	kdelibs.spec
This commit is contained in:
Rex Dieter 2013-12-09 08:19:14 -06:00
commit 9eb06908f0
3 changed files with 33 additions and 16 deletions

View File

@ -0,0 +1,25 @@
diff -ur kdelibs-4.11.3/kinit/klauncher_main.cpp kdelibs-4.11.3-klauncher-no-glib/kinit/klauncher_main.cpp
--- kdelibs-4.11.3/kinit/klauncher_main.cpp 2013-06-28 19:03:41.000000000 +0200
+++ kdelibs-4.11.3-klauncher-no-glib/kinit/klauncher_main.cpp 2013-12-09 00:32:12.000000000 +0100
@@ -75,10 +75,21 @@
// WABA: Make sure not to enable session management.
putenv(strdup("SESSION_MANAGER="));
+ // Disable the GLib event loop (rh#983110)
+ bool wasQtNoGlibSet = (getenv("QT_NO_GLIB") != 0);
+ if (!wasQtNoGlibSet) {
+ setenv("QT_NO_GLIB", "1", true);
+ }
+
// We need a QCoreApplication to get a DBus event loop
QCoreApplication app(argc, argv);
app.setApplicationName( componentData.componentName() );
+ // Now get rid of QT_NO_GLIB again so launched processes don't inherit it
+ if (!wasQtNoGlibSet) {
+ unsetenv("QT_NO_GLIB");
+ }
+
int maxTry = 3;
while(true)
{

View File

@ -1,12 +0,0 @@
diff -ur kdelibs-4.11.3/kinit/klauncher.cpp kdelibs-4.11.3-klauncher-timeout/kinit/klauncher.cpp
--- kdelibs-4.11.3/kinit/klauncher.cpp 2013-11-01 16:45:56.000000000 +0100
+++ kdelibs-4.11.3-klauncher-timeout/kinit/klauncher.cpp 2013-12-07 03:36:42.000000000 +0100
@@ -314,7 +314,7 @@
// Same thing if kdeinit dies without warning.
fd_set in;
- timeval tm = { 30, 0 }; // 30 seconds timeout, so we're not stuck in case kdeinit dies on us
+ timeval tm = { 60, 0 }; // 60 seconds timeout, so we're not stuck in case kdeinit dies on us
FD_ZERO ( &in );
FD_SET( sock, &in );
select( sock + 1, &in, 0, 0, &tm );

View File

@ -39,7 +39,7 @@
Summary: KDE Libraries
Version: 4.11.97
Release: 5%{?dist}
Release: 6%{?dist}
Name: kdelibs
Epoch: 6
@ -159,8 +159,8 @@ Patch61: kdelibs-4.9.3-dot.patch
# workaround for bz#969524 on arm
Patch62: kdelibs-4.11.3-arm.patch
# increase KLauncher timeout as a possible fix/workaround for #983110
Patch63: kdelibs-4.11.3-klauncher-timeout.patch
# set QT_NO_GLIB in klauncher_main.cpp as a possible fix/workaround for #983110
Patch63: kdelibs-4.11.3-klauncher-no-glib.patch
## upstream
@ -368,7 +368,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch59 -p1 -b .filter
%patch61 -p1 -b .dot
%patch62 -p1 -b .arm-plasma
%patch63 -p1 -b .klauncher-timeout
%patch63 -p1 -b .klauncher-no-glib
# upstream patches
%patch090 -p1 -R -b .return-not-break.-copy-paste-error
@ -633,6 +633,10 @@ gtk-update-icon-cache %{_kde4_iconsdir}/hicolor &> /dev/null || :
%changelog
* Mon Dec 09 2013 Kevin Kofler <Kevin@tigcc.ticalc.org> - 6:4.11.97-6
- drop klauncher-timeout patch that did not help
- set QT_NO_GLIB in klauncher_main.cpp as a possible fix/workaround for #983110
* Sat Dec 07 2013 Rex Dieter <rdieter@fedoraproject.org> - 6:4.11.97-5
- avoid possible crasher in autostart-debug.patch