Merge remote branch 'origin/master' into f14/master
This commit is contained in:
commit
8eb9c8a719
19
kdelibs-4.5.2-comic_applet_kde253387.patch
Normal file
19
kdelibs-4.5.2-comic_applet_kde253387.patch
Normal file
@ -0,0 +1,19 @@
|
||||
--- branches/KDE/4.5/kdelibs/plasma/tooltipmanager.cpp 2010/09/28 01:19:58 1180436
|
||||
+++ branches/KDE/4.5/kdelibs/plasma/tooltipmanager.cpp 2010/10/08 11:35:52 1183776
|
||||
@@ -236,10 +236,12 @@
|
||||
}
|
||||
}
|
||||
|
||||
- d->tipWidget->setContent(widget, data);
|
||||
- d->tipWidget->prepareShowing();
|
||||
- if (m_corona) {
|
||||
- d->tipWidget->moveTo(m_corona->popupPosition(widget, d->tipWidget->size(), Qt::AlignCenter));
|
||||
+ if (d->tipWidget) {
|
||||
+ d->tipWidget->setContent(widget, data);
|
||||
+ d->tipWidget->prepareShowing();
|
||||
+ if (m_corona) {
|
||||
+ d->tipWidget->moveTo(m_corona->popupPosition(widget, d->tipWidget->size(), Qt::AlignCenter));
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
18
kdelibs.spec
18
kdelibs.spec
@ -12,7 +12,7 @@
|
||||
|
||||
Summary: KDE Libraries
|
||||
Version: 4.5.2
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
|
||||
Name: kdelibs
|
||||
Epoch: 6
|
||||
@ -90,9 +90,10 @@ Patch27: kdelibs-4.4.80-no_rpath.patch
|
||||
Patch50: kdelibs-4.5.1-knewstuff_gpg2.patch
|
||||
|
||||
## 4.5 upstream
|
||||
Patch100: kdelibs-4.5.2-comic_applet_kde253387.patch
|
||||
|
||||
## trunk upstream
|
||||
Patch100: kdelibs-4.5.2-krun-kde#253294.patch
|
||||
Patch150: kdelibs-4.5.2-krun-kde#253294.patch
|
||||
|
||||
## security fix
|
||||
# Not Upstreamed? why not ? -- Rex
|
||||
@ -243,6 +244,8 @@ format for use with the Qt 4 Assistant or KDevelop 4.
|
||||
%patch2 -p1 -b .kde149705
|
||||
%patch8 -p1 -b .install_all_css
|
||||
%patch9 -p1 -b .branding
|
||||
# add release version as part of branding (suggested by cailon)
|
||||
sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanager.cpp
|
||||
%patch11 -p1 -b .policykit-workaround
|
||||
%patch12 -p1 -b .Administration-menu
|
||||
%patch14 -p1 -b .libexecdir
|
||||
@ -257,7 +260,8 @@ format for use with the Qt 4 Assistant or KDevelop 4.
|
||||
%patch50 -p1 -b .knewstuff_gpg2
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .kde#253294
|
||||
%patch100 -p4 -b .comic_applet_kde253387
|
||||
%patch150 -p1 -b .kde#253294
|
||||
|
||||
# security fix
|
||||
%patch200 -p1 -b .CVE-2009-2702
|
||||
@ -265,9 +269,6 @@ format for use with the Qt 4 Assistant or KDevelop 4.
|
||||
|
||||
%build
|
||||
|
||||
# add release version
|
||||
sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanager.cpp
|
||||
|
||||
mkdir -p %{_target_platform}
|
||||
pushd %{_target_platform}
|
||||
%{cmake_kde4} -DKDE_DISTRIBUTION_TEXT="%{version}-%{release} Fedora" ..
|
||||
@ -277,7 +278,7 @@ make %{?_smp_mflags} -C %{_target_platform}
|
||||
|
||||
# build apidocs
|
||||
%if 0%{?apidocs}
|
||||
export QTDOCDIR=`pkg-config --variable=docdir Qt`
|
||||
export QTDOCDIR="%{?_qt4_docdir}%{?!_qt4_docdir:%(pkg-config --variable=docdir Qt)}"
|
||||
%if 0%{?apidocs_qch}
|
||||
export PROJECT_NAME="%{name}"
|
||||
export PROJECT_VERSION="%{version}%{?alphatag}"
|
||||
@ -505,6 +506,9 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Oct 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-5
|
||||
- switching comic in commic applet crashes plasma (kde#253387,rh#640619)
|
||||
|
||||
* Thu Oct 07 2010 Than Ngo <than@redhat.com> - 4.5.2-4
|
||||
- kde253294, KMail and Kopete download and open https url instead of only opening
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user