* Thu Apr 23 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.2-11

- fix the kconf_update scriptlet for #495998 again (missing DELETEGROUP)
This commit is contained in:
Kevin Kofler 2009-04-23 22:50:29 +00:00
parent 7a89a56e7f
commit 8c6aaa9c21
2 changed files with 11 additions and 7 deletions

View File

@ -9,12 +9,13 @@ diff -Nur kdelibs-4.2.2/plasma/CMakeLists.txt kdelibs-4.2.2-popupapplet-kconf_up
+install(PROGRAMS plasma_popupapplet_fix_groups.pl DESTINATION ${KCONF_UPDATE_INSTALL_DIR})
diff -Nur kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.pl kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl
--- kdelibs-4.2.2/plasma/plasma_popupapplet_fix_groups.pl 1970-01-01 01:00:00.000000000 +0100
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl 2009-04-19 05:24:00.000000000 +0200
@@ -0,0 +1,8 @@
+++ kdelibs-4.2.2-popupapplet-kconf_update/plasma/plasma_popupapplet_fix_groups.pl 2009-04-24 00:42:44.000000000 +0200
@@ -0,0 +1,9 @@
+#!/usr/bin/perl
+
+while(<>) {
+ if ($_ =~ m/^\[.*\[Configuration\]\[PopupApplet\]$/) {
+ print "# DELETEGROUP $_";
+ $_ =~ s/\[Configuration\]\[PopupApplet\]$/[PopupApplet]/;
+ }
+ print $_;

View File

@ -1,6 +1,6 @@
Summary: K Desktop Environment 4 - Libraries
Version: 4.2.2
Release: 10%{?dist}
Release: 11%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs
@ -83,8 +83,6 @@ Patch23: kdelibs-4.2.0-gcc44-workaround.patch
# disable strict aliasing in kjs/dtoa.cpp (GCC 4.4 x86_64 crash) (#485968)
Patch24: kdelibs-4.2.0-kjs-gcc44-crash.patch
Patch25: kdelibs-4.2.0-gcc44-misc.patch
# kconf_update script for Patch201 - to be upstreamed
Patch27: kdelibs-4.2.2-popupapplet-kconf_update.patch
# upstream
# 4.2 branch
@ -99,6 +97,8 @@ Patch105: kdelibs-4.2.2-plasma-focus.patch
Patch200: kdelibs-4.1.96-AllowExternalPaths.patch
# fix Plasma PopupApplet configuration interfering with weather applet (#495998)
Patch201: kdelibs-4.2.2-popupapplet-config.patch
# kconf_update script for Patch201
Patch202: kdelibs-4.2.2-popupapplet-kconf_update.patch
BuildRequires: qt4-devel >= 4.4.0
# qt4%{_?_isa} isn't provided yet -- Rex
@ -232,7 +232,6 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch23 -p1 -b .gcc44
%patch24 -p1 -b .kjs-gcc44-crash
%patch25 -p1 -b .gcc44-misc
%patch27 -p1 -b .popupapplet-kconf_update
# upstream patches
# 4.2
@ -246,6 +245,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
# 4.3
%patch200 -p1 -b .AllowExternalPaths
%patch201 -p0 -b .popupapplet-config
%patch202 -p1 -b .popupapplet-kconf_update
%build
@ -428,8 +428,11 @@ rm -rf %{buildroot}
%changelog
* Thu Apr 23 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.2-11
- fix the kconf_update scriptlet for #495998 again (missing DELETEGROUP)
* Thu Apr 23 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.2.2-10
- fix the kconf_update scriptlet for #495998
- fix the kconf_update scriptlet for #495998 (broken .upd syntax)
* Tue Apr 21 2009 Than Ngo <than@redhat.com> - 4.2.2-9
- don't let plasma appear over screensaver