KDE 4.3.1
This commit is contained in:
parent
e2211ed4b9
commit
8c04914275
@ -1,2 +1 @@
|
|||||||
kdelibs-4.2.98.tar.bz2
|
kdelibs-4.3.1.tar.bz2
|
||||||
kdelibs-4.3.0.tar.bz2
|
|
||||||
|
@ -1,69 +0,0 @@
|
|||||||
Index: kio/kio/kfileitem.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kio/kio/kfileitem.cpp (revision 1012563)
|
|
||||||
+++ kio/kio/kfileitem.cpp (revision 1012564)
|
|
||||||
@@ -532,6 +532,9 @@
|
|
||||||
{
|
|
||||||
d->m_strName = name;
|
|
||||||
d->m_strText = KIO::decodeFileName( d->m_strName );
|
|
||||||
+ if (d->m_entry.contains(KIO::UDSEntry::UDS_NAME))
|
|
||||||
+ d->m_entry.insert(KIO::UDSEntry::UDS_NAME, d->m_strName); // #195385
|
|
||||||
+
|
|
||||||
}
|
|
||||||
|
|
||||||
QString KFileItem::linkDest() const
|
|
||||||
Index: kio/tests/kfileitemtest.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kio/tests/kfileitemtest.cpp (revision 1012563)
|
|
||||||
+++ kio/tests/kfileitemtest.cpp (revision 1012564)
|
|
||||||
@@ -241,6 +241,21 @@
|
|
||||||
QVERIFY(fileItem.cmp(fileItem2));
|
|
||||||
}
|
|
||||||
|
|
||||||
+void KFileItemTest::testRename()
|
|
||||||
+{
|
|
||||||
+ KIO::UDSEntry entry;
|
|
||||||
+ const QString origName = QString::fromLatin1("foo");
|
|
||||||
+ entry.insert(KIO::UDSEntry::UDS_NAME, origName);
|
|
||||||
+ entry.insert(KIO::UDSEntry::UDS_FILE_TYPE, S_IFDIR);
|
|
||||||
+ KFileItem fileItem(entry, KUrl("/dir/foo"));
|
|
||||||
+ QCOMPARE(fileItem.name(), origName);
|
|
||||||
+ QCOMPARE(fileItem.text(), origName);
|
|
||||||
+ const QString newName = QString::fromLatin1("FiNeX_rocks");
|
|
||||||
+ fileItem.setName(newName);
|
|
||||||
+ QCOMPARE(fileItem.name(), newName);
|
|
||||||
+ QCOMPARE(fileItem.text(), newName);
|
|
||||||
+ QCOMPARE(fileItem.entry().stringValue(KIO::UDSEntry::UDS_NAME), newName); // #195385
|
|
||||||
+}
|
|
||||||
|
|
||||||
void KFileItemTest::testDecodeFileName_data()
|
|
||||||
{
|
|
||||||
Index: kio/tests/kdirmodeltest.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kio/tests/kdirmodeltest.cpp (revision 1012563)
|
|
||||||
+++ kio/tests/kdirmodeltest.cpp (revision 1012564)
|
|
||||||
@@ -418,6 +418,12 @@
|
|
||||||
// check renaming happened
|
|
||||||
QCOMPARE( m_dirModel->itemForIndex( m_secondFileIndex ).url().url(), newUrl.url() );
|
|
||||||
|
|
||||||
+ // check that KDirLister::cachedItemForUrl won't give a bad name if copying that item (#195385)
|
|
||||||
+ KFileItem cachedItem = KDirLister::cachedItemForUrl(newUrl);
|
|
||||||
+ Q_ASSERT(!cachedItem.isNull());
|
|
||||||
+ QCOMPARE(cachedItem.name(), QString("toplevelfile_2_renamed"));
|
|
||||||
+ QCOMPARE(cachedItem.entry().stringValue(KIO::UDSEntry::UDS_NAME), QString("toplevelfile_2_renamed"));
|
|
||||||
+
|
|
||||||
// Put things back to normal
|
|
||||||
job = KIO::rename(newUrl, url, KIO::HideProgressInfo);
|
|
||||||
ok = job->exec();
|
|
||||||
Index: kio/tests/kfileitemtest.h
|
|
||||||
===================================================================
|
|
||||||
--- kio/tests/kfileitemtest.h (revision 1012563)
|
|
||||||
+++ kio/tests/kfileitemtest.h (revision 1012564)
|
|
||||||
@@ -35,6 +35,7 @@
|
|
||||||
void testHiddenFile();
|
|
||||||
void testMimeTypeOnDemand();
|
|
||||||
void testCmp();
|
|
||||||
+ void testRename();
|
|
||||||
|
|
||||||
void testDecodeFileName_data();
|
|
||||||
void testDecodeFileName();
|
|
@ -1,13 +0,0 @@
|
|||||||
Index: kfile/kurlbutton.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kfile/kurlbutton.cpp (revision 1006184)
|
|
||||||
+++ kfile/kurlbutton.cpp (revision 1006185)
|
|
||||||
@@ -123,7 +123,7 @@
|
|
||||||
QAction* activatedAction = popup.exec(QCursor::pos());
|
|
||||||
if (activatedAction == copyAction) {
|
|
||||||
QMimeData* mimeData = new QMimeData();
|
|
||||||
- mimeData->setText(m_urlNavigator->url().prettyUrl());
|
|
||||||
+ mimeData->setText(m_urlNavigator->url().pathOrUrl());
|
|
||||||
clipboard->setMimeData(mimeData);
|
|
||||||
} else if (activatedAction == pasteAction) {
|
|
||||||
m_urlNavigator->setUrl(KUrl(clipboard->text()));
|
|
@ -1,20 +0,0 @@
|
|||||||
--- branches/KDE/4.3/kdelibs/kdecore/localization/kencodingdetector.cpp 2009/07/31 10:31:46 1005095
|
|
||||||
+++ branches/KDE/4.3/kdelibs/kdecore/localization/kencodingdetector.cpp 2009/07/31 10:33:05 1005096
|
|
||||||
@@ -889,7 +889,7 @@
|
|
||||||
const char *autoDetectedEncoding;
|
|
||||||
if ((c1 == 0xFE && c2 == 0xFF) || (c1 == 0xFF && c2 == 0xFE))
|
|
||||||
{
|
|
||||||
- autoDetectedEncoding = "ISO-10646-UCS-2";
|
|
||||||
+ autoDetectedEncoding = "UTF-16";
|
|
||||||
}
|
|
||||||
else if (c1 == 0xEF && c2 == 0xBB && c3 == 0xBF)
|
|
||||||
{
|
|
||||||
@@ -908,7 +908,7 @@
|
|
||||||
int nul_count_even = (c2 != 0) + (c4 != 0) + (c6 != 0) + (c8 != 0) + (c10 != 0);
|
|
||||||
int nul_count_odd = (c1 != 0) + (c3 != 0) + (c5 != 0) + (c7 != 0) + (c9 != 0);
|
|
||||||
if ((nul_count_even==0 && nul_count_odd==5) || (nul_count_even==5 && nul_count_odd==0))
|
|
||||||
- autoDetectedEncoding = "ISO-10646-UCS-2";
|
|
||||||
+ autoDetectedEncoding = "UTF-16";
|
|
||||||
else
|
|
||||||
autoDetectedEncoding = 0;
|
|
||||||
}
|
|
@ -1,75 +0,0 @@
|
|||||||
--- branches/KDE/4.3/kdelibs/plasma/private/service_p.h 2009/08/02 18:26:50 1005966
|
|
||||||
+++ branches/KDE/4.3/kdelibs/plasma/private/service_p.h 2009/08/02 18:27:44 1005967
|
|
||||||
@@ -73,6 +73,7 @@
|
|
||||||
ServicePrivate(Service *service)
|
|
||||||
: q(service),
|
|
||||||
config(0),
|
|
||||||
+ dummyConfig(0),
|
|
||||||
tempFile(0)
|
|
||||||
{
|
|
||||||
}
|
|
||||||
@@ -80,6 +81,7 @@
|
|
||||||
~ServicePrivate()
|
|
||||||
{
|
|
||||||
delete config;
|
|
||||||
+ delete dummyConfig;
|
|
||||||
delete tempFile;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -98,10 +100,25 @@
|
|
||||||
associatedGraphicsWidgets.remove(static_cast<QGraphicsWidget*>(obj));
|
|
||||||
}
|
|
||||||
|
|
||||||
+ KConfigGroup dummyGroup()
|
|
||||||
+ {
|
|
||||||
+ if (!dummyConfig) {
|
|
||||||
+ if (!tempFile) {
|
|
||||||
+ tempFile = new KTemporaryFile;
|
|
||||||
+ tempFile->open();
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ dummyConfig = new KConfig(tempFile->fileName());
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ return KConfigGroup(dummyConfig, "DummyGroup");
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
Service *q;
|
|
||||||
QString destination;
|
|
||||||
QString name;
|
|
||||||
ConfigLoader *config;
|
|
||||||
+ KConfig *dummyConfig;
|
|
||||||
KTemporaryFile *tempFile;
|
|
||||||
QMultiHash<QWidget *, QString> associatedWidgets;
|
|
||||||
QMultiHash<QGraphicsWidget *, QString> associatedGraphicsWidgets;
|
|
||||||
--- branches/KDE/4.3/kdelibs/plasma/service.cpp 2009/08/02 18:26:50 1005966
|
|
||||||
+++ branches/KDE/4.3/kdelibs/plasma/service.cpp 2009/08/02 18:27:44 1005967
|
|
||||||
@@ -116,7 +116,7 @@
|
|
||||||
{
|
|
||||||
if (!d->config) {
|
|
||||||
kDebug() << "No valid operations scheme has been registered";
|
|
||||||
- return KConfigGroup();
|
|
||||||
+ return d->dummyGroup();
|
|
||||||
}
|
|
||||||
|
|
||||||
d->config->writeConfig();
|
|
||||||
@@ -212,6 +212,9 @@
|
|
||||||
delete d->tempFile;
|
|
||||||
d->tempFile = 0;
|
|
||||||
|
|
||||||
+ delete d->dummyConfig;
|
|
||||||
+ d->dummyConfig = 0;
|
|
||||||
+
|
|
||||||
registerOperationsScheme();
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -258,6 +261,9 @@
|
|
||||||
delete d->config;
|
|
||||||
delete d->tempFile;
|
|
||||||
|
|
||||||
+ delete d->dummyConfig;
|
|
||||||
+ d->dummyConfig = 0;
|
|
||||||
+
|
|
||||||
//FIXME: make KSharedConfig and KConfigSkeleton not braindamaged in 4.2 and then get rid of the
|
|
||||||
// temp file object here
|
|
||||||
d->tempFile = new KTemporaryFile;
|
|
@ -1,26 +0,0 @@
|
|||||||
Index: kdeui/actions/kstandardaction.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kdeui/actions/kstandardaction.cpp (revision 1013099)
|
|
||||||
+++ kdeui/actions/kstandardaction.cpp (revision 1013100)
|
|
||||||
@@ -198,12 +198,15 @@
|
|
||||||
}
|
|
||||||
|
|
||||||
if (recvr && slot) {
|
|
||||||
- if (id != OpenRecent)
|
|
||||||
- QObject::connect(pAction, SIGNAL(triggered(bool)), recvr, slot);
|
|
||||||
- else
|
|
||||||
- // FIXME KAction port: probably a good idea to find a cleaner way to do this
|
|
||||||
- // Open Recent is a special case - provide the selected URL
|
|
||||||
- QObject::connect(pAction, SIGNAL(urlSelected(const KUrl &)), recvr, slot);
|
|
||||||
+ if (id == OpenRecent) {
|
|
||||||
+ // FIXME KAction port: probably a good idea to find a cleaner way to do this
|
|
||||||
+ // Open Recent is a special case - provide the selected URL
|
|
||||||
+ QObject::connect(pAction, SIGNAL(urlSelected(const KUrl &)), recvr, slot);
|
|
||||||
+ } else if (id == ConfigureToolbars) { // #200815
|
|
||||||
+ QObject::connect(pAction, SIGNAL(triggered(bool)), recvr, slot, Qt::QueuedConnection);
|
|
||||||
+ } else {
|
|
||||||
+ QObject::connect(pAction, SIGNAL(triggered(bool)), recvr, slot);
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
KActionCollection *collection = qobject_cast<KActionCollection *>(parent);
|
|
@ -1,26 +0,0 @@
|
|||||||
Index: kioslave/file/file.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kioslave/file/file.cpp (revision 1008903)
|
|
||||||
+++ kioslave/file/file.cpp (revision 1008904)
|
|
||||||
@@ -1146,7 +1146,7 @@
|
|
||||||
error( KIO::ERR_COULD_NOT_UNMOUNT, i18n("Could not find program \"umount\""));
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
- buffer = umountProg + QFile::encodeName(KShell::quoteArg(_point)) + " 2>" + tmpFileName;
|
|
||||||
+ buffer = umountProg + ' ' + QFile::encodeName(KShell::quoteArg(_point)) + " 2>" + tmpFileName;
|
|
||||||
system( buffer.constData() );
|
|
||||||
#endif /* HAVE_VOLMGT */
|
|
||||||
|
|
||||||
Index: kio/kio/kautomount.cpp
|
|
||||||
===================================================================
|
|
||||||
--- kio/kio/kautomount.cpp (revision 1008897)
|
|
||||||
+++ kio/kio/kautomount.cpp (revision 1008898)
|
|
||||||
@@ -108,7 +108,7 @@
|
|
||||||
};
|
|
||||||
|
|
||||||
KAutoUnmount::KAutoUnmount( const QString & _mountpoint, const QString & _desktopFile )
|
|
||||||
- : d( new KAutoUnmountPrivate(this, _desktopFile, _mountpoint) )
|
|
||||||
+ : d( new KAutoUnmountPrivate(this, _mountpoint, _desktopFile) )
|
|
||||||
{
|
|
||||||
KIO::Job * job = KIO::unmount( d->m_mountpoint );
|
|
||||||
connect( job, SIGNAL( result( KJob * ) ), this, SLOT( slotResult( KJob * ) ) );
|
|
43
kdelibs.spec
43
kdelibs.spec
@ -3,8 +3,8 @@
|
|||||||
%define strigi_ver 0.7
|
%define strigi_ver 0.7
|
||||||
|
|
||||||
Summary: K Desktop Environment 4 - Libraries
|
Summary: K Desktop Environment 4 - Libraries
|
||||||
Version: 4.3.0
|
Version: 4.3.1
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
%if 0%{?fedora} > 8
|
%if 0%{?fedora} > 8
|
||||||
Name: kdelibs
|
Name: kdelibs
|
||||||
@ -83,17 +83,6 @@ Patch20: kdelibs-4.1.70-cmake.patch
|
|||||||
|
|
||||||
# upstream
|
# upstream
|
||||||
# 4.3 branch
|
# 4.3 branch
|
||||||
# http://bugs.kde.org/202550
|
|
||||||
Patch100: kdelibs-4.3.1-kdebug#202550.patch
|
|
||||||
# http://bugs.kde.org/199557
|
|
||||||
Patch101: kdelibs-4.3.1-kdebug#199557.patch
|
|
||||||
Patch102: kdelibs-4.3.1-unmountfix.patch
|
|
||||||
# http://bugs.kde.org/170608
|
|
||||||
Patch103: kdelibs-4.3.1-copyurls.patch
|
|
||||||
# http://bugs.kde.org/195385
|
|
||||||
Patch104: kdelibs-4.3.1-copyrename.patch
|
|
||||||
# http://bugs.kde.org/200815
|
|
||||||
Patch105: kdelibs-4.3.1-toolbarEditCrash.patch
|
|
||||||
|
|
||||||
BuildRequires: qt4-devel >= 4.5.0
|
BuildRequires: qt4-devel >= 4.5.0
|
||||||
# qt4%{_?_isa} isn't provided yet -- Rex
|
# qt4%{_?_isa} isn't provided yet -- Rex
|
||||||
@ -126,6 +115,7 @@ BuildRequires: libjpeg-devel
|
|||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libxslt-devel libxml2-devel
|
BuildRequires: libxslt-devel libxml2-devel
|
||||||
|
BuildRequires: libutempter-devel
|
||||||
BuildRequires: OpenEXR-devel
|
BuildRequires: OpenEXR-devel
|
||||||
BuildRequires: openssl-devel
|
BuildRequires: openssl-devel
|
||||||
BuildRequires: pcre-devel
|
BuildRequires: pcre-devel
|
||||||
@ -133,8 +123,8 @@ BuildRequires: phonon-devel >= %{phonon_ver}
|
|||||||
BuildRequires: shared-mime-info
|
BuildRequires: shared-mime-info
|
||||||
BuildRequires: soprano-devel >= %{soprano_ver}
|
BuildRequires: soprano-devel >= %{soprano_ver}
|
||||||
BuildRequires: strigi-devel >= %{strigi_ver}
|
BuildRequires: strigi-devel >= %{strigi_ver}
|
||||||
|
BuildRequires: xz-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: libutempter-devel
|
|
||||||
# extra X deps (seemingly needed and/or checked-for by most kde4 buildscripts)
|
# extra X deps (seemingly needed and/or checked-for by most kde4 buildscripts)
|
||||||
%define x_deps libSM-devel libXcomposite-devel libXdamage-devel libxkbfile-devel libXpm-devel libXScrnSaver-devel libXtst-devel libXv-devel libXxf86misc-devel
|
%define x_deps libSM-devel libXcomposite-devel libXdamage-devel libxkbfile-devel libXpm-devel libXScrnSaver-devel libXtst-devel libXv-devel libXxf86misc-devel
|
||||||
%{?x_deps:BuildRequires: %{x_deps}}
|
%{?x_deps:BuildRequires: %{x_deps}}
|
||||||
@ -211,15 +201,9 @@ format for easy browsing.
|
|||||||
|
|
||||||
%patch0 -p1 -b .parallel_devel
|
%patch0 -p1 -b .parallel_devel
|
||||||
%patch2 -p1 -b .kde149705
|
%patch2 -p1 -b .kde149705
|
||||||
%if 0%{?fedora} >= 9
|
|
||||||
%patch5 -p1 -b .k3spell-hunspell
|
%patch5 -p1 -b .k3spell-hunspell
|
||||||
%else
|
|
||||||
# shouldn't be needed f9+, we'll see -- Rex
|
|
||||||
%patch6 -p1 -b .openssl
|
|
||||||
%endif
|
|
||||||
%patch8 -p1 -b .all-css
|
%patch8 -p1 -b .all-css
|
||||||
%patch9 -p1 -b .branding
|
%patch9 -p1 -b .branding
|
||||||
sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanager.cpp
|
|
||||||
%patch11 -p1 -b .policykit
|
%patch11 -p1 -b .policykit
|
||||||
%patch12 -p1 -b .Administration-menu
|
%patch12 -p1 -b .Administration-menu
|
||||||
%patch14 -p1 -b .libexecdir
|
%patch14 -p1 -b .libexecdir
|
||||||
@ -228,15 +212,13 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
|||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
# 4.3
|
# 4.3
|
||||||
%patch100 -p4 -b .kdebug#202550
|
|
||||||
%patch101 -p4 -b .kdebug#199557
|
|
||||||
%patch102 -p0 -b .unmountfix
|
|
||||||
%patch103 -p0 -b .copyurls
|
|
||||||
%patch104 -p0 -b .copyrename
|
|
||||||
%patch105 -p0 -b .toolbarEditCrash
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
|
# add release version
|
||||||
|
sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanager.cpp
|
||||||
|
|
||||||
mkdir -p %{_target_platform}
|
mkdir -p %{_target_platform}
|
||||||
pushd %{_target_platform}
|
pushd %{_target_platform}
|
||||||
%{cmake_kde4} -DKDE_DISTRIBUTION_TEXT="%{version}-%{release} Fedora" ..
|
%{cmake_kde4} -DKDE_DISTRIBUTION_TEXT="%{version}-%{release} Fedora" ..
|
||||||
@ -415,6 +397,15 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Aug 28 2009 Than Ngo <than@redhat.com> - 4.3.1-1
|
||||||
|
- 4.3.1
|
||||||
|
|
||||||
|
* Wed Aug 26 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.0-8
|
||||||
|
- BR: xz-devel
|
||||||
|
|
||||||
|
* Sun Aug 23 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.0-7
|
||||||
|
- buildsys_phonon patch (to be compatible with newer kde-qt.git qt builds)
|
||||||
|
|
||||||
* Wed Aug 19 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.0-6
|
* Wed Aug 19 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.0-6
|
||||||
- fix crash when editting toolbars (kdebug:200815)
|
- fix crash when editting toolbars (kdebug:200815)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user