Merge branch 'master' into f14

Conflicts:
	kdelibs.spec
This commit is contained in:
Rex Dieter 2010-08-28 23:55:59 -05:00
commit 8baa4ab87d
4 changed files with 158 additions and 7 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
kdelibs-4.5.0.tar.bz2
kdelibs-4.5.1.tar.bz2

View File

@ -0,0 +1,78 @@
diff -up kdelibs-4.5.1/knewstuff/knewstuff2/core/security.cpp.gpg2 kdelibs-4.5.1/knewstuff/knewstuff2/core/security.cpp
--- kdelibs-4.5.1/knewstuff/knewstuff2/core/security.cpp.gpg2 2009-11-30 18:27:20.000000000 -0600
+++ kdelibs-4.5.1/knewstuff/knewstuff2/core/security.cpp 2010-08-27 10:49:10.619703933 -0500
@@ -61,7 +61,7 @@ void Security::readKeys()
m_runMode = List;
m_keys.clear();
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--no-tty"
<< "--with-colon"
@@ -87,7 +87,7 @@ void Security::readSecretKeys()
}
m_runMode = ListSecret;
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--no-tty"
<< "--with-colon"
@@ -258,7 +258,7 @@ void Security::slotCheckValidity()
//verify the signature
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--status-fd=2"
<< "--command-fd=0"
@@ -340,7 +340,7 @@ void Security::slotSignFile()
//verify the signature
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--status-fd=2"
<< "--command-fd=0"
diff -up kdelibs-4.5.1/knewstuff/knewstuff3/core/security.cpp.gpg2 kdelibs-4.5.1/knewstuff/knewstuff3/core/security.cpp
--- kdelibs-4.5.1/knewstuff/knewstuff3/core/security.cpp.gpg2 2009-11-30 18:27:19.000000000 -0600
+++ kdelibs-4.5.1/knewstuff/knewstuff3/core/security.cpp 2010-08-27 10:49:50.493454042 -0500
@@ -61,7 +61,7 @@ void Security::readKeys()
m_runMode = List;
m_keys.clear();
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--no-tty"
<< "--with-colon"
@@ -87,7 +87,7 @@ void Security::readSecretKeys()
}
m_runMode = ListSecret;
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--no-tty"
<< "--with-colon"
@@ -258,7 +258,7 @@ void Security::slotCheckValidity()
//verify the signature
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--status-fd=2"
<< "--command-fd=0"
@@ -340,7 +340,7 @@ void Security::slotSignFile()
//verify the signature
m_process = new KProcess();
- *m_process << "gpg"
+ *m_process << "gpg2"
<< "--no-secmem-warning"
<< "--status-fd=2"
<< "--command-fd=0"

View File

@ -7,9 +7,11 @@
%define strigi_ver 0.7.2
# to build/include apidocs or not
%define apidocs 1
# to build/include QCH apidocs or not (currently broken)
#define apidocs_qch 1
Summary: KDE Libraries
Version: 4.5.0
Version: 4.5.1
Release: 3%{?dist}
Name: kdelibs
@ -28,6 +30,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: kde4-macros(api) >= 2
BuildRequires: kde-filesystem >= 4-23
BuildRequires: docbook-dtds docbook-style-xsl
Requires: ca-certificates
%global dbusmenu_qt_version %(pkg-config --modversion dbusmenu-qt 2>/dev/null || echo %{dbusmenu_qt_ver})
Requires: dbusmenu-qt%{?_isa} >= %{dbusmenu_qt_version}
Requires: docbook-dtds docbook-style-xsl
@ -80,7 +83,11 @@ Patch24: kdelibs-4.3.1-drkonq.patch
# -DCMAKE_SKIP_RPATH:BOOL=ON (finally)
Patch27: kdelibs-4.4.80-no_rpath.patch
# upstreamable
## upstreamable
# add gpg2 support to knewstuff, rough first try s/gpg/gpg2/
# reverting to our past gnupg2-only setup.
# TODO: try to use either gpg or gpg2, whichever is available
Patch50: kdelibs-4.5.1-knewstuff_gpg2.patch
## 4.4 upstream
@ -213,6 +220,20 @@ BuildArch: noarch
This package includes the KDE 4 API documentation in HTML
format for easy browsing.
%package apidocs-qch
Group: Development/Documentation
Summary: KDE 4 API documentation for Qt Assistant
# Not strictly required -- Rex
# Requires: %{name} = %{?epoch:%{epoch}:}%{version}
# Directory ownership (%{_qt4_docdir}/qch)
Requires: qt4
Provides: kdelibs4-apidocs-qch = %{version}-%{release}
BuildArch: noarch
%description apidocs-qch
This package includes the KDE 4 API documentation in Qt Assistant QCH
format for use with the Qt 4 Assistant or KDevelop 4.
%prep
%setup -q -n kdelibs-%{version}%{?alphatag}
@ -232,6 +253,7 @@ format for easy browsing.
%patch27 -p1 -b .no_rpath
# upstreamable patches
%patch50 -p1 -b .knewstuff_gpg2
# upstream patches
@ -254,8 +276,14 @@ make %{?_smp_mflags} -C %{_target_platform}
# build apidocs
%if 0%{?apidocs}
export QTDOCDIR=`pkg-config --variable=docdir Qt`
%if 0%{?apidocs_qch}
export PROJECT_NAME="%{name}"
export PROJECT_VERSION="%{version}%{?alphatag}"
doc/api/doxygen.sh --qhppages .
%else
doc/api/doxygen.sh .
%endif
%endif
%install
@ -272,6 +300,14 @@ mv %{buildroot}%{_kde4_sysconfdir}/xdg/menus/applications.menu \
mkdir -p %{buildroot}%{_kde4_libdir}/kconf_update_bin
mkdir -p %{buildroot}%{_kde4_libdir}/plugins/{gui_platform,styles}
## use ca-certificates' ca-bundle.crt, symlink as what most other
## distros do these days (http://bugzilla.redhat.com/521902)
if [ -f %{buildroot}%{_kde4_appsdir}/kssl/ca-bundle.crt -a \
-f /etc/pki/tls/certs/ca-bundle.crt ]; then
ln -sf /etc/pki/tls/certs/ca-bundle.crt \
%{buildroot}%{_kde4_appsdir}/kssl/ca-bundle.crt
fi
# move devel symlinks
mkdir -p %{buildroot}%{_kde4_libdir}/kde4/devel
pushd %{buildroot}%{_kde4_libdir}
@ -301,7 +337,19 @@ install -p -D doc/api/doxygen.sh %{buildroot}%{_kde4_bindir}/kde4-doxygen.sh
%if 0%{?apidocs}
mkdir -p %{buildroot}%{_kde4_docdir}/HTML/en
cp -a kdelibs-%{version}%{?alphatag}-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs
find %{buildroot}%{_kde4_docdir}/HTML/en/ -name '*.tmp' -o -name 'installdox' -exec rm -fv {} ';'
find %{buildroot}%{_kde4_docdir}/HTML/en/ -name 'installdox' -exec rm -fv {} ';'
rm -vf %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/*.tmp \
%{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/index.qhp \
%{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/*/html/index.qhp
%if 0%{?apidocs_qch}
mkdir -p %{buildroot}%{_qt4_docdir}/qch
for i in %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/*/qch
do
mv -f "$i"/* %{buildroot}%{_qt4_docdir}/qch/
rmdir "$i"
done
%endif
%endif
@ -445,12 +493,37 @@ rm -rf %{buildroot}
%files apidocs
%defattr(-,root,root,-)
%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/
%if 0%{?apidocs_qch}
%files apidocs-qch
%defattr(-,root,root,-)
%{_qt4_docdir}/qch/*.qch
%endif
%endif
%changelog
* Mon Aug 23 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-3
- -apidocs: exclude installdox
* Fri Aug 27 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.5.1-3
- make building -apidocs-qch optional and disable it by default until fixed
* Fri Aug 27 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-2
- -apidocs : exclude installdox
* Fri Aug 27 2010 Jaroslav Reznik <jreznik@redhat.com> - 4.5.1-1
- 4.5.1
- use gpg2 in knewstuff (kde#249152)
* Thu Aug 26 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-6
- use ca-certificates' ca-bundle.crt (#521902)
* Wed Aug 18 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.5.0-5
- fix packaging of QCH apidocs
* Wed Aug 18 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.5.0-4
- package QCH apidocs (-apidocs-qch noarch subpackage)
* Wed Aug 18 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.5.0-3
- generate QCH apidocs (try 1)
* Tue Aug 10 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-2
- (Build)Requires: qt4(-devel) >= 4.6.3

View File

@ -1 +1 @@
5da80f7549924808a394e6f8fb477212 kdelibs-4.5.0.tar.bz2
f91f16b4349f8a2ca41dab5ca95f3877 kdelibs-4.5.1.tar.bz2