This commit is contained in:
Jaroslav Reznik 2011-11-18 13:33:03 +01:00
parent 0daefb6f30
commit 6e0612c392
4 changed files with 32 additions and 56 deletions

3
.gitignore vendored
View File

@ -1,2 +1 @@
/kdelibs-4.7.2.tar.bz2 /kdelibs-4.7.80.tar.bz2
/kdelibs-4.7.3.tar.bz2

View File

@ -1,30 +1,13 @@
From 5bf9e0aa14f849726f3573b04eb51acfff635fc6 Mon Sep 17 00:00:00 2001 diff -up kdelibs-4.7.80/plasma/CMakeLists.txt.libplasma-pk-0001 kdelibs-4.7.80/plasma/CMakeLists.txt
Message-Id: <5bf9e0aa14f849726f3573b04eb51acfff635fc6.1312359834.git.kevin.kofler@chello.at> --- kdelibs-4.7.80/plasma/CMakeLists.txt.libplasma-pk-0001 2011-11-17 21:54:56.000000000 +0100
From: Kevin Kofler <kevin.kofler@chello.at> +++ kdelibs-4.7.80/plasma/CMakeLists.txt 2011-11-18 13:16:23.243039344 +0100
Date: Mon, 1 Aug 2011 21:53:32 +0200 @@ -6,10 +6,15 @@ if(KDE_PLATFORM_FEATURE_BINARY_COMPATIBL
Subject: [PATCH] Add an API (currently private) for installing missing Plasma
engines.
Use it when a requested data or script engine is not found.
REVIEW: 102175
---
plasma/CMakeLists.txt | 11 ++++
plasma/dataenginemanager.cpp | 4 +
plasma/private/componentinstaller.cpp | 103 +++++++++++++++++++++++++++++++++
plasma/private/componentinstaller_p.h | 94 ++++++++++++++++++++++++++++++
plasma/scripting/scriptengine.cpp | 4 +
5 files changed, 216 insertions(+), 0 deletions(-)
diff --git a/plasma/CMakeLists.txt b/plasma/CMakeLists.txt
index ef411df..f929967 100644
--- a/plasma/CMakeLists.txt
+++ b/plasma/CMakeLists.txt
@@ -6,8 +6,13 @@ if(KDE_PLATFORM_FEATURE_BINARY_COMPATIBLE_FEATURE_REDUCTION)
set(PLASMA_NO_KNEWSTUFF TRUE) set(PLASMA_NO_KNEWSTUFF TRUE)
set(PLASMA_NO_SOLID TRUE) set(PLASMA_NO_SOLID TRUE)
set(PLASMA_NO_KIO TRUE) set(PLASMA_NO_KIO TRUE)
+ set(PLASMA_NO_PACKAGEKIT TRUE) + set(PLASMA_NO_PACKAGEKIT TRUE)
set(PLASMA_NO_KUTILS TRUE)
set(PLASMA_NO_GLOBAL_SHORTCUTS TRUE)
endif(KDE_PLATFORM_FEATURE_BINARY_COMPATIBLE_FEATURE_REDUCTION) endif(KDE_PLATFORM_FEATURE_BINARY_COMPATIBLE_FEATURE_REDUCTION)
+if(NOT Q_WS_X11) +if(NOT Q_WS_X11)
@ -34,7 +17,7 @@ index ef411df..f929967 100644
include_directories(${CMAKE_CURRENT_SOURCE_DIR} include_directories(${CMAKE_CURRENT_SOURCE_DIR}
${KDE4_KDECORE_INCLUDES} ${KDE4_KDECORE_INCLUDES}
${KDE4_KDEUI_INCLUDES} ${KDE4_KDEUI_INCLUDES}
@@ -42,6 +47,11 @@ if(NOT PLASMA_NO_SOLID) @@ -44,6 +49,11 @@ if(NOT PLASMA_NO_SOLID)
set(PLASMA_EXTRA_LIBS ${PLASMA_EXTRA_LIBS} ${KDE4_SOLID_LIBS}) set(PLASMA_EXTRA_LIBS ${PLASMA_EXTRA_LIBS} ${KDE4_SOLID_LIBS})
endif(NOT PLASMA_NO_SOLID) endif(NOT PLASMA_NO_SOLID)
@ -43,10 +26,10 @@ index ef411df..f929967 100644
+ set(PLASMA_EXTRA_LIBS ${PLASMA_EXTRA_LIBS} ${QT_QTDBUS_LIBRARY}) + set(PLASMA_EXTRA_LIBS ${PLASMA_EXTRA_LIBS} ${QT_QTDBUS_LIBRARY})
+endif(NOT PLASMA_NO_PACKAGEKIT) +endif(NOT PLASMA_NO_PACKAGEKIT)
+ +
if(QCA2_FOUND) if (NOT PLASMA_NO_KUTILS)
include_directories(${QCA2_INCLUDE_DIR}) include_directories(${CMAKE_SOURCE_DIR}/kutils)
set(ENABLE_REMOTE_WIDGETS TRUE) set(PLASMA_EXTRA_LIBS ${PLASMA_EXTRA_LIBS} ${KDE4_KUTILS_LIBS})
@@ -110,6 +120,7 @@ set(plasma_LIB_SRCS @@ -117,6 +127,7 @@ set(plasma_LIB_SRCS
private/animablegraphicswebview.cpp private/animablegraphicswebview.cpp
private/applethandle.cpp private/applethandle.cpp
private/associatedapplicationmanager.cpp private/associatedapplicationmanager.cpp
@ -54,10 +37,9 @@ index ef411df..f929967 100644
private/datacontainer_p.cpp private/datacontainer_p.cpp
private/dataenginebindings.cpp private/dataenginebindings.cpp
private/dataengineconsumer.cpp private/dataengineconsumer.cpp
diff --git a/plasma/dataenginemanager.cpp b/plasma/dataenginemanager.cpp diff -up kdelibs-4.7.80/plasma/dataenginemanager.cpp.libplasma-pk-0001 kdelibs-4.7.80/plasma/dataenginemanager.cpp
index 988fe76..c98ac40 100644 --- kdelibs-4.7.80/plasma/dataenginemanager.cpp.libplasma-pk-0001 2011-08-22 15:13:55.000000000 +0200
--- a/plasma/dataenginemanager.cpp +++ kdelibs-4.7.80/plasma/dataenginemanager.cpp 2011-11-18 12:48:37.513008572 +0100
+++ b/plasma/dataenginemanager.cpp
@@ -29,6 +29,7 @@ @@ -29,6 +29,7 @@
#include "datacontainer.h" #include "datacontainer.h"
@ -66,7 +48,7 @@ index 988fe76..c98ac40 100644
#include "private/dataengine_p.h" #include "private/dataengine_p.h"
#include "private/datacontainer_p.h" #include "private/datacontainer_p.h"
#include "scripting/scriptengine.h" #include "scripting/scriptengine.h"
@@ -130,6 +131,9 @@ Plasma::DataEngine *DataEngineManager::loadEngine(const QString &name) @@ -130,6 +131,9 @@ Plasma::DataEngine *DataEngineManager::l
DataEngine *engine = PluginLoader::pluginLoader()->loadDataEngine(name); DataEngine *engine = PluginLoader::pluginLoader()->loadDataEngine(name);
if (!engine) { if (!engine) {
@ -76,11 +58,9 @@ index 988fe76..c98ac40 100644
return d->nullEngine(); return d->nullEngine();
} }
diff --git a/plasma/private/componentinstaller.cpp b/plasma/private/componentinstaller.cpp diff -up kdelibs-4.7.80/plasma/private/componentinstaller.cpp.libplasma-pk-0001 kdelibs-4.7.80/plasma/private/componentinstaller.cpp
new file mode 100644 --- kdelibs-4.7.80/plasma/private/componentinstaller.cpp.libplasma-pk-0001 2011-11-18 12:48:37.513008572 +0100
index 0000000..870667f +++ kdelibs-4.7.80/plasma/private/componentinstaller.cpp 2011-11-18 12:48:37.513008572 +0100
--- /dev/null
+++ b/plasma/private/componentinstaller.cpp
@@ -0,0 +1,103 @@ @@ -0,0 +1,103 @@
+/* +/*
+ * Copyright 2011 Kevin Kofler <kevin.kofler@chello.at> + * Copyright 2011 Kevin Kofler <kevin.kofler@chello.at>
@ -185,11 +165,9 @@ index 0000000..870667f
+} +}
+ +
+} // namespace Plasma +} // namespace Plasma
diff --git a/plasma/private/componentinstaller_p.h b/plasma/private/componentinstaller_p.h diff -up kdelibs-4.7.80/plasma/private/componentinstaller_p.h.libplasma-pk-0001 kdelibs-4.7.80/plasma/private/componentinstaller_p.h
new file mode 100644 --- kdelibs-4.7.80/plasma/private/componentinstaller_p.h.libplasma-pk-0001 2011-11-18 12:48:37.514008574 +0100
index 0000000..f85cbb6 +++ kdelibs-4.7.80/plasma/private/componentinstaller_p.h 2011-11-18 12:48:37.514008574 +0100
--- /dev/null
+++ b/plasma/private/componentinstaller_p.h
@@ -0,0 +1,94 @@ @@ -0,0 +1,94 @@
+/* +/*
+ * Copyright 2011 Kevin Kofler <kevin.kofler@chello.at> + * Copyright 2011 Kevin Kofler <kevin.kofler@chello.at>
@ -285,10 +263,9 @@ index 0000000..f85cbb6
+} // namespace Plasma +} // namespace Plasma
+ +
+#endif // multiple inclusion guard +#endif // multiple inclusion guard
diff --git a/plasma/scripting/scriptengine.cpp b/plasma/scripting/scriptengine.cpp diff -up kdelibs-4.7.80/plasma/scripting/scriptengine.cpp.libplasma-pk-0001 kdelibs-4.7.80/plasma/scripting/scriptengine.cpp
index fb8cd1a..21f8a9a 100644 --- kdelibs-4.7.80/plasma/scripting/scriptengine.cpp.libplasma-pk-0001 2011-09-26 11:41:11.000000000 +0200
--- a/plasma/scripting/scriptengine.cpp +++ kdelibs-4.7.80/plasma/scripting/scriptengine.cpp 2011-11-18 12:48:37.514008574 +0100
+++ b/plasma/scripting/scriptengine.cpp
@@ -27,6 +27,7 @@ @@ -27,6 +27,7 @@
#include "applet.h" #include "applet.h"
#include "dataengine.h" #include "dataengine.h"
@ -297,7 +274,7 @@ index fb8cd1a..21f8a9a 100644
#include "scripting/appletscript.h" #include "scripting/appletscript.h"
#include "scripting/dataenginescript.h" #include "scripting/dataenginescript.h"
#include "scripting/runnerscript.h" #include "scripting/runnerscript.h"
@@ -196,6 +197,9 @@ ScriptEngine *loadEngine(const QString &language, ComponentType type, QObject *p @@ -196,6 +197,9 @@ ScriptEngine *loadEngine(const QString &
<< "! error reported: " << error; << "! error reported: " << error;
} }
@ -307,6 +284,3 @@ index fb8cd1a..21f8a9a 100644
return 0; return 0;
} }
--
1.7.4.4

View File

@ -22,8 +22,8 @@
%define no_libkactivities 1 %define no_libkactivities 1
Summary: KDE Libraries Summary: KDE Libraries
Version: 4.7.3 Version: 4.7.80
Release: 5%{?dist} Release: 1%{?dist}
Name: kdelibs Name: kdelibs
Epoch: 6 Epoch: 6
@ -573,6 +573,9 @@ rm -rf %{buildroot}
%changelog %changelog
* Fri Nov 18 2011 Jaroslav Reznik <jreznik@redhat.com> 4.7.80-1
- 4.7.80 (beta 1)
* Wed Nov 16 2011 Rex Dieter <rdieter@fedoraproject.org> 4.7.3-5 * Wed Nov 16 2011 Rex Dieter <rdieter@fedoraproject.org> 4.7.3-5
- restore halectomy patch (sans fstab-removing pieces) - restore halectomy patch (sans fstab-removing pieces)

View File

@ -1 +1 @@
57fdc211995a6846b15dfdbf40a3e2e3 kdelibs-4.7.3.tar.bz2 b95b6690d85eded585095ba19ec5eaba kdelibs-4.7.80.tar.bz2