This commit is contained in:
Rex Dieter 2015-04-10 10:40:32 -05:00
parent c88f7f4469
commit 647c75e513
7 changed files with 7 additions and 1537 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
/kdelibs-4.14.6.tar.xz
/kdelibs-4.14.7.tar.xz

File diff suppressed because it is too large Load Diff

View File

@ -1,27 +0,0 @@
From 45edd7e5c333ea5dd90e3a9814b1f30216dda667 Mon Sep 17 00:00:00 2001
From: Luigi Toscano <luigi.toscano@tiscali.it>
Date: Tue, 3 Mar 2015 23:42:03 +0100
Subject: [PATCH 2/4] More up-to-date image for web pages (forgotten cmake fix)
The new image is now installed; followup of review 122080.
This change is not needed in Frameworks due to the different way
CMakeLists.txt works there.
---
doc/common/CMakeLists.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/doc/common/CMakeLists.txt b/doc/common/CMakeLists.txt
index 4228625..0380fe9 100644
--- a/doc/common/CMakeLists.txt
+++ b/doc/common/CMakeLists.txt
@@ -29,5 +29,6 @@ install(FILES
top-middle.png
top-right.png
top-left.png
+ part_of_the_kde_family_horizontal_190.png
1.png 2.png 3.png 4.png 5.png 6.png 7.png 8.png 9.png 10.png
DESTINATION ${HTML_INSTALL_DIR}/en/common)
--
2.3.1

View File

@ -1,61 +0,0 @@
From 92d3cb4804bad73f8ebabf9be8f6f2a2c0daa471 Mon Sep 17 00:00:00 2001
From: Andrea Iacovitti <aiacovitti@libero.it>
Date: Thu, 5 Mar 2015 15:05:11 +0100
Subject: [PATCH 3/4] Fix BIC introduced in 4.14.6
REVIEW: 122812
---
khtml/dom/dom_string.cpp | 7 +++++++
khtml/dom/dom_string.h | 15 ++++++++++++++-
2 files changed, 21 insertions(+), 1 deletion(-)
diff --git a/khtml/dom/dom_string.cpp b/khtml/dom/dom_string.cpp
index a3c4abd..4da676b 100644
--- a/khtml/dom/dom_string.cpp
+++ b/khtml/dom/dom_string.cpp
@@ -336,6 +336,13 @@ DOMString DOMString::parsedUrl() const
return out;
}
+#ifndef KDE_NO_DEPRECATED
+DOMString DOMString::trimSpaces() const
+{
+ return parsedUrl();
+}
+#endif
+
// ------------------------------------------------------------------------
bool DOM::strcasecmp( const DOMString &as, const DOMString &bs )
diff --git a/khtml/dom/dom_string.h b/khtml/dom/dom_string.h
index 087f697..b269213 100644
--- a/khtml/dom/dom_string.h
+++ b/khtml/dom/dom_string.h
@@ -124,10 +124,23 @@ public:
bool endsWith(const DOMString& str) const;
bool startsWith(const DOMString& str) const;
- // http://www.w3.org/TR/html/infrastructure.html#urls
+ /**
+ * Return a parsed url.
+ * Used to parse SRC url attribute,
+ * see http://www.w3.org/TR/html/infrastructure.html#urls
+ *
+ * @since 4.14.6
+ */
DOMString parsedUrl() const;
/**
+ * @deprecated, use parsedUrl()
+ */
+#ifndef KDE_NO_DEPRECATED
+ KDE_DEPRECATED DOMString trimSpaces() const;
+#endif
+
+ /**
* @internal get a handle to the imlementation of the DOMString
* Use at own risk!!!
*/
--
2.3.1

View File

@ -1,56 +0,0 @@
From e957417b21f68cceeb8536fe60f880c40bb7a7d5 Mon Sep 17 00:00:00 2001
From: Andrea Iacovitti <aiacovitti@libero.it>
Date: Fri, 6 Mar 2015 23:30:14 +0100
Subject: [PATCH 4/4] Fix parsing single-quoted meta charset attribute. Ignore
whitespaces after the quote.
BUG: 322484
FIXED-IN: 4.14.7
---
kdecore/localization/kencodingdetector.cpp | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/kdecore/localization/kencodingdetector.cpp b/kdecore/localization/kencodingdetector.cpp
index 1f20bec..13b4909 100644
--- a/kdecore/localization/kencodingdetector.cpp
+++ b/kdecore/localization/kencodingdetector.cpp
@@ -1031,6 +1031,7 @@ bool KEncodingDetector::analyze(const char *data, int len)
//if ( *end == '\0' ) break;
QByteArray str( ptr, (end-ptr)+1);
str = str.toLower();
+ const int strLength = str.length();
int pos=0;
//if( (pos = str.find("http-equiv", pos)) == -1) break;
//if( (pos = str.find("content-type", pos)) == -1) break;
@@ -1045,19 +1046,22 @@ bool KEncodingDetector::analyze(const char *data, int len)
++pos;
// skip whitespace before encoding itself
- while (pos < (int)str.length() && str[pos] <= ' ')
+ while (pos < strLength && str[pos] <= ' ')
++pos;
- // there may also be an opening quote, if this is a charset= and not
- // a http-equiv.
- if (pos < (int)str.length() && str[pos] == '"')
+ // there may also be an opening quote, if this is a charset= and not a http-equiv.
+ if (pos < strLength && (str[pos] == '"' || str[pos] == '\''))
++pos;
- if ( pos == (int)str.length())
+ // skip whitespace
+ while (pos < strLength && str[pos] <= ' ')
+ ++pos;
+
+ if ( pos == strLength)
continue;
int endpos = pos;
- while( endpos < str.length() &&
+ while( endpos < strLength &&
(str[endpos] != ' ' && str[endpos] != '"' && str[endpos] != '\''
&& str[endpos] != ';' && str[endpos] != '>') )
++endpos;
--
2.3.1

View File

@ -47,8 +47,8 @@
Summary: KDE Libraries
# shipped with kde applications, version...
%global apps_version 14.12.3
Version: 4.14.6
Release: 2%{?dist}
Version: 4.14.7
Release: 1%{?dist}
Name: kdelibs
Epoch: 6
@ -188,10 +188,6 @@ Patch64: kdelibs-4.13.2-invokeTerminal.patch
## upstream
# 4.14 branch
Patch101: 0001-Add-dollar.patch
Patch102: 0002-More-up-to-date-image-for-web-pages-forgotten-cmake-.patch
Patch103: 0003-Fix-BIC-introduced-in-4.14.6.patch
Patch104: 0004-Fix-parsing-single-quoted-meta-charset-attribute.patch
# revert these commits for
#https://bugs.kde.org/315578
@ -445,10 +441,6 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch64 -p1 -b .invokeTerminal
# upstream patches
%patch101 -p1 -b .0001
%patch102 -p1 -b .0002
%patch103 -p1 -b .0003
%patch104 -p1 -b .0004
%patch090 -p1 -R -b .return-not-break.-copy-paste-error
%patch091 -p1 -R -b .coding-style-fixes.patch
@ -805,6 +797,9 @@ update-mime-database %{?fedora:-n} %{_datadir}/mime &> /dev/null || :
%changelog
* Fri Apr 10 2015 Rex Dieter <rdieter@fedoraproject.org> - 6:4.14.7-1
- 4.14.7
* Sun Mar 08 2015 Rex Dieter <rdieter@fedoraproject.org> - 6:4.14.6-2
- pull in upstream fixes, including minor BIC fix for 4.14.6
- disable plasma/pacakgekit feature (for f22+)

View File

@ -1 +1 @@
fbd349f460a00b91327f470313f4218b kdelibs-4.14.6.tar.xz
31359eecc8543843a13b35a0c7004dc1 kdelibs-4.14.7.tar.xz