Merge remote branch 'origin/master' into f14/master
This commit is contained in:
commit
612c898d8c
14
kdelibs-4.5.2-kio_krun_services.patch
Normal file
14
kdelibs-4.5.2-kio_krun_services.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- branches/KDE/4.5/kdelibs/kio/kio/krun.cpp 2010/10/15 15:53:49 1186277
|
||||||
|
+++ branches/KDE/4.5/kdelibs/kio/kio/krun.cpp 2010/10/15 16:00:27 1186278
|
||||||
|
@@ -368,9 +368,9 @@
|
||||||
|
}
|
||||||
|
else {
|
||||||
|
if (supportedProtocols.isEmpty()) {
|
||||||
|
- // compat mode: assume KIO if not set and it's a KDE app
|
||||||
|
+ // compat mode: assume KIO if not set and it's a KDE app (or a KDE service)
|
||||||
|
const QStringList categories = _service.property("Categories").toStringList();
|
||||||
|
- if (categories.contains("KDE")) {
|
||||||
|
+ if (categories.contains("KDE") || !_service.isApplication()) {
|
||||||
|
supportedProtocols.append("KIO");
|
||||||
|
}
|
||||||
|
else { // if no KDE app, be a bit over-generic
|
36
kdelibs-4.5.2-plasma_wallpaper_configchanged.patch
Normal file
36
kdelibs-4.5.2-plasma_wallpaper_configchanged.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
--- trunk/KDE/kdelibs/plasma/containment.cpp 2010/10/14 15:42:21 1185911
|
||||||
|
+++ trunk/KDE/kdelibs/plasma/containment.cpp 2010/10/14 15:46:05 1185912
|
||||||
|
@@ -2079,6 +2079,17 @@
|
||||||
|
Applet::showConfigurationInterface();
|
||||||
|
}
|
||||||
|
|
||||||
|
+void Containment::configChanged()
|
||||||
|
+{
|
||||||
|
+ if (d->drawWallpaper) {
|
||||||
|
+ KConfigGroup group = config();
|
||||||
|
+ setWallpaper(group.readEntry("wallpaperplugin", defaultWallpaper),
|
||||||
|
+ group.readEntry("wallpaperpluginmode", defaultWallpaperMode));
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
+ Applet::configChanged();
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
void ContainmentPrivate::requestConfiguration()
|
||||||
|
{
|
||||||
|
emit q->configureRequested(q);
|
||||||
|
--- trunk/KDE/kdelibs/plasma/containment.h 2010/10/14 15:42:21 1185911
|
||||||
|
+++ trunk/KDE/kdelibs/plasma/containment.h 2010/10/14 15:46:05 1185912
|
||||||
|
@@ -527,6 +527,13 @@
|
||||||
|
*/
|
||||||
|
void showConfigurationInterface();
|
||||||
|
|
||||||
|
+ /**
|
||||||
|
+ * Called when applet configuration values have changed.
|
||||||
|
+ * @reimp
|
||||||
|
+ * @sa Applet::configChanged()
|
||||||
|
+ */
|
||||||
|
+ void configChanged();
|
||||||
|
+
|
||||||
|
protected:
|
||||||
|
/**
|
||||||
|
* Sets the type of this containment.
|
18
kdelibs.spec
18
kdelibs.spec
@ -12,7 +12,7 @@
|
|||||||
|
|
||||||
Summary: KDE Libraries
|
Summary: KDE Libraries
|
||||||
Version: 4.5.2
|
Version: 4.5.2
|
||||||
Release: 5%{?dist}
|
Release: 7%{?dist}
|
||||||
|
|
||||||
Name: kdelibs
|
Name: kdelibs
|
||||||
Epoch: 6
|
Epoch: 6
|
||||||
@ -90,10 +90,14 @@ Patch27: kdelibs-4.4.80-no_rpath.patch
|
|||||||
Patch50: kdelibs-4.5.1-knewstuff_gpg2.patch
|
Patch50: kdelibs-4.5.1-knewstuff_gpg2.patch
|
||||||
|
|
||||||
## 4.5 upstream
|
## 4.5 upstream
|
||||||
Patch100: kdelibs-4.5.2-comic_applet_kde253387.patch
|
Patch100: kdelibs-4.5.2-comic_applet_kde253387.patch
|
||||||
|
# http://websvn.kde.org/?view=revision&revision=1186278
|
||||||
|
Patch101: kdelibs-4.5.2-kio_krun_services.patch
|
||||||
|
|
||||||
## trunk upstream
|
## trunk upstream
|
||||||
Patch150: kdelibs-4.5.2-krun-kde#253294.patch
|
Patch150: kdelibs-4.5.2-krun-kde#253294.patch
|
||||||
|
# http://websvn.kde.org/?view=revision&revision=1185912
|
||||||
|
Patch151: kdelibs-4.5.2-plasma_wallpaper_configchanged.patch
|
||||||
|
|
||||||
## security fix
|
## security fix
|
||||||
# Not Upstreamed? why not ? -- Rex
|
# Not Upstreamed? why not ? -- Rex
|
||||||
@ -261,7 +265,9 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
|||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p4 -b .comic_applet_kde253387
|
%patch100 -p4 -b .comic_applet_kde253387
|
||||||
|
%patch101 -p4 -b .kio_krun_services
|
||||||
%patch150 -p1 -b .kde#253294
|
%patch150 -p1 -b .kde#253294
|
||||||
|
%patch151 -p3 -b .plasma_wallpaper_configchanged
|
||||||
|
|
||||||
# security fix
|
# security fix
|
||||||
%patch200 -p1 -b .CVE-2009-2702
|
%patch200 -p1 -b .CVE-2009-2702
|
||||||
@ -506,8 +512,14 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-7
|
||||||
|
- backport configChanged() for wallpaper
|
||||||
|
|
||||||
|
* Fri Oct 15 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-6
|
||||||
|
- kio/krun patch so kde services can open urls directly too
|
||||||
|
|
||||||
* Fri Oct 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-5
|
* Fri Oct 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.5.2-5
|
||||||
- switching comic in commic applet crashes plasma (kde#253387,rh#640619)
|
- switching comic in comic applet crashes plasma (kde#253387,rh#640619)
|
||||||
|
|
||||||
* Thu Oct 07 2010 Than Ngo <than@redhat.com> - 4.5.2-4
|
* Thu Oct 07 2010 Than Ngo <than@redhat.com> - 4.5.2-4
|
||||||
- kde253294, KMail and Kopete download and open https url instead of only opening
|
- kde253294, KMail and Kopete download and open https url instead of only opening
|
||||||
|
Loading…
Reference in New Issue
Block a user