Revert "Fix build failure by adding pthread linkage explicitely"

This reverts commit 060432be2b.
This commit is contained in:
Rex Dieter 2011-09-15 13:38:28 -05:00
parent 060432be2b
commit 60b21b6ab4
2 changed files with 1 additions and 32 deletions

View File

@ -1,24 +0,0 @@
diff -up kdelibs-4.7.1/kdecore/CMakeLists.txt.missing-pthread-linkage kdelibs-4.7.1/kdecore/CMakeLists.txt
--- kdelibs-4.7.1/kdecore/CMakeLists.txt.missing-pthread-linkage 2011-09-14 09:18:00.907260238 +0200
+++ kdelibs-4.7.1/kdecore/CMakeLists.txt 2011-09-14 09:34:58.083605518 +0200
@@ -395,7 +395,7 @@ endif (NOT Q_WS_X11 AND NOT Q_WS_QWS)
kde4_add_library(kdecore ${LIBRARY_TYPE} ${kdecore_LIB_SRCS})
-target_link_libraries(kdecore ${QT_QTCORE_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${QT_QTDBUS_LIBRARY} ${QT_QTXML_LIBRARY} ${ZLIB_LIBRARY} ${kdecore_OPTIONAL_LIBS})
+target_link_libraries(kdecore ${QT_QTCORE_LIBRARY} ${QT_QTNETWORK_LIBRARY} ${QT_QTDBUS_LIBRARY} ${QT_QTXML_LIBRARY} ${ZLIB_LIBRARY} ${kdecore_OPTIONAL_LIBS} pthread)
if(WINCE)
target_link_libraries(kdecore ${WCECOMPAT_LIBRARIES} Ceshell.lib)
diff -up kdelibs-4.7.1/kjs/CMakeLists.txt.missing-pthread-linkage kdelibs-4.7.1/kjs/CMakeLists.txt
--- kdelibs-4.7.1/kjs/CMakeLists.txt.missing-pthread-linkage 2011-09-14 09:23:11.345676225 +0200
+++ kdelibs-4.7.1/kjs/CMakeLists.txt 2011-09-14 09:23:33.985287017 +0200
@@ -210,7 +210,7 @@ if(CMAKE_THREAD_LIBS_INIT)
endif(CMAKE_THREAD_LIBS_INIT)
if(UNIX)
- target_link_libraries(${KJSLIBNAME} m)
+ target_link_libraries(${KJSLIBNAME} m pthread)
endif(UNIX)
if(PCRE_FOUND)

View File

@ -20,7 +20,7 @@
Summary: KDE Libraries
Version: 4.7.1
Release: 2%{?dist}
Release: 1%{?dist}
Name: kdelibs
Epoch: 6
@ -89,9 +89,6 @@ Patch18: kdelibs-4.6.90-kstandarddirs.patch
# set build type
Patch20: kdelibs-4.1.70-cmake.patch
# Explicitely specify linkage of pthread library
Patch21: kdelibs-4.7.1-missing-pthread-linkage.patch
# die rpath die, since we're using standard paths, we can avoid
# this extra hassle (even though cmake is *supposed* to not add standard
# paths (like /usr/lib64) already! With this, we can drop
@ -300,7 +297,6 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch14 -p1 -b .libexecdir
%patch18 -p1 -b .kstandarddirs
%patch20 -p1 -b .xxcmake
%patch21 -p1 -b .missing-pthread-linkage
%patch27 -p1 -b .no_rpath
# libplasma PackageKit integration
@ -565,9 +561,6 @@ rm -rf %{buildroot}
%changelog
* Wed Sep 14 2011 Radek Novacek <rnovacek@redhat.com> 4.7.1-2
- Fix build failure by adding pthread linkage explicitely
* Fri Sep 02 2011 Than Ngo <than@redhat.com> - 4.7.1-1
- 4.7.1