- remove redundant FEDORA, use CMAKE_BUILD_TYPE=release
- fix install problem with cmake > 2.5
This commit is contained in:
parent
488e7455b6
commit
5bdcb098f7
@ -1,17 +0,0 @@
|
||||
diff -ur kdelibs-4.0.3/cmake/modules/FindKDE4Internal.cmake kdelibs-4.0.3-fedora-buildtype/cmake/modules/FindKDE4Internal.cmake
|
||||
--- kdelibs-4.0.3/cmake/modules/FindKDE4Internal.cmake 2008-03-27 21:33:23.000000000 +0100
|
||||
+++ kdelibs-4.0.3-fedora-buildtype/cmake/modules/FindKDE4Internal.cmake 2008-03-31 17:34:40.000000000 +0200
|
||||
@@ -882,11 +882,13 @@
|
||||
set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
|
||||
set(CMAKE_CXX_FLAGS_DEBUGFULL "-g3 -fno-inline")
|
||||
set(CMAKE_CXX_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
|
||||
+ set(CMAKE_CXX_FLAGS_FEDORA "-DNDEBUG -DQT_NO_DEBUG")
|
||||
set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
|
||||
set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG -DQT_NO_DEBUG")
|
||||
set(CMAKE_C_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
|
||||
set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline")
|
||||
set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
|
||||
+ set(CMAKE_C_FLAGS_FEDORA "-DNDEBUG -DQT_NO_DEBUG")
|
||||
|
||||
if (CMAKE_SYSTEM_NAME MATCHES Linux)
|
||||
set ( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")
|
34
kdelibs-4.1.1-cmake.patch
Normal file
34
kdelibs-4.1.1-cmake.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff -up kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake.orig kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake
|
||||
--- kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake.orig 2008-09-12 23:54:36.000000000 +0200
|
||||
+++ kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake 2008-09-13 00:02:50.000000000 +0200
|
||||
@@ -745,6 +745,7 @@ endif(WIN32)
|
||||
# CMake generators if no build type is set.
|
||||
if (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
|
||||
set(CMAKE_BUILD_TYPE RelWithDebInfo)
|
||||
+ set(CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} CMAKE_BUILD_TYPE)
|
||||
endif (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
|
||||
|
||||
|
||||
@@ -953,10 +954,6 @@ endif(MSVC)
|
||||
|
||||
|
||||
if (CMAKE_COMPILER_IS_GNUCXX)
|
||||
- if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
|
||||
- set (CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} "Debugfull")
|
||||
- endif("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
|
||||
-
|
||||
set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
|
||||
# Select flags.
|
||||
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
|
||||
@@ -1063,11 +1060,6 @@ endif (CMAKE_COMPILER_IS_GNUCXX)
|
||||
|
||||
|
||||
if (CMAKE_C_COMPILER MATCHES "icc")
|
||||
-
|
||||
- if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
|
||||
- set (CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} "Debugfull")
|
||||
- endif("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
|
||||
-
|
||||
set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
|
||||
# Select flags.
|
||||
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
|
13
kdelibs.spec
13
kdelibs.spec
@ -2,7 +2,7 @@
|
||||
|
||||
Summary: K Desktop Environment 4 - Libraries
|
||||
Version: 4.1.1
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
|
||||
%if 0%{?fedora} > 8
|
||||
Name: kdelibs
|
||||
@ -28,7 +28,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
%define rest 1
|
||||
%endif
|
||||
|
||||
BuildRequires: kde4-macros(api) >= 2
|
||||
BuildRequires: kde4-macros(api) >= 3
|
||||
BuildRequires: kde-filesystem >= 4
|
||||
Requires: dbus-x11
|
||||
Requires: hicolor-icon-theme
|
||||
@ -71,14 +71,13 @@ Patch10: kdelibs-4.0.2-no-cache-kdeglobals-paths.patch
|
||||
# workaround for policykit
|
||||
Patch11: kdelibs-4.0.2-policykit-workaround.patch
|
||||
Patch12: kdelibs-4.1.0-xdg-menu.patch
|
||||
# Fedora build type - adds -DNDEBUG -DQT_NO_DEBUG, removes -O2 -g (already in RPM_OPT_FLAGS)
|
||||
Patch13: kdelibs-4.0.5-fedora-buildtype.patch
|
||||
# patch KStandardDirs to use %{_libexecdir}/kde4 instead of %{_libdir}/kde4/libexec
|
||||
Patch14: kdelibs-4.0.85-libexecdir.patch
|
||||
# kstandarddirs changes: search /etc/kde, find /usr/libexec/kde4
|
||||
Patch18: kdelibs-4.1.0-kstandarddirs.patch
|
||||
# fix running commands in kglobalconfig before KComponentData init (#455130)
|
||||
Patch19: kdelibs-4.1.0-#455130.patch
|
||||
Patch20: kdelibs-4.1.1-cmake.patch
|
||||
|
||||
## upstream patches
|
||||
Patch100: kdelibs-4.1.1-kde#169447-khtml-regression.patch
|
||||
@ -206,10 +205,10 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
%patch10 -p1 -b .no-cache-kdeglobals-paths
|
||||
%patch11 -p1 -b .policykit
|
||||
%patch12 -p1 -b .Administration-menu
|
||||
%patch13 -p1 -b .fedora-buildtype
|
||||
%patch14 -p1 -b .libexecdir
|
||||
%patch18 -p1 -b .kstandarddirs
|
||||
%patch19 -p1 -b .#455130
|
||||
%patch20 -p1 -b .cmake
|
||||
|
||||
## upstream patches
|
||||
%patch100 -p0 -b .kde#169447-khtml-regression
|
||||
@ -377,6 +376,10 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Sep 13 2008 Than Ngo <than@redhat.com> 4.1.1-7
|
||||
- remove redundant FEDORA, use CMAKE_BUILD_TYPE=release
|
||||
- fix install problem with cmake > 2.5
|
||||
|
||||
* Mon Sep 08 2008 Lukáš Tinkl <ltinkl@redhat.com> 4.1.1-6
|
||||
- fix crashes in plugin selector
|
||||
- fix problems in various kdeui widgets
|
||||
|
Loading…
Reference in New Issue
Block a user