import kdelibs 4.1.69

This commit is contained in:
Lorenzo Villani 2008-10-17 17:49:41 +00:00
parent 110dc2b3a8
commit 46768e5f89
10 changed files with 270 additions and 239 deletions

View File

@ -1 +1 @@
kdelibs-4.1.2.tar.bz2
kdelibs-4.1.69.tar.bz2

1
import.log Normal file
View File

@ -0,0 +1 @@
kdelibs-4_1_69-1_fc10:HEAD:kdelibs-4.1.69-1.fc10.src.rpm:1224265644

View File

@ -0,0 +1,17 @@
diff -ur kdelibs-4.0.3/cmake/modules/FindKDE4Internal.cmake kdelibs-4.0.3-fedora-buildtype/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.0.3/cmake/modules/FindKDE4Internal.cmake 2008-03-27 21:33:23.000000000 +0100
+++ kdelibs-4.0.3-fedora-buildtype/cmake/modules/FindKDE4Internal.cmake 2008-03-31 17:34:40.000000000 +0200
@@ -882,11 +882,13 @@
set(CMAKE_CXX_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
set(CMAKE_CXX_FLAGS_DEBUGFULL "-g3 -fno-inline")
set(CMAKE_CXX_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
+ set(CMAKE_CXX_FLAGS_FEDORA "-DNDEBUG -DQT_NO_DEBUG")
set(CMAKE_C_FLAGS_RELWITHDEBINFO "-O2 -g")
set(CMAKE_C_FLAGS_RELEASE "-O2 -DNDEBUG -DQT_NO_DEBUG")
set(CMAKE_C_FLAGS_DEBUG "-g -O2 -fno-reorder-blocks -fno-schedule-insns -fno-inline")
set(CMAKE_C_FLAGS_DEBUGFULL "-g3 -fno-inline")
set(CMAKE_C_FLAGS_PROFILE "-g3 -fno-inline -ftest-coverage -fprofile-arcs")
+ set(CMAKE_C_FLAGS_FEDORA "-DNDEBUG -DQT_NO_DEBUG")
if (CMAKE_SYSTEM_NAME MATCHES Linux)
set ( CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common")

View File

@ -1,34 +0,0 @@
diff -up kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake.orig kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake.orig 2008-09-12 23:54:36.000000000 +0200
+++ kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake 2008-09-13 00:02:50.000000000 +0200
@@ -745,6 +745,7 @@ endif(WIN32)
# CMake generators if no build type is set.
if (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo)
+ set(CMAKE_CONFIGURATION_TYPES ${CMAKE_BUILD_TYPE})
endif (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
@@ -953,10 +954,6 @@ endif(MSVC)
if (CMAKE_COMPILER_IS_GNUCXX)
- if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
- set (CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} "Debugfull")
- endif("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
-
set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
# Select flags.
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
@@ -1063,11 +1060,6 @@ endif (CMAKE_COMPILER_IS_GNUCXX)
if (CMAKE_C_COMPILER MATCHES "icc")
-
- if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
- set (CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} "Debugfull")
- endif("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
-
set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
# Select flags.
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")

View File

@ -1,19 +1,20 @@
diff -ur kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.0.2-userdiskmount/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp 2008-01-05 01:00:10.000000000 +0100
+++ kdelibs-4.0.2-userdiskmount/solid/solid/backends/hal/halstorageaccess.cpp 2008-03-18 11:00:40.000000000 +0100
@@ -20,6 +20,7 @@
diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp 2008-10-09 11:48:40.000000000 +0200
+++ kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.cpp 2008-10-17 15:19:48.000000000 +0200
@@ -17,6 +17,8 @@
*/
+#include <config-prefix.h> // for LIBEXEC_INSTALL_DIR
+
#include "halstorageaccess.h"
#include <QtCore/QDebug>
+#include <QtCore/QProcess>
#include <QtDBus/QDBusConnection>
#include <QtDBus/QDBusInterface>
#include <QtDBus/QDBusReply>
@@ -131,11 +132,21 @@
#include "halfstabhandling.h"
@@ -168,11 +170,21 @@
{
// TODO: Better error reporting here
if (m_setupInProgress) {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (callPrivilegedMount())
+ return;
+ // if we fail to run kdesu, fall through and emit the original PermissionDeniedByPolicy error
@ -23,7 +24,7 @@ diff -ur kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.0
error.name()+": "+error.message(),
m_device->udi());
} else if (m_teardownInProgress) {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (error.name() == "org.freedesktop.Hal.Device.PermissionDeniedByPolicy") {
+ if (callPrivilegedUnmount())
+ return;
+ // if we fail to run kdesu, fall through and emit the original PermissionDeniedByPolicy error
@ -31,19 +32,28 @@ diff -ur kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.0
m_teardownInProgress = false;
emit teardownDone(Solid::UnauthorizedOperation,
error.name()+": "+error.message(),
@@ -229,8 +240,10 @@
@@ -266,17 +278,18 @@
"Mount");
QStringList options;
QStringList halOptions = m_device->property("volume.mount.valid_options").toStringList();
+ QString fstype = m_device->property("volume.fstype").toString();
- if (halOptions.contains("uid=")) {
+ if (halOptions.contains("uid=")
+ && (fstype == "vfat" || fstype == "iso9660" || fstype == "hfs" || fstype == "udf")) {
options << "uid="+QString::number(::getuid());
#ifdef Q_OS_FREEBSD
QString uid="-u=";
#else
QString uid="uid=";
#endif
- if (halOptions.contains(uid)) {
+ if (halOptions.contains(uid)
+ && (fstype == "vfat" || fstype == "iso9660" || fstype == "hfs" || fstype == "udf")) {
options << uid+QString::number(::getuid());
}
@@ -256,6 +269,59 @@
- QString fstype=m_device->property("volume.fstype").toString();
//respect Microsoft Windows-enforced charsets for fat
#ifdef Q_OS_FREEBSD
if ( fstype=="vfat" ) {
@@ -377,6 +390,60 @@
SLOT(slotDBusError(const QDBusError &)));
}
@ -100,12 +110,13 @@ diff -ur kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.0
+ }
+}
+
bool Solid::Backends::Hal::StorageAccess::callSystemMount()
+
bool StorageAccess::callHalVolumeUnmount()
{
const QString device = m_device->property("block.device").toString();
diff -ur kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.0.2-userdiskmount/solid/solid/backends/hal/halstorageaccess.h
--- kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.h 2008-01-05 01:00:11.000000000 +0100
+++ kdelibs-4.0.2-userdiskmount/solid/solid/backends/hal/halstorageaccess.h 2008-03-18 09:26:39.000000000 +0100
QDBusConnection c = QDBusConnection::systemBus();
diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.h
--- kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.h 2008-05-21 13:07:38.000000000 +0200
+++ kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.h 2008-10-17 14:59:31.000000000 +0200
@@ -69,6 +69,9 @@
bool callSystemMount();
bool callSystemUnmount();
@ -116,15 +127,3 @@ diff -ur kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.0.2
bool requestPassphrase();
void callCryptoSetup(const QString &passphrase);
bool callCryptoTeardown();
diff -up kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp.orig kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp.orig 2008-03-26 17:00:23.000000000 +0100
+++ kdelibs-4.0.2/solid/solid/backends/hal/halstorageaccess.cpp 2008-03-26 17:04:35.000000000 +0100
@@ -17,6 +17,8 @@
*/
+#include <config-prefix.h> // for LIBEXEC_INSTALL_DIR
+
#include "halstorageaccess.h"
#include <QtCore/QDebug>

View File

@ -0,0 +1,17 @@
--- kdecore/kconfig_compiler/CMakeLists.txt.orig 2008-09-05 13:16:43.000000000 +0200
+++ kdecore/kconfig_compiler/CMakeLists.txt 2008-09-05 13:16:57.000000000 +0200
@@ -8,11 +8,11 @@
set(kconfig_compiler_SRCS kconfig_compiler.cpp)
-kde4_add_executable(kconfig_compiler NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
+kde4_add_executable(kconfig_compiler4 NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
-target_link_libraries(kconfig_compiler ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
+target_link_libraries(kconfig_compiler4 ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
-install(TARGETS kconfig_compiler DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS kconfig_compiler4 DESTINATION ${BIN_INSTALL_DIR} )
########### install files ###############

View File

@ -0,0 +1,30 @@
--- kdewidgets/CMakeLists.txt.orig 2008-09-05 13:18:25.000000000 +0200
+++ kdewidgets/CMakeLists.txt 2008-09-05 13:19:35.000000000 +0200
@@ -16,22 +16,22 @@
set(makekdewidgets_SRCS makekdewidgets.cpp )
-kde4_add_executable(makekdewidgets NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
+kde4_add_executable(makekdewidgets4 NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
-target_link_libraries(makekdewidgets ${KDE4_KDECORE_LIBS} )
+target_link_libraries(makekdewidgets4 ${KDE4_KDECORE_LIBS} )
-install(TARGETS makekdewidgets DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS makekdewidgets4 DESTINATION ${BIN_INSTALL_DIR} )
########### next target ###############
# get the name of the generated wrapper script (which sets up LD_LIBRARY_PATH)
-get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets WRAPPER_SCRIPT)
+get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets4 WRAPPER_SCRIPT)
add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp
COMMAND "${MAKEKDEWIDGETS_EXECUTABLE}" -o ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp ${CMAKE_CURRENT_SOURCE_DIR}/kde.widgets
- MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets)
+ MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets4)
set(kdewidgets_PART_SRCS
classpreviews.cpp

View File

@ -1,6 +1,5 @@
diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel 2008-07-23 10:26:30.000000000 +0200
+++ kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake 2008-07-23 18:11:28.000000000 +0200
--- cmake/modules/FindKDE4Internal.cmake.orig 2008-09-05 12:25:51.000000000 +0200
+++ cmake/modules/FindKDE4Internal.cmake 2008-09-05 12:37:45.000000000 +0200
@@ -15,10 +15,10 @@
# The following variables are defined for the various tools required to
# compile KDE software:
@ -14,6 +13,15 @@ diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdeli
#
# The following variables point to the location of the KDE libraries,
# but shouldn't be used directly:
@@ -72,7 +72,7 @@
# KDE4_KNEPOMUK_LIBS - the knepomuk library and all depending libraries
# KDE4_KMETADATA_LIBS - the kmetadata library and all depending libraries
#
-# This module defines a bunch of variables used as locations for install directories.
+# This module defines a bunch of variables used as locations for install directories.
# They can be relative (to CMAKE_INSTALL_PREFIX) or absolute.
# Under Windows they are always relative.
#
@@ -124,7 +124,7 @@
# Use optional GENERATE_MOC to generate moc if you use signals in your kcfg files.
#
@ -23,7 +31,19 @@ diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdeli
# for Qt Designer plugins.
#
# KDE4_CREATE_FINAL_FILES (filename_CXX filename_C file1 ... fileN)
@@ -307,23 +307,23 @@ if (_kdeBootStrapping)
@@ -292,9 +292,9 @@
find_package(Perl ${_REQ_STRING_KDE4})
# Check that we really found everything.
-# If KDE4 was searched with REQUIRED, we error out with FATAL_ERROR if something wasn't found
+# If KDE4 was searched with REQUIRED, we error out with FATAL_ERROR if something wasn't found
# already above in the other FIND_PACKAGE() calls.
-# If KDE4 was searched without REQUIRED and something in the FIND_PACKAGE() calls above wasn't found,
+# If KDE4 was searched without REQUIRED and something in the FIND_PACKAGE() calls above wasn't found,
# then we get here and must check that everything has actually been found. If something is missing,
# we must not fail with FATAL_ERROR, but only not set KDE4_FOUND.
if(NOT PERL_FOUND)
@@ -362,23 +362,23 @@
if (WIN32)
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} )
# CMAKE_CFG_INTDIR is the output subdirectory created e.g. by XCode and MSVC
@ -53,7 +73,21 @@ diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdeli
set( _KDE4_MEINPROC_EXECUTABLE_DEP meinproc4)
set(KDE4_INSTALLED_VERSION_OK TRUE)
@@ -372,69 +372,69 @@ else (_kdeBootStrapping)
@@ -429,11 +429,11 @@
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib )
if (WIN32)
- # we don't want to be forced to set two paths into the build tree
+ # we don't want to be forced to set two paths into the build tree
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/bin )
# on win32 the install dir is determined on runtime not install time
- # KDELIBS_INSTALL_DIR and QT_INSTALL_DIR are used in KDELibsDependencies.cmake to setup
+ # KDELIBS_INSTALL_DIR and QT_INSTALL_DIR are used in KDELibsDependencies.cmake to setup
# kde install paths and library dependencies
get_filename_component(_DIR ${KDE4_KDECONFIG_EXECUTABLE} PATH )
get_filename_component(KDE4_INSTALL_DIR ${_DIR} PATH )
@@ -445,69 +445,69 @@
include(${kde_cmake_module_dir}/KDELibsDependencies.cmake)
if (UNIX)
@ -144,7 +178,7 @@ diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdeli
set(KDE4_KTEXTEDITOR_LIBS ${ktexteditor_LIB_DEPENDS} ${KDE4_KTEXTEDITOR_LIBRARY} )
# Can't do that, it's not always compiled.
@@ -453,14 +453,14 @@ else (_kdeBootStrapping)
@@ -526,14 +526,14 @@
# at first look in LIBEXEC_INSTALL_DIR and no default paths,
# if this didn't succeed, the second call makes cmake search again, but in the standard paths
@ -163,17 +197,82 @@ diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdeli
# allow searching cmake modules in all given kde install locations (KDEDIRS based)
execute_process(COMMAND "${KDE4_KDECONFIG_EXECUTABLE}" --path data OUTPUT_VARIABLE _data_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -708,7 +708,8 @@ set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SY
"${_CMAKE_INSTALL_DIR}/bin"
"${CMAKE_INSTALL_PREFIX}/bin" )
@@ -570,14 +570,14 @@
# # This option enables the reduced link interface for libs on UNIX
# #
-# # The purpose of the KDE4_DISABLE_PROPERTY_ variable is to be used as a prefix for
+# # The purpose of the KDE4_DISABLE_PROPERTY_ variable is to be used as a prefix for
# # the target property LINK_INTERFACE_LIBRARIES. If it is empty, the property will have its
# # correct name, if it's not empty, it will be a different name, i.e. the actual property
# # will not be set, i.e. disabled. See kdelibs/kdecore/CMakeLists.txt for an example.
# #
-# # By default (i.e. also for Windows) make it non-empty, so the property name will
-# # change from "LINK_INTERFACE_LIBRARIES" to "DISABLED_LINK_INTERFACE_LIBRARIES",
-# # which is a different (non-existing) target property, and so setting that property
+# # By default (i.e. also for Windows) make it non-empty, so the property name will
+# # change from "LINK_INTERFACE_LIBRARIES" to "DISABLED_LINK_INTERFACE_LIBRARIES",
+# # which is a different (non-existing) target property, and so setting that property
# # won't have an effect
# disable this for now for Windows, since there is an issue with the use of "debug" and
@@ -586,7 +586,7 @@
# disable the reduced linking temporarily for Windows, cmake HEAD and the soon-to-be-released cmake 2.6.2
# With 2.6.0 and 2.6.1 it can happen that the "debug", "optimized" and "general" keywords are
# misinterpreted by cmake as library names, the linking fails. Usually this happens under Windows.
-# In 2.6.2 this will be an error at cmake time, so we disable it for now and once we require
+# In 2.6.2 this will be an error at cmake time, so we disable it for now and once we require
# 2.6.2 we'll fix it the right way (using TARGET_LINK_LIBRARIES(foo LINK_INTERFACE_LIBRARIES ...)
if (WIN32 OR "${CMAKE_MINOR_VERSION}" EQUAL 7 OR "${CMAKE_PATCH_VERSION}" EQUAL 2)
set(KDE4_DISABLE_PROPERTY_ "DISABLED_")
@@ -747,7 +747,7 @@
# The INSTALL_TARGETS_DEFAULT_ARGS variable should be used when libraries are installed.
# The arguments are also ok for regular executables, i.e. executables which don't go
-# into sbin/ or libexec/, but for installing executables the basic syntax
+# into sbin/ or libexec/, but for installing executables the basic syntax
# INSTALL(TARGETS kate DESTINATION "${BIN_INSTALL_DIR}")
# is enough, so using this variable there doesn't help a lot.
# The variable must not be used for installing plugins.
@@ -757,7 +757,7 @@
# This will install libraries correctly under UNIX, OSX and Windows (i.e. dll's go
# into bin/.
# Later on it will be possible to extend this for installing OSX frameworks
-# The COMPONENT Devel argument has the effect that static libraries belong to the
+# The COMPONENT Devel argument has the effect that static libraries belong to the
# "Devel" install component. If we use this also for all install() commands
# for header files, it will be possible to install
# -everything: make install OR cmake -P cmake_install.cmake
@@ -789,13 +789,14 @@
set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SYSTEM_PROGRAM_PATH}
"${KDE4_BIN_INSTALL_DIR}" )
-set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
+set(CMAKE_SYSTEM_LIBRARY_PATH "${KDE4_LIB_INSTALL_DIR}/kde4/devel"
+ ${CMAKE_SYSTEM_LIBRARY_PATH}
"${KDE4_LIB_INSTALL_DIR}"
"${_CMAKE_INSTALL_DIR}/lib"
"${CMAKE_INSTALL_PREFIX}/lib" )
@@ -1108,9 +1109,9 @@ macro (KDE4_PRINT_RESULTS)
+ ${CMAKE_SYSTEM_LIBRARY_PATH}
"${KDE4_LIB_INSTALL_DIR}" )
# under Windows dlls may be also installed in bin/
if(WIN32)
- set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
- "${_CMAKE_INSTALL_DIR}/bin"
+ set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
+ "${_CMAKE_INSTALL_DIR}/bin"
"${CMAKE_INSTALL_PREFIX}/bin" )
endif(WIN32)
@@ -819,8 +820,8 @@
find_package(KDEWIN32 REQUIRED)
- # limit win32 packaging to kdelibs at now
- # don't know if package name, version and notes are always available
+ # limit win32 packaging to kdelibs at now
+ # don't know if package name, version and notes are always available
if(_kdeBootStrapping)
find_package(KDEWIN_Packager)
if (KDEWIN_PACKAGER_FOUND)
@@ -1185,9 +1186,9 @@
endif (NOT _kdeBootStrapping)
if(KDE4_KCFGC_EXECUTABLE)
@ -185,97 +284,12 @@ diff -up kdelibs-4.1.0/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdeli
endif(KDE4_KCFGC_EXECUTABLE)
if(AUTOMOC4_EXECUTABLE)
diff -up kdelibs-4.1.0/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel kdelibs-4.1.0/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.1.0/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel 2008-05-21 13:07:26.000000000 +0200
+++ kdelibs-4.1.0/doc/api/doxygen-preprocess-kcfg.sh 2008-07-23 18:01:48.000000000 +0200
@@ -2,9 +2,9 @@
# Generates and cleans KConfigXT source code during a API dox build
#
@@ -1228,7 +1229,7 @@
${KDE4_INCLUDE_DIR}/KDE
${KDE4_PHONON_INCLUDES}
${QT_INCLUDES}
- ${_KDE4_PLATFORM_INCLUDE_DIRS}
+ ${_KDE4_PLATFORM_INCLUDE_DIRS}
)
-kcfg_compiler="`kde4-config --prefix`/bin/kconfig_compiler"
+kcfg_compiler="`kde4-config --prefix`/bin/kconfig_compiler4"
if test -z "$kcfg_compiler"; then
- echo "kconfig_compiler not found!"
+ echo "kconfig_compiler4 not found!"
exit 1;
fi
diff -up kdelibs-4.1.0/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel kdelibs-4.1.0/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.1.0/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.0/kdecore/kconfig_compiler/checkkcfg.pl 2008-07-23 18:01:48.000000000 +0200
@@ -15,12 +15,12 @@ $file_cpp = "$filebase.cpp";
$kcfgc = $file . "c";
-$cmd = "./kconfig_compiler $file $kcfgc";
+$cmd = "./kconfig_compiler4 $file $kcfgc";
#print "CMD $cmd\n";
if ( system( $cmd ) != 0 ) {
- print STDERR "Unable to run kconfig_compiler\n";
+ print STDERR "Unable to run kconfig_compiler4\n";
exit 1;
}
diff -up kdelibs-4.1.0/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.1.0/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.0/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.0/kdecore/kconfig_compiler/CMakeLists.txt 2008-07-23 18:01:48.000000000 +0200
@@ -8,11 +8,11 @@ add_subdirectory( example )
set(kconfig_compiler_SRCS kconfig_compiler.cpp)
-kde4_add_executable(kconfig_compiler NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
+kde4_add_executable(kconfig_compiler4 NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
-target_link_libraries(kconfig_compiler ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
+target_link_libraries(kconfig_compiler4 ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
-install(TARGETS kconfig_compiler DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS kconfig_compiler4 DESTINATION ${BIN_INSTALL_DIR} )
########### install files ###############
diff -up kdelibs-4.1.0/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.1.0/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.0/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-05-21 13:08:30.000000000 +0200
+++ kdelibs-4.1.0/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-07-23 18:01:48.000000000 +0200
@@ -9,7 +9,7 @@ macro(GEN_KCFG_TEST_SOURCE _testName _sr
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h
COMMAND ${KDE4_KCFGC_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc kconfig_compiler)
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc kconfig_compiler4)
# set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h PROPERTIES GENERATED TRUE)
qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.moc )
diff -up kdelibs-4.1.0/kdewidgets/CMakeLists.txt.parallel_devel kdelibs-4.1.0/kdewidgets/CMakeLists.txt
--- kdelibs-4.1.0/kdewidgets/CMakeLists.txt.parallel_devel 2008-05-21 13:08:17.000000000 +0200
+++ kdelibs-4.1.0/kdewidgets/CMakeLists.txt 2008-07-23 18:01:48.000000000 +0200
@@ -16,22 +16,22 @@ include_directories(
set(makekdewidgets_SRCS makekdewidgets.cpp )
-kde4_add_executable(makekdewidgets NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
+kde4_add_executable(makekdewidgets4 NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
-target_link_libraries(makekdewidgets ${KDE4_KDECORE_LIBS} )
+target_link_libraries(makekdewidgets4 ${KDE4_KDECORE_LIBS} )
-install(TARGETS makekdewidgets DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS makekdewidgets4 DESTINATION ${BIN_INSTALL_DIR} )
########### next target ###############
# get the name of the generated wrapper script (which sets up LD_LIBRARY_PATH)
-get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets WRAPPER_SCRIPT)
+get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets4 WRAPPER_SCRIPT)
add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp
COMMAND "${MAKEKDEWIDGETS_EXECUTABLE}" -o ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp ${CMAKE_CURRENT_SOURCE_DIR}/kde.widgets
- MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets)
+ MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets4)
set(kdewidgets_PART_SRCS
classpreviews.cpp
set(KDE4_DEFINITIONS ${_KDE4_PLATFORM_DEFINITIONS} -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS )

View File

@ -1,8 +1,8 @@
%define _default_patch_fuzz 2
Summary: K Desktop Environment 4 - Libraries
Version: 4.1.2
Release: 2%{?dist}
Version: 4.1.69
Release: 1%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs
@ -19,7 +19,7 @@ Name: kdelibs4
License: LGPLv2
URL: http://www.kde.org/
Group: System Environment/Libraries
Source0: ftp://ftp.kde.org/pub/kde/unstable/%{version}/src/kdelibs-%{version}.tar.bz2
Source0: http://ftp-stud.fht-esslingen.de/Mirrors/ftp.kde.org/pub/kde/unstable/%{version}/src/kdelibs-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%ifarch noarch
@ -51,9 +51,11 @@ Source1: kde4.sh
Source2: kde4.csh
# make -devel packages parallel-installable
Patch0: kdelibs-4.1.0-parallel_devel.patch
Patch0: kdelibs-4.2.0-parallel_devel.patch
Patch1: kdelibs-4.2.0-parallel_devel-kconfig_compiler.patch
Patch2: kdelibs-4.2.0-parallel_devel-makekdewidgets.patch
# fix kde#149705
Patch2: kdelibs-3.95.0-kde149705.patch
Patch3: kdelibs-3.95.0-kde149705.patch
# Hunspell support for K3Spell
# http://fedoraproject.org/wiki/Releases/FeatureDictionary
# http://bugs.kde.org/show_bug.cgi?id=154561
@ -69,18 +71,17 @@ Patch9: kdelibs-4.0.2-branding.patch
# are loaded from kde4rc
Patch10: kdelibs-4.0.2-no-cache-kdeglobals-paths.patch
# workaround for policykit
Patch11: kdelibs-4.0.2-policykit-workaround.patch
Patch11: kdelibs-4.1.69-policykit-workaround.patch
Patch12: kdelibs-4.1.0-xdg-menu.patch
# Fedora build type - adds -DNDEBUG -DQT_NO_DEBUG, removes -O2 -g (already in RPM_OPT_FLAGS)
Patch13: kdelibs-4.0.5-fedora-buildtype.patch
# patch KStandardDirs to use %{_libexecdir}/kde4 instead of %{_libdir}/kde4/libexec
Patch14: kdelibs-4.0.85-libexecdir.patch
# kstandarddirs changes: search /etc/kde, find /usr/libexec/kde4
Patch18: kdelibs-4.1.0-kstandarddirs.patch
Patch20: kdelibs-4.1.1-cmake.patch
## upstream patches
BuildRequires: qt4-devel >= 4.4.0
Requires: qt4 >= %{_qt4_version}
Requires: qt4 >= %{_qt4_version}
Requires: xdg-utils
Requires(post): /sbin/ldconfig xdg-utils
Requires(postun): /sbin/ldconfig xdg-utils
@ -93,7 +94,7 @@ BuildRequires: aspell-devel
BuildRequires: automoc
BuildRequires: avahi-devel
BuildRequires: bzip2-devel
BuildRequires: cmake
BuildRequires: cmake >= 2.6
BuildRequires: cups-devel cups
BuildRequires: enchant-devel
BuildRequires: gamin-devel
@ -116,10 +117,10 @@ BuildRequires: phonon-backend-gstreamer
BuildRequires: phonon-devel >= 4.2
BuildRequires: shared-mime-info
BuildRequires: soprano-devel >= 2.1
BuildRequires: strigi-devel >= 0.5.7
BuildRequires: strigi-devel >= 0.6.0
BuildRequires: zlib-devel
BuildRequires: libutempter-devel
# extra X deps (seemingly needed and/or checked-for by most kde4 buildscripts)
# extra X deps (seemingly needed and/or checked-for by most kde4 buildscripts)
%define x_deps libXcomposite-devel libXdamage-devel libxkbfile-devel libXpm-devel libXScrnSaver-devel libXtst-devel libXv-devel libXxf86misc-devel
%{?x_deps:BuildRequires: %{x_deps}}
BuildRequires: openssh-clients
@ -184,8 +185,11 @@ format for easy browsing.
%prep
%setup -q -n kdelibs-%{version}
%patch0 -p1 -b .parallel_devel
%patch2 -p1 -b .kde149705
%patch0 -p0 -b .parallel_devel
%patch1 -p0 -b .parallel_devel-kconfig_compiler
%patch2 -p0 -b .parallel_devel-makekdewidgets
%patch3 -p1 -b .kde149705
%if 0%{?fedora} >= 9
%patch5 -p1 -b .k3spell-hunspell
%else
@ -196,23 +200,21 @@ format for easy browsing.
%patch9 -p1 -b .branding
sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanager.cpp
%patch10 -p1 -b .no-cache-kdeglobals-paths
%patch11 -p1 -b .policykit
#%patch11 -p1 -b .policykit
%patch12 -p1 -b .Administration-menu
%patch13 -p1 -b .fedora-buildtype
%patch14 -p1 -b .libexecdir
%patch18 -p1 -b .kstandarddirs
%patch20 -p1 -b .cmake
## upstream patches
%build
mkdir -p %{_target_platform}
pushd %{_target_platform}
%{__mkdir} -p %{_target_platform}
pushd %{_target_platform}
%{cmake_kde4} -DKDE_DISTRIBUTION_TEXT="%{version}-%{release} Fedora" ..
popd
%if 0%{?rest}
make %{?_smp_mflags} -C %{_target_platform} VERBOSE=1
%{__make} %{?_smp_mflags} -C %{_target_platform}
%endif
# build apidocs
@ -226,7 +228,7 @@ doc/api/doxygen.sh .
rm -rf %{buildroot}
%if 0%{?rest}
make install DESTDIR=%{buildroot} -C %{_target_platform}
make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
# see also use-of/patching of XDG_MENU_PREFIX in kdebase/kde-settings
mv %{buildroot}%{_kde4_sysconfdir}/xdg/menus/applications.menu \
@ -250,6 +252,8 @@ do
case "$i" in
libkdeinit4_*.so)
;;
libkformulalib.so)
;;
## FIXME/TODO: imo, should leave everything except for known-conflicts -- Rex
*)
linktarget=`readlink "$i"`
@ -260,8 +264,8 @@ do
done
popd
install -p -m 644 -D %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d/kde4.sh
install -p -m 644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d/kde4.csh
%{__install} -p -m 644 -D %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d/kde4.sh
%{__install} -p -m 644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d/kde4.csh
# fix Sonnet documentation multilib conflict
bunzip2 %{buildroot}%{_kde4_docdir}/HTML/en/sonnet/index.cache.bz2
@ -269,12 +273,12 @@ sed -i -e 's!<a name="id[0-9]*"></a>!!g' %{buildroot}%{_kde4_docdir}/HTML/en/son
bzip2 -9 %{buildroot}%{_kde4_docdir}/HTML/en/sonnet/index.cache
# install apidocs and generator script
install -p -D doc/api/doxygen.sh %{buildroot}%{_kde4_bindir}/kde4-doxygen.sh
%{__install} -p -D doc/api/doxygen.sh %{buildroot}%{_kde4_bindir}/kde4-doxygen.sh
%endif
%if 0%{?apidocs}
mkdir -p %{buildroot}%{_kde4_docdir}/HTML/en
cp -prf kdelibs-%{version}-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs
%{__mkdir} -p %{buildroot}%{_kde4_docdir}/HTML/en
%{__cp} -prf kdelibs-%{version}-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs
%endif
@ -283,7 +287,7 @@ cp -prf kdelibs-%{version}-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
xdg-desktop-menu forceupdate 2> /dev/null || :
%postun
%postun
/sbin/ldconfig ||:
xdg-icon-resource forceupdate --theme hicolor 2> /dev/null || :
xdg-desktop-menu forceupdate 2> /dev/null || :
@ -313,9 +317,10 @@ rm -rf %{buildroot}
%{_kde4_datadir}/mime/packages/*
%{_kde4_sharedir}/kde4/services/*
%{_kde4_sharedir}/kde4/servicetypes/*
%{_kde4_sharedir}/icons/hicolor/*/actions/presence_*
%{_kde4_sharedir}/icons/hicolor/*/actions/*
%{_kde4_docdir}/HTML/en/sonnet/
%{_kde4_libdir}/lib*.so.*
%{_kde4_libdir}/libkformulalib.so
%{_kde4_libdir}/libkdeinit4_*.so
%dir %{_kde4_libdir}/kde4/
%{_kde4_libdir}/kde4/*.so
@ -363,41 +368,23 @@ rm -rf %{buildroot}
%changelog
* Sun Sep 28 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-2
- make VERBOSE=1
- respin against new(er) kde-filesystem
* Sun Oct 12 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.69-1
- 4.1.69
* Thu Sep 25 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-1
- kde-4.1.2
* Fri Oct 03 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.68-1
- 4.1.68
* Fri Sep 19 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.1.1-12
- make "Stop Animations" work again in Konqueror (KDE 4 regression kde#157789)
* Fri Oct 03 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.67-1
- 4.1.67
* Thu Sep 18 2008 Than Ngo <than@redhat.com> 4.1.1-11
- apply upstream patch to fix the regression
- drop the kdelibs-4.1.1-bz#461725-regression.patch
* Thu Sep 18 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.66-2
- 4.1.66
* Thu Sep 18 2008 Lukáš Tinkl <ltinkl@redhat.com> 4.1.1-10
- Fix file association bug, the global mimeapps.list file had priority
over the local one.
- khtml scroll crash fix (kdebug:170880)
- Don't eat text when the emoticons were not installed. This fixes
mail text not being displayed in KMail when kdebase-runtime wasn't
installed.
* Thu Sep 18 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.66-1
- 4.1.66
* Wed Sep 17 2008 Than Ngo <than@redhat.com> 4.1.1-9
- #461725, revert the patch to fix the regression
* Sat Sep 13 2008 Than Ngo <than@redhat.com> 4.1.1-8
- fix kdelibs-4.1.1-kdeui-widgets-fixes.patch
* Sat Sep 13 2008 Than Ngo <than@redhat.com> 4.1.1-7
- remove redundant FEDORA, use CMAKE_BUILD_TYPE=release
- fix install problem with cmake > 2.5
* Mon Sep 08 2008 Lukáš Tinkl <ltinkl@redhat.com> 4.1.1-6
- fix crashes in plugin selector
- fix problems in various kdeui widgets
* Thu Sep 04 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.65-1
- 4.1.65
* Wed Sep 03 2008 Lukáš Tinkl <ltinkl@redhat.com> 4.1.1-5
- fixed crash on setting cookies on empty domains (like the file
@ -804,7 +791,7 @@ rm -rf %{buildroot}
* Wed Jun 27 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.91.0-1
- kde-3.91.0
- CMAKE_BUILD_TYPE=debug
- CMAKE_BUILD_TYPE=debug
* Sat Jun 23 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.90.1-3
- specfile cleanup (%%prefix issues mostly)

View File

@ -1 +1 @@
cb5f43d2b11669fb17b0a1ecf3736c17 kdelibs-4.1.2.tar.bz2
1a5b1834df6e782236ebd3294d8c7f2a kdelibs-4.1.69.tar.bz2