4.3.4
This commit is contained in:
parent
dee507b24d
commit
41c8cfe17b
@ -1,61 +0,0 @@
|
||||
diff -up kdelibs-4.3.1/kio/kssl/kopenssl.cpp.orig kdelibs-4.3.1/kio/kssl/kopenssl.cpp
|
||||
--- kdelibs-4.3.1/kio/kssl/kopenssl.cpp.orig 2009-09-01 21:58:06.000000000 +0200
|
||||
+++ kdelibs-4.3.1/kio/kssl/kopenssl.cpp 2009-09-01 22:08:16.000000000 +0200
|
||||
@@ -622,7 +622,7 @@ KOpenSSLProxy::KOpenSSLProxy()
|
||||
K_SSL_set_session = (int (*)(SSL*,SSL_SESSION*)) d->sslLib->resolveFunction("SSL_set_session");
|
||||
K_d2i_SSL_SESSION = (SSL_SESSION* (*)(SSL_SESSION**,unsigned char**, long)) d->sslLib->resolveFunction("d2i_SSL_SESSION");
|
||||
K_i2d_SSL_SESSION = (int (*)(SSL_SESSION*,unsigned char**)) d->sslLib->resolveFunction("i2d_SSL_SESSION");
|
||||
- K_SSL_get_ciphers = (STACK *(*)(const SSL*)) d->sslLib->resolveFunction("SSL_get_ciphers");
|
||||
+ K_SSL_get_ciphers = (STACK_OF(SSL_CIPHER) *(*)(const SSL*)) d->sslLib->resolveFunction("SSL_get_ciphers");
|
||||
#endif
|
||||
|
||||
|
||||
diff -up kdelibs-4.3.1/kio/kssl/kopenssl.h.orig kdelibs-4.3.1/kio/kssl/kopenssl.h
|
||||
--- kdelibs-4.3.1/kio/kssl/kopenssl.h.orig 2009-09-01 21:58:31.000000000 +0200
|
||||
+++ kdelibs-4.3.1/kio/kssl/kopenssl.h 2009-09-01 22:48:44.000000000 +0200
|
||||
@@ -44,6 +44,14 @@ class KOpenSSLProxyPrivate;
|
||||
#include <openssl/stack.h>
|
||||
#include <openssl/bn.h>
|
||||
#undef crypt
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
+#define STACK _STACK
|
||||
+#define OSSL_SKVALUE_RTYPE void
|
||||
+#define OSSL_MORECONST const
|
||||
+#else
|
||||
+#define OSSL_SKVALUE_RTYPE char
|
||||
+#define OSSL_MORECONST
|
||||
+#endif
|
||||
#endif
|
||||
|
||||
/**
|
||||
@@ -505,6 +513,9 @@ public:
|
||||
*/
|
||||
void sk_free(STACK *s);
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
+ void sk_free(void *s) { return sk_free(reinterpret_cast<STACK*>(s)); }
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Number of elements in the stack
|
||||
@@ -517,6 +528,9 @@ public:
|
||||
*/
|
||||
char *sk_value(STACK *s, int n);
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
+ char *sk_value(void *s, int n) { return sk_value(reinterpret_cast<STACK*>(s), n); }
|
||||
+#endif
|
||||
|
||||
/*
|
||||
* Create a new stack
|
||||
@@ -529,6 +543,10 @@ public:
|
||||
*/
|
||||
int sk_push(STACK *s, char *d);
|
||||
|
||||
+#if OPENSSL_VERSION_NUMBER >= 0x10000000L
|
||||
+ int sk_push(void *s, void *d) { return sk_push(reinterpret_cast<STACK*>(s), reinterpret_cast<char*>(d)); }
|
||||
+#endif
|
||||
+
|
||||
|
||||
/*
|
||||
* Duplicate the stack
|
@ -1,21 +0,0 @@
|
||||
diff -ur kdelibs-4.3.3/kdecore/fakes.c kdelibs-4.3.3-fix-kdefakes-build/kdecore/fakes.c
|
||||
--- kdelibs-4.3.3/kdecore/fakes.c 2008-05-21 13:09:15.000000000 +0200
|
||||
+++ kdelibs-4.3.3-fix-kdefakes-build/kdecore/fakes.c 2009-11-06 01:47:27.000000000 +0100
|
||||
@@ -313,6 +313,8 @@
|
||||
#endif /* !HAVE_MKDTEMP */
|
||||
|
||||
#ifndef HAVE_STRLCPY
|
||||
+#include <string.h>
|
||||
+
|
||||
KDECORE_EXPORT unsigned long strlcpy(char* d, const char* s, unsigned long bufsize)
|
||||
{
|
||||
unsigned long len, ret = strlen(s);
|
||||
@@ -331,6 +333,8 @@
|
||||
#endif
|
||||
|
||||
#ifndef HAVE_STRLCAT
|
||||
+#include <string.h>
|
||||
+
|
||||
KDECORE_EXPORT unsigned long strlcat(char* d, const char* s, unsigned long bufsize)
|
||||
{
|
||||
char *cp;
|
29
kdelibs.spec
29
kdelibs.spec
@ -1,14 +1,10 @@
|
||||
%define phonon_ver 4.3.1
|
||||
%define soprano_ver 2.3.0
|
||||
%define soprano_ver 2.3.1
|
||||
%define strigi_ver 0.7
|
||||
|
||||
%if 0%{?fedora} > 11
|
||||
%define soprano_ver 2.3.1
|
||||
%endif
|
||||
|
||||
Summary: K Desktop Environment 4 - Libraries
|
||||
Version: 4.3.3
|
||||
Release: 4%{?dist}
|
||||
Version: 4.3.4
|
||||
Release: 2%{?dist}
|
||||
|
||||
Name: kdelibs
|
||||
Epoch: 6
|
||||
@ -76,13 +72,11 @@ Patch14: kdelibs-4.2.85-libexecdir.patch
|
||||
# kstandarddirs changes: search /etc/kde, find /usr/libexec/kde4
|
||||
Patch18: kdelibs-4.1.72-kstandarddirs.patch
|
||||
Patch20: kdelibs-4.1.70-cmake.patch
|
||||
Patch21: kdelibs-4.3.1-ossl-1.x.patch
|
||||
# patch to fix keditbookmarks crash (kde#160679)
|
||||
Patch22: kdelibs-4.3.0-bookmarks.patch
|
||||
Patch24: kdelibs-4.3.1-drkonq.patch
|
||||
# fix build of fakes.c due to missing #include <string.h>
|
||||
Patch25: kdelibs-4.3.3-fix-kdefakes-build.patch
|
||||
# use -fno-var-tracking-assignments on khtml/svg bits, use in a pinch on f12+
|
||||
# workaound for low-mem systems (ppc64, x86_64)
|
||||
Patch26: kdelibs-4.3.3-khtml_svg_no_var_tracking_assignments.patch
|
||||
|
||||
# upstream
|
||||
@ -205,13 +199,11 @@ format for easy browsing.
|
||||
%patch14 -p1 -b .libexecdir
|
||||
%patch18 -p1 -b .kstandarddirs
|
||||
%patch20 -p1 -b .xxcmake
|
||||
%patch21 -p1 -b .ossl-1.x
|
||||
%patch22 -p1 -b .bookmarks
|
||||
%if 0%{?rhel} > 5
|
||||
%patch24 -p1 -b .drkonq
|
||||
%endif
|
||||
%patch25 -p1 -b .fix-kdefakes-build
|
||||
%if 0%{?fedora} > 11
|
||||
%ifarch ppc64 x86_64
|
||||
%patch26 -p1 -b .khtml_svg_no_var_tracking_assignments
|
||||
%endif
|
||||
|
||||
@ -411,9 +403,18 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Dec 04 2009 Than Ngo <than@redhat.com> - 4.3.4-2
|
||||
- add workaound for low-mem systems
|
||||
|
||||
* Tue Dec 01 2009 Than Ngo <than@redhat.com> - 4.3.4-1
|
||||
- 4.3.4
|
||||
|
||||
* Mon Nov 16 2009 Than Ngo <than@redhat.com> - 4.3.3-5
|
||||
- fix conditional
|
||||
|
||||
* Fri Nov 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.3-4
|
||||
- kubuntu_80_kaction_qt_keys.diff (#475247)
|
||||
- soprano_ver 2.3.1 (f12+)
|
||||
- soprano_ver 2.3.1
|
||||
|
||||
* Fri Nov 13 2009 Than Ngo <than@redhat.com> - 4.3.3-3
|
||||
- rhel cleanup, fix conditional for RHEL
|
||||
|
Loading…
Reference in New Issue
Block a user