include followup commits too...
so we can back out all of them.
This commit is contained in:
parent
c0f75e8d30
commit
3d61393ab3
61
coding-style-fixes.patch
Normal file
61
coding-style-fixes.patch
Normal file
@ -0,0 +1,61 @@
|
||||
From 2173580f070e806d4715e13048c697c49ec262e2 Mon Sep 17 00:00:00 2001
|
||||
From: Aaron Seigo <aseigo@kde.org>
|
||||
Date: Thu, 21 Feb 2013 17:59:58 +0100
|
||||
Subject: [PATCH 047/111] coding style fixes
|
||||
|
||||
---
|
||||
kdeui/icons/kiconloader.cpp | 27 ++++++++++++---------------
|
||||
1 file changed, 12 insertions(+), 15 deletions(-)
|
||||
|
||||
diff --git a/kdeui/icons/kiconloader.cpp b/kdeui/icons/kiconloader.cpp
|
||||
index 6fed667..dba474d 100644
|
||||
--- a/kdeui/icons/kiconloader.cpp
|
||||
+++ b/kdeui/icons/kiconloader.cpp
|
||||
@@ -938,32 +938,29 @@ K3Icon KIconLoaderPrivate::findMatchingIcon(const QString& name, int size) const
|
||||
}
|
||||
}
|
||||
|
||||
- foreach (KIconThemeNode *themeNode, links)
|
||||
- {
|
||||
+ foreach (KIconThemeNode *themeNode, links) {
|
||||
QString currentName = name;
|
||||
|
||||
- while (!currentName.isEmpty())
|
||||
- {
|
||||
-
|
||||
+ while (!currentName.isEmpty()) {
|
||||
//kDebug(264) << "Looking up" << currentName;
|
||||
|
||||
-// The following code has been commented out because the Qt SVG renderer needs
|
||||
-// to be improved. If you are going to change/remove some code from this part,
|
||||
-// please contact me before (ereslibre@kde.org), or kde-core-devel@kde.org. (ereslibre)
|
||||
- for (int i = 0 ; i < 4 ; i++)
|
||||
- {
|
||||
+ for (int i = 0 ; i < 4 ; i++) {
|
||||
icon = themeNode->theme->iconPath(currentName + ext[i], size, KIconLoader::MatchExact);
|
||||
- if (icon.isValid())
|
||||
- return icon;
|
||||
+ if (icon.isValid()) {
|
||||
+ break;
|
||||
+ }
|
||||
|
||||
icon = themeNode->theme->iconPath(currentName + ext[i], size, KIconLoader::MatchBest);
|
||||
- if (icon.isValid())
|
||||
- return icon;
|
||||
+ if (icon.isValid()) {
|
||||
+ break;
|
||||
+ }
|
||||
}
|
||||
+ //kDebug(264) << "Looking up" << currentName;
|
||||
|
||||
- if (genericFallback)
|
||||
+ if (genericFallback) {
|
||||
// we already tested the base name
|
||||
break;
|
||||
+ }
|
||||
|
||||
int rindex = currentName.lastIndexOf('-');
|
||||
if (rindex > 1) { // > 1 so that we don't split x-content or x-epoc
|
||||
--
|
||||
1.8.1.4
|
||||
|
10
kdelibs.spec
10
kdelibs.spec
@ -156,11 +156,13 @@ Patch61: kdelibs-4.9.3-dot.patch
|
||||
|
||||
## upstream
|
||||
|
||||
# revert this fix for
|
||||
# revert these commits for
|
||||
#https://bugs.kde.org/315578
|
||||
# for now, causes regression,
|
||||
#https://bugs.kde.org/317138
|
||||
Patch100: return-application-icons-properly.patch
|
||||
Patch100: return-not-break.-copy-paste-error.patch
|
||||
Patch101: coding-style-fixes.patch
|
||||
Patch102: return-application-icons-properly.patch
|
||||
|
||||
## security fix
|
||||
# Not Upstreamed? why not ? -- Rex
|
||||
@ -350,7 +352,9 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
%patch61 -p1 -b .dot
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -R -b .return-application-icons-properly
|
||||
%patch100 -p1 -R -b .return-not-break.-copy-paste-error
|
||||
%patch101 -p1 -R -b .coding-style-fixes.patch
|
||||
%patch102 -p1 -R -b .return-application-icons-properly
|
||||
|
||||
# security fixes
|
||||
%patch200 -p1 -b .CVE-2009-2702
|
||||
|
31
return-not-break.-copy-paste-error.patch
Normal file
31
return-not-break.-copy-paste-error.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 0edfd42151ad57322a10a24ab4971b638e220e6e Mon Sep 17 00:00:00 2001
|
||||
From: Aaron Seigo <aseigo@kde.org>
|
||||
Date: Thu, 21 Feb 2013 18:14:54 +0100
|
||||
Subject: [PATCH 049/111] return, not break. copy/paste error
|
||||
|
||||
---
|
||||
kdeui/icons/kiconloader.cpp | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/kdeui/icons/kiconloader.cpp b/kdeui/icons/kiconloader.cpp
|
||||
index dba474d..ce6aeea 100644
|
||||
--- a/kdeui/icons/kiconloader.cpp
|
||||
+++ b/kdeui/icons/kiconloader.cpp
|
||||
@@ -947,12 +947,12 @@ K3Icon KIconLoaderPrivate::findMatchingIcon(const QString& name, int size) const
|
||||
for (int i = 0 ; i < 4 ; i++) {
|
||||
icon = themeNode->theme->iconPath(currentName + ext[i], size, KIconLoader::MatchExact);
|
||||
if (icon.isValid()) {
|
||||
- break;
|
||||
+ return icon;
|
||||
}
|
||||
|
||||
icon = themeNode->theme->iconPath(currentName + ext[i], size, KIconLoader::MatchBest);
|
||||
if (icon.isValid()) {
|
||||
- break;
|
||||
+ return icon;
|
||||
}
|
||||
}
|
||||
//kDebug(264) << "Looking up" << currentName;
|
||||
--
|
||||
1.8.1.4
|
||||
|
Loading…
Reference in New Issue
Block a user