sync to 4.8rc2, fix apidocs (hopefully)

This commit is contained in:
Lukas Tinkl 2012-01-04 16:01:13 +01:00
parent 63f78f53cb
commit 399e027e1e
5 changed files with 24 additions and 24 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
/kdelibs-4.7.4.tar.bz2
/kdelibs-4.7.80.tar.bz2
/kdelibs-4.7.95.tar.bz2
/kdelibs-4.7.97.tar.bz2

View File

@ -1,18 +0,0 @@
diff -ur kdelibs-orig/CMakeLists.txt kdelibs-4.7.95/CMakeLists.txt
--- kdelibs-orig/CMakeLists.txt 2012-01-03 23:05:43.900097430 +0100
+++ kdelibs-4.7.95/CMakeLists.txt 2012-01-03 23:08:27.349635175 +0100
@@ -10,11 +10,11 @@
set (KDE_VERSION_MAJOR 4)
set (KDE_VERSION_MINOR 7)
-set (KDE_VERSION_RELEASE 95)
+set (KDE_VERSION_RELEASE 4)
set (KDE_VERSION "${KDE_VERSION_MAJOR}.${KDE_VERSION_MINOR}.${KDE_VERSION_RELEASE}" )
-set (KDE_VERSION_STRING "${KDE_VERSION} (4.8 RC1 (4.7.95)")
+set (KDE_VERSION_STRING "${KDE_VERSION} (4.7.4 reloaded (aka 4.7.5)")
-set (KDE_DISTRIBUTION_TEXT "compiled sources" CACHE STRING "Indicate the distribution in bug reports" )
+set (KDE_DISTRIBUTION_TEXT "Fedora" CACHE STRING "Indicate the distribution in bug reports" )
# win32: give kde home in debug mode a different name as the release home dir because the settings and caches are different
if (WIN32 AND CMAKE_BUILD_TYPE STREQUAL "Debug")

View File

@ -0,0 +1,15 @@
diff -ur kdelibs-orig/CMakeLists.txt kdelibs-4.7.97/CMakeLists.txt
--- kdelibs-orig/CMakeLists.txt 2012-01-04 15:51:22.362740976 +0100
+++ kdelibs-4.7.97/CMakeLists.txt 2012-01-04 15:52:14.679630524 +0100
@@ -10,9 +10,9 @@
set (KDE_VERSION_MAJOR 4)
set (KDE_VERSION_MINOR 7)
-set (KDE_VERSION_RELEASE 97)
+set (KDE_VERSION_RELEASE 4)
set (KDE_VERSION "${KDE_VERSION_MAJOR}.${KDE_VERSION_MINOR}.${KDE_VERSION_RELEASE}" )
-set (KDE_VERSION_STRING "${KDE_VERSION} (4.8 RC2 (4.7.97)")
+set (KDE_VERSION_STRING "${KDE_VERSION} (4.7.4 reloaded (aka 4.7.5)")
set (KDE_DISTRIBUTION_TEXT "compiled sources" CACHE STRING "Indicate the distribution in bug reports" )

View File

@ -25,6 +25,8 @@ Summary: KDE Libraries
Version: 4.7.4
Release: 3%{?dist}
%define fakeversion 4.7.97
Name: kdelibs
Epoch: 6
Obsoletes: kdelibs4 < %{version}-%{release}
@ -35,7 +37,7 @@ Provides: kdelibs4 = %{version}-%{release}
License: LGPLv2+
URL: http://www.kde.org/
Group: System Environment/Libraries
Source0: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdelibs-4.7.95%{?alphatag}.tar.bz2
Source0: ftp://ftp.kde.org/pub/kde/unstable/%{fakeversion}/src/kdelibs-%{fakeversion}%{?alphatag}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: kde4-macros(api) >= 2
@ -143,7 +145,7 @@ Patch201: kdelibs-4.7.3-CVE-0046.patch
## Fedora specific patches
# make forcefully hal-free build
Patch300: kdelibs-4.7.3-halectomy.patch
Patch301: kdelibs-4.7.95-respin.patch
Patch301: kdelibs-%{fakeversion}-respin.patch
# force upgrade of apps using the discontinued KatePart Smart* interfaces to
# versions using the new Moving* interfaces instead
@ -300,7 +302,7 @@ format for use with the Qt 4 Assistant or KDevelop 4.
%prep
%setup -q -n kdelibs-4.7.95
%setup -q -n kdelibs-%{fakeversion}
%patch0 -p1 -b .parallel_devel
%patch2 -p1 -b .kde149705
@ -336,7 +338,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
# Fedora patches
%patch300 -p1 -b .halectomy
%patch301 -p1 -b .kdelibs-4-7-95-respin
%patch301 -p1 -b .kdelibs-respin
%build
@ -417,7 +419,7 @@ install -p -D doc/api/doxygen.sh %{buildroot}%{_kde4_bindir}/kde4-doxygen.sh
%if 0%{?apidocs}
mkdir -p %{buildroot}%{_kde4_docdir}/HTML/en
cp -a kdelibs-%{version}%{?alphatag}-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs
cp -a kdelibs-%{fakeversion}%{?alphatag}-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs
find %{buildroot}%{_kde4_docdir}/HTML/en/ -name 'installdox' -exec rm -fv {} ';'
rm -vf %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/*.tmp \
%{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/index.qhp \

View File

@ -1 +1 @@
7efc9e7df71345b8de25988fb7094ce9 kdelibs-4.7.95.tar.bz2
fd85943b3011035b0555da81de36d65e kdelibs-4.7.97.tar.bz2