* Thu Feb 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-9
- ssl/proxy patch (kde#179934)
This commit is contained in:
parent
e9f7446680
commit
317e06b184
28
kdelibs-4.2.0-ssl_proxy.patch
Normal file
28
kdelibs-4.2.0-ssl_proxy.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- trunk/KDE/kdelibs/kio/kio/tcpslavebase.cpp 2009/01/14 00:07:11 910707
|
||||
+++ trunk/KDE/kdelibs/kio/kio/tcpslavebase.cpp 2009/01/14 00:07:20 910708
|
||||
@@ -177,8 +177,6 @@
|
||||
success = d->socket.waitForBytesWritten(0);
|
||||
}
|
||||
|
||||
- d->socket.flush(); //this is supposed to get the data on the wire faster
|
||||
-
|
||||
if (d->socket.state() != KTcpSocket::ConnectedState || !success) {
|
||||
kDebug(7027) << "Write failed, will return -1! Socket error is"
|
||||
<< d->socket.error() << ", Socket state is" << d->socket.state()
|
||||
@@ -198,10 +196,12 @@
|
||||
return -1;
|
||||
}
|
||||
|
||||
- if (d->isBlocking && !d->socket.bytesAvailable()) {
|
||||
- d->socket.waitForReadyRead(-1);
|
||||
- } else {
|
||||
- d->socket.waitForReadyRead(0);
|
||||
+ if (!d->socket.bytesAvailable()) {
|
||||
+ if (d->isBlocking) {
|
||||
+ d->socket.waitForReadyRead(-1);
|
||||
+ } else {
|
||||
+ d->socket.waitForReadyRead(0);
|
||||
+ }
|
||||
}
|
||||
|
||||
return d->socket.read(data, len);
|
17
kdelibs.spec
17
kdelibs.spec
@ -1,6 +1,6 @@
|
||||
Summary: K Desktop Environment 4 - Libraries
|
||||
Version: 4.2.0
|
||||
Release: 7%{?dist}
|
||||
Release: 9%{?dist}
|
||||
|
||||
%if 0%{?fedora} > 8
|
||||
Name: kdelibs
|
||||
@ -87,6 +87,8 @@ Patch110: kdelibs-4.2.1-kde#917170.patch
|
||||
Patch111: kdelibs-4.2.1-kde#918403.patch
|
||||
Patch112: kdelibs-4.2.1-kde#918654.patch
|
||||
Patch113: kdelibs-4.2.0-kded-kdirwatch.patch
|
||||
# http://bugs.kde.org/179934
|
||||
Patch114: kdelibs-4.2.0-ssl_proxy.patch
|
||||
|
||||
BuildRequires: qt4-devel >= 4.4.0
|
||||
# qt4%{_?_isa} isn't provided yet -- Rex
|
||||
@ -220,6 +222,7 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
|
||||
%patch111 -p0 -b .kde#918403
|
||||
%patch112 -p0 -b .kde#918654
|
||||
%patch113 -p4 -b .kde#182472
|
||||
%patch114 -p3 -b .kde#179934
|
||||
|
||||
|
||||
%build
|
||||
@ -250,6 +253,9 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
|
||||
mv %{buildroot}%{_kde4_sysconfdir}/xdg/menus/applications.menu \
|
||||
%{buildroot}%{_kde4_sysconfdir}/xdg/menus/kde4-applications.menu
|
||||
|
||||
# create/own, see http://bugzilla.redhat.com/483318
|
||||
mkdir -p %{buildroot}%{_kde4_libdir}/kconf_update_bin
|
||||
|
||||
%if "%{name}" != "kdelibs"
|
||||
# remove files which conflict with KDE 3
|
||||
rm -f %{buildroot}%{_kde4_bindir}/checkXML %{buildroot}%{_kde4_bindir}/kjscmd \
|
||||
@ -327,7 +333,6 @@ rm -rf %{buildroot}
|
||||
%exclude %{_kde4_appsdir}/cmake/
|
||||
%{_kde4_configdir}/*
|
||||
%{_datadir}/dbus-1/interfaces/*
|
||||
%{_libdir}/kde4/plugins/script/*
|
||||
%{_kde4_datadir}/mime/packages/*
|
||||
%{_kde4_sharedir}/kde4/services/*
|
||||
%{_kde4_sharedir}/kde4/servicetypes/*
|
||||
@ -336,11 +341,13 @@ rm -rf %{buildroot}
|
||||
%{_kde4_docdir}/HTML/en/kioslave/
|
||||
%{_kde4_libdir}/lib*.so.*
|
||||
%{_kde4_libdir}/libkdeinit4_*.so
|
||||
%{_kde4_libdir}/kconf_update_bin/
|
||||
%dir %{_kde4_libdir}/kde4/
|
||||
%{_kde4_libdir}/kde4/*.so
|
||||
%{_kde4_libexecdir}/*
|
||||
%dir %{_kde4_libdir}/kde4/plugins/
|
||||
%{_kde4_libdir}/kde4/plugins/imageformats/
|
||||
%{_kde4_libdir}/kde4/plugins/script/
|
||||
%{_kde4_sysconfdir}/xdg/menus/*.menu
|
||||
%doc %{_mandir}/man*/*
|
||||
# kdelibs-common comes from here for fedora >= 9
|
||||
@ -382,6 +389,12 @@ rm -rf %{buildroot}
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Feb 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-9
|
||||
- ssl/proxy patch (kde#179934)
|
||||
|
||||
* Sat Jan 31 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-8
|
||||
- unowned dirs (#483315,#483318)
|
||||
|
||||
* Fri Jan 30 2009 Rex Dieter <rdieter@fedoraproject.org> 4.2.0-7
|
||||
- kded/kdirwatch patch (kde#182472)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user