Fix parallel_devel patch:

* unify - no reason to split it in 3 parts, they all depend on each other
* remove hunks only removing trailing spaces
* readd missing hunks (compared with the 4.1.0 patch, contains the same changes)
* rediff
* rename to match actual version number
This commit is contained in:
Kevin Kofler 2008-10-17 21:33:08 +00:00
parent a6dead4a6f
commit 3024683a1e
4 changed files with 106 additions and 172 deletions

View File

@ -1,5 +1,6 @@
--- cmake/modules/FindKDE4Internal.cmake.orig 2008-09-05 12:25:51.000000000 +0200
+++ cmake/modules/FindKDE4Internal.cmake 2008-09-05 12:37:45.000000000 +0200
diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-parallel_devel/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake 2008-09-26 16:57:01.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/cmake/modules/FindKDE4Internal.cmake 2008-10-17 23:23:59.000000000 +0200
@@ -15,10 +15,10 @@
# The following variables are defined for the various tools required to
# compile KDE software:
@ -13,16 +14,7 @@
#
# The following variables point to the location of the KDE libraries,
# but shouldn't be used directly:
@@ -72,7 +72,7 @@
# KDE4_KNEPOMUK_LIBS - the knepomuk library and all depending libraries
# KDE4_KMETADATA_LIBS - the kmetadata library and all depending libraries
#
-# This module defines a bunch of variables used as locations for install directories.
+# This module defines a bunch of variables used as locations for install directories.
# They can be relative (to CMAKE_INSTALL_PREFIX) or absolute.
# Under Windows they are always relative.
#
@@ -124,7 +124,7 @@
@@ -126,7 +126,7 @@
# Use optional GENERATE_MOC to generate moc if you use signals in your kcfg files.
#
# KDE4_ADD_WIDGET_FILES (SRCS_VAR file1.widgets ... fileN.widgets)
@ -31,19 +23,7 @@
# for Qt Designer plugins.
#
# KDE4_CREATE_FINAL_FILES (filename_CXX filename_C file1 ... fileN)
@@ -292,9 +292,9 @@
find_package(Perl ${_REQ_STRING_KDE4})
# Check that we really found everything.
-# If KDE4 was searched with REQUIRED, we error out with FATAL_ERROR if something wasn't found
+# If KDE4 was searched with REQUIRED, we error out with FATAL_ERROR if something wasn't found
# already above in the other FIND_PACKAGE() calls.
-# If KDE4 was searched without REQUIRED and something in the FIND_PACKAGE() calls above wasn't found,
+# If KDE4 was searched without REQUIRED and something in the FIND_PACKAGE() calls above wasn't found,
# then we get here and must check that everything has actually been found. If something is missing,
# we must not fail with FATAL_ERROR, but only not set KDE4_FOUND.
if(NOT PERL_FOUND)
@@ -362,23 +362,23 @@
@@ -367,23 +367,23 @@
if (WIN32)
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} )
# CMAKE_CFG_INTDIR is the output subdirectory created e.g. by XCode and MSVC
@ -73,21 +53,7 @@
set( _KDE4_MEINPROC_EXECUTABLE_DEP meinproc4)
set(KDE4_INSTALLED_VERSION_OK TRUE)
@@ -429,11 +429,11 @@
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib )
if (WIN32)
- # we don't want to be forced to set two paths into the build tree
+ # we don't want to be forced to set two paths into the build tree
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/bin )
# on win32 the install dir is determined on runtime not install time
- # KDELIBS_INSTALL_DIR and QT_INSTALL_DIR are used in KDELibsDependencies.cmake to setup
+ # KDELIBS_INSTALL_DIR and QT_INSTALL_DIR are used in KDELibsDependencies.cmake to setup
# kde install paths and library dependencies
get_filename_component(_DIR ${KDE4_KDECONFIG_EXECUTABLE} PATH )
get_filename_component(KDE4_INSTALL_DIR ${_DIR} PATH )
@@ -445,69 +445,69 @@
@@ -449,69 +449,69 @@
include(${kde_cmake_module_dir}/KDELibsDependencies.cmake)
if (UNIX)
@ -178,7 +144,7 @@
set(KDE4_KTEXTEDITOR_LIBS ${ktexteditor_LIB_DEPENDS} ${KDE4_KTEXTEDITOR_LIBRARY} )
# Can't do that, it's not always compiled.
@@ -526,14 +526,14 @@
@@ -534,14 +534,14 @@
# at first look in LIBEXEC_INSTALL_DIR and no default paths,
# if this didn't succeed, the second call makes cmake search again, but in the standard paths
@ -197,53 +163,7 @@
# allow searching cmake modules in all given kde install locations (KDEDIRS based)
execute_process(COMMAND "${KDE4_KDECONFIG_EXECUTABLE}" --path data OUTPUT_VARIABLE _data_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -570,14 +570,14 @@
# # This option enables the reduced link interface for libs on UNIX
# #
-# # The purpose of the KDE4_DISABLE_PROPERTY_ variable is to be used as a prefix for
+# # The purpose of the KDE4_DISABLE_PROPERTY_ variable is to be used as a prefix for
# # the target property LINK_INTERFACE_LIBRARIES. If it is empty, the property will have its
# # correct name, if it's not empty, it will be a different name, i.e. the actual property
# # will not be set, i.e. disabled. See kdelibs/kdecore/CMakeLists.txt for an example.
# #
-# # By default (i.e. also for Windows) make it non-empty, so the property name will
-# # change from "LINK_INTERFACE_LIBRARIES" to "DISABLED_LINK_INTERFACE_LIBRARIES",
-# # which is a different (non-existing) target property, and so setting that property
+# # By default (i.e. also for Windows) make it non-empty, so the property name will
+# # change from "LINK_INTERFACE_LIBRARIES" to "DISABLED_LINK_INTERFACE_LIBRARIES",
+# # which is a different (non-existing) target property, and so setting that property
# # won't have an effect
# disable this for now for Windows, since there is an issue with the use of "debug" and
@@ -586,7 +586,7 @@
# disable the reduced linking temporarily for Windows, cmake HEAD and the soon-to-be-released cmake 2.6.2
# With 2.6.0 and 2.6.1 it can happen that the "debug", "optimized" and "general" keywords are
# misinterpreted by cmake as library names, the linking fails. Usually this happens under Windows.
-# In 2.6.2 this will be an error at cmake time, so we disable it for now and once we require
+# In 2.6.2 this will be an error at cmake time, so we disable it for now and once we require
# 2.6.2 we'll fix it the right way (using TARGET_LINK_LIBRARIES(foo LINK_INTERFACE_LIBRARIES ...)
if (WIN32 OR "${CMAKE_MINOR_VERSION}" EQUAL 7 OR "${CMAKE_PATCH_VERSION}" EQUAL 2)
set(KDE4_DISABLE_PROPERTY_ "DISABLED_")
@@ -747,7 +747,7 @@
# The INSTALL_TARGETS_DEFAULT_ARGS variable should be used when libraries are installed.
# The arguments are also ok for regular executables, i.e. executables which don't go
-# into sbin/ or libexec/, but for installing executables the basic syntax
+# into sbin/ or libexec/, but for installing executables the basic syntax
# INSTALL(TARGETS kate DESTINATION "${BIN_INSTALL_DIR}")
# is enough, so using this variable there doesn't help a lot.
# The variable must not be used for installing plugins.
@@ -757,7 +757,7 @@
# This will install libraries correctly under UNIX, OSX and Windows (i.e. dll's go
# into bin/.
# Later on it will be possible to extend this for installing OSX frameworks
-# The COMPONENT Devel argument has the effect that static libraries belong to the
+# The COMPONENT Devel argument has the effect that static libraries belong to the
# "Devel" install component. If we use this also for all install() commands
# for header files, it will be possible to install
# -everything: make install OR cmake -P cmake_install.cmake
@@ -789,13 +789,14 @@
@@ -797,7 +797,8 @@
set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SYSTEM_PROGRAM_PATH}
"${KDE4_BIN_INSTALL_DIR}" )
@ -253,26 +173,7 @@
"${KDE4_LIB_INSTALL_DIR}" )
# under Windows dlls may be also installed in bin/
if(WIN32)
- set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
- "${_CMAKE_INSTALL_DIR}/bin"
+ set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
+ "${_CMAKE_INSTALL_DIR}/bin"
"${CMAKE_INSTALL_PREFIX}/bin" )
endif(WIN32)
@@ -819,8 +820,8 @@
find_package(KDEWIN32 REQUIRED)
- # limit win32 packaging to kdelibs at now
- # don't know if package name, version and notes are always available
+ # limit win32 packaging to kdelibs at now
+ # don't know if package name, version and notes are always available
if(_kdeBootStrapping)
find_package(KDEWIN_Packager)
if (KDEWIN_PACKAGER_FOUND)
@@ -1185,9 +1186,9 @@
@@ -1191,9 +1192,9 @@
endif (NOT _kdeBootStrapping)
if(KDE4_KCFGC_EXECUTABLE)
@ -284,12 +185,97 @@
endif(KDE4_KCFGC_EXECUTABLE)
if(AUTOMOC4_EXECUTABLE)
@@ -1228,7 +1229,7 @@
${KDE4_INCLUDE_DIR}/KDE
${KDE4_PHONON_INCLUDES}
${QT_INCLUDES}
- ${_KDE4_PLATFORM_INCLUDE_DIRS}
+ ${_KDE4_PLATFORM_INCLUDE_DIRS}
)
diff -ur kdelibs-4.1.69/doc/api/doxygen-preprocess-kcfg.sh kdelibs-4.1.69-parallel_devel/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.1.69/doc/api/doxygen-preprocess-kcfg.sh 2008-05-21 13:07:26.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/doc/api/doxygen-preprocess-kcfg.sh 2008-10-17 23:24:29.000000000 +0200
@@ -2,9 +2,9 @@
# Generates and cleans KConfigXT source code during a API dox build
#
set(KDE4_DEFINITIONS ${_KDE4_PLATFORM_DEFINITIONS} -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS )
-kcfg_compiler="`kde4-config --prefix`/bin/kconfig_compiler"
+kcfg_compiler="`kde4-config --prefix`/bin/kconfig_compiler4"
if test -z "$kcfg_compiler"; then
- echo "kconfig_compiler not found!"
+ echo "kconfig_compiler4 not found!"
exit 1;
fi
diff -ur kdelibs-4.1.69/kdecore/kconfig_compiler/checkkcfg.pl kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.1.69/kdecore/kconfig_compiler/checkkcfg.pl 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl 2008-10-17 23:24:29.000000000 +0200
@@ -15,12 +15,12 @@
$kcfgc = $file . "c";
-$cmd = "./kconfig_compiler $file $kcfgc";
+$cmd = "./kconfig_compiler4 $file $kcfgc";
#print "CMD $cmd\n";
if ( system( $cmd ) != 0 ) {
- print STDERR "Unable to run kconfig_compiler\n";
+ print STDERR "Unable to run kconfig_compiler4\n";
exit 1;
}
diff -ur kdelibs-4.1.69/kdecore/kconfig_compiler/CMakeLists.txt kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.69/kdecore/kconfig_compiler/CMakeLists.txt 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt 2008-10-17 23:23:59.000000000 +0200
@@ -8,11 +8,11 @@
set(kconfig_compiler_SRCS kconfig_compiler.cpp)
-kde4_add_executable(kconfig_compiler NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
+kde4_add_executable(kconfig_compiler4 NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
-target_link_libraries(kconfig_compiler ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
+target_link_libraries(kconfig_compiler4 ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
-install(TARGETS kconfig_compiler DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS kconfig_compiler4 DESTINATION ${BIN_INSTALL_DIR} )
########### install files ###############
diff -ur kdelibs-4.1.69/kdeui/tests/kconfig_compiler/CMakeLists.txt kdelibs-4.1.69-parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.69/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-05-21 13:08:30.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-10-17 23:24:29.000000000 +0200
@@ -9,7 +9,7 @@
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h
COMMAND ${KDE4_KCFGC_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc
- DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc kconfig_compiler)
+ DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfg ${CMAKE_CURRENT_SOURCE_DIR}/${_testName}.kcfgc kconfig_compiler4)
# set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h PROPERTIES GENERATED TRUE)
qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.moc )
diff -ur kdelibs-4.1.69/kdewidgets/CMakeLists.txt kdelibs-4.1.69-parallel_devel/kdewidgets/CMakeLists.txt
--- kdelibs-4.1.69/kdewidgets/CMakeLists.txt 2008-05-21 13:08:17.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdewidgets/CMakeLists.txt 2008-10-17 23:23:59.000000000 +0200
@@ -16,22 +16,22 @@
set(makekdewidgets_SRCS makekdewidgets.cpp )
-kde4_add_executable(makekdewidgets NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
+kde4_add_executable(makekdewidgets4 NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
-target_link_libraries(makekdewidgets ${KDE4_KDECORE_LIBS} )
+target_link_libraries(makekdewidgets4 ${KDE4_KDECORE_LIBS} )
-install(TARGETS makekdewidgets DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS makekdewidgets4 DESTINATION ${BIN_INSTALL_DIR} )
########### next target ###############
# get the name of the generated wrapper script (which sets up LD_LIBRARY_PATH)
-get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets WRAPPER_SCRIPT)
+get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets4 WRAPPER_SCRIPT)
add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp
COMMAND "${MAKEKDEWIDGETS_EXECUTABLE}" -o ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp ${CMAKE_CURRENT_SOURCE_DIR}/kde.widgets
- MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets)
+ MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets4)
set(kdewidgets_PART_SRCS
classpreviews.cpp

View File

@ -1,17 +0,0 @@
--- kdecore/kconfig_compiler/CMakeLists.txt.orig 2008-09-05 13:16:43.000000000 +0200
+++ kdecore/kconfig_compiler/CMakeLists.txt 2008-09-05 13:16:57.000000000 +0200
@@ -8,11 +8,11 @@
set(kconfig_compiler_SRCS kconfig_compiler.cpp)
-kde4_add_executable(kconfig_compiler NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
+kde4_add_executable(kconfig_compiler4 NOGUI RUN_UNINSTALLED ${kconfig_compiler_SRCS})
-target_link_libraries(kconfig_compiler ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
+target_link_libraries(kconfig_compiler4 ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
-install(TARGETS kconfig_compiler DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS kconfig_compiler4 DESTINATION ${BIN_INSTALL_DIR} )
########### install files ###############

View File

@ -1,30 +0,0 @@
--- kdewidgets/CMakeLists.txt.orig 2008-09-05 13:18:25.000000000 +0200
+++ kdewidgets/CMakeLists.txt 2008-09-05 13:19:35.000000000 +0200
@@ -16,22 +16,22 @@
set(makekdewidgets_SRCS makekdewidgets.cpp )
-kde4_add_executable(makekdewidgets NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
+kde4_add_executable(makekdewidgets4 NOGUI RUN_UNINSTALLED ${makekdewidgets_SRCS})
-target_link_libraries(makekdewidgets ${KDE4_KDECORE_LIBS} )
+target_link_libraries(makekdewidgets4 ${KDE4_KDECORE_LIBS} )
-install(TARGETS makekdewidgets DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS makekdewidgets4 DESTINATION ${BIN_INSTALL_DIR} )
########### next target ###############
# get the name of the generated wrapper script (which sets up LD_LIBRARY_PATH)
-get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets WRAPPER_SCRIPT)
+get_target_property(MAKEKDEWIDGETS_EXECUTABLE makekdewidgets4 WRAPPER_SCRIPT)
add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp
COMMAND "${MAKEKDEWIDGETS_EXECUTABLE}" -o ${CMAKE_CURRENT_BINARY_DIR}/kdewidgets.cpp ${CMAKE_CURRENT_SOURCE_DIR}/kde.widgets
- MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets)
+ MAIN_DEPENDENCY kde.widgets DEPENDS makekdewidgets4)
set(kdewidgets_PART_SRCS
classpreviews.cpp

View File

@ -51,11 +51,9 @@ Source1: kde4.sh
Source2: kde4.csh
# make -devel packages parallel-installable
Patch0: kdelibs-4.2.0-parallel_devel.patch
Patch1: kdelibs-4.2.0-parallel_devel-kconfig_compiler.patch
Patch2: kdelibs-4.2.0-parallel_devel-makekdewidgets.patch
Patch0: kdelibs-4.1.69-parallel_devel.patch
# fix kde#149705
Patch3: kdelibs-3.95.0-kde149705.patch
Patch2: kdelibs-3.95.0-kde149705.patch
# Hunspell support for K3Spell
# http://fedoraproject.org/wiki/Releases/FeatureDictionary
# http://bugs.kde.org/show_bug.cgi?id=154561
@ -184,11 +182,8 @@ format for easy browsing.
%prep
%setup -q -n kdelibs-%{version}
%patch0 -p0 -b .parallel_devel
%patch1 -p0 -b .parallel_devel-kconfig_compiler
%patch2 -p0 -b .parallel_devel-makekdewidgets
%patch3 -p1 -b .kde149705
%patch0 -p1 -b .parallel_devel
%patch2 -p1 -b .kde149705
%if 0%{?fedora} >= 9
%patch5 -p1 -b .k3spell-hunspell
%else