* Wed Mar 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-4

- install all .css files in kdelibs-common to build kdepimlibs-apidocs against
- install doxygen.sh as kde4-doxygen.sh in -devel
- build apidocs and put them into an -apidocs subpackage (can be turned off)
This commit is contained in:
Kevin Kofler 2008-03-05 21:39:51 +00:00
parent 7a2ae5b5db
commit 2aafce6ee4
2 changed files with 57 additions and 6 deletions

View File

@ -0,0 +1,11 @@
diff -ur kdelibs-4.0.2/doc/common/CMakeLists.txt kdelibs-4.0.2-install-all-css/doc/common/CMakeLists.txt
--- kdelibs-4.0.2/doc/common/CMakeLists.txt 2008-01-05 01:00:05.000000000 +0100
+++ kdelibs-4.0.2-install-all-css/doc/common/CMakeLists.txt 2008-03-05 21:22:32.000000000 +0100
@@ -7,6 +7,7 @@
xml.dcl
doxygen.css
tabs.css
+ kde.css flat.css print.css
header.html
footer.html
mainheader.html

View File

@ -1,10 +1,9 @@
# TODO:
# 1. package some noarch bits separately: apidocs.
# set this to 0 to disable -apidocs for a faster build
%define apidocs 1
Summary: K Desktop Environment 4 - Libraries
Version: 4.0.2
Release: 3%{?dist}
Release: 4%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs
@ -61,6 +60,8 @@ Patch6: kdelibs-4.0.0-openssl.patch
# fix running KDE 3 apps as filetype viewers from KDE 4 Dolphin
# (can't talk over D-Bus to an app only supporting DCOP)
Patch7: kdelibs-4.0.1-dcop-servicetype.patch
# install all .css files in kdelibs-common to build kdepimlibs-apidocs against
Patch8: kdelibs-4.0.2-install-all-css.patch
# upstream patches
@ -133,6 +134,23 @@ Requires: strigi-devel >= 0.5.7
This package includes the header files you will need to compile
applications for KDE 4.
%package apidocs
Group: Development/Documentation
Summary: KDE 4 API documentation
Requires: %{name} = %{?epoch:%{epoch}:}%{version}
%if "%{name}" == "kdelibs"
Provides: kdelibs4-apidocs = %{version}-%{release}
#else
# Don't do that for now, we'd need to make sure all Requires: kdelibs-apidocs
# (in kdevelop etc.) are fixed to kdelibs3-apidocs first and it may not be
# worth it anyway.
#Provides: kdelibs-apidocs = 6:%{version}-%{release}
%endif
%description apidocs
This package includes the KDE 4 API documentation in HTML
format for easy browsing.
%prep
%setup -q -n kdelibs-%{version}
@ -147,6 +165,7 @@ applications for KDE 4.
%patch6 -p1 -b .openssl
%endif
%patch7 -p1 -b .dcop-servicetype
%patch8 -p1 -b .all-css
# upstream patches
@ -159,8 +178,11 @@ popd
make %{?_smp_mflags} -C %{_target_platform} VERBOSE=1
# FIXME/TODO: apidocs
# doc/api/doxygen.sh --doxdatadir=doc/common .
# build apidocs
%if "%{?apidocs}" == "1"
export QTDOCDIR=`pkg-config --variable=docdir Qt`
doc/api/doxygen.sh .
%endif
%install
@ -202,6 +224,12 @@ popd
install -p -m 644 -D %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d/kde4.sh
install -p -m 644 -D %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d/kde4.csh
# install apidocs and generator script
install -p -D doc/api/doxygen.sh %{buildroot}%{_kde4_bindir}/kde4-doxygen.sh
%if "%{?apidocs}" == "1"
install -p -D kdelibs-apidocs %{buildroot}%{_kde4_docdir}/HTML/en/kdelibs4-apidocs
%endif
%post
/sbin/ldconfig ||:
@ -272,6 +300,7 @@ rm -rf %{buildroot}
%doc KDE4PORTING.html
%{_kde4_bindir}/kconfig_compiler4
%{_kde4_bindir}/makekdewidgets4
%{_kde4_bindir}/kde4-doxygen.sh
%{_kde4_appsdir}/cmake/
%{_kde4_appsdir}/kdewidgets/
%{_kde4_appsdir}/ksgmltools2/
@ -279,8 +308,19 @@ rm -rf %{buildroot}
%{_kde4_libdir}/kde4/devel/
%{_kde4_libdir}/kde4/plugins/designer/
%if "%{?apidocs}" == "1"
%files apidocs
%defattr(-,root,root,-)
%{_kde4_docdir}/HTML/en/kdelibs4-apidocs/
%endif
%changelog
* Wed Mar 05 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.0.2-4
- install all .css files in kdelibs-common to build kdepimlibs-apidocs against
- install doxygen.sh as kde4-doxygen.sh in -devel
- build apidocs and put them into an -apidocs subpackage (can be turned off)
* Fri Feb 29 2008 Than Ngo <than@redhat.com> 4.0.2-3
- rebuilt