- Drop upstreamed patches
This commit is contained in:
Radek Novacek 2012-03-05 09:43:51 +01:00
parent 1303dad95f
commit 16d10212c3
5 changed files with 9 additions and 40 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
/kdelibs-4.6.5.tar.bz2
/kdelibs-4.7.4.tar.bz2
/kdelibs-4.8.0.tar.bz2
/kdelibs-4.8.1.tar.xz

View File

@ -1,16 +0,0 @@
diff -up kdelibs-4.7.3/khtml/css/cssparser.cpp.orig kdelibs-4.7.3/khtml/css/cssparser.cpp
--- kdelibs-4.7.3/khtml/css/cssparser.cpp.orig 2011-11-07 19:14:53.000000000 +0100
+++ kdelibs-4.7.3/khtml/css/cssparser.cpp 2011-11-09 16:02:11.000000000 +0100
@@ -2275,8 +2275,11 @@ bool CSSParser::parseFontFaceSrc()
expectComma = true;
} else if (val->unit == Value::Function) {
// There are two allowed functions: local() and format().
+ // For both we expect a string argument
ValueList *args = val->function->args;
- if (args && args->size() == 1) {
+ if (args && args->size() == 1 &&
+ (args->current()->unit == CSSPrimitiveValue::CSS_STRING ||
+ args->current()->unit == CSSPrimitiveValue::CSS_IDENT)) {
if (!strcasecmp(domString(val->function->name), "local(") && !expectComma) {
expectComma = true;
allowFormat = false;

View File

@ -1,12 +0,0 @@
diff -up kdelibs-4.8.0/CMakeLists.txt.version kdelibs-4.8.0/CMakeLists.txt
--- kdelibs-4.8.0/CMakeLists.txt.version 2012-01-18 12:06:22.000000000 -0600
+++ kdelibs-4.8.0/CMakeLists.txt 2012-02-04 10:16:47.076941064 -0600
@@ -12,7 +12,7 @@ set (KDE_VERSION_MAJOR 4)
set (KDE_VERSION_MINOR 8)
set (KDE_VERSION_RELEASE 00)
set (KDE_VERSION "${KDE_VERSION_MAJOR}.${KDE_VERSION_MINOR}.${KDE_VERSION_RELEASE}" )
-set (KDE_VERSION_STRING "${KDE_VERSION} (4.8.0")
+set (KDE_VERSION_STRING "${KDE_VERSION} (4.8.0)")
set (KDE_DISTRIBUTION_TEXT "compiled sources" CACHE STRING "Indicate the distribution in bug reports" )

View File

@ -19,8 +19,8 @@
%global dbusmenu_qt_version %(pkg-config --modversion dbusmenu-qt 2>/dev/null || echo %{dbusmenu_qt_ver})
Summary: KDE Libraries
Version: 4.8.0
Release: 5%{?dist}
Version: 4.8.1
Release: 1%{?dist}
Name: kdelibs
Epoch: 6
@ -38,7 +38,7 @@ Group: System Environment/Libraries
%else
%global stable stable
%endif
Source0: ftp://ftp.kde.org/pub/kde/%{stable}/%{version}/src/kdelibs-%{version}%{?alphatag}.tar.bz2
Source0: ftp://ftp.kde.org/pub/kde/%{stable}/%{version}/src/kdelibs-%{version}%{?alphatag}.tar.xz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: kde4-macros(api) >= 2
@ -129,18 +129,12 @@ Patch52: kdelibs-4.7.4-SOLID_UPNP.patch
# add s390/s390x support in kjs
Patch53: kdelibs-4.7.2-kjs-s390.patch
## upstream
Patch100: kdelibs-4.8.0-kde_version_string.patch
# don't set rpath on multiarch dirs, https://git.reviewboard.kde.org/r/103422
Patch101: kdelibs-4.8.0-cmake_cxx_implicit_link_directories.patch
## security fix
# Not Upstreamed? why not ? -- Rex
Patch200: kdelibs-4.3.1-CVE-2009-2702.patch
# CVE-2010-0046, The Cascading Style Sheets (CSS) implementation in khtml/WebKit
# allows remote attackers to execute arbitrary code or cause a denial of service
# (memory corruption and application crash) via crafted format arguments.
Patch201: kdelibs-4.7.3-CVE-0046.patch
## Fedora specific patches
# make forcefully hal-free build
@ -326,12 +320,10 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch53 -p1 -b .kjs-s390
# upstream patches
%patch100 -p1 -b .kde_version_string
%patch101 -p1 -b .cmake_cxx_implicit_link_directories
# security fixes
%patch200 -p1 -b .CVE-2009-2702
%patch201 -p1 -b .CVE-2010-0046
# Fedora patches
%patch300 -p1 -b .halectomy
@ -580,6 +572,10 @@ rm -rf %{buildroot}
%changelog
* Mon Mar 05 2012 Radek Novacek <rnovacek@redhat.com> 6:4.8.1-1
- 4.8.1
- Drop upstreamed patches
* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6:4.8.0-5
- Rebuilt for c++ ABI breakage

View File

@ -1 +1 @@
c19858c68f9a209ae521d7fb3c34747b kdelibs-4.8.0.tar.bz2
0488ec7d753c3455876d9e3f76406292 kdelibs-4.8.1.tar.xz