This commit is contained in:
Than Ngo 2008-06-13 21:15:44 +00:00
parent 891bb90889
commit 0edeb29cf2
4 changed files with 76 additions and 129 deletions

View File

@ -1,45 +0,0 @@
--- kdelibs-4.0.80/khtml/css/html4.css (Revision 813565)
+++ kdelibs-4.0.80/khtml/css/html4.css (Revision 813566)
@@ -5,6 +5,8 @@
* Konqueror/khtml relies on the existence of this style sheet for
* rendering. Do not remove or modify this file unless you know
* what you are doing.
+ *
+ * KHTML_STYLE_VERSION: 1
*/
@namespace "http://www.w3.org/1999/xhtml";
--- kdelibs-4.0.80/khtml/css/cssstyleselector.cpp (Revision 813565)
+++ kdelibs-4.0.80/khtml/css/cssstyleselector.cpp (Revision 813566)
@@ -62,12 +62,16 @@
#include <kconfig.h>
#include <QtCore/QFile>
#include <QtCore/QString>
+#include <QtCore/QFileInfo>
#include <kdebug.h>
#include <kurl.h>
#include <assert.h>
#include <stdlib.h>
+// keep in sync with html4.css'
+#define KHTML_STYLE_VERSION 1
+
#undef RELATIVE
#undef ABSOLUTE
@@ -386,6 +390,14 @@
file[readbytes] = '\0';
QString style = QLatin1String( file.data() );
+
+ QRegExp checkVersion( "KHTML_STYLE_VERSION:\\s*(\\d+)" );
+ checkVersion.setMinimal( true );
+ if (checkVersion.indexIn( style ) == -1 || checkVersion.cap(1).toInt() != KHTML_STYLE_VERSION) {
+ qFatal( "!!!!!!! ERROR !!!!!!! - KHTML default stylesheet version mismatch. Aborting. Check your installation. File used was: %s. Expected STYLE_VERSION %d\n",
+ QFileInfo( f ).absoluteFilePath().toLatin1().data(), KHTML_STYLE_VERSION );
+ }
+
if(s)
style += s->settingsToCSS();
DOMString str(style);

View File

@ -1,6 +1,6 @@
diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel 2008-05-21 13:06:10.000000000 +0200 --- kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel 2008-06-12 22:12:53.000000000 +0200
+++ kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake 2008-05-26 16:34:57.000000000 +0200 +++ kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake 2008-06-12 22:35:52.000000000 +0200
@@ -15,10 +15,10 @@ @@ -15,10 +15,10 @@
# The following variables are defined for the various tools required to # The following variables are defined for the various tools required to
# compile KDE software: # compile KDE software:
@ -14,7 +14,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
# #
# The following variables point to the location of the KDE libraries, # The following variables point to the location of the KDE libraries,
# but shouldn't be used directly: # but shouldn't be used directly:
@@ -125,7 +125,7 @@ @@ -124,7 +124,7 @@
# Use optional GENERATE_MOC to generate moc if you use signals in your kcfg files. # Use optional GENERATE_MOC to generate moc if you use signals in your kcfg files.
# #
# KDE4_ADD_WIDGET_FILES (SRCS_VAR file1.widgets ... fileN.widgets) # KDE4_ADD_WIDGET_FILES (SRCS_VAR file1.widgets ... fileN.widgets)
@ -23,7 +23,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
# for Qt Designer plugins. # for Qt Designer plugins.
# #
# KDE4_CREATE_FINAL_FILES (filename_CXX filename_C file1 ... fileN) # KDE4_CREATE_FINAL_FILES (filename_CXX filename_C file1 ... fileN)
@@ -278,7 +278,7 @@ if (_kdeBootStrapping) @@ -285,7 +285,7 @@ if (_kdeBootStrapping)
if (WIN32) if (WIN32)
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} ) set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} )
# CMAKE_CFG_INTDIR is the output subdirectory created e.g. by XCode and MSVC # CMAKE_CFG_INTDIR is the output subdirectory created e.g. by XCode and MSVC
@ -32,7 +32,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
# use automoc4 from kdesupport if it has been found # use automoc4 from kdesupport if it has been found
if(AUTOMOC4_EXECUTABLE) if(AUTOMOC4_EXECUTABLE)
@@ -288,10 +288,10 @@ if (_kdeBootStrapping) @@ -295,10 +295,10 @@ if (_kdeBootStrapping)
endif(AUTOMOC4_EXECUTABLE) endif(AUTOMOC4_EXECUTABLE)
set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4 ) set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4 )
@ -45,7 +45,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
# use automoc4 from kdesupport if it has been found # use automoc4 from kdesupport if it has been found
if(AUTOMOC4_EXECUTABLE) if(AUTOMOC4_EXECUTABLE)
@@ -301,14 +301,14 @@ if (_kdeBootStrapping) @@ -308,14 +308,14 @@ if (_kdeBootStrapping)
endif(AUTOMOC4_EXECUTABLE) endif(AUTOMOC4_EXECUTABLE)
set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4.shell ) set(KDE4_MEINPROC_EXECUTABLE ${EXECUTABLE_OUTPUT_PATH}/${CMAKE_CFG_INTDIR}/meinproc4.shell )
@ -63,7 +63,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
set( _KDE4_MEINPROC_EXECUTABLE_DEP meinproc4) set( _KDE4_MEINPROC_EXECUTABLE_DEP meinproc4)
if(AUTOMOC4_EXECUTABLE) if(AUTOMOC4_EXECUTABLE)
@@ -364,75 +364,75 @@ else (_kdeBootStrapping) @@ -371,69 +371,69 @@ else (_kdeBootStrapping)
include(${kde_cmake_module_dir}/KDELibsDependencies.cmake) include(${kde_cmake_module_dir}/KDELibsDependencies.cmake)
if (UNIX) if (UNIX)
@ -129,13 +129,6 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
+ find_library(KDE4_KDNSSD_LIBRARY NAMES kdnssd PATHS ${KDE4_LIB_INSTALL_DIR}/kde4/devel NO_DEFAULT_PATH ) + find_library(KDE4_KDNSSD_LIBRARY NAMES kdnssd PATHS ${KDE4_LIB_INSTALL_DIR}/kde4/devel NO_DEFAULT_PATH )
set(KDE4_KDNSSD_LIBS ${kdnssd_LIB_DEPENDS} ${KDE4_KDNSSD_LIBRARY} ) set(KDE4_KDNSSD_LIBS ${kdnssd_LIB_DEPENDS} ${KDE4_KDNSSD_LIBRARY} )
find_library(KDE4_PHONON_LIBRARY NAMES phonon PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH )
set(KDE4_PHONON_LIBS ${phonon_LIB_DEPENDS} ${KDE4_PHONON_LIBRARY} )
- find_library(KDE4_KAUDIODEVICELIST_LIBRARY NAMES kaudiodevicelist PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH )
+ find_library(KDE4_KAUDIODEVICELIST_LIBRARY NAMES kaudiodevicelist PATHS ${KDE4_LIB_INSTALL_DIR}/kde4/devel NO_DEFAULT_PATH )
set(KDE4_KAUDIODEVICELIST_LIBS ${kaudiodevicelist_LIB_DEPENDS} ${KDE4_KAUDIODEVICELIST_LIBRARY} )
- find_library(KDE4_SOLID_LIBRARY NAMES solid PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH ) - find_library(KDE4_SOLID_LIBRARY NAMES solid PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH )
+ find_library(KDE4_SOLID_LIBRARY NAMES solid PATHS ${KDE4_LIB_INSTALL_DIR}/kde4/devel NO_DEFAULT_PATH ) + find_library(KDE4_SOLID_LIBRARY NAMES solid PATHS ${KDE4_LIB_INSTALL_DIR}/kde4/devel NO_DEFAULT_PATH )
set(KDE4_SOLID_LIBS ${solid_LIB_DEPENDS} ${KDE4_SOLID_LIBRARY} ) set(KDE4_SOLID_LIBS ${solid_LIB_DEPENDS} ${KDE4_SOLID_LIBRARY} )
@ -161,7 +154,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
set(KDE4_KTEXTEDITOR_LIBS ${ktexteditor_LIB_DEPENDS} ${KDE4_KTEXTEDITOR_LIBRARY} ) set(KDE4_KTEXTEDITOR_LIBS ${ktexteditor_LIB_DEPENDS} ${KDE4_KTEXTEDITOR_LIBRARY} )
# Can't do that, it's not always compiled. # Can't do that, it's not always compiled.
@@ -451,8 +451,8 @@ else (_kdeBootStrapping) @@ -452,8 +452,8 @@ else (_kdeBootStrapping)
# at first look in LIBEXEC_INSTALL_DIR and no default paths, # at first look in LIBEXEC_INSTALL_DIR and no default paths,
# if this didn't succeed, the second call makes cmake search again, but in the standard paths # if this didn't succeed, the second call makes cmake search again, but in the standard paths
@ -172,7 +165,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
if (AUTOMOC4_EXECUTABLE) if (AUTOMOC4_EXECUTABLE)
set(KDE4_AUTOMOC_EXECUTABLE "${AUTOMOC4_EXECUTABLE}") set(KDE4_AUTOMOC_EXECUTABLE "${AUTOMOC4_EXECUTABLE}")
@@ -464,8 +464,8 @@ else (_kdeBootStrapping) @@ -465,8 +465,8 @@ else (_kdeBootStrapping)
find_program(KDE4_MEINPROC_EXECUTABLE NAME meinproc4 PATHS ${KDE4_BIN_INSTALL_DIR} NO_DEFAULT_PATH ) find_program(KDE4_MEINPROC_EXECUTABLE NAME meinproc4 PATHS ${KDE4_BIN_INSTALL_DIR} NO_DEFAULT_PATH )
find_program(KDE4_MEINPROC_EXECUTABLE NAME meinproc4 ) find_program(KDE4_MEINPROC_EXECUTABLE NAME meinproc4 )
@ -183,7 +176,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
# allow searching cmake modules in all given kde install locations (KDEDIRS based) # allow searching cmake modules in all given kde install locations (KDEDIRS based)
execute_process(COMMAND "${KDE4_KDECONFIG_EXECUTABLE}" --path data OUTPUT_VARIABLE _data_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE) execute_process(COMMAND "${KDE4_KDECONFIG_EXECUTABLE}" --path data OUTPUT_VARIABLE _data_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -686,7 +686,8 @@ set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SY @@ -695,7 +695,8 @@ set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SY
"${_CMAKE_INSTALL_DIR}/bin" "${_CMAKE_INSTALL_DIR}/bin"
"${CMAKE_INSTALL_PREFIX}/bin" ) "${CMAKE_INSTALL_PREFIX}/bin" )
@ -193,7 +186,7 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
"${KDE4_LIB_INSTALL_DIR}" "${KDE4_LIB_INSTALL_DIR}"
"${_CMAKE_INSTALL_DIR}/lib" "${_CMAKE_INSTALL_DIR}/lib"
"${CMAKE_INSTALL_PREFIX}/lib" ) "${CMAKE_INSTALL_PREFIX}/lib" )
@@ -1079,9 +1080,9 @@ macro (KDE4_PRINT_RESULTS) @@ -1067,9 +1068,9 @@ macro (KDE4_PRINT_RESULTS)
endif (NOT _kdeBootStrapping) endif (NOT _kdeBootStrapping)
if(KDE4_KCFGC_EXECUTABLE) if(KDE4_KCFGC_EXECUTABLE)
@ -206,8 +199,8 @@ diff -up kdelibs-4.0.80/cmake/modules/FindKDE4Internal.cmake.parallel_devel kdel
if(KDE4_AUTOMOC_EXECUTABLE) if(KDE4_AUTOMOC_EXECUTABLE)
diff -up kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh diff -up kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel 2008-05-21 13:07:26.000000000 +0200 --- kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel 2008-06-01 08:12:31.000000000 +0200
+++ kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh 2008-05-26 16:32:04.000000000 +0200 +++ kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh 2008-06-12 22:23:01.000000000 +0200
@@ -2,9 +2,9 @@ @@ -2,9 +2,9 @@
# Generates and cleans KConfigXT source code during a API dox build # Generates and cleans KConfigXT source code during a API dox build
# #
@ -221,8 +214,8 @@ diff -up kdelibs-4.0.80/doc/api/doxygen-preprocess-kcfg.sh.parallel_devel kdelib
fi fi
diff -up kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl diff -up kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel 2008-05-21 13:09:13.000000000 +0200 --- kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel 2008-06-01 08:17:18.000000000 +0200
+++ kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl 2008-05-26 16:32:04.000000000 +0200 +++ kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl 2008-06-12 22:23:01.000000000 +0200
@@ -15,12 +15,12 @@ $file_cpp = "$filebase.cpp"; @@ -15,12 +15,12 @@ $file_cpp = "$filebase.cpp";
$kcfgc = $file . "c"; $kcfgc = $file . "c";
@ -239,8 +232,8 @@ diff -up kdelibs-4.0.80/kdecore/kconfig_compiler/checkkcfg.pl.parallel_devel kde
} }
diff -up kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt diff -up kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-05-21 13:09:13.000000000 +0200 --- kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-06-01 08:17:18.000000000 +0200
+++ kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt 2008-05-26 16:32:04.000000000 +0200 +++ kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt 2008-06-12 22:23:01.000000000 +0200
@@ -8,11 +8,11 @@ add_subdirectory( example ) @@ -8,11 +8,11 @@ add_subdirectory( example )
set(kconfig_compiler_SRCS kconfig_compiler.cpp) set(kconfig_compiler_SRCS kconfig_compiler.cpp)
@ -257,8 +250,8 @@ diff -up kdelibs-4.0.80/kdecore/kconfig_compiler/CMakeLists.txt.parallel_devel k
########### install files ############### ########### install files ###############
diff -up kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt diff -up kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-05-21 13:08:30.000000000 +0200 --- kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_devel 2008-06-01 08:15:17.000000000 +0200
+++ kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-05-26 16:32:04.000000000 +0200 +++ kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-06-12 22:23:01.000000000 +0200
@@ -9,7 +9,7 @@ macro(GEN_KCFG_TEST_SOURCE _testName _sr @@ -9,7 +9,7 @@ macro(GEN_KCFG_TEST_SOURCE _testName _sr
add_custom_command( add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h
@ -269,8 +262,8 @@ diff -up kdelibs-4.0.80/kdeui/tests/kconfig_compiler/CMakeLists.txt.parallel_dev
# set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h PROPERTIES GENERATED TRUE) # set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h PROPERTIES GENERATED TRUE)
qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.moc ) qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.moc )
diff -up kdelibs-4.0.80/kdewidgets/CMakeLists.txt.parallel_devel kdelibs-4.0.80/kdewidgets/CMakeLists.txt diff -up kdelibs-4.0.80/kdewidgets/CMakeLists.txt.parallel_devel kdelibs-4.0.80/kdewidgets/CMakeLists.txt
--- kdelibs-4.0.80/kdewidgets/CMakeLists.txt.parallel_devel 2008-05-21 13:08:17.000000000 +0200 --- kdelibs-4.0.80/kdewidgets/CMakeLists.txt.parallel_devel 2008-06-01 08:14:41.000000000 +0200
+++ kdelibs-4.0.80/kdewidgets/CMakeLists.txt 2008-05-26 16:32:04.000000000 +0200 +++ kdelibs-4.0.80/kdewidgets/CMakeLists.txt 2008-06-12 22:23:01.000000000 +0200
@@ -16,22 +16,22 @@ include_directories( @@ -16,22 +16,22 @@ include_directories(
set(makekdewidgets_SRCS makekdewidgets.cpp ) set(makekdewidgets_SRCS makekdewidgets.cpp )

View File

@ -1,5 +1,6 @@
--- kioslave/http/http.cpp.orig 2008-04-30 21:00:26.000000000 +0700 diff -up kdelibs/kioslave/http/http.cpp.orig kdelibs/kioslave/http/http.cpp
+++ kioslave/http/http.cpp 2008-05-14 16:46:43.000000000 +0700 --- kdelibs/kioslave/http/http.cpp.orig 2008-06-12 17:23:34.000000000 +0200
+++ kdelibs/kioslave/http/http.cpp 2008-06-12 17:36:29.000000000 +0200
@@ -43,6 +43,7 @@ @@ -43,6 +43,7 @@
#include <QtCore/QDate> #include <QtCore/QDate>
#include <QtDBus/QtDBus> #include <QtDBus/QtDBus>
@ -8,7 +9,7 @@
#include <QtNetwork/QHostInfo> #include <QtNetwork/QHostInfo>
#include <kurl.h> #include <kurl.h>
@@ -259,9 +260,11 @@ @@ -259,9 +260,11 @@ void HTTPProtocol::resetSessionSettings(
// Do not reset the URL on redirection if the proxy // Do not reset the URL on redirection if the proxy
// URL, username or password has not changed! // URL, username or password has not changed!
KUrl proxy ( config()->readEntry("UseProxy") ); KUrl proxy ( config()->readEntry("UseProxy") );
@ -20,7 +21,7 @@
(!proxy.user().isNull() && proxy.user() != m_proxyURL.user()) || (!proxy.user().isNull() && proxy.user() != m_proxyURL.user()) ||
(!proxy.pass().isNull() && proxy.pass() != m_proxyURL.pass()) ) (!proxy.pass().isNull() && proxy.pass() != m_proxyURL.pass()) )
{ {
@@ -272,8 +275,22 @@ @@ -272,6 +275,21 @@ void HTTPProtocol::resetSessionSettings(
kDebug(7113) << "Using proxy:" << m_bUseProxy kDebug(7113) << "Using proxy:" << m_bUseProxy
<< "URL: " << m_proxyURL.url() << "URL: " << m_proxyURL.url()
<< "Realm: " << m_strProxyRealm; << "Realm: " << m_strProxyRealm;
@ -33,17 +34,16 @@
+ proxyType = QNetworkProxy::HttpProxy; + proxyType = QNetworkProxy::HttpProxy;
+ +
+ m_request.proxyURL = proxy; + m_request.proxyURL = proxy;
} + }
+ else + else
+ m_request.proxyURL = KUrl(); + m_request.proxyURL = KUrl();
+
+ QNetworkProxy::setApplicationProxy(QNetworkProxy(proxyType,m_proxyURL.host(),m_proxyURL.port(),m_proxyURL.user(),m_proxyURL.pass())); + QNetworkProxy::setApplicationProxy(QNetworkProxy(proxyType,m_proxyURL.host(),m_proxyURL.port(),m_proxyURL.user(),m_proxyURL.pass()));
+ +
+ } }
m_bPersistentProxyConnection = config()->readEntry("PersistentProxyConnection", false); m_bPersistentProxyConnection = config()->readEntry("PersistentProxyConnection", false);
kDebug(7113) << "Enable Persistent Proxy Connection: " @@ -1903,7 +1921,7 @@ void HTTPProtocol::httpCheckConnection()
<< m_bPersistentProxyConnection;
@@ -1903,7 +1920,7 @@
kDebug(7113) << "Connection lost!"; kDebug(7113) << "Connection lost!";
closeDown = true; closeDown = true;
} }
@ -52,7 +52,7 @@
{ {
closeDown = true; closeDown = true;
} }
@@ -1915,6 +1932,14 @@ @@ -1915,6 +1933,14 @@ void HTTPProtocol::httpCheckConnection()
m_state.passwd != m_request.passwd) m_state.passwd != m_request.passwd)
closeDown = true; closeDown = true;
} }
@ -67,7 +67,7 @@
else else
{ {
// Keep the connection to the proxy. // Keep the connection to the proxy.
@@ -1933,19 +1958,26 @@ @@ -1933,17 +1959,23 @@ void HTTPProtocol::httpCheckConnection()
m_state.user = m_request.user; m_state.user = m_request.user;
m_state.passwd = m_request.passwd; m_state.passwd = m_request.passwd;
m_state.doProxy = m_request.doProxy; m_state.doProxy = m_request.doProxy;
@ -76,10 +76,7 @@
bool HTTPProtocol::httpOpenConnection() bool HTTPProtocol::httpOpenConnection()
{ {
int errCode;
QString errMsg;
+ bool connResult; + bool connResult;
kDebug(7113); kDebug(7113);
setBlocking( true ); setBlocking( true );
@ -90,13 +87,13 @@
+ connResult = connectToHost(m_proxyURL.protocol(), m_proxyURL.host(), m_proxyURL.port() ); + connResult = connectToHost(m_proxyURL.protocol(), m_proxyURL.host(), m_proxyURL.port() );
+ else + else
+ connResult = connectToHost(m_protocol, m_state.hostname, m_state.port ); + connResult = connectToHost(m_protocol, m_state.hostname, m_state.port );
+
+ if ( connResult ) + if ( connResult )
+ { + {
#if 0 // QTcpSocket doesn't support this #if 0 // QTcpSocket doesn't support this
// Set our special socket option!! // Set our special socket option!!
@@ -1955,7 +1987,8 @@ socket().setNoDelay(true);
@@ -1952,7 +1984,8 @@ bool HTTPProtocol::httpOpenConnection()
m_bFirstRequest = true; m_bFirstRequest = true;
connected(); connected();
@ -106,9 +103,10 @@
} }
--- kioslave/http/http.h.orig 2008-01-29 15:20:03.000000000 +0600 diff -up kdelibs/kioslave/http/http.h.orig kdelibs/kioslave/http/http.h
+++ kioslave/http/http.h 2008-05-07 17:26:45.000000000 +0700 --- kdelibs/kioslave/http/http.h.orig 2008-06-12 17:36:35.000000000 +0200
@@ -83,6 +83,7 @@ +++ kdelibs/kioslave/http/http.h 2008-06-12 17:37:47.000000000 +0200
@@ -83,6 +83,7 @@ public:
QString user; QString user;
QString passwd; QString passwd;
bool doProxy; bool doProxy;
@ -116,7 +114,7 @@
}; };
/** DAV-specific request elements for the current connection **/ /** DAV-specific request elements for the current connection **/
@@ -145,6 +146,7 @@ @@ -145,6 +146,7 @@ public:
QString id; QString id;
DAVRequest davData; DAVRequest davData;
bool doProxy; bool doProxy;

View File

@ -1,7 +1,7 @@
Summary: K Desktop Environment 4 - Libraries Summary: K Desktop Environment 4 - Libraries
Version: 4.0.80 Version: 4.0.82
Release: 2%{?dist} Release: 1%{?dist}
%if 0%{?fedora} > 8 %if 0%{?fedora} > 8
Name: kdelibs Name: kdelibs
@ -49,7 +49,7 @@ Source1: kde4.sh
Source2: kde4.csh Source2: kde4.csh
# make -devel packages parallel-installable # make -devel packages parallel-installable
Patch0: kdelibs-4.0.80-parallel_devel.patch Patch0: kdelibs-4.0.81-parallel_devel.patch
# fix kde#149705 # fix kde#149705
Patch2: kdelibs-3.95.0-kde149705.patch Patch2: kdelibs-3.95.0-kde149705.patch
# Hunspell support for K3Spell # Hunspell support for K3Spell
@ -75,12 +75,11 @@ Patch13: kdelibs-4.0.3-fedora-buildtype.patch
Patch14: kdelibs-4.0.3-libexecdir.patch Patch14: kdelibs-4.0.3-libexecdir.patch
# fix proxy support (#443931, kde#155707) # fix proxy support (#443931, kde#155707)
# patch by Sergey Saukh: http://bugs.kde.org/show_bug.cgi?id=155707#c46 # patch by Sergey Saukh: http://bugs.kde.org/show_bug.cgi?id=155707#c46
Patch15: kdelibs-4.0.4-proxy.patch Patch15: kdelibs-4.0.82-proxy.patch
# forward port kstandarddirs hack to search /etc/kde # forward port kstandarddirs hack to search /etc/kde
Patch18: kdelibs-4.0.80-kstandarddirs.patch Patch18: kdelibs-4.0.80-kstandarddirs.patch
## upstream patches # upstream patches
Patch100: kdelibs-4.0.80-khtml-stylesheet.patch
BuildRequires: qt4-devel >= 4.4.0 BuildRequires: qt4-devel >= 4.4.0
Requires: qt4 >= %{_qt4_version} Requires: qt4 >= %{_qt4_version}
@ -196,11 +195,10 @@ sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanage
%patch12 -p1 -b .Administration-menu %patch12 -p1 -b .Administration-menu
%patch13 -p1 -b .fedora-buildtype %patch13 -p1 -b .fedora-buildtype
%patch14 -p1 -b .libexecdir %patch14 -p1 -b .libexecdir
%patch15 -p0 -b .proxy %patch15 -p1 -b .proxy
%patch18 -p1 -b .kstandarddirs %patch18 -p1 -b .kstandarddirs
# upstream patches # upstream patches
%patch100 -p1 -b .khtml-stylesheet
%build %build
@ -366,6 +364,9 @@ rm -rf %{buildroot}
%changelog %changelog
* Fri Jun 13 2008 Than Ngo <than@redhat.com> 4.0.82-1
- 4.0.82
* Fri May 30 2008 Than Ngo <than@redhat.com> 4.0.80-2 * Fri May 30 2008 Than Ngo <than@redhat.com> 4.0.80-2
- fix #447965, order issue in kde path, thanks to Kevin - fix #447965, order issue in kde path, thanks to Kevin
- backport patch to check html style version - backport patch to check html style version