kde-4.2 beta1

This commit is contained in:
Than Ngo 2008-11-20 10:22:49 +00:00
parent 4f5b7b5c3d
commit 055eeab1d6
9 changed files with 231 additions and 125 deletions

View File

@ -1 +1,2 @@
kdelibs-4.1.69.tar.bz2
kdelibs-4.1.80.tar.bz2

View File

@ -1,34 +0,0 @@
diff -up kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake.orig kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake.orig 2008-09-12 23:54:36.000000000 +0200
+++ kdelibs-4.1.1/cmake/modules/FindKDE4Internal.cmake 2008-09-13 00:02:50.000000000 +0200
@@ -745,6 +745,7 @@ endif(WIN32)
# CMake generators if no build type is set.
if (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo)
+ set(CMAKE_CONFIGURATION_TYPES ${CMAKE_BUILD_TYPE})
endif (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
@@ -953,10 +954,6 @@ endif(MSVC)
if (CMAKE_COMPILER_IS_GNUCXX)
- if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
- set (CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} "Debugfull")
- endif("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
-
set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
# Select flags.
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")
@@ -1063,11 +1060,6 @@ endif (CMAKE_COMPILER_IS_GNUCXX)
if (CMAKE_C_COMPILER MATCHES "icc")
-
- if("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
- set (CMAKE_CONFIGURATION_TYPES ${CMAKE_CONFIGURATION_TYPES} "Debugfull")
- endif("${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}" GREATER 2.5)
-
set (KDE4_ENABLE_EXCEPTIONS -fexceptions)
# Select flags.
set(CMAKE_CXX_FLAGS_RELWITHDEBINFO "-O2 -g")

View File

@ -0,0 +1,11 @@
diff -Naur kdelibs-4.1.70/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.70.cmake/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.70/cmake/modules/FindKDE4Internal.cmake 2008-10-19 16:56:45.000000000 +0200
+++ kdelibs-4.1.70.cmake/cmake/modules/FindKDE4Internal.cmake 2008-10-19 17:06:14.000000000 +0200
@@ -817,6 +817,7 @@
# CMake generators if no build type is set.
if (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE RelWithDebInfo)
+ set(CMAKE_CONFIGURATION_TYPES ${CMAKE_BUILD_TYPE})
endif (NOT CMAKE_CONFIGURATION_TYPES AND NOT CMAKE_BUILD_TYPE)

View File

@ -1,7 +1,7 @@
diff -ur kdelibs-4.1.0/kdecore/kernel/kstandarddirs.cpp kdelibs-4.1.0-kstandarddirs/kdecore/kernel/kstandarddirs.cpp
--- kdelibs-4.1.0/kdecore/kernel/kstandarddirs.cpp 2008-07-09 15:28:22.000000000 +0200
+++ kdelibs-4.1.0-kstandarddirs/kdecore/kernel/kstandarddirs.cpp 2008-08-29 00:07:51.000000000 +0200
@@ -996,7 +996,9 @@
diff -Naur kdelibs-4.1.72/kdecore/kernel/kstandarddirs.cpp kdelibs-4.1.72.kstandarddirs/kdecore/kernel/kstandarddirs.cpp
--- kdelibs-4.1.72/kdecore/kernel/kstandarddirs.cpp 2008-11-12 18:31:44.000000000 +0100
+++ kdelibs-4.1.72.kstandarddirs/kdecore/kernel/kstandarddirs.cpp 2008-11-12 18:38:40.000000000 +0100
@@ -1002,7 +1002,9 @@
pit != prefixList->end();
++pit)
{
@ -10,9 +10,9 @@ diff -ur kdelibs-4.1.0/kdecore/kernel/kstandarddirs.cpp kdelibs-4.1.0-kstandardd
+ // a false positive due to the libexecdir patch
+ if((*pit)!=installprefix||installdir.isEmpty()||!strcmp("exe", type))
{
for (QStringList::ConstIterator it = dirs.begin();
it != dirs.end(); ++it)
@@ -1010,6 +1012,11 @@
for (QStringList::ConstIterator it = dirs.constBegin();
it != dirs.constEnd(); ++it)
@@ -1016,6 +1018,11 @@
if ((local || testdir.exists()) && !candidates.contains(path))
candidates.append(path);
}

View File

@ -1,7 +1,7 @@
diff -ur kdelibs-4.0.2/kdecore/config/kconfig.cpp kdelibs-4.0.2-no-cache-kdeglobals-paths/kdecore/config/kconfig.cpp
--- kdelibs-4.0.2/kdecore/config/kconfig.cpp 2008-01-05 01:00:39.000000000 +0100
+++ kdelibs-4.0.2-no-cache-kdeglobals-paths/kdecore/config/kconfig.cpp 2008-03-09 23:58:41.000000000 +0100
@@ -60,12 +60,6 @@
diff -Naur kdelibs-4.1.72/kdecore/config/kconfig.cpp kdelibs-4.1.72.no-cache-kdeglobals-path/kdecore/config/kconfig.cpp
--- kdelibs-4.1.72/kdecore/config/kconfig.cpp 2008-10-23 01:05:09.000000000 +0200
+++ kdelibs-4.1.72.no-cache-kdeglobals-path/kdecore/config/kconfig.cpp 2008-11-10 17:38:33.000000000 +0100
@@ -61,12 +61,6 @@
{
sGlobalFileName = componentData.dirs()->saveLocation("config") +
QString::fromLatin1("kdeglobals");
@ -13,8 +13,8 @@ diff -ur kdelibs-4.0.2/kdecore/config/kconfig.cpp kdelibs-4.0.2-no-cache-kdeglob
- }
const QString etc_kderc =
#ifdef Q_WS_WIN
QFile::decodeName( QByteArray(::getenv("WINDIR")) + "\\kde4rc" );
@@ -75,15 +69,11 @@
QFile::decodeName( qgetenv("WINDIR") + "/kde4rc" );
@@ -76,15 +70,11 @@
KEntryMap tmp;
// first entry is always /etc/kderc or empty if cannot read
if (KStandardDirs::checkAccess(etc_kderc, R_OK)) {
@ -30,7 +30,7 @@ diff -ur kdelibs-4.0.2/kdecore/config/kconfig.cpp kdelibs-4.0.2-no-cache-kdeglob
mappingsRegistered = true;
}
@@ -372,10 +362,31 @@
@@ -461,10 +451,31 @@
void KConfigPrivate::parseGlobalFiles()
{
@ -64,10 +64,10 @@ diff -ur kdelibs-4.0.2/kdecore/config/kconfig.cpp kdelibs-4.0.2-no-cache-kdeglob
const QByteArray utf8Locale = locale.toUtf8();
foreach(const QString& file, globalFiles) {
KConfigBackend::ParseOptions parseOpts = KConfigBackend::ParseGlobal|KConfigBackend::ParseExpansions;
diff -ur kdelibs-4.0.2/kdecore/config/kconfig_p.h kdelibs-4.0.2-no-cache-kdeglobals-paths/kdecore/config/kconfig_p.h
--- kdelibs-4.0.2/kdecore/config/kconfig_p.h 2008-01-05 01:00:39.000000000 +0100
+++ kdelibs-4.0.2-no-cache-kdeglobals-paths/kdecore/config/kconfig_p.h 2008-03-09 23:50:26.000000000 +0100
@@ -82,7 +82,6 @@
diff -Naur kdelibs-4.1.72/kdecore/config/kconfig_p.h kdelibs-4.1.72.no-cache-kdeglobals-path/kdecore/config/kconfig_p.h
--- kdelibs-4.1.72/kdecore/config/kconfig_p.h 2008-06-03 11:34:54.000000000 +0200
+++ kdelibs-4.1.72.no-cache-kdeglobals-path/kdecore/config/kconfig_p.h 2008-11-10 17:38:33.000000000 +0100
@@ -86,7 +86,6 @@
KEntryMap entryMap;
QString backendType;

View File

@ -1,6 +1,6 @@
diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-parallel_devel/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake 2008-09-26 16:57:01.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/cmake/modules/FindKDE4Internal.cmake 2008-10-17 23:23:59.000000000 +0200
diff -Naur kdelibs-4.1.72/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.72.parallel_devel/cmake/modules/FindKDE4Internal.cmake
--- kdelibs-4.1.72/cmake/modules/FindKDE4Internal.cmake 2008-11-12 18:31:44.000000000 +0100
+++ kdelibs-4.1.72.parallel_devel/cmake/modules/FindKDE4Internal.cmake 2008-11-12 18:35:47.000000000 +0100
@@ -15,10 +15,10 @@
# The following variables are defined for the various tools required to
# compile KDE software:
@ -14,7 +14,16 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
#
# The following variables point to the location of the KDE libraries,
# but shouldn't be used directly:
@@ -126,7 +126,7 @@
@@ -76,7 +76,7 @@
# KDE4_KFORMULA_LIBS - the kformula library and all depending librairies
# KDE4_PLASMA_LIBS - the plasma library and all depending librairies
#
-# This module defines a bunch of variables used as locations for install directories.
+# This module defines a bunch of variables used as locations for install directories.
# They can be relative (to CMAKE_INSTALL_PREFIX) or absolute.
# Under Windows they are always relative.
#
@@ -128,7 +128,7 @@
# Use optional GENERATE_MOC to generate moc if you use signals in your kcfg files.
#
# KDE4_ADD_WIDGET_FILES (SRCS_VAR file1.widgets ... fileN.widgets)
@ -23,7 +32,19 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
# for Qt Designer plugins.
#
# KDE4_CREATE_FINAL_FILES (filename_CXX filename_C file1 ... fileN)
@@ -367,23 +367,23 @@
@@ -299,9 +299,9 @@
find_package(Perl ${_REQ_STRING_KDE4})
# Check that we really found everything.
-# If KDE4 was searched with REQUIRED, we error out with FATAL_ERROR if something wasn't found
+# If KDE4 was searched with REQUIRED, we error out with FATAL_ERROR if something wasn't found
# already above in the other FIND_PACKAGE() calls.
-# If KDE4 was searched without REQUIRED and something in the FIND_PACKAGE() calls above wasn't found,
+# If KDE4 was searched without REQUIRED and something in the FIND_PACKAGE() calls above wasn't found,
# then we get here and must check that everything has actually been found. If something is missing,
# we must not fail with FATAL_ERROR, but only not set KDE4_FOUND.
if(NOT PERL_FOUND)
@@ -369,23 +369,23 @@
if (WIN32)
set(LIBRARY_OUTPUT_PATH ${EXECUTABLE_OUTPUT_PATH} )
# CMAKE_CFG_INTDIR is the output subdirectory created e.g. by XCode and MSVC
@ -53,7 +74,21 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
set( _KDE4_MEINPROC_EXECUTABLE_DEP meinproc4)
set(KDE4_INSTALLED_VERSION_OK TRUE)
@@ -449,69 +449,69 @@
@@ -435,11 +435,11 @@
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/lib )
if (WIN32)
- # we don't want to be forced to set two paths into the build tree
+ # we don't want to be forced to set two paths into the build tree
set(LIBRARY_OUTPUT_PATH ${CMAKE_BINARY_DIR}/bin )
# on win32 the install dir is determined on runtime not install time
- # KDELIBS_INSTALL_DIR and QT_INSTALL_DIR are used in KDELibsDependencies.cmake to setup
+ # KDELIBS_INSTALL_DIR and QT_INSTALL_DIR are used in KDELibsDependencies.cmake to setup
# kde install paths and library dependencies
get_filename_component(_DIR ${KDE4_KDECONFIG_EXECUTABLE} PATH )
get_filename_component(KDE4_INSTALL_DIR ${_DIR} PATH )
@@ -451,69 +451,69 @@
include(${kde_cmake_module_dir}/KDELibsDependencies.cmake)
if (UNIX)
@ -144,7 +179,16 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
set(KDE4_KTEXTEDITOR_LIBS ${ktexteditor_LIB_DEPENDS} ${KDE4_KTEXTEDITOR_LIBRARY} )
# Can't do that, it's not always compiled.
@@ -534,14 +534,14 @@
@@ -527,7 +527,7 @@
find_library(KDE4_KFORMULA_LIBRARY NAMES kformula PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH )
set(KDE4_KFORMULA_LIBS ${kformula_LIB_DEPENDS} ${KDE4_KFORMULA_LIBRARY} )
- find_library(KDE4_PLASMA_LIBRARY NAMES plasma PATHS ${KDE4_LIB_INSTALL_DIR} NO_DEFAULT_PATH )
+ find_library(KDE4_PLASMA_LIBRARY NAMES plasma PATHS ${KDE4_LIB_INSTALL_DIR}/kde4/devel NO_DEFAULT_PATH )
set(KDE4_PLASMA_LIBS ${plasma_LIB_DEPENDS} ${KDE4_PLASMA_LIBRARY} )
@@ -540,14 +540,14 @@
# at first look in LIBEXEC_INSTALL_DIR and no default paths,
# if this didn't succeed, the second call makes cmake search again, but in the standard paths
@ -163,7 +207,53 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
# allow searching cmake modules in all given kde install locations (KDEDIRS based)
execute_process(COMMAND "${KDE4_KDECONFIG_EXECUTABLE}" --path data OUTPUT_VARIABLE _data_DIR ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)
@@ -797,7 +797,8 @@
@@ -584,14 +584,14 @@
# # This option enables the reduced link interface for libs on UNIX
# #
-# # The purpose of the KDE4_DISABLE_PROPERTY_ variable is to be used as a prefix for
+# # The purpose of the KDE4_DISABLE_PROPERTY_ variable is to be used as a prefix for
# # the target property LINK_INTERFACE_LIBRARIES. If it is empty, the property will have its
# # correct name, if it's not empty, it will be a different name, i.e. the actual property
# # will not be set, i.e. disabled. See kdelibs/kdecore/CMakeLists.txt for an example.
# #
-# # By default (i.e. also for Windows) make it non-empty, so the property name will
-# # change from "LINK_INTERFACE_LIBRARIES" to "DISABLED_LINK_INTERFACE_LIBRARIES",
-# # which is a different (non-existing) target property, and so setting that property
+# # By default (i.e. also for Windows) make it non-empty, so the property name will
+# # change from "LINK_INTERFACE_LIBRARIES" to "DISABLED_LINK_INTERFACE_LIBRARIES",
+# # which is a different (non-existing) target property, and so setting that property
# # won't have an effect
# disable this for now for Windows, since there is an issue with the use of "debug" and
@@ -600,7 +600,7 @@
# disable the reduced linking temporarily for Windows, cmake HEAD and the soon-to-be-released cmake 2.6.2
# With 2.6.0 and 2.6.1 it can happen that the "debug", "optimized" and "general" keywords are
# misinterpreted by cmake as library names, the linking fails. Usually this happens under Windows.
-# In 2.6.2 this will be an error at cmake time, so we disable it for now and once we require
+# In 2.6.2 this will be an error at cmake time, so we disable it for now and once we require
# 2.6.2 we'll fix it the right way (using TARGET_LINK_LIBRARIES(foo LINK_INTERFACE_LIBRARIES ...)
if (WIN32 OR "${CMAKE_MINOR_VERSION}" EQUAL 7 OR "${CMAKE_PATCH_VERSION}" EQUAL 2)
set(KDE4_DISABLE_PROPERTY_ "DISABLED_")
@@ -761,7 +761,7 @@
# The INSTALL_TARGETS_DEFAULT_ARGS variable should be used when libraries are installed.
# The arguments are also ok for regular executables, i.e. executables which don't go
-# into sbin/ or libexec/, but for installing executables the basic syntax
+# into sbin/ or libexec/, but for installing executables the basic syntax
# INSTALL(TARGETS kate DESTINATION "${BIN_INSTALL_DIR}")
# is enough, so using this variable there doesn't help a lot.
# The variable must not be used for installing plugins.
@@ -771,7 +771,7 @@
# This will install libraries correctly under UNIX, OSX and Windows (i.e. dll's go
# into bin/.
# Later on it will be possible to extend this for installing OSX frameworks
-# The COMPONENT Devel argument has the effect that static libraries belong to the
+# The COMPONENT Devel argument has the effect that static libraries belong to the
# "Devel" install component. If we use this also for all install() commands
# for header files, it will be possible to install
# -everything: make install OR cmake -P cmake_install.cmake
@@ -803,13 +803,14 @@
set(CMAKE_SYSTEM_PROGRAM_PATH ${CMAKE_SYSTEM_PROGRAM_PATH}
"${KDE4_BIN_INSTALL_DIR}" )
@ -173,7 +263,26 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
"${KDE4_LIB_INSTALL_DIR}" )
# under Windows dlls may be also installed in bin/
@@ -1191,9 +1192,9 @@
if(WIN32)
- set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
- "${_CMAKE_INSTALL_DIR}/bin"
+ set(CMAKE_SYSTEM_LIBRARY_PATH ${CMAKE_SYSTEM_LIBRARY_PATH}
+ "${_CMAKE_INSTALL_DIR}/bin"
"${CMAKE_INSTALL_PREFIX}/bin" )
endif(WIN32)
@@ -834,8 +835,8 @@
find_package(KDEWIN32 REQUIRED)
- # limit win32 packaging to kdelibs at now
- # don't know if package name, version and notes are always available
+ # limit win32 packaging to kdelibs at now
+ # don't know if package name, version and notes are always available
if(_kdeBootStrapping)
find_package(KDEWIN_Packager)
if (KDEWIN_PACKAGER_FOUND)
@@ -1198,9 +1199,9 @@
endif (NOT _kdeBootStrapping)
if(KDE4_KCFGC_EXECUTABLE)
@ -185,9 +294,18 @@ diff -ur kdelibs-4.1.69/cmake/modules/FindKDE4Internal.cmake kdelibs-4.1.69-para
endif(KDE4_KCFGC_EXECUTABLE)
if(AUTOMOC4_EXECUTABLE)
diff -ur kdelibs-4.1.69/doc/api/doxygen-preprocess-kcfg.sh kdelibs-4.1.69-parallel_devel/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.1.69/doc/api/doxygen-preprocess-kcfg.sh 2008-05-21 13:07:26.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/doc/api/doxygen-preprocess-kcfg.sh 2008-10-17 23:24:29.000000000 +0200
@@ -1241,7 +1242,7 @@
${KDE4_INCLUDE_DIR}/KDE
${KDE4_PHONON_INCLUDES}
${QT_INCLUDES}
- ${_KDE4_PLATFORM_INCLUDE_DIRS}
+ ${_KDE4_PLATFORM_INCLUDE_DIRS}
)
set(KDE4_DEFINITIONS ${_KDE4_PLATFORM_DEFINITIONS} -DQT_NO_STL -DQT_NO_CAST_TO_ASCII -D_REENTRANT -DKDE_DEPRECATED_WARNINGS )
diff -Naur kdelibs-4.1.72/doc/api/doxygen-preprocess-kcfg.sh kdelibs-4.1.72.parallel_devel/doc/api/doxygen-preprocess-kcfg.sh
--- kdelibs-4.1.72/doc/api/doxygen-preprocess-kcfg.sh 2008-05-21 13:07:26.000000000 +0200
+++ kdelibs-4.1.72.parallel_devel/doc/api/doxygen-preprocess-kcfg.sh 2008-11-12 18:34:17.000000000 +0100
@@ -2,9 +2,9 @@
# Generates and cleans KConfigXT source code during a API dox build
#
@ -200,9 +318,9 @@ diff -ur kdelibs-4.1.69/doc/api/doxygen-preprocess-kcfg.sh kdelibs-4.1.69-parall
exit 1;
fi
diff -ur kdelibs-4.1.69/kdecore/kconfig_compiler/checkkcfg.pl kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.1.69/kdecore/kconfig_compiler/checkkcfg.pl 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl 2008-10-17 23:24:29.000000000 +0200
diff -Naur kdelibs-4.1.72/kdecore/kconfig_compiler/checkkcfg.pl kdelibs-4.1.72.parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl
--- kdelibs-4.1.72/kdecore/kconfig_compiler/checkkcfg.pl 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.72.parallel_devel/kdecore/kconfig_compiler/checkkcfg.pl 2008-11-12 18:34:17.000000000 +0100
@@ -15,12 +15,12 @@
$kcfgc = $file . "c";
@ -218,9 +336,9 @@ diff -ur kdelibs-4.1.69/kdecore/kconfig_compiler/checkkcfg.pl kdelibs-4.1.69-par
exit 1;
}
diff -ur kdelibs-4.1.69/kdecore/kconfig_compiler/CMakeLists.txt kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.69/kdecore/kconfig_compiler/CMakeLists.txt 2008-05-21 13:09:13.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt 2008-10-17 23:23:59.000000000 +0200
diff -Naur kdelibs-4.1.72/kdecore/kconfig_compiler/CMakeLists.txt kdelibs-4.1.72.parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.72/kdecore/kconfig_compiler/CMakeLists.txt 2008-10-30 15:19:14.000000000 +0100
+++ kdelibs-4.1.72.parallel_devel/kdecore/kconfig_compiler/CMakeLists.txt 2008-11-12 18:34:17.000000000 +0100
@@ -8,11 +8,11 @@
set(kconfig_compiler_SRCS kconfig_compiler.cpp)
@ -231,14 +349,14 @@ diff -ur kdelibs-4.1.69/kdecore/kconfig_compiler/CMakeLists.txt kdelibs-4.1.69-p
-target_link_libraries(kconfig_compiler ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
+target_link_libraries(kconfig_compiler4 ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} )
-install(TARGETS kconfig_compiler DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS kconfig_compiler4 DESTINATION ${BIN_INSTALL_DIR} )
-install(TARGETS kconfig_compiler ${INSTALL_TARGETS_DEFAULT_ARGS} )
+install(TARGETS kconfig_compiler4 ${INSTALL_TARGETS_DEFAULT_ARGS} )
########### install files ###############
diff -ur kdelibs-4.1.69/kdeui/tests/kconfig_compiler/CMakeLists.txt kdelibs-4.1.69-parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.69/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-05-21 13:08:30.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-10-17 23:24:29.000000000 +0200
diff -Naur kdelibs-4.1.72/kdeui/tests/kconfig_compiler/CMakeLists.txt kdelibs-4.1.72.parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt
--- kdelibs-4.1.72/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-05-21 13:08:30.000000000 +0200
+++ kdelibs-4.1.72.parallel_devel/kdeui/tests/kconfig_compiler/CMakeLists.txt 2008-11-12 18:34:17.000000000 +0100
@@ -9,7 +9,7 @@
add_custom_command(
OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.cpp ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h
@ -248,9 +366,23 @@ diff -ur kdelibs-4.1.69/kdeui/tests/kconfig_compiler/CMakeLists.txt kdelibs-4.1.
# set_source_files_properties(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h PROPERTIES GENERATED TRUE)
qt4_generate_moc(${CMAKE_CURRENT_BINARY_DIR}/${_testName}.h ${CMAKE_CURRENT_BINARY_DIR}/${_testName}.moc )
diff -ur kdelibs-4.1.69/kdewidgets/CMakeLists.txt kdelibs-4.1.69-parallel_devel/kdewidgets/CMakeLists.txt
--- kdelibs-4.1.69/kdewidgets/CMakeLists.txt 2008-05-21 13:08:17.000000000 +0200
+++ kdelibs-4.1.69-parallel_devel/kdewidgets/CMakeLists.txt 2008-10-17 23:23:59.000000000 +0200
diff -Naur kdelibs-4.1.72/kdewidgets/CMakeLists.txt kdelibs-4.1.72.parallel_devel/kdewidgets/CMakeLists.txt
--- kdelibs-4.1.72/kdewidgets/CMakeLists.txt 2008-10-30 15:19:04.000000000 +0100
+++ kdelibs-4.1.72.parallel_devel/kdewidgets/CMakeLists.txt 2008-11-12 18:34:17.000000000 +0100
@@ -1,10 +1,10 @@
project(kdewidgets)
-add_subdirectory( pics )
-add_subdirectory( tests )
+add_subdirectory( pics )
+add_subdirectory( tests )
-include_directories(
+include_directories(
${KDE4_KIO_INCLUDES}
${CMAKE_SOURCE_DIR}/kde3support
${CMAKE_SOURCE_DIR}/kde3support/kdeui
@@ -16,22 +16,22 @@
set(makekdewidgets_SRCS makekdewidgets.cpp )
@ -261,8 +393,8 @@ diff -ur kdelibs-4.1.69/kdewidgets/CMakeLists.txt kdelibs-4.1.69-parallel_devel/
-target_link_libraries(makekdewidgets ${KDE4_KDECORE_LIBS} )
+target_link_libraries(makekdewidgets4 ${KDE4_KDECORE_LIBS} )
-install(TARGETS makekdewidgets DESTINATION ${BIN_INSTALL_DIR} )
+install(TARGETS makekdewidgets4 DESTINATION ${BIN_INSTALL_DIR} )
-install(TARGETS makekdewidgets ${INSTALL_TARGETS_DEFAULT_ARGS} )
+install(TARGETS makekdewidgets4 ${INSTALL_TARGETS_DEFAULT_ARGS} )
########### next target ###############

View File

@ -1,6 +1,6 @@
diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp 2008-10-09 11:48:40.000000000 +0200
+++ kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.cpp 2008-10-17 15:19:48.000000000 +0200
diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cpp kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.cpp
--- kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.cpp 2008-11-04 18:13:11.000000000 +0100
+++ kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.cpp 2008-11-10 18:45:41.000000000 +0100
@@ -17,6 +17,8 @@
*/
@ -10,7 +10,7 @@ diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp kde
#include "halstorageaccess.h"
#include "halfstabhandling.h"
@@ -168,11 +170,21 @@
@@ -172,11 +174,21 @@
{
// TODO: Better error reporting here
if (m_setupInProgress) {
@ -32,28 +32,19 @@ diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp kde
m_teardownInProgress = false;
emit teardownDone(Solid::UnauthorizedOperation,
error.name()+": "+error.message(),
@@ -266,17 +278,18 @@
"Mount");
QStringList options;
QStringList halOptions = m_device->property("volume.mount.valid_options").toStringList();
+ QString fstype = m_device->property("volume.fstype").toString();
#ifdef Q_OS_FREEBSD
QString uid="-u=";
@@ -294,8 +306,9 @@
#else
QString uid="uid=";
#endif
- if (halOptions.contains(uid)) {
+ if (halOptions.contains(uid)
+ && (fstype == "vfat" || fstype == "iso9660" || fstype == "hfs" || fstype == "udf")) {
options << uid+QString::number(::getuid());
- options << uid+QString::number(::getuid());
+ if (halOptions.contains(uid) &&
+ (fstype == "vfat" || fstype == "iso9660" || fstype == "hfs" || fstype == "udf")) {
+ options << uid+QString::number(::getuid());
}
- QString fstype=m_device->property("volume.fstype").toString();
//respect Microsoft Windows-enforced charsets for fat
#ifdef Q_OS_FREEBSD
if ( fstype=="vfat" ) {
@@ -377,6 +390,60 @@
@@ -333,6 +346,59 @@
SLOT(slotDBusError(const QDBusError &)));
}
@ -109,14 +100,13 @@ diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.cpp kde
+ return false;
+ }
+}
+
+
bool StorageAccess::callHalVolumeUnmount()
{
QDBusConnection c = QDBusConnection::systemBus();
diff -Naur kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.h
--- kdelibs-4.1.69.orig/solid/solid/backends/hal/halstorageaccess.h 2008-05-21 13:07:38.000000000 +0200
+++ kdelibs-4.1.69/solid/solid/backends/hal/halstorageaccess.h 2008-10-17 14:59:31.000000000 +0200
diff -Naur kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.h kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.h
--- kdelibs-4.1.72.policykit/solid/solid/backends/hal/halstorageaccess.h 2008-05-21 13:07:38.000000000 +0200
+++ kdelibs-4.1.72/solid/solid/backends/hal/halstorageaccess.h 2008-11-10 18:45:01.000000000 +0100
@@ -69,6 +69,9 @@
bool callSystemMount();
bool callSystemUnmount();

View File

@ -1,8 +1,6 @@
%define _default_patch_fuzz 2
Summary: K Desktop Environment 4 - Libraries
Version: 4.1.69
Release: 1%{?dist}
Version: 4.1.80
Release: 2%{?dist}
%if 0%{?fedora} > 8
Name: kdelibs
@ -32,9 +30,6 @@ BuildRequires: kde4-macros(api) >= 2
BuildRequires: kde-filesystem >= 4
Requires: dbus-x11
Requires: hicolor-icon-theme
# kdebase-runtime not *strictly* required here, but how better to pull
# it in? comps only?
#Requires: kdebase-runtime
Requires: kde-filesystem >= 4
Requires: kde-settings
%{?_kde4_macros_api:Requires: kde4-macros(api) = %{_kde4_macros_api} }
@ -51,7 +46,7 @@ Source1: kde4.sh
Source2: kde4.csh
# make -devel packages parallel-installable
Patch0: kdelibs-4.1.69-parallel_devel.patch
Patch0: kdelibs-4.1.72-parallel_devel.patch
# fix kde#149705
Patch2: kdelibs-3.95.0-kde149705.patch
# Hunspell support for K3Spell
@ -67,15 +62,15 @@ Patch8: kdelibs-4.0.2-install-all-css.patch
Patch9: kdelibs-4.0.2-branding.patch
# don't cache kdeglobals paths because they change after profile directories
# are loaded from kde4rc
Patch10: kdelibs-4.0.2-no-cache-kdeglobals-paths.patch
Patch10: kdelibs-4.1.72-no-cache-kdeglobals-paths.patch
# workaround for policykit
Patch11: kdelibs-4.1.69-policykit-workaround.patch
Patch11: kdelibs-4.1.72-policykit-workaround.patch
Patch12: kdelibs-4.1.0-xdg-menu.patch
# patch KStandardDirs to use %{_libexecdir}/kde4 instead of %{_libdir}/kde4/libexec
Patch14: kdelibs-4.0.85-libexecdir.patch
# kstandarddirs changes: search /etc/kde, find /usr/libexec/kde4
Patch18: kdelibs-4.1.0-kstandarddirs.patch
Patch20: kdelibs-4.1.1-cmake.patch
Patch18: kdelibs-4.1.72-kstandarddirs.patch
Patch20: kdelibs-4.1.70-cmake.patch
BuildRequires: qt4-devel >= 4.4.0
Requires: qt4 >= %{_qt4_version}
@ -91,7 +86,7 @@ BuildRequires: aspell-devel
BuildRequires: automoc
BuildRequires: avahi-devel
BuildRequires: bzip2-devel
BuildRequires: cmake >= 2.6
BuildRequires: cmake >= 2.6.2
BuildRequires: cups-devel cups
BuildRequires: enchant-devel
BuildRequires: gamin-devel
@ -148,6 +143,7 @@ Requires: %{name} = %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: kdelibs4-devel < %{version}-%{release}
Provides: kdelibs4-devel = %{version}-%{release}
%endif
Requires: cmake >= 2.6.2
Requires: automoc
Requires: qt4-devel
Requires: openssl-devel
@ -194,7 +190,7 @@ format for easy browsing.
%patch9 -p1 -b .branding
sed -i -e "s|@@VERSION_RELEASE@@|%{version}-%{release}|" kio/kio/kprotocolmanager.cpp
%patch10 -p1 -b .no-cache-kdeglobals-paths
%patch11 -p1 -b .policykit
#%patch11 -p1 -b .policykit
%patch12 -p1 -b .Administration-menu
%patch14 -p1 -b .libexecdir
%patch18 -p1 -b .kstandarddirs
@ -246,8 +242,6 @@ do
case "$i" in
libkdeinit4_*.so)
;;
libkformulalib.so)
;;
## FIXME/TODO: imo, should leave everything except for known-conflicts -- Rex
*)
linktarget=`readlink "$i"`
@ -314,7 +308,6 @@ rm -rf %{buildroot}
%{_kde4_sharedir}/icons/hicolor/*/actions/*
%{_kde4_docdir}/HTML/en/sonnet/
%{_kde4_libdir}/lib*.so.*
%{_kde4_libdir}/libkformulalib.so
%{_kde4_libdir}/libkdeinit4_*.so
%dir %{_kde4_libdir}/kde4/
%{_kde4_libdir}/kde4/*.so
@ -362,10 +355,23 @@ rm -rf %{buildroot}
%changelog
* Sun Oct 17 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.69-1
- 4.1.69
- BR cmake >= 2.6, strigi-devel >= 0.6.0
- use make install/fast
* Thu Nov 20 2008 Than Ngo <than@redhat.com> 4.1.80-2
- merged
* Thu Nov 20 2008 Lorenzo Villani <lvillani@binaryhelix.net> - 6:4.1.80-1
- 4.1.80
- BR strigi 0.60
- BR cmake 2.6
- make install/fast
- rebase policykit patch
- rebase cmake patch
- rebase a couple of patches and drop _default_patch_fuzz 2
* Wed Nov 12 2008 Than Ngo <than@redhat.com> 4.1.3-1
- 4.1.3
* Fri Nov 07 2008 Rex Dieter <rdieter@fedoraproject.org> 4.1.2-6
- backport http_cache_cleaner fix (kdebug:172182)
* Wed Oct 15 2008 Lukáš Tinkl <ltinkl@redhat.com> 4.1.2-5
- backport fix for faulty window resizing (kdebug:172042)

View File

@ -1 +1 @@
1a5b1834df6e782236ebd3294d8c7f2a kdelibs-4.1.69.tar.bz2
46673e485f296b8f3741c7394e6cbc52 kdelibs-4.1.80.tar.bz2