Initial import (#653682).
This commit is contained in:
parent
f427988e16
commit
7ff3efd173
1
.gitignore
vendored
1
.gitignore
vendored
@ -0,0 +1 @@
|
|||||||
|
/jemalloc-2.0.1.tar.bz2
|
33
jemalloc-2.0.1.no_pprof.patch
Normal file
33
jemalloc-2.0.1.no_pprof.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
--- Makefile.in.orig 2010-11-18 10:58:56.977574922 +0100
|
||||||
|
+++ Makefile.in 2010-11-18 10:59:32.307037415 +0100
|
||||||
|
@@ -41,7 +41,6 @@
|
||||||
|
endif
|
||||||
|
|
||||||
|
# Lists of files.
|
||||||
|
-BINS := @srcroot@bin/pprof
|
||||||
|
CHDRS := @objroot@include/jemalloc/jemalloc@install_suffix@.h \
|
||||||
|
@objroot@include/jemalloc/jemalloc_defs@install_suffix@.h
|
||||||
|
CSRCS := @srcroot@src/jemalloc.c @srcroot@src/arena.c @srcroot@src/base.c \
|
||||||
|
@@ -103,13 +102,6 @@
|
||||||
|
$(CC) -o $@ $< -L@objroot@lib -ljemalloc@install_suffix@
|
||||||
|
endif
|
||||||
|
|
||||||
|
-install_bin:
|
||||||
|
- install -d $(BINDIR)
|
||||||
|
- @for b in $(BINS); do \
|
||||||
|
- echo "install -m 755 $$b $(BINDIR)"; \
|
||||||
|
- install -m 755 $$b $(BINDIR); \
|
||||||
|
-done
|
||||||
|
-
|
||||||
|
install_include:
|
||||||
|
install -d $(INCLUDEDIR)/jemalloc
|
||||||
|
@for h in $(CHDRS); do \
|
||||||
|
@@ -130,7 +122,7 @@
|
||||||
|
install -m 644 $$m $(MANDIR)/man3; \
|
||||||
|
done
|
||||||
|
|
||||||
|
-install: install_bin install_include install_lib install_man
|
||||||
|
+install: install_include install_lib install_man
|
||||||
|
|
||||||
|
tests: $(CTESTS:@srcroot@%.c=@objroot@%)
|
||||||
|
|
72
jemalloc.spec
Normal file
72
jemalloc.spec
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
Name: jemalloc
|
||||||
|
Version: 2.0.1
|
||||||
|
|
||||||
|
Release: 2%{?dist}
|
||||||
|
Summary: General-purpose scalable concurrent malloc implementation
|
||||||
|
|
||||||
|
Group: System Environment/Libraries
|
||||||
|
License: BSD
|
||||||
|
URL: http://www.canonware.com/jemalloc/
|
||||||
|
Source0: http://www.canonware.com/download/jemalloc/%{name}-%{version}.tar.bz2
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
|
# Remove pprof, as it already exists in google-perftools
|
||||||
|
Patch0: jemalloc-2.0.1.no_pprof.patch
|
||||||
|
|
||||||
|
%description
|
||||||
|
General-purpose scalable concurrent malloc(3) implementation.
|
||||||
|
This distribution is the stand-alone "portable" implementation of %{name}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
Group: Development/Libraries
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
make install DESTDIR=%{buildroot}
|
||||||
|
|
||||||
|
# None of these in fedora
|
||||||
|
find %{buildroot}%{_libdir}/ -name '*.a' -exec rm -vf {} ';'
|
||||||
|
|
||||||
|
|
||||||
|
%clean
|
||||||
|
rm -rf %{buildroot}
|
||||||
|
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_libdir}/libjemalloc.so.*
|
||||||
|
%doc COPYING README VERSION
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root,-)
|
||||||
|
%{_includedir}/jemalloc
|
||||||
|
%{_libdir}/libjemalloc.so
|
||||||
|
%{_mandir}/man3/jemalloc.3*
|
||||||
|
|
||||||
|
%post -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Thu Nov 18 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-2
|
||||||
|
- Added a patch that removes pprof, as it already exists in the
|
||||||
|
google-perftools package
|
||||||
|
- Cosmetic fixes as requested in the package review (rhbz#653682)
|
||||||
|
|
||||||
|
* Mon Nov 15 2010 Ingvar Hagelund <ingvar@redpill-linpro.com> - 2.0.1-1
|
||||||
|
- First cut of an rpm distribution of jemalloc
|
Loading…
Reference in New Issue
Block a user