updated to OpenJDK 21.0.1 (2023-10-17)

- adjsuted generate_source_tarball
- removed icedtea_sync
- dropped standalone licenses
- added usntripped subpkg
- added docs subpkg
- adjsuted versions of bundled libraries
- build refactored to several solid methods following gnu_andrew
- removed no longer needed jdk8296108-tzdata2022f.patch, jdk8296715-cldr2022f.patch, rh1648644-java_access_bridge_privileged_security.patch
- added jdk8311630-s390_ffmapi.patch to support virtual threads on s390x
- aligned fips-21u-75ffdc48eda.patch (gnu_andrew)
This commit is contained in:
Jiri Vanek 2023-11-21 15:48:20 +01:00
parent 898c425bb6
commit 1eb10e704b
14 changed files with 2804 additions and 691 deletions

1
.gitignore vendored
View File

@ -37,3 +37,4 @@
/openjdk-jdk21u-jdk-21+34.tar.xz
/openjdk-jdk21u-jdk-21+35.tar.xz
/openjdk-21+35.tar.xz
/openjdk-21.0.1+12.tar.xz

282
NEWS
View File

@ -3,13 +3,210 @@ Key:
JDK-X - https://bugs.openjdk.java.net/browse/JDK-X
CVE-XXXX-YYYY: https://cve.mitre.org/cgi-bin/cvename.cgi?name=XXXX-YYYY
New in release OpenJDK 21.0.1 (2023-10-17):
===========================================
* CVEs
- CVE-2023-22081
- CVE-2023-22025
* Security fixes
- JDK-8286503, JDK-8312367: Enhance security classes
- JDK-8296581: Better system proxy support
- JDK-8297856: Improve handling of Bidi characters
- JDK-8309966: Enhanced TLS connections
- JDK-8312248: Enhanced archival support redux
- JDK-8314649: Enhanced archival support redux
- JDK-8317121: vector_masked_load instruction is moved too early after JDK-8286941
* Other changes
- JDK-8240567: MethodTooLargeException thrown while creating a jlink image
- JDK-8284772: GHA: Use GCC Major Version Dependencies Only
- JDK-8293114: JVM should trim the native heap
- JDK-8299658: C1 compilation crashes in LinearScan::resolve_exception_edge
- JDK-8302017: Allocate BadPaddingException only if it will be thrown
- JDK-8303815: Improve Metaspace test speed
- JDK-8304954: SegmentedCodeCache fails when using large pages
- JDK-8307766: Linux: Provide the option to override the timer slack
- JDK-8308042: [macos] Developer ID Application Certificate not picked up by jpackage if it contains UNICODE characters
- JDK-8308047: java/util/concurrent/ScheduledThreadPoolExecutor/BasicCancelTest.java timed out and also had jcmd pipe errors
- JDK-8308184: Launching java with large number of jars in classpath with java.protocol.handler.pkgs system property set can lead to StackOverflowError
- JDK-8308474: DSA does not reset SecureRandom when initSign is called again
- JDK-8308609: java/lang/ScopedValue/StressStackOverflow.java fails with "-XX:-VMContinuations"
- JDK-8309032: jpackage does not work for module projects unless --module-path is specified
- JDK-8309088: security/infra/java/security/cert/CertPathValidator/certification/AmazonCA.java fails
- JDK-8309214: sun/security/pkcs11/KeyStore/CertChainRemoval.java fails after 8301154
- JDK-8309475: Test java/foreign/TestByteBuffer.java fails: a problem with msync (aix)
- JDK-8309502: RISC-V: String.indexOf intrinsic may produce misaligned memory loads
- JDK-8309591: Socket.setOption(TCP_QUICKACK) uses wrong level
- JDK-8309746: Reconfigure check should include make/conf/version-numbers.conf
- JDK-8309889: [s390] Missing return statement after calling jump_to_native_invoker method in generate_method_handle_dispatch.
- JDK-8310106: sun.security.ssl.SSLHandshake.getHandshakeProducer() incorrectly checks handshakeConsumers
- JDK-8310171: Bump version numbers for 21.0.1
- JDK-8310211: serviceability/jvmti/thread/GetStackTrace/getstacktr03/getstacktr03.java failing
- JDK-8310233: Fix THP detection on Linux
- JDK-8310268: RISC-V: misaligned memory access in String.Compare intrinsic
- JDK-8310321: make JDKOPT_CHECK_CODESIGN_PARAMS more verbose
- JDK-8310586: ProblemList java/lang/ScopedValue/StressStackOverflow.java#default with virtual threads on linux-all
- JDK-8310687: JDK-8303215 is incomplete
- JDK-8310873: Re-enable locked_create_entry symbol check in runtime/NMT/CheckForProperDetailStackTrace.java for RISC-V
- JDK-8311026: Some G1 specific tests do not set -XX:+UseG1GC
- JDK-8311033: [macos] PrinterJob does not take into account Sides attribute
- JDK-8311160: [macOS, Accessibility] VoiceOver: No announcements on JRadioButtonMenuItem and JCheckBoxMenuItem
- JDK-8311249: Remove unused MemAllocator::obj_memory_range
- JDK-8311285: report some fontconfig related environment variables in hs_err file
- JDK-8311511: Improve description of NativeLibrary JFR event
- JDK-8311592: ECKeySizeParameterSpec causes too many exceptions on third party providers
- JDK-8311682: Change milestone to fcs for all releases
- JDK-8311862: RISC-V: small improvements to shift immediate instructions
- JDK-8311917: MAP_FAILED definition seems to be obsolete in src/java.desktop/unix/native/common/awt/fontpath.c
- JDK-8311921: Inform about MaxExpectedDataSegmentSize in case of pthread_create failures on AIX
- JDK-8311923: TestIRMatching.java fails on RISC-V
- JDK-8311926: java/lang/ScopedValue/StressStackOverflow.java takes 9mins in tier1
- JDK-8311955: c++filt is now ibm-llvm-cxxfilt when using xlc17 / clang on AIX
- JDK-8311981: Test gc/stringdedup/TestStringDeduplicationAgeThreshold.java#ZGenerational timed out
- JDK-8312127: FileDescriptor.sync should temporarily increase parallelism
- JDK-8312180: (bf) MappedMemoryUtils passes incorrect arguments to msync (aix)
- JDK-8312182: THPs cause huge RSS due to thread start timing issue
- JDK-8312394: [linux] SIGSEGV if kernel was built without hugepage support
- JDK-8312395: Improve assertions in growableArray
- JDK-8312401: SymbolTable::do_add_if_needed hangs when called in InstanceKlass::add_initialization_error path with requesting length exceeds max_symbol_length
- JDK-8312489: Increase jdk.jar.maxSignatureFileSize default which is too low for JARs such as WhiteSource/Mend unified agent jar
- JDK-8312525: New test runtime/os/TestTrimNative.java#trimNative is failing: did not see the expected RSS reduction
- JDK-8312535: MidiSystem.getSoundbank() throws unexpected SecurityException
- JDK-8312555: Ideographic characters aren't stretched by AffineTransform.scale(2, 1)
- JDK-8312573: Failure during CompileOnly parsing leads to ShouldNotReachHere
- JDK-8312585: Rename DisableTHPStackMitigation flag to THPStackMitigation
- JDK-8312591: GCC 6 build failure after JDK-8280982
- JDK-8312619: Strange error message when switching over long
- JDK-8312620: WSL Linux build crashes after JDK-8310233
- JDK-8312625: Test serviceability/dcmd/vm/TrimLibcHeapTest.java failed: RSS use increased
- JDK-8312909: C1 should not inline through interface calls with non-subtype receiver
- JDK-8312976: MatchResult produces StringIndexOutOfBoundsException for groups outside match
- JDK-8312984: javac may crash on a record pattern with too few components
- JDK-8313081: MonitoringSupport_lock should be unconditionally initialized after 8304074
- JDK-8313248: C2: setScopedValueCache intrinsic exposes nullptr pre-values to store barriers
- JDK-8313262: C2: Sinking node may cause required cast to be dropped
- JDK-8313307: java/util/Formatter/Padding.java fails on some Locales
- JDK-8313312: Add missing classpath exception copyright header
- JDK-8313323: javac -g on a java file which uses unnamed variable leads to ClassFormatError when launching that class
- JDK-8313402: C1: Incorrect LoadIndexed value numbering
- JDK-8313428: GHA: Bump GCC versions for July 2023 updates
- JDK-8313576: GCC 7 reports compiler warning in bundled freetype 2.13.0
- JDK-8313602: increase timeout for jdk/classfile/CorpusTest.java
- JDK-8313626: C2 crash due to unexpected exception control flow
- JDK-8313657: com.sun.jndi.ldap.Connection.cleanup does not close connections on SocketTimeoutErrors
- JDK-8313676: Amend TestLoadIndexedMismatch test to target intrinsic directly
- JDK-8313678: SymbolTable can leak Symbols during cleanup
- JDK-8313691: use close after failing os::fdopen in vmError and ciEnv
- JDK-8313701: GHA: RISC-V should use the official repository for bootstrap
- JDK-8313707: GHA: Bootstrap sysroots with --variant=minbase
- JDK-8313752: InstanceKlassFlags::print_on doesn't print the flag names
- JDK-8313765: Invalid CEN header (invalid zip64 extra data field size)
- JDK-8313796: AsyncGetCallTrace crash on unreadable interpreter method pointer
- JDK-8313874: JNI NewWeakGlobalRef throws exception for null arg
- JDK-8313901: [TESTBUG] test/hotspot/jtreg/compiler/codecache/CodeCacheFullCountTest.java fails with java.lang.VirtualMachineError
- JDK-8313904: [macos] All signing tests which verifies unsigned app images are failing
- JDK-8314020: Print instruction blocks in byte units
- JDK-8314024: SIGSEGV in PhaseIdealLoop::build_loop_late_post_work due to bad immediate dominator info
- JDK-8314063: The socket is not closed in Connection::createSocket when the handshake failed for LDAP connection
- JDK-8314117: RISC-V: Incorrect VMReg encoding in RISCV64Frame.java
- JDK-8314118: Update JMH devkit to 1.37
- JDK-8314139: TEST_BUG: runtime/os/THPsInThreadStackPreventionTest.java could fail on machine with large number of cores
- JDK-8314144: gc/g1/ihop/TestIHOPStatic.java fails due to extra concurrent mark with -Xcomp
- JDK-8314216: Case enumConstant, pattern compilation fails
- JDK-8314262: GHA: Cut down cross-compilation sysroots deeper
- JDK-8314423: Multiple patterns without unnamed variables
- JDK-8314426: runtime/os/TestTrimNative.java is failing on slow machines
- JDK-8314501: Shenandoah: sun/tools/jhsdb/heapconfig/JMapHeapConfigTest.java fails
- JDK-8314517: some tests fail in case ipv6 is disabled on the machine
- JDK-8314618: RISC-V: -XX:MaxVectorSize does not work as expected
- JDK-8314656: GHA: No need for Debian ports keyring installation after JDK-8313701
- JDK-8314679: SA fails to properly attach to JVM after having just detached from a different JVM
- JDK-8314730: GHA: Drop libfreetype6-dev transitional package in favor of libfreetype-dev
- JDK-8314850: SharedRuntime::handle_wrong_method() gets called too often when resolving Continuation.enter
- JDK-8314960: Add Certigna Root CA - 2
- JDK-8315020: The macro definition for LoongArch64 zero build is not accurate.
- JDK-8315051: jdk/jfr/jvm/TestGetEventWriter.java fails with non-JVMCI GCs
- JDK-8315534: Incorrect warnings about implicit annotation processing
Notes on individual issues:
===========================
core-libs/java.util.jar:
JDK-8313765: Invalid CEN header (invalid zip64 extra data field size)
=====================================================================
Additional validity checks in the handling of Zip64 files,
JDK-8302483, introduced in 21.0.0, caused the use of some valid zip
files to now fail with the error, `Invalid CEN header (invalid zip64
extra data field size)`
This release, 21.0.1, allows for zero length headers and additional
padding produced by some Zip64 creation tools.
The following third party tools have also released patches to better
adhere to the ZIP File Format Specification:
* Apache Commons Compress fix for Empty CEN Zip64 Extra Headers fixed in Commons Compress release 1.11
* Apache Ant fix for Empty CEN Zip64 Extra Headers fixed in Ant 1.10.14
* BND issue with writing invalid Extra Headers fixed in BND 5.3
The maven-bundle-plugin 5.1.5 includes the BND 5.3 patch.
If these improved validation checks cause issues for deployed zip or
jar files, check how the file was created and whether patches are
available from the generating software to resolve the issue. With
both JDK releases, the checks can be disabled by setting the new
system property, `jdk.util.zip.disableZip64ExtraFieldValidation` to
`true`.
hotspot/runtime:
JDK-8311981: JVM May Hang When Using Generational ZGC if a VM Handshake Stalls on Memory
========================================================================================
The JVM can hang under an uncommon condition that involves the JVM
running out of heap memory, the GC just starting a relocation phase to
reclaim memory, and a JVM thread-local Handshake asking to relocate an
object. This potential deadlock should now be avoided in this
release.
core-libs/java.util.regex:
JDK-8312976: `java.util.regex.MatchResult` Might Throw `StringIndexOutOfBoundsException` on Regex Patterns Containing Lookaheads and Lookbehinds
================================================================================================================================================
JDK-8132995 introduced an unintended regression when using instances
returned by `java.util.regex.Matcher.toMatchResult()`.
This regression happens with a `java.util.regex.Pattern`s containing
lookaheads and lookbehinds that, in turn, contain groups. If these are
located outside the match, a `StringIndexOutOfBoundsException` is
thrown when accessing these groups. See JDK-8312976 for an example.
The issue is resolved in this release by calculating a minimum start
location as part of the match result and using this in constructing
String objects, rather than the location of the first match.
JDK-8314960: Added Certigna Root CA Certificate
===============================================
The following root certificate has been added to the cacerts
truststore:
Name: Certigna (Dhimyotis)
Alias Name: certignarootca
Distinguished Name: CN=Certigna Root CA, OU=0002 48146308100036, O=Dhimyotis, C=FR
JDK-8312489: Increase Default Value of the System Property `jdk.jar.maxSignatureFileSize`
=========================================================================================
A maximum signature file size property, jdk.jar.maxSignatureFileSize,
was introduced in the 21.0.0 release of OpenJDK by JDK-8300596 to
control the maximum size of signature files in a signed JAR. The
default value of 8MB proved to be too small for some JAR files. This
release, 21.0.1, increases it to 16MB.
New in release OpenJDK 21.0.0 (2023-09-XX):
===========================================
Major changes are listed below. Some changes may have been backported
to earlier releases following their first appearance in OpenJDK 21.
The full list of changes in 21u can be found at:
- * https://builds.shipilev.net/backports-monitor/release-notes-21.txt
to earlier releases following their first appearance in OpenJDK 18
through to 21.
NEW FEATURES
============
@ -76,8 +273,8 @@ an underscore character, _.
This is a preview feature (http://openjdk.java.net/jeps/12) introduced
in OpenJDK 21 (JEP 443).
Unnamed Classes and Instance Main Methods
=========================================
Unnamed Classes and Instance Main Methods (Preview)
===================================================
https://openjdk.org/jeps/445
Evolve the Java language so that students can write their first
@ -93,6 +290,24 @@ in OpenJDK 21 (JEP 445).
Library Features
================
UTF-8 by Default
================
https://openjdk.org/jeps/400
Specify UTF-8 as the default charset of the standard Java APIs. With
this change, APIs that depend upon the default charset will behave
consistently across all implementations, operating systems, locales,
and configurations.
Reimplement Core Reflection with Method Handles
===============================================
https://openjdk.org/jeps/416
Reimplement java.lang.reflect.Method, Constructor, and Field on top of
java.lang.invoke method handles. Making method handles the underlying
mechanism for reflection will reduce the maintenance and development
cost of both the java.lang.reflect and java.lang.invoke APIs.
Vector API
==========
https://openjdk.org/jeps/338
@ -113,6 +328,14 @@ place in OpenJDK 17 (JEP 414), OpenJDK 18 (JEP 417) saw a third,
OpenJDK 19 a fourth (JEP 426), OpenJDK 20 (JEP 438) a fifth and
OpenJDK 21 a sixth (JEP 448).
Internet-Address Resolution SPI
===============================
https://openjdk.org/jeps/418
Define a service-provider interface (SPI) for host name and address
resolution, so that java.net.InetAddress can make use of resolvers
other than the platform's built-in resolver.
Foreign Function & Memory API
=============================
https://openjdk.org/jeps/412
@ -211,9 +434,55 @@ Improve application performance by extending the Z Garbage Collector
will allow ZGC to collect young objects — which tend to die young —
more frequently.
Tools
=====
Simple Web Server
=================
https://openjdk.org/jeps/408
Provide a command-line tool, `jwebserver`, to start a minimal web
server that serves static files only. No CGI or servlet-like
functionality is available. This tool will be useful for prototyping,
ad-hoc coding, and testing purposes, particularly in educational
contexts.
Code Snippets in Java API Documentation
=======================================
https://openjdk.org/jeps/413
Introduce an @snippet tag for JavaDoc's Standard Doclet, to simplify
the inclusion of example source code in API documentation.
Ports
=====
Linux/RISC-V Port
=================
https://openjdk.org/jeps/422
RISC-V is a free and open-source RISC instruction set architecture
(ISA) designed originally at the University of California, Berkeley,
and now developed collaboratively under the sponsorship of RISC-V
International. It is already supported by a wide range of language
toolchains. With the increasing availability of RISC-V hardware, a
port of the JDK would be valuable.
DEPRECATIONS
============
Deprecate Finalization for Removal
==================================
https://openjdk.org/jeps/421
Deprecate finalization for removal in a future release. Finalization
remains enabled by default for now, but can be disabled to facilitate
early testing. In a future release it will be disabled by default, and
in a later release it will be removed. Maintainers of libraries and
applications that rely upon finalization should consider migrating to
other resource management techniques such as the try-with-resources
statement and cleaners.
Deprecate the Windows 32-bit x86 Port for Removal
=================================================
https://openjdk.org/jeps/449
@ -230,4 +499,3 @@ JVM. These warnings aim to prepare users for a future release which
disallows the dynamic loading of agents by default in order to improve
integrity by default. Serviceability tools that load agents at startup
will not cause warnings to be issued in any release.

54
discover_trees.sh Executable file
View File

@ -0,0 +1,54 @@
#!/bin/sh
# Copyright (C) 2020 Red Hat, Inc.
# Written by Andrew John Hughes <gnu.andrew@redhat.com>.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as
# published by the Free Software Foundation, either version 3 of the
# License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU Affero General Public License for more details.
#
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <https://www.gnu.org/licenses/>.
TREE=${1}
if test "x${TREE}" = "x"; then
TREE=${PWD}
fi
if [ -e ${TREE}/nashorn/.hg -o -e ${TREE}/nashorn/merge.changeset ] ; then
NASHORN="nashorn" ;
fi
if [ -e ${TREE}/corba/.hg -o -e ${TREE}/corba/merge.changeset ] ; then
CORBA="corba";
fi
if [ -e ${TREE}/jaxp/.hg -o -e ${TREE}/jaxp/merge.changeset ] ; then
JAXP="jaxp";
fi
if [ -e ${TREE}/jaxws/.hg -o -e ${TREE}/jaxws/merge.changeset ] ; then
JAXWS="jaxws";
fi
if [ -e ${TREE}/langtools/.hg -o -e ${TREE}/langtools/merge.changeset ] ; then
LANGTOOLS="langtools";
fi
if [ -e ${TREE}/jdk/.hg -o -e ${TREE}/jdk/merge.changeset ] ; then
JDK="jdk";
fi
if [ -e ${TREE}/hotspot/.hg -o -e ${TREE}/hotspot/merge.changeset ] ; then
HOTSPOT="hotspot";
fi
SUBTREES="${CORBA} ${JAXP} ${JAXWS} ${LANGTOOLS} ${NASHORN} ${JDK} ${HOTSPOT}";
echo ${SUBTREES}

View File

@ -4231,4 +4231,3 @@ index 00000000000..87f1ad04505
+ }
+ }
+}

View File

@ -6,10 +6,9 @@
# If your local repo follows upstream forests conventions, it may be enough to set OPENJDK_URL
#
# In any case you have to set PROJECT_NAME REPO_NAME and VERSION. eg:
# BOOT_JDK=/usr/lib/jvm/java-20-openjdk
# PROJECT_NAME=openjdk
# REPO_NAME=jdk21u
# VERSION=jdk-21+35
# VERSION=jdk-21.0.1+12
# or to eg prepare systemtap:
# icedtea7's jstack and other tapsets
# VERSION=6327cf1cea9e
@ -36,13 +35,13 @@ if [ "x$1" = "xhelp" ] ; then
VERSION="<unspecified>";
fi
echo -e "Behaviour may be specified by setting the following variables:\n"
echo "VERSION - the version of the specified OpenJDK project (current value: ${VERSION})"
echo "VERSION - the version of the specified OpenJDK project"
echo "PROJECT_NAME -- the name of the OpenJDK project being archived (optional; only needed by defaults)"
echo "REPO_NAME - the name of the OpenJDK repository (optional; only needed by defaults)"
echo "OPENJDK_URL - the URL to retrieve code from (optional; defaults to ${OPENJDK_URL_DEFAULT})"
echo "COMPRESSION - the compression type to use (optional; defaults to ${COMPRESSION_DEFAULT})"
echo "FILE_NAME_ROOT - name of the archive, minus extensions (optional; defaults to open${VERSION})"
echo "REPO_ROOT - the location of the Git repository to archive (optional; defaults to OPENJDK_URL/PROJECT_NAME/REPO_NAME)"
echo "FILE_NAME_ROOT - name of the archive, minus extensions (optional; defaults to PROJECT_NAME-REPO_NAME-VERSION)"
echo "REPO_ROOT - the location of the Git repository to archive (optional; defaults to OPENJDK_URL/PROJECT_NAME/REPO_NAME.git)"
echo "TO_COMPRESS - what part of clone to pack (default is ${VERSION})"
echo "BOOT_JDK - the bootstrap JDK to satisfy the configure run"
exit 1;
@ -111,7 +110,7 @@ fi
echo "Creating a tar.${COMPRESSION} archive"
if [ "x$FILE_NAME_ROOT" = "x" ] ; then
FILE_NAME_ROOT=open${VERSION}
FILE_NAME_ROOT=${PROJECT_NAME}-${REPO_NAME}-${VERSION}
echo "No file name root specified; default to ${FILE_NAME_ROOT}"
fi
if [ "x$REPO_ROOT" = "x" ] ; then
@ -121,7 +120,7 @@ fi;
if [ "x$TO_COMPRESS" = "x" ] ; then
TO_COMPRESS="${VERSION}"
echo "No targets to be compressed specified, ; default to ${TO_COMPRESS}"
echo "No targets to be compressed specified ; default to ${TO_COMPRESS}"
fi;
echo -e "Settings:"
@ -147,6 +146,7 @@ else
popd
fi
pushd "${FILE_NAME_ROOT}"
# Generate .src-rev so build has knowledge of the revision the tarball was created from
mkdir build
pushd build
@ -161,17 +161,17 @@ pushd "${FILE_NAME_ROOT}"
# Remove history and GHA
echo "find ${VERSION} -name '.hgtags'"
find ${VERSION} -name '.hgtags' -exec rm -v '{}' '+'
find ${VERSION} -name '.hgtags' -exec rm -fv '{}' '+'
echo "find ${VERSION} -name '.hgignore'"
find ${VERSION} -name '.hgignore' -exec rm -v '{}' '+'
find ${VERSION} -name '.hgignore' -exec rm -fv '{}' '+'
echo "find ${VERSION} -name '.gitattributes'"
find ${VERSION} -name '.gitattributes' -exec rm -v '{}' '+'
find ${VERSION} -name '.gitattributes' -exec rm -fv '{}' '+'
echo "find ${VERSION} -name '.gitignore'"
find ${VERSION} -name '.gitignore' -exec rm -v '{}' '+'
find ${VERSION} -name '.gitignore' -exec rm -fv '{}' '+'
echo "find ${VERSION} -name '.git'"
find ${VERSION} -name '.git' -exec rm -rv '{}' '+'
find ${VERSION} -name '.git' -exec rm -rfv '{}' '+'
echo "find ${VERSION} -name '.github'"
find ${VERSION} -name '.github' -exec rm -rv '{}' '+'
find ${VERSION} -name '.github' -exec rm -rfv '{}' '+'
echo "Compressing remaining forest"
if [ "X$COMPRESSION" = "Xxz" ] ; then

View File

@ -1,192 +1 @@
#!/bin/bash
# Copyright (C) 2019 Red Hat, Inc.
# Written by Andrew John Hughes <gnu.andrew@redhat.com>.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU Affero General Public License as
# published by the Free Software Foundation, either version 3 of the
# License, or (at your option) any later version.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU Affero General Public License for more details.
#
# You should have received a copy of the GNU Affero General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
ICEDTEA_USE_VCS=true
ICEDTEA_VERSION=3.15.0
ICEDTEA_URL=https://icedtea.classpath.org/download/source
ICEDTEA_SIGNING_KEY=CFDA0F9B35964222
ICEDTEA_HG_URL=https://icedtea.classpath.org/hg/icedtea11
set -e
RPM_DIR=${PWD}
if [ ! -f ${RPM_DIR}/jconsole.desktop.in ] ; then
echo "Not in RPM source tree.";
exit 1;
fi
if test "x${TMPDIR}" = "x"; then
TMPDIR=/tmp;
fi
WORKDIR=${TMPDIR}/it.sync
echo "Using working directory ${WORKDIR}"
mkdir ${WORKDIR}
pushd ${WORKDIR}
if test "x${WGET}" = "x"; then
WGET=$(which wget);
if test "x${WGET}" = "x"; then
echo "wget not found";
exit 1;
fi
fi
if test "x${TAR}" = "x"; then
TAR=$(which tar)
if test "x${TAR}" = "x"; then
echo "tar not found";
exit 2;
fi
fi
echo "Dependencies:";
echo -e "\tWGET: ${WGET}";
echo -e "\tTAR: ${TAR}\n";
if test "x${ICEDTEA_USE_VCS}" = "xtrue"; then
echo "Mode: Using VCS";
if test "x${GREP}" = "x"; then
GREP=$(which grep);
if test "x${GREP}" = "x"; then
echo "grep not found";
exit 3;
fi
fi
if test "x${CUT}" = "x"; then
CUT=$(which cut);
if test "x${CUT}" = "x"; then
echo "cut not found";
exit 4;
fi
fi
if test "x${TR}" = "x"; then
TR=$(which tr);
if test "x${TR}" = "x"; then
echo "tr not found";
exit 5;
fi
fi
if test "x${HG}" = "x"; then
HG=$(which hg);
if test "x${HG}" = "x"; then
echo "hg not found";
exit 6;
fi
fi
echo "Dependencies:";
echo -e "\tGREP: ${GREP}";
echo -e "\tCUT: ${CUT}";
echo -e "\tTR: ${TR}";
echo -e "\tHG: ${HG}";
echo "Checking out repository from VCS...";
${HG} clone ${ICEDTEA_HG_URL} icedtea
echo "Obtaining version from configure.ac...";
ROOT_VER=$(${GREP} '^AC_INIT' icedtea/configure.ac|${CUT} -d ',' -f 2|${TR} -d '[][:space:]')
echo "Root version from configure: ${ROOT_VER}";
VCS_REV=$(${HG} log -R icedtea --template '{node|short}' -r tip)
echo "VCS revision: ${VCS_REV}";
ICEDTEA_VERSION="${ROOT_VER}-${VCS_REV}"
echo "Creating icedtea-${ICEDTEA_VERSION}";
mkdir icedtea-${ICEDTEA_VERSION}
echo "Copying required files from checkout to icedtea-${ICEDTEA_VERSION}";
# Commented out for now as IcedTea 6's jconsole.desktop.in is outdated
#cp -a icedtea/jconsole.desktop.in ../icedtea-${ICEDTEA_VERSION}
cp -a ${RPM_DIR}/jconsole.desktop.in icedtea-${ICEDTEA_VERSION}
cp -a icedtea/tapset icedtea-${ICEDTEA_VERSION}
rm -rf icedtea
else
echo "Mode: Using tarball";
if test "x${ICEDTEA_VERSION}" = "x"; then
echo "No IcedTea version specified for tarball download.";
exit 3;
fi
if test "x${CHECKSUM}" = "x"; then
CHECKSUM=$(which sha256sum)
if test "x${CHECKSUM}" = "x"; then
echo "sha256sum not found";
exit 4;
fi
fi
if test "x${PGP}" = "x"; then
PGP=$(which gpg)
if test "x${PGP}" = "x"; then
echo "gpg not found";
exit 5;
fi
fi
echo "Dependencies:";
echo -e "\tCHECKSUM: ${CHECKSUM}";
echo -e "\tPGP: ${PGP}\n";
echo "Checking for IcedTea signing key ${ICEDTEA_SIGNING_KEY}...";
if ! gpg --list-keys ${ICEDTEA_SIGNING_KEY}; then
echo "IcedTea signing key ${ICEDTEA_SIGNING_KEY} not installed.";
exit 6;
fi
echo "Downloading IcedTea release tarball...";
${WGET} -v ${ICEDTEA_URL}/icedtea-${ICEDTEA_VERSION}.tar.xz
echo "Downloading IcedTea tarball signature...";
${WGET} -v ${ICEDTEA_URL}/icedtea-${ICEDTEA_VERSION}.tar.xz.sig
echo "Downloading IcedTea tarball checksums...";
${WGET} -v ${ICEDTEA_URL}/icedtea-${ICEDTEA_VERSION}.sha256
echo "Verifying checksums...";
${CHECKSUM} --check --ignore-missing icedtea-${ICEDTEA_VERSION}.sha256
echo "Checking signature...";
${PGP} --verify icedtea-${ICEDTEA_VERSION}.tar.xz.sig
echo "Extracting files...";
${TAR} xJf icedtea-${ICEDTEA_VERSION}.tar.xz \
icedtea-${ICEDTEA_VERSION}/tapset \
icedtea-${ICEDTEA_VERSION}/jconsole.desktop.in
rm -vf icedtea-${ICEDTEA_VERSION}.tar.xz
rm -vf icedtea-${ICEDTEA_VERSION}.tar.xz.sig
rm -vf icedtea-${ICEDTEA_VERSION}.sha256
fi
echo "Replacing desktop files...";
mv -v icedtea-${ICEDTEA_VERSION}/jconsole.desktop.in ${RPM_DIR}
echo "Creating new tapset tarball...";
mv -v icedtea-${ICEDTEA_VERSION} openjdk
${TAR} cJf ${RPM_DIR}/tapsets-icedtea-${ICEDTEA_VERSION}.tar.xz openjdk
rm -rvf openjdk
popd
rm -rf ${WORKDIR}
# this file is intentionally not here, as portable builds do not have desktop integration

File diff suppressed because it is too large Load Diff

View File

@ -1,10 +1 @@
[Desktop Entry]
Name=OpenJDK @JAVA_VER@ for @target_cpu@ Monitoring & Management Console (@OPENJDK_VER@)
Comment=Monitor and manage OpenJDK applications
Exec=_SDKBINDIR_/jconsole
Icon=java-@JAVA_VER@-@JAVA_VENDOR@
Terminal=false
Type=Application
StartupWMClass=sun-tools-jconsole-JConsole
Categories=Development;Profiling;Java;
Version=1.0
# this file is intentionally not here, as portable builds do not have desktop integration

View File

@ -1 +0,0 @@

View File

@ -1 +0,0 @@

1906
jdk8311630-s390_ffmapi.patch Normal file

File diff suppressed because it is too large Load Diff

View File

@ -18,8 +18,8 @@
OLD_RELEASE=$1
NEW_RELEASE=$2
SUBDIR=$3
REPO=$4
REPO=$3
SUBDIR=$4
SCRIPT_DIR=$(dirname ${0})
if test "x${SUBDIR}" = "x"; then

View File

@ -1,20 +0,0 @@
--- openjdk/src/java.base/share/conf/security/java.security
+++ openjdk/src/java.base/share/conf/security/java.security
@@ -304,6 +304,8 @@
#
package.access=sun.misc.,\
sun.reflect.,\
+ org.GNOME.Accessibility.,\
+ org.GNOME.Bonobo.,\
#
# List of comma-separated packages that start with or equal this string
@@ -316,6 +318,8 @@
#
package.definition=sun.misc.,\
sun.reflect.,\
+ org.GNOME.Accessibility.,\
+ org.GNOME.Bonobo.,\
#
# Determines whether this properties file can be appended to

View File

@ -1 +1 @@
SHA512 (openjdk-21+35.tar.xz) = 311e954cc8d28a336b85efc05baade8945fe5292ae2d91cc7ff71c6b3a1830b1a4b9fc641f87e68a4b3db175eb5c21a18664457715da9b37720c5d4b3eb67195
SHA512 (openjdk-21.0.1+12.tar.xz) = 96513e1346dea623183ae68f88690aa7ea41d65f6a2499b7f9c08954643dd2a6f10d3f4f529fc34e00ff14e8c1bd3764ac78a5c669937a200c910ebcc74e782b