Add support for riscv64
We need to pick lib64 for riscv64 instead lib. Signed-off-by: David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
parent
9211be9ad7
commit
c1bd09b981
13
isomd5sum-1.2.3-add-riscv64.patch
Normal file
13
isomd5sum-1.2.3-add-riscv64.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index c98cf35..a601e78 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -4,7 +4,7 @@ PYTHONINCLUDE := $(shell $(PYTHON)-config --includes)
|
||||
|
||||
VERSION=1.2.3
|
||||
|
||||
-ifneq (,$(filter sparc64 ppc64 ppc64le x86_64 s390x aarch64,$(shell uname -m)))
|
||||
+ifneq (,$(filter sparc64 ppc64 ppc64le x86_64 s390x aarch64 riscv64,$(shell uname -m)))
|
||||
LIBDIR = lib64
|
||||
else
|
||||
LIBDIR = lib
|
@ -1,7 +1,7 @@
|
||||
Summary: Utilities for working with md5sum implanted in ISO images
|
||||
Name: isomd5sum
|
||||
Version: 1.2.3
|
||||
Release: 1%{?dist}
|
||||
Release: 1.0.riscv64%{?dist}
|
||||
Epoch: 1
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
@ -9,6 +9,8 @@ Group: Applications/System
|
||||
Url: https://github.com/rhinstaller/isomd5sum
|
||||
Source0: https://github.com/rhinstaller/%{name}/archive/%{version}.tar.gz
|
||||
|
||||
Patch0: isomd5sum-1.2.3-add-riscv64.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: popt-devel
|
||||
BuildRequires: python2-devel python3-devel
|
||||
@ -83,6 +85,9 @@ popd
|
||||
%{python3_sitearch}/pyisomd5sum.so
|
||||
|
||||
%changelog
|
||||
* Mon Apr 23 2018 David Abdurachmanov <david.abdurachmanov@gmail.com> - 1:1.2.3-1.0.riscv64
|
||||
- Add support for riscv64
|
||||
|
||||
* Tue Apr 10 2018 Brian C. Lane <bcl@redhat.com> - 1:1.2.3-1
|
||||
- New Version 1.2.3 (bcl)
|
||||
- Fix 32bit bug on large files (squimrel)
|
||||
|
Loading…
Reference in New Issue
Block a user