- Rediff patches for zero fuzz
- Use uniconvertor to handle CDR and WMF (#458845)
This commit is contained in:
parent
acc359f106
commit
f227316bdf
13
inkscape-0.46-cxxinclude.patch
Normal file
13
inkscape-0.46-cxxinclude.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up inkscape-0.46/src/Makefile.in.cxxinclude inkscape-0.46/src/Makefile.in
|
||||
--- inkscape-0.46/src/Makefile.in.cxxinclude 2008-03-11 05:47:10.000000000 +0100
|
||||
+++ inkscape-0.46/src/Makefile.in 2008-08-13 23:26:52.000000000 +0200
|
||||
@@ -1487,7 +1487,8 @@ INCLUDES = \
|
||||
$(POPPLER_GLIB_CFLAGS) \
|
||||
-DPOTRACE=\"potrace\" \
|
||||
$(INKSCAPE_CFLAGS) \
|
||||
- -I$(top_srcdir)/cxxtest
|
||||
+ -I$(top_srcdir)/cxxtest \
|
||||
+ -I$(top_srcdir)/src/extension/script
|
||||
|
||||
@PLATFORM_WIN32_TRUE@win32_sources = winmain.cpp registrytool.cpp registrytool.h
|
||||
@PLATFORM_WIN32_TRUE@win32ldflags = -lcomdlg32
|
@ -4,10 +4,11 @@ and let it conform enough not to break the build in Rawhide.
|
||||
(Lubomir Kundrak <lkundrak@redhat.com>)
|
||||
https://bugs.launchpad.net/inkscape/+bug/190420
|
||||
|
||||
--- inkscape-0.45.1.orig/inkscape.desktop.in 2007-01-16 03:49:00.000000000 +0100
|
||||
+++ inkscape-0.45.1/inkscape.desktop.in 2007-12-02 03:17:08.000000000 +0100
|
||||
diff -up inkscape-0.46/inkscape.desktop.in.desktop inkscape-0.46/inkscape.desktop.in
|
||||
--- inkscape-0.46/inkscape.desktop.in.desktop 2008-03-11 05:21:19.000000000 +0100
|
||||
+++ inkscape-0.46/inkscape.desktop.in 2008-08-13 23:29:56.000000000 +0200
|
||||
@@ -2,18 +2,16 @@
|
||||
_Name=Inkscape SVG Vector Illustrator
|
||||
_Name=Inkscape Vector Graphics Editor
|
||||
_Comment=Create and edit Scalable Vector Graphics images
|
||||
|
||||
-Encoding=UTF-8
|
54
inkscape-0.46-uniconv.patch
Normal file
54
inkscape-0.46-uniconv.patch
Normal file
@ -0,0 +1,54 @@
|
||||
See https://bugs.launchpad.net/inkscape/+bug/226383
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=458845
|
||||
|
||||
Lubomir Rintel <lkundrak@v3.sk>
|
||||
|
||||
diff -up inkscape-0.46/inkscape.desktop.in.uniconv inkscape-0.46/inkscape.desktop.in
|
||||
diff -up inkscape-0.46/inkscape.desktop.in.uniconv inkscape-0.46/inkscape.desktop.in
|
||||
--- inkscape-0.46/inkscape.desktop.in.uniconv 2008-08-13 23:31:17.000000000 +0200
|
||||
+++ inkscape-0.46/inkscape.desktop.in 2008-08-13 23:32:35.000000000 +0200
|
||||
@@ -7,7 +7,7 @@ Version=1.0
|
||||
Type=Application
|
||||
Categories=Graphics;VectorGraphics;GTK;
|
||||
|
||||
-MimeType=image/svg+xml;image/svg+xml-compressed;
|
||||
+MimeType=image/svg+xml;image/svg+xml-compressed;application/vnd.corel-draw;image/x-wmf;
|
||||
|
||||
Exec=inkscape %F
|
||||
TryExec=inkscape
|
||||
diff -up inkscape-0.46/share/extensions/cdr2svg.sh.uniconv inkscape-0.46/share/extensions/cdr2svg.sh
|
||||
--- inkscape-0.46/share/extensions/cdr2svg.sh.uniconv 2008-03-11 05:21:10.000000000 +0100
|
||||
+++ inkscape-0.46/share/extensions/cdr2svg.sh 2008-08-13 23:31:17.000000000 +0200
|
||||
@@ -4,7 +4,7 @@ TMPDIR="${TMPDIR-/tmp}"
|
||||
TEMPFILENAME=`mktemp 2>/dev/null || echo "$TMPDIR/$$"`
|
||||
TEMPFILENAME=${TEMPFILENAME}.svg
|
||||
|
||||
-uniconv "$1" "${TEMPFILENAME}" > /dev/null 2>&1 || rc=1
|
||||
+unviconvertor "$1" "${TEMPFILENAME}" > /dev/null 2>&1 || rc=1
|
||||
|
||||
cat < "${TEMPFILENAME}" || rc=1
|
||||
rm -f "${TEMPFILENAME}"
|
||||
diff -up inkscape-0.46/share/extensions/cdr_input.inx.uniconv inkscape-0.46/share/extensions/cdr_input.inx
|
||||
--- inkscape-0.46/share/extensions/cdr_input.inx.uniconv 2008-03-11 05:21:07.000000000 +0100
|
||||
+++ inkscape-0.46/share/extensions/cdr_input.inx 2008-08-13 23:31:17.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
<inkscape-extension>
|
||||
<_name>Corel DRAW Input</_name>
|
||||
<id>org.inkscape.input.cdr</id>
|
||||
- <dependency type="executable" location="path">uniconv</dependency>
|
||||
+ <dependency type="executable" location="path">unviconvertor</dependency>
|
||||
<dependency type="executable" location="extensions">cdr2svg.sh</dependency>
|
||||
<input>
|
||||
<extension>.cdr</extension>
|
||||
diff -up inkscape-0.46/share/extensions/wmf_input.inx.uniconv inkscape-0.46/share/extensions/wmf_input.inx
|
||||
--- inkscape-0.46/share/extensions/wmf_input.inx.uniconv 2008-03-11 05:21:10.000000000 +0100
|
||||
+++ inkscape-0.46/share/extensions/wmf_input.inx 2008-08-13 23:31:17.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
<inkscape-extension>
|
||||
<_name>Windows Metafile Input</_name>
|
||||
<id>org.inkscape.input.wmf</id>
|
||||
- <dependency type="executable" location="path">uniconv</dependency>
|
||||
+ <dependency type="executable" location="path">unviconvertor</dependency>
|
||||
<dependency type="executable" location="extensions">cdr2svg.sh</dependency>
|
||||
<input>
|
||||
<extension>.wmf</extension>
|
@ -1,12 +0,0 @@
|
||||
--- inkscape-16571/src/Makefile.in.orig 2007-11-29 13:38:13.000000000 +0100
|
||||
+++ inkscape-16571/src/Makefile.in 2007-11-29 13:38:29.000000000 +0100
|
||||
@@ -317,7 +317,8 @@
|
||||
$(POPPLER_GLIB_CFLAGS) \
|
||||
-DPOTRACE=\"potrace\" \
|
||||
$(INKSCAPE_CFLAGS) \
|
||||
- -I$(top_srcdir)/cxxtest
|
||||
+ -I$(top_srcdir)/cxxtest \
|
||||
+ -I$(top_srcdir)/src/extension/script
|
||||
|
||||
|
||||
@PLATFORM_WIN32_TRUE@win32_sources = winmain.cpp registrytool.cpp registrytool.h
|
@ -1,19 +1,20 @@
|
||||
Name: inkscape
|
||||
Version: 0.46
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
Summary: Vector-based drawing program using SVG
|
||||
|
||||
Group: Applications/Productivity
|
||||
License: GPLv2+
|
||||
URL: http://inkscape.sourceforge.net/
|
||||
Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
|
||||
Patch0: inkscape-16571-cxxinclude.patch
|
||||
Patch1: inkscape-0.45.1-desktop.patch
|
||||
Patch0: inkscape-0.46-cxxinclude.patch
|
||||
Patch1: inkscape-0.46-desktop.patch
|
||||
Patch2: inkscape-0.46pre2-icons.patch
|
||||
Patch3: inkscape-0.46-fixlatex.patch
|
||||
Patch4: inkscape-0.46-gtkopen.patch
|
||||
Patch5: inkscape-0.46-gtk2.13.3.patch
|
||||
Patch6: inkscape-0.46-poppler-0.8.3.patch
|
||||
Patch7: inkscape-0.46-uniconv.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
@ -53,6 +54,7 @@ Requires: perl(Image::Magick)
|
||||
Requires: numpy
|
||||
Requires: PyXML
|
||||
Requires: python-lxml
|
||||
Requires: uniconvertor
|
||||
|
||||
Requires(post): desktop-file-utils
|
||||
Requires(postun): desktop-file-utils
|
||||
@ -80,6 +82,7 @@ C and C++, using the Gtk+ toolkit and optionally some Gnome libraries.
|
||||
%patch4 -p0 -b .gtkopen
|
||||
%patch5 -p1 -b .gtk2.13.3
|
||||
%patch6 -p1 -b .poppler-0.8.3
|
||||
%patch7 -p1 -b .uniconv
|
||||
find -type f -regex '.*\.\(cpp\|h\)' -perm +111 -exec chmod -x {} ';'
|
||||
find share/extensions/ -type f -regex '.*\.py' -perm +111 -exec chmod -x {} ';'
|
||||
dos2unix -k -q share/extensions/*.py
|
||||
@ -139,6 +142,10 @@ update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Aug 13 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.46-5
|
||||
- Rediff patches for zero fuzz
|
||||
- Use uniconvertor to handle CDR and WMF (#458845)
|
||||
|
||||
* Wed Jul 09 2008 Lubomir Rintel <lkundrak@v3.sk> - 0.46-4
|
||||
- Fix compile issues with newer gtk and poppler
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user