- Update to a post-alpha snapshot
- Upstream applied our GCC 4.4 patch
This commit is contained in:
parent
ad3c2f2896
commit
e9e6887556
@ -1,40 +0,0 @@
|
||||
One more typing fix for GCC 4.4, and fix a NULL dereference on startup.
|
||||
|
||||
Lubomir Rintel <lkundrak@v3.sk>
|
||||
|
||||
diff -up inkscape/src/extension/internal/bitmap/imagemagick.cpp.gcc44 inkscape/src/extension/internal/bitmap/imagemagick.cpp
|
||||
--- inkscape/src/extension/internal/bitmap/imagemagick.cpp.gcc44 2009-01-28 22:12:57.000000000 +0100
|
||||
+++ inkscape/src/extension/internal/bitmap/imagemagick.cpp 2009-04-10 12:34:09.189576256 +0200
|
||||
@@ -114,7 +114,7 @@ ImageMagickDocCache::readImage(const cha
|
||||
char *search = (char *) g_strndup(xlink, 30);
|
||||
if (strstr(search, "base64") != (char*)NULL) {
|
||||
// 7 = strlen("base64") + strlen(",")
|
||||
- char* pureBase64 = strstr(xlink, "base64") + 7;
|
||||
+ const char* pureBase64 = strstr(xlink, "base64") + 7;
|
||||
Magick::Blob blob;
|
||||
blob.base64(pureBase64);
|
||||
image->read(blob);
|
||||
diff -up inkscape/src/libnr/nr-object.cpp.gcc44 inkscape/src/libnr/nr-object.cpp
|
||||
--- inkscape/src/libnr/nr-object.cpp.gcc44 2008-05-04 07:14:00.000000000 +0200
|
||||
+++ inkscape/src/libnr/nr-object.cpp 2009-04-10 12:34:09.190577328 +0200
|
||||
@@ -198,8 +198,8 @@ NRObject *NRObject::alloc(NRType type)
|
||||
);
|
||||
memset(object, 0xf0, c->isize);
|
||||
|
||||
- object->klass = c;
|
||||
c->cpp_ctor(object);
|
||||
+ object->klass = c;
|
||||
nr_class_tree_object_invoke_init (c, object);
|
||||
|
||||
return object;
|
||||
diff -up inkscape/src/widgets/ege-paint-def.cpp.gcc44 inkscape/src/widgets/ege-paint-def.cpp
|
||||
--- inkscape/src/widgets/ege-paint-def.cpp.gcc44 2009-04-10 14:31:06.349578336 +0200
|
||||
+++ inkscape/src/widgets/ege-paint-def.cpp 2009-04-10 14:31:20.011577660 +0200
|
||||
@@ -45,6 +45,7 @@
|
||||
|
||||
#include <stdint.h>
|
||||
#include <string>
|
||||
+#include <cstdio>
|
||||
#include <iostream>
|
||||
#include <sstream>
|
||||
#include <stdlib.h>
|
@ -1,20 +1,19 @@
|
||||
Name: inkscape
|
||||
Version: 0.47
|
||||
Release: 0.6.20090410svn%{?dist}
|
||||
Release: 0.7.20090508svn%{?dist}
|
||||
Summary: Vector-based drawing program using SVG
|
||||
|
||||
Group: Applications/Productivity
|
||||
License: GPLv2+
|
||||
URL: http://inkscape.sourceforge.net/
|
||||
#Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
|
||||
# svn export -r21114 https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk@21114 inkscape
|
||||
# svn export -r21302 https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk@21302 inkscape
|
||||
# tar cf - inkscape |lzma -9 -c >inkscape.tar.lzma
|
||||
# Chuck the SVN snapshot specific blocks when bumping to a release:
|
||||
# perl -e 'while (<>) {/^# BEGIN SVN/ .. /^# END SVN/ or print}' <inkscape.spec
|
||||
Source0: %{name}.tar.lzma
|
||||
|
||||
Patch0: inkscape-20090410svn-uniconv.patch
|
||||
Patch1: inkscape-20090410svn-gcc44.patch
|
||||
Patch2: inkscape-20090226svn-oldcairo.patch
|
||||
Patch4: inkscape-20090410svn-formats.patch
|
||||
# BEGIN SVN SNAPSHOT SPECIFIC
|
||||
@ -135,7 +134,6 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch0 -p1 -b .uniconv
|
||||
%patch1 -p1 -b .gcc44
|
||||
%patch2 -p0 -b .oldcairo
|
||||
%patch4 -p1 -b .formats
|
||||
# BEGIN SVN SNAPSHOT SPECIFIC
|
||||
@ -247,6 +245,10 @@ touch --no-create %{_datadir}/icons/hicolor
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri May 08 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.7.20090508svn
|
||||
- Update to a post-alpha snapshot
|
||||
- Upstream applied our GCC 4.4 patch
|
||||
|
||||
* Fri Apr 10 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.6.20090410svn
|
||||
- Update to newer snapshot
|
||||
- Fix doc/incview reversed subpackage content
|
||||
|
Loading…
x
Reference in New Issue
Block a user