0.46 prerelease

This commit is contained in:
Lubomir Rintel 2008-02-06 12:02:12 +00:00
parent 23d6a4dda4
commit d6bc41e11d
8 changed files with 43 additions and 351 deletions

View File

@ -1 +1 @@
inkscape-0.45.1.tar.gz inkscape-0.45.1+0.46pre1.tar.bz2

View File

@ -1,42 +0,0 @@
--- inkscape-0.44.1/share/extensions/ps_input.inx.orig 2006-12-06 11:47:27.000000000 +0100
+++ inkscape-0.44.1/share/extensions/ps_input.inx 2006-12-06 11:46:40.000000000 +0100
@@ -1,7 +1,6 @@
<inkscape-extension>
<_name>Postscript Input</_name>
<id>org.inkscape.input.ps</id>
- <dependency type="extension">org.inkscape.input.sk</dependency>
<dependency type="executable">pstoedit</dependency>
<input>
<extension>.ps</extension>
@@ -11,7 +10,6 @@
<output_extension>org.inkscape.output.ps</output_extension>
</input>
<script>
- <command reldir="path">pstoedit -f sk</command>
- <helper_extension>org.inkscape.input.sk</helper_extension>
+ <command reldir="path">pstoedit -quiet -ndt -f plot-svg</command>
</script>
</inkscape-extension>
--- inkscape-0.44.1/share/extensions/eps_input.inx.orig 2006-12-06 12:19:56.000000000 +0100
+++ inkscape-0.44.1/share/extensions/eps_input.inx 2006-12-06 12:19:42.000000000 +0100
@@ -1,9 +1,8 @@
<inkscape-extension>
<_name>EPS Input</_name>
<id>org.inkscape.input.eps</id>
- <dependency type="extension">org.inkscape.input.ps</dependency>
- <dependency type="executable">gs</dependency>
- <input>
+ <dependency type="executable">pstoedit</dependency>
+ <input>
<extension>.eps</extension>
<mimetype>image/x-encapsulated-postscript</mimetype>
<_filetypename>Encapsulated Postscript (*.eps)</_filetypename>
@@ -11,7 +10,6 @@
<output_extension>org.inkscape.output.eps</output_extension>
</input>
<script>
- <command reldir="path">gs -q -sDEVICE=pswrite -sOutputFile=- -dNOPAUSE -dBATCH -dSAFER -dDEVICEWIDTH=250000 -dDEVICEHEIGHT=250000</command>
- <helper_extension>org.inkscape.input.ps</helper_extension>
+ <command reldir="path">pstoedit -quiet -ndt -f plot-svg</command>
</script>
</inkscape-extension>

View File

@ -1,36 +0,0 @@
--- inkscape-0.45/configure.orig 2007-02-07 12:08:44.000000000 -0800
+++ inkscape-0.45/configure 2007-02-07 12:22:34.000000000 -0800
@@ -10769,7 +10769,7 @@
if test "$?" -gt "0"; then
with_python="no"
else
- checkPYTHON_LIBS=`python -c "import distutils.sysconfig ; print '%s/%s %s' % (distutils.sysconfig.get_config_var('LIBPL'),distutils.sysconfig.get_config_var('LDLIBRARY'),distutils.sysconfig.get_config_var('LIBS'))" 2>/dev/null`
+ checkPYTHON_LIBS=`python -c "import distutils.sysconfig ; print '%s/%s %s' % (distutils.sysconfig.get_config_var('DBLIB'),distutils.sysconfig.get_config_var('LDLIBRARY'),distutils.sysconfig.get_config_var('LIBS'))" 2>/dev/null`
if test "$?" -gt "0"; then
with_python="no"
else
--- inkscape-0.45/src/extension/script/inkscape_py_wrap.cpp.orig 2007-02-07 17:11:42.000000000 -0800
+++ inkscape-0.45/src/extension/script/inkscape_py_wrap.cpp 2007-02-07 18:19:21.000000000 -0800
@@ -802,7 +802,7 @@
obj = pyobj;
if (PyCFunction_Check(obj)) {
/* here we get the method pointer for callbacks */
- char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
+ const char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
c = doc ? strstr(doc, "swig_ptr: ") : 0;
if (c) {
c += 10;
@@ -977,11 +977,11 @@
swig_type_info **types_initial) {
int i;
for (i = 0; methods[i].ml_name; ++i) {
- char *c = methods[i].ml_doc;
+ const char *c = methods[i].ml_doc;
if (c && (c = strstr(c, "swig_ptr: "))) {
int j;
swig_const_info *ci = 0;
- char *name = c + 10;
+ const char *name = c + 10;
for (j = 0; const_table[j].type; j++) {
if (strncmp(const_table[j].name, name,
strlen(const_table[j].name)) == 0) {

View File

@ -1,215 +0,0 @@
Patch from upstream SVN, by Kees Cook of Ubuntu
Index: src/extension/internal/ps.cpp
===================================================================
--- src/extension/internal/ps.cpp (revision 14039)
+++ src/extension/internal/ps.cpp (revision 14040)
@@ -43,6 +43,8 @@
#include <gtk/gtkentry.h>
#include <gtk/gtktooltips.h>
+#include <gtk/gtkprintunixdialog.h>
+
#include <glibmm/i18n.h>
#include "display/nr-arena-item.h"
#include "display/canvas-bpath.h"
@@ -102,6 +104,59 @@
return;
}
+static void
+unix_print_complete (GtkPrintJob *print_job,
+ gpointer user_data,
+ GError *error)
+{
+ fprintf(stderr,"job finished: %s\n",error ? error->message : "no error");
+}
+
+static void
+unix_print_dialog (const gchar * ps_file, const gchar * jobname)
+{
+ GtkWidget* dlg = gtk_print_unix_dialog_new(_("Print"), NULL);
+
+/*
+ gtk_print_unix_dialog_add_custom_tab (GtkPrintUnixDialog *dialog,
+ GtkWidget *child,
+ GtkWidget *tab_label);
+*/
+
+ int const response = gtk_dialog_run(GTK_DIALOG(dlg));
+
+ if (response == GTK_RESPONSE_OK) {
+ GtkPrinter* printer = gtk_print_unix_dialog_get_selected_printer(GTK_PRINT_UNIX_DIALOG(dlg));
+
+ fprintf(stderr,"Selected printer '%s'\n",gtk_printer_get_name (printer));
+
+ if (gtk_printer_accepts_ps (printer)) {
+ GtkPrintJob* job = gtk_print_job_new (jobname, printer,
+ gtk_print_unix_dialog_get_settings(GTK_PRINT_UNIX_DIALOG(dlg)),
+ gtk_print_unix_dialog_get_page_setup(GTK_PRINT_UNIX_DIALOG(dlg)));
+
+
+ GError * error = NULL;
+ if ( gtk_print_job_set_source_file (job, ps_file, &error)) {
+ fprintf(stderr,"sending...\n");
+ gtk_print_job_send (job, unix_print_complete, NULL, NULL);
+ }
+ else {
+ fprintf(stderr,"Could not set print source: %s\n",error ? error->message : "unknown error");
+ }
+ }
+ else {
+ fprintf(stderr,"Printer can't support PS output\n");
+ }
+ }
+ else if (response == GTK_RESPONSE_APPLY) {
+ fprintf(stderr,"preview not available\n");
+ }
+
+ gtk_widget_destroy(dlg);
+}
+
+
unsigned int
PrintPS::setup(Inkscape::Extension::Print * mod)
{
@@ -118,13 +173,21 @@
g_object_ref((GObject *) tt);
gtk_object_sink((GtkObject *) tt);
+#ifdef HAVE_GTK_UNIX_PRINT
+ GtkWidget *dlg = gtk_dialog_new_with_buttons(_("Print Configuration"),
+#else
GtkWidget *dlg = gtk_dialog_new_with_buttons(_("Print Destination"),
+#endif
// SP_DT_WIDGET(SP_ACTIVE_DESKTOP)->window,
NULL,
(GtkDialogFlags) (GTK_DIALOG_MODAL | GTK_DIALOG_NO_SEPARATOR | GTK_DIALOG_DESTROY_WITH_PARENT),
GTK_STOCK_CANCEL,
GTK_RESPONSE_CANCEL,
+#ifdef HAVE_GTK_UNIX_PRINT
+ GTK_STOCK_GO_FORWARD,
+#else
GTK_STOCK_PRINT,
+#endif
GTK_RESPONSE_OK,
NULL);
@@ -180,6 +243,7 @@
GtkWidget *l = gtk_label_new(_("Resolution:"));
gtk_box_pack_end(GTK_BOX(hb), l, FALSE, FALSE, 0);
+#ifndef HAVE_GTK_UNIX_PRINT
/* Print destination frame */
f = gtk_frame_new(_("Print destination"));
gtk_box_pack_start(GTK_BOX(vbox), f, FALSE, FALSE, 4);
@@ -204,6 +268,7 @@
// pressing enter in the destination field is the same as clicking Print:
gtk_entry_set_activates_default(GTK_ENTRY(e), TRUE);
+#endif
gtk_widget_show_all(vbox);
@@ -218,15 +283,26 @@
_bitmap = gtk_toggle_button_get_active((GtkToggleButton *) rb);
sstr = gtk_entry_get_text(GTK_ENTRY(GTK_COMBO(combo)->entry));
_dpi = (unsigned int) MAX((int)(atof(sstr)), 1);
+#ifndef HAVE_GTK_UNIX_PRINT
/* Arrgh, have to do something */
fn = gtk_entry_get_text(GTK_ENTRY(e));
/* skip leading whitespace, bug #1068483 */
while (fn && *fn==' ') { fn++; }
/* g_print("Printing to %s\n", fn); */
+ mod->set_param_string("destination", (gchar *)fn);
+#else
+ /* unix print dialog prints to a tempfile */
+ char * filename = strdup("/tmp/inkscape-ps-XXXXXX");
+ int tmpfd = mkstemp(filename);
+ close(tmpfd);
+ Glib::ustring dest = ">";
+ dest+=filename;
+ free(filename);
+ mod->set_param_string("destination", dest.c_str());
+#endif
mod->set_param_bool("bitmap", _bitmap);
mod->set_param_string("resolution", (gchar *)sstr);
- mod->set_param_string("destination", (gchar *)fn);
ret = TRUE;
}
@@ -283,6 +359,7 @@
epsexport = g_str_has_suffix(fn,".eps");
while (isspace(*fn)) fn += 1;
Inkscape::IO::dump_fopen_call(fn, "K");
+ _tmpfilename = fn;
osf = Inkscape::IO::fopen_utf8name(fn, "w+");
if (!osf) {
fprintf(stderr, "inkscape: fopen(%s): %s\n",
@@ -582,12 +659,23 @@
{
while((c = fgetc(_stream))!=EOF) fputc(c, _begin_stream);
}
- fclose(_begin_stream);
+ fclose(_stream);
+ _stream = _begin_stream;
}
+#ifdef HAVE_GTK_UNIX_PRINT
+ /* redirect output to new print dialog */
+ fseek(_stream, 0, SEEK_SET);
+ Glib::ustring output = _tmpfilename;
+ unix_print_dialog(output.c_str(),"job name");
+ unlink(output.c_str());
+ /* end redirected new print dialog */
+#endif
+
/* fixme: should really use pclose for popen'd streams */
fclose(_stream);
- _stream = 0;
+ _stream = NULL;
+
_latin1_encoded_fonts.clear();
g_tree_destroy(_fonts);
Index: src/extension/internal/ps.h
===================================================================
--- src/extension/internal/ps.h (revision 14039)
+++ src/extension/internal/ps.h (revision 14040)
@@ -36,6 +36,7 @@
float _height;
FILE * _begin_stream;//stream to print prolog and document setup of EPS, if font embedding
FILE * _stream;//(main) stream to print the (E)PS output, or only the script part following prolog/document setup, if font embedding
+ Glib::ustring _tmpfilename;
unsigned short _dpi;
bool _bitmap;
Index: src/Makefile.am
===================================================================
--- src/Makefile.am (revision 14039)
+++ src/Makefile.am (revision 14040)
@@ -20,6 +20,7 @@
$(GNOME_VFS_CFLAGS) \
$(INKBOARD_CFLAGS) \
$(XFT_CFLAGS) \
+ $(GTK_UNIX_PRINT_CFLAGS) \
-DPOTRACE=\"potrace\" \
$(INKSCAPE_CFLAGS) \
-I$(top_srcdir)/cxxtest
Index: configure.ac
===================================================================
--- configure.ac (revision 14039)
+++ configure.ac (revision 14040)
@@ -525,6 +525,11 @@
AC_DEFINE(HAVE_CAIRO_PDF, 1, [Whether the Cairo PDF backend is available])
fi
+PKG_CHECK_MODULES(GTK_UNIX_PRINT, gtk+-unix-print-2.0, gtk_unix_print=yes, gtk_unix_print=no)
+if test "x$gtk_unix_print" = "xyes"; then
+ AC_DEFINE(HAVE_GTK_UNIX_PRINT, 1, [Whether the GTK Unix printing backend is available])
+fi
+
dnl Shouldn't we test for libpng and libz?
INKSCAPE_LIBS="$INKSCAPE_LIBS -lpng -lz"

View File

@ -1,25 +0,0 @@
--- inkscape-0.45.1/share/extensions/ill2svg.pl.orig 2007-03-25 14:40:18.000000000 +0200
+++ inkscape-0.45.1/share/extensions/ill2svg.pl 2007-03-25 14:41:47.000000000 +0200
@@ -355,20 +355,9 @@
print " xmlns:xlink=\"http://www.w3.org/1999/xlink\">\r\n";
while (<>) {
- if (m/$NL_DOS$/) {
- $/ = $NL_DOS;
- foreach (split /$NL_DOS/) {
- process_line($_);
- }
- } elsif (m/$NL_MAC$/) {
- $/ = $NL_MAC;
- foreach (split /$NL_MAC/) {
- process_line($_);
- }
- } else {
- chomp;
+ foreach (split /[\015\012]+/) {
process_line($_);
- }
+ }
}
print "</svg>\n";

View File

@ -0,0 +1,12 @@
--- inkscape-16571/src/Makefile.in.orig 2007-11-29 13:38:13.000000000 +0100
+++ inkscape-16571/src/Makefile.in 2007-11-29 13:38:29.000000000 +0100
@@ -317,7 +317,8 @@
$(POPPLER_GLIB_CFLAGS) \
-DPOTRACE=\"potrace\" \
$(INKSCAPE_CFLAGS) \
- -I$(top_srcdir)/cxxtest
+ -I$(top_srcdir)/cxxtest \
+ -I$(top_srcdir)/src/extension/script
@PLATFORM_WIN32_TRUE@win32_sources = winmain.cpp registrytool.cpp registrytool.h

View File

@ -1,18 +1,14 @@
%define _with_inkboard 1
Name: inkscape Name: inkscape
Version: 0.45.1 Version: 0.45.1+0.46pre1
Release: 5%{?dist} Release: 1%{?dist}
Summary: Vector-based drawing program using SVG Summary: Vector-based drawing program using SVG
Group: Applications/Productivity Group: Applications/Productivity
License: GPLv2+ License: GPLv2+
URL: http://inkscape.sourceforge.net/ URL: http://inkscape.sourceforge.net/
Source0: http://download.sourceforge.net/inkscape/inkscape-%{version}.tar.gz Source0: http://download.sourceforge.net/inkscape/inkscape-%{version}.tar.bz2
Patch0: inkscape-0.44.1-psinput.patch Patch0: inkscape-16571-cxxinclude.patch
Patch1: inkscape-0.45-python.patch Patch1: inkscape-0.45.1-desktop.patch
Patch2: inkscape-0.45.1-gtkprint.patch
Patch3: inkscape-0.45.1-desktop.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: atk-devel BuildRequires: atk-devel
@ -20,11 +16,10 @@ BuildRequires: desktop-file-utils
BuildRequires: freetype-devel BuildRequires: freetype-devel
BuildRequires: gc-devel >= 6.4 BuildRequires: gc-devel >= 6.4
BuildRequires: gettext BuildRequires: gettext
BuildRequires: gtkmm24-devel BuildRequires: gtkmm24-devel >= 2.8.0
BuildRequires: gtkspell-devel BuildRequires: gtkspell-devel
BuildRequires: gnome-vfs2-devel >= 2.0 BuildRequires: gnome-vfs2-devel >= 2.0
BuildRequires: libpng-devel >= 1.2 BuildRequires: libpng-devel >= 1.2
BuildRequires: libsigc++20-devel >= 2.0.12
BuildRequires: libxml2-devel >= 2.6.11 BuildRequires: libxml2-devel >= 2.6.11
BuildRequires: libxslt-devel >= 1.0.15 BuildRequires: libxslt-devel >= 1.0.15
BuildRequires: pango-devel BuildRequires: pango-devel
@ -35,19 +30,16 @@ BuildRequires: openssl-devel
BuildRequires: dos2unix BuildRequires: dos2unix
BuildRequires: perl-XML-Parser BuildRequires: perl-XML-Parser
BuildRequires: python-devel BuildRequires: python-devel
%if %{fedora} > 7 BuildRequires: poppler-devel >= 0.5.9
BuildRequires: popt-devel BuildRequires: popt-devel
%else BuildRequires: loudmouth-devel >= 1.0
BuildRequires: popt BuildRequires: boost-devel
%endif
# The following are needed due to gtkprint patch changing configure.ac
BuildRequires: autoconf automake17 intltool
%{?_with_inkboard:BuildRequires: loudmouth-devel >= 1.0}
Requires: pstoedit Requires: pstoedit
Requires: perl(Image::Magick) Requires: perl(Image::Magick)
Requires: numpy Requires: numpy
Requires: PyXML Requires: PyXML
Requires: python-lxml
Requires(post): desktop-file-utils Requires(post): desktop-file-utils
Requires(postun): desktop-file-utils Requires(postun): desktop-file-utils
@ -69,19 +61,14 @@ C and C++, using the Gtk+ toolkit and optionally some Gnome libraries.
%prep %prep
%setup -q %setup -q
%patch0 -p1 -b .psinput %patch0 -p1 -b .cxxinclude
%patch1 -p1 -b .python %patch1 -p1 -b .desktop
%patch2 -p0 -b .gtkprint
%patch3 -p1 -b .desktop
find -type f -regex '.*\.\(cpp\|h\)' -perm +111 -exec chmod -x {} ';' find -type f -regex '.*\.\(cpp\|h\)' -perm +111 -exec chmod -x {} ';'
find share/extensions/ -type f -regex '.*\.py' -perm +111 -exec chmod -x {} ';' find share/extensions/ -type f -regex '.*\.py' -perm +111 -exec chmod -x {} ';'
dos2unix share/extensions/*.py dos2unix share/extensions/*.py
%build %build
intltoolize --force
autoconf
autoheader
%configure \ %configure \
--disable-dependency-tracking \ --disable-dependency-tracking \
--with-xinerama \ --with-xinerama \
@ -91,14 +78,15 @@ autoheader
--with-gnome-vfs \ --with-gnome-vfs \
--with-inkjar \ --with-inkjar \
--enable-inkboard \ --enable-inkboard \
--enable-lcms --enable-lcms \
--enable-poppler-cairo
make %{?_smp_mflags} make %{?_smp_mflags}
%install %install
rm -rf ${RPM_BUILD_ROOT} rm -rf $RPM_BUILD_ROOT
make install DESTDIR=${RPM_BUILD_ROOT} make install DESTDIR=$RPM_BUILD_ROOT
%find_lang %{name} %find_lang %{name}
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';' find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
@ -106,12 +94,12 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions/outline2svg.*
rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions/txt2svg.* rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions/txt2svg.*
desktop-file-install --vendor fedora --delete-original \ desktop-file-install --vendor fedora --delete-original \
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \ --dir $RPM_BUILD_ROOT%{_datadir}/applications \
${RPM_BUILD_ROOT}/usr/share/applications/%{name}.desktop $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
%clean %clean
rm -rf ${RPM_BUILD_ROOT} rm -rf $RPM_BUILD_ROOT
%post %post
@ -134,6 +122,16 @@ update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
%changelog %changelog
* Wed Feb 06 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-1
- 0.46 prerelease
- Minor cosmetic changes to satisfy the QA script
- Dependency on Boost
- Inkboard is not optional
- Merge from Denis Leroy's svn16571 snapshot:
- Require specific gtkmm24-devel versions
- enable-poppler-cairo
- No longer BuildRequire libsigc++20-devel
* Wed Dec 5 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-5 * Wed Dec 5 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-5
- Rebuild with new openssl - Rebuild with new openssl

View File

@ -1 +1 @@
1ac63dfd5d78a676599bf5cf6d22e493 inkscape-0.45.1.tar.gz 2b3b31cb92c558a68534f190d31b0d72 inkscape-0.45.1+0.46pre1.tar.bz2