- Update to newer snapshot

- Fix doc/incview reversed subpackage content
This commit is contained in:
Lubomir Rintel 2009-04-10 13:34:27 +00:00
parent 4d99400645
commit ad3c2f2896
6 changed files with 84 additions and 125 deletions

View File

@ -1,108 +0,0 @@
See https://bugs.launchpad.net/inkscape/+bug/226383
https://bugzilla.redhat.com/show_bug.cgi?id=458845
Lubomir Rintel <lkundrak@v3.sk>
diff -up inkscape/inkscape.desktop.in.uniconv inkscape/inkscape.desktop.in
--- inkscape/inkscape.desktop.in.uniconv 2009-01-06 11:38:13.000000000 +0100
+++ inkscape/inkscape.desktop.in 2009-01-06 11:38:39.000000000 +0100
@@ -4,7 +4,7 @@ _Name=Inkscape Vector Graphics Editor
_Comment=Create and edit Scalable Vector Graphics images
Type=Application
Categories=Graphics;VectorGraphics;GTK;
-MimeType=image/svg+xml;image/svg+xml-compressed;
+MimeType=image/svg+xml;image/svg+xml-compressed;image/cgm;image/x-wmf;application/vnd.corel-draw;application/x-xccx;application/x-xcgm;application/x-xcdt;application/x-xsk1;application/x-xcmx;image/x-xcdr;
Exec=inkscape %F
TryExec=inkscape
Terminal=false
diff -up inkscape/share/extensions/ccx_input.inx.uniconv inkscape/share/extensions/ccx_input.inx
--- inkscape/share/extensions/ccx_input.inx.uniconv 2009-01-05 14:23:27.000000000 +0100
+++ inkscape/share/extensions/ccx_input.inx 2009-01-06 11:37:02.000000000 +0100
@@ -2,7 +2,7 @@
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">
<_name>Corel DRAW Compressed Exchange files input</_name>
<id>org.inkscape.input.ccx</id>
- <dependency type="executable" location="path">uniconv</dependency>
+ <dependency type="executable" location="path">uniconvertor</dependency>
<dependency type="executable" location="extensions">uniconv-ext.py</dependency>
<input>
<extension>.ccx</extension>
diff -up inkscape/share/extensions/cdr_input.inx.uniconv inkscape/share/extensions/cdr_input.inx
diff -up inkscape/share/extensions/cdt_input.inx.uniconv inkscape/share/extensions/cdt_input.inx
--- inkscape/share/extensions/cdt_input.inx.uniconv 2009-01-05 14:23:28.000000000 +0100
+++ inkscape/share/extensions/cdt_input.inx 2009-01-06 11:37:02.000000000 +0100
@@ -2,7 +2,7 @@
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">
<_name>Corel DRAW templates input</_name>
<id>org.inkscape.input.cdt</id>
- <dependency type="executable" location="path">uniconv</dependency>
+ <dependency type="executable" location="path">uniconvertor</dependency>
<dependency type="executable" location="extensions">uniconv-ext.py</dependency>
<input>
<extension>.cdt</extension>
diff -up inkscape/share/extensions/cgm_input.inx.uniconv inkscape/share/extensions/cgm_input.inx
--- inkscape/share/extensions/cgm_input.inx.uniconv 2009-01-05 14:23:26.000000000 +0100
+++ inkscape/share/extensions/cgm_input.inx 2009-01-06 11:37:02.000000000 +0100
@@ -2,7 +2,7 @@
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">
<_name>Computer Graphics Metafile files input</_name>
<id>org.inkscape.input.cgm</id>
- <dependency type="executable" location="path">uniconv</dependency>
+ <dependency type="executable" location="path">uniconvertor</dependency>
<dependency type="executable" location="extensions">uniconv-ext.py</dependency>
<input>
<extension>.cgm</extension>
diff -up inkscape/share/extensions/cmx_input.inx.uniconv inkscape/share/extensions/cmx_input.inx
--- inkscape/share/extensions/cmx_input.inx.uniconv 2009-01-05 14:23:26.000000000 +0100
+++ inkscape/share/extensions/cmx_input.inx 2009-01-06 11:37:02.000000000 +0100
@@ -2,7 +2,7 @@
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">
<_name>Corel DRAW Presentation Exchange files input</_name>
<id>org.inkscape.input.cmx</id>
- <dependency type="executable" location="path">uniconv</dependency>
+ <dependency type="executable" location="path">uniconvertor</dependency>
<dependency type="executable" location="extensions">uniconv-ext.py</dependency>
<input>
<extension>.cmx</extension>
diff -up inkscape/share/extensions/sk1_input.inx.uniconv inkscape/share/extensions/sk1_input.inx
--- inkscape/share/extensions/sk1_input.inx.uniconv 2009-01-05 14:23:27.000000000 +0100
+++ inkscape/share/extensions/sk1_input.inx 2009-01-06 11:37:02.000000000 +0100
@@ -2,7 +2,7 @@
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">
<_name>sK1 vector graphics files input</_name>
<id>org.inkscape.input.sk1</id>
- <dependency type="executable" location="path">uniconv</dependency>
+ <dependency type="executable" location="path">uniconvertor</dependency>
<dependency type="executable" location="extensions">uniconv-ext.py</dependency>
<input>
<extension>.sk1</extension>
diff -up inkscape/share/extensions/uniconv-ext.py.uniconv inkscape/share/extensions/uniconv-ext.py
--- inkscape/share/extensions/uniconv-ext.py.uniconv 2009-01-05 14:23:28.000000000 +0100
+++ inkscape/share/extensions/uniconv-ext.py 2009-01-06 11:41:29.000000000 +0100
@@ -28,14 +28,10 @@ from subprocess import Popen, PIPE
cmd = 'none'
try:
- p = Popen('uniconv', shell=True, stdout=PIPE, stderr=PIPE).wait()
- if p!=127 : cmd = 'uniconv'
p = Popen('uniconvertor', shell=True, stdout=PIPE, stderr=PIPE).wait()
if p!=127 : cmd = 'uniconvertor'
except ImportError:
from popen2 import Popen3
- p = Popen3('uniconv', True).wait()
- if p!=32512 : cmd = 'uniconv'
p = Popen3('uniconvertor', True).wait()
if p!=32512 : cmd = 'uniconvertor'
diff -up inkscape/share/extensions/wmf_input.inx.uniconv inkscape/share/extensions/wmf_input.inx
--- inkscape/share/extensions/wmf_input.inx.uniconv 2009-01-05 14:23:28.000000000 +0100
+++ inkscape/share/extensions/wmf_input.inx 2009-01-06 11:37:02.000000000 +0100
@@ -2,7 +2,7 @@
<inkscape-extension xmlns="http://www.inkscape.org/namespace/inkscape/extension">
<_name>Windows Metafile Input</_name>
<id>org.inkscape.input.wmf</id>
- <dependency type="executable" location="path">uniconv</dependency>
+ <dependency type="executable" location="path">uniconvertor</dependency>
<dependency type="executable" location="extensions">uniconv-ext.py</dependency>
<input>
<extension>.wmf</extension>

View File

@ -0,0 +1,16 @@
See https://bugzilla.redhat.com/show_bug.cgi?id=458845
Lubomir Rintel <lkundrak@v3.sk>
diff -up inkscape/inkscape.desktop.in.uniconv inkscape/inkscape.desktop.in
--- inkscape/inkscape.desktop.in.uniconv 2009-01-06 11:38:13.000000000 +0100
+++ inkscape/inkscape.desktop.in 2009-01-06 11:38:39.000000000 +0100
@@ -4,7 +4,7 @@ _Name=Inkscape Vector Graphics Editor
_Comment=Create and edit Scalable Vector Graphics images
Type=Application
Categories=Graphics;VectorGraphics;GTK;
-MimeType=image/svg+xml;image/svg+xml-compressed;
+MimeType=image/svg+xml;image/svg+xml-compressed;image/cgm;image/x-wmf;application/vnd.corel-draw;application/x-xccx;application/x-xcgm;application/x-xcdt;application/x-xsk1;application/x-xcmx;image/x-xcdr;
Exec=inkscape %F
TryExec=inkscape
Terminal=false

View File

@ -4,7 +4,7 @@ Lubomir Rintel <lkundrak@v3.sk>
diff -up inkscape/src/extension/internal/bitmap/imagemagick.cpp.gcc44 inkscape/src/extension/internal/bitmap/imagemagick.cpp
--- inkscape/src/extension/internal/bitmap/imagemagick.cpp.gcc44 2009-01-28 22:12:57.000000000 +0100
+++ inkscape/src/extension/internal/bitmap/imagemagick.cpp 2009-03-02 17:05:57.000000000 +0100
+++ inkscape/src/extension/internal/bitmap/imagemagick.cpp 2009-04-10 12:34:09.189576256 +0200
@@ -114,7 +114,7 @@ ImageMagickDocCache::readImage(const cha
char *search = (char *) g_strndup(xlink, 30);
if (strstr(search, "base64") != (char*)NULL) {
@ -15,8 +15,8 @@ diff -up inkscape/src/extension/internal/bitmap/imagemagick.cpp.gcc44 inkscape/s
blob.base64(pureBase64);
image->read(blob);
diff -up inkscape/src/libnr/nr-object.cpp.gcc44 inkscape/src/libnr/nr-object.cpp
--- inkscape/src/libnr/nr-object.cpp.gcc44 2009-03-02 17:06:46.000000000 +0100
+++ inkscape/src/libnr/nr-object.cpp 2009-03-02 17:06:58.000000000 +0100
--- inkscape/src/libnr/nr-object.cpp.gcc44 2008-05-04 07:14:00.000000000 +0200
+++ inkscape/src/libnr/nr-object.cpp 2009-04-10 12:34:09.190577328 +0200
@@ -198,8 +198,8 @@ NRObject *NRObject::alloc(NRType type)
);
memset(object, 0xf0, c->isize);
@ -27,3 +27,14 @@ diff -up inkscape/src/libnr/nr-object.cpp.gcc44 inkscape/src/libnr/nr-object.cpp
nr_class_tree_object_invoke_init (c, object);
return object;
diff -up inkscape/src/widgets/ege-paint-def.cpp.gcc44 inkscape/src/widgets/ege-paint-def.cpp
--- inkscape/src/widgets/ege-paint-def.cpp.gcc44 2009-04-10 14:31:06.349578336 +0200
+++ inkscape/src/widgets/ege-paint-def.cpp 2009-04-10 14:31:20.011577660 +0200
@@ -45,6 +45,7 @@
#include <stdint.h>
#include <string>
+#include <cstdio>
#include <iostream>
#include <sstream>
#include <stdlib.h>

View File

@ -0,0 +1,38 @@
uniconvertor and uniconv are looked in in reversed order
(therefore we can call uniconv that's different from the uniconvertor one)
https://bugs.launchpad.net/inkscape/+bug/226383
Lubomir Rintel <lkundrak@v3.sk>
diff -up inkscape/share/extensions/uniconv-ext.py.uniconv inkscape/share/extensions/uniconv-ext.py
--- inkscape/share/extensions/uniconv-ext.py.uniconv 2009-03-01 18:06:19.000000000 +0100
+++ inkscape/share/extensions/uniconv-ext.py 2009-04-10 15:22:21.916579400 +0200
@@ -28,19 +28,21 @@ cmd = None
try:
from subprocess import Popen, PIPE
- p = Popen('uniconv', shell=True, stdout=PIPE, stderr=PIPE).wait()
+ p = Popen('uniconvertor', shell=True, stdout=PIPE, stderr=PIPE).wait()
if p==0 :
- cmd = 'uniconv'
+ cmd = 'uniconvertor'
else:
- p = Popen('uniconvertor', shell=True, stdout=PIPE, stderr=PIPE).wait()
+ p = Popen('uniconv', shell=True, stdout=PIPE, stderr=PIPE).wait()
if p==0 :
- cmd = 'uniconvertor'
+ cmd = 'uniconv'
except ImportError:
from popen2 import Popen3
- p = Popen3('uniconv', True).wait()
- if p!=32512 : cmd = 'uniconv'
p = Popen3('uniconvertor', True).wait()
- if p!=32512 : cmd = 'uniconvertor'
+ if p!=32512 :
+ cmd = 'uniconvertor'
+ else:
+ p = Popen3('uniconv', True).wait()
+ if p!=32512 : cmd = 'uniconv'
if cmd == None:
# there's no succeffully-returning uniconv command; try to get the module directly (on Windows)

View File

@ -1,25 +1,22 @@
# Preserve lot of debugging information for now. This effectively
# disables FORTIFY_SOURCE, so it must be enabled before Gold
%define optflags %(rpm --eval %%optflags |sed 's/-O2/-O0/')
Name: inkscape
Version: 0.47
Release: 0.6.20090301svn%{?dist}
Release: 0.6.20090410svn%{?dist}
Summary: Vector-based drawing program using SVG
Group: Applications/Productivity
License: GPLv2+
URL: http://inkscape.sourceforge.net/
#Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
# svn export -r20798 https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk@20798 inkscape
# svn export -r21114 https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk@21114 inkscape
# tar cf - inkscape |lzma -9 -c >inkscape.tar.lzma
# Chuck the SVN snapshot specific blocks when bumping to a release:
# perl -e 'while (<>) {/^# BEGIN SVN/ .. /^# END SVN/ or print}' <inkscape.spec
Source0: %{name}.tar.lzma
Patch0: inkscape-0.46+devel-uniconv.patch
Patch1: inkscape-20090227svn-gcc44.patch
Patch0: inkscape-20090410svn-uniconv.patch
Patch1: inkscape-20090410svn-gcc44.patch
Patch2: inkscape-20090226svn-oldcairo.patch
Patch4: inkscape-20090410svn-formats.patch
# BEGIN SVN SNAPSHOT SPECIFIC
Patch3: inkscape-20090227svn-automake.patch
# END SVN SNAPSHOT SPECIFIC
@ -128,6 +125,7 @@ format.
%package docs
Summary: Documentation for Inkscape
Group: Documentation
Requires: inkscape
%description docs
Tutorial and examples for Inkscape, a graphics editor for vector
@ -139,6 +137,7 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
%patch0 -p1 -b .uniconv
%patch1 -p1 -b .gcc44
%patch2 -p0 -b .oldcairo
%patch4 -p1 -b .formats
# BEGIN SVN SNAPSHOT SPECIFIC
%patch3 -p0 -b .automake
# END SVN SNAPSHOT SPECIFIC
@ -236,19 +235,22 @@ touch --no-create %{_datadir}/icons/hicolor
%files view
%defattr(-,root,root,-)
%dir %{_datadir}/inkscape
%{_datadir}/inkscape/tutorials
%{_datadir}/inkscape/examples
%{_bindir}/inkview
%doc AUTHORS COPYING ChangeLog NEWS README
%files docs
%defattr(-,root,root,-)
%{_bindir}/inkview
%doc AUTHORS COPYING ChangeLog NEWS README
%dir %{_datadir}/inkscape
%{_datadir}/inkscape/tutorials
%{_datadir}/inkscape/examples
%changelog
* Fri Apr 10 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.6.20090410svn
- Update to newer snapshot
- Fix doc/incview reversed subpackage content
* Wed Mar 04 2009 Lubomir Rintel <lkundrak@v3.sk> - 0.47-0.6.20090301svn
- Rebuild for new ImageMagick

View File

@ -1 +1 @@
8803034773154e5d90e3bdac7de7ab30 inkscape.tar.lzma
b2f839c29e8ad5c3eab82c2540c6e12d inkscape.tar.lzma