Rebuild (poppler-0.30.0)
Backport commit "Fix build with poppler 0.29.0 (Bug #1399811)"
This commit is contained in:
parent
cd1266ae6c
commit
961913ef82
90
inkscape-0.48.5-poppler-0.29.0.patch
Normal file
90
inkscape-0.48.5-poppler-0.29.0.patch
Normal file
@ -0,0 +1,90 @@
|
||||
--- inkscape-0.48.5/configure.ac
|
||||
+++ inkscape-0.48.5/configure.ac
|
||||
@@ -593,6 +593,11 @@ if test "x$popplernewercolorspaceapi" =
|
||||
AC_DEFINE(POPPLER_EVEN_NEWER_COLOR_SPACE_API, 1, [Use even newer color space API from Poppler >= 0.26.0])
|
||||
fi
|
||||
|
||||
+PKG_CHECK_MODULES(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API, poppler >= 0.29.0, popplernewernewcolorspaceapi=yes, popplernewernewcolorspaceapi=no)
|
||||
+if test "x$popplernewernewcolorspaceapi" = "xyes"; then
|
||||
+ AC_DEFINE(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API, 1, [Use even newer new color space API from Poppler >= 0.29.0])
|
||||
+fi
|
||||
+
|
||||
# Poppler's b604a008 commit changes this
|
||||
AC_MSG_CHECKING([whether Poppler's GfxPatch no longer uses GfxColor])
|
||||
popplergfxcolor="no"
|
||||
--- inkscape-0.48.5/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
+++ inkscape-0.48.5/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
@@ -860,7 +860,9 @@ void PdfParser::opSetExtGState(Object ar
|
||||
blendingColorSpace = NULL;
|
||||
isolated = knockout = gFalse;
|
||||
if (!obj4.dictLookup(const_cast<char*>("CS"), &obj5)->isNull()) {
|
||||
-#if defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
+#if defined(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API)
|
||||
+ blendingColorSpace = GfxColorSpace::parse(NULL, &obj5, NULL, NULL);
|
||||
+#elif defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
blendingColorSpace = GfxColorSpace::parse(&obj5, NULL, NULL);
|
||||
#elif defined(POPPLER_NEW_COLOR_SPACE_API) || defined(POPPLER_NEW_ERRORAPI)
|
||||
blendingColorSpace = GfxColorSpace::parse(&obj5, NULL);
|
||||
@@ -1085,7 +1087,13 @@ void PdfParser::opSetFillColorSpace(Obje
|
||||
|
||||
state->setFillPattern(NULL);
|
||||
res->lookupColorSpace(args[0].getName(), &obj);
|
||||
-#if defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
+#if defined(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API)
|
||||
+ if (obj.isNull()) {
|
||||
+ colorSpace = GfxColorSpace::parse(NULL, &args[0], NULL, NULL);
|
||||
+ } else {
|
||||
+ colorSpace = GfxColorSpace::parse(NULL, &obj, NULL, NULL);
|
||||
+ }
|
||||
+#elif defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
if (obj.isNull()) {
|
||||
colorSpace = GfxColorSpace::parse(&args[0], NULL, NULL);
|
||||
} else {
|
||||
@@ -1126,7 +1134,13 @@ void PdfParser::opSetStrokeColorSpace(Ob
|
||||
|
||||
state->setStrokePattern(NULL);
|
||||
res->lookupColorSpace(args[0].getName(), &obj);
|
||||
-#if defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
+#if defined(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API)
|
||||
+ if (obj.isNull()) {
|
||||
+ colorSpace = GfxColorSpace::parse(NULL, &args[0], NULL, NULL);
|
||||
+ } else {
|
||||
+ colorSpace = GfxColorSpace::parse(NULL, &obj, NULL, NULL);
|
||||
+ }
|
||||
+#elif defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
if (obj.isNull()) {
|
||||
colorSpace = GfxColorSpace::parse(&args[0], NULL, NULL);
|
||||
} else {
|
||||
@@ -2756,7 +2770,9 @@ void PdfParser::doImage(Object *ref, Str
|
||||
}
|
||||
}
|
||||
if (!obj1.isNull()) {
|
||||
-#if defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
+#if defined(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API)
|
||||
+ colorSpace = GfxColorSpace::parse(NULL, &obj1, NULL, NULL);
|
||||
+#elif defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
colorSpace = GfxColorSpace::parse(&obj1, NULL, NULL);
|
||||
#elif defined(POPPLER_NEW_COLOR_SPACE_API) || defined(POPPLER_NEW_ERRORAPI)
|
||||
colorSpace = GfxColorSpace::parse(&obj1, NULL);
|
||||
@@ -2847,7 +2863,9 @@ void PdfParser::doImage(Object *ref, Str
|
||||
obj2.free();
|
||||
}
|
||||
}
|
||||
-#if defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
+#if defined(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API)
|
||||
+ GfxColorSpace *maskColorSpace = GfxColorSpace::parse(NULL, &obj1, NULL, NULL);
|
||||
+#elif defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
GfxColorSpace *maskColorSpace = GfxColorSpace::parse(&obj1, NULL, NULL);
|
||||
#elif defined(POPPLER_NEW_COLOR_SPACE_API) || defined(POPPLER_NEW_ERRORAPI)
|
||||
maskColorSpace = GfxColorSpace::parse(&obj1, NULL);
|
||||
@@ -3040,7 +3058,9 @@ void PdfParser::doForm(Object *str) {
|
||||
if (obj1.dictLookup(const_cast<char*>("S"), &obj2)->isName(const_cast<char*>("Transparency"))) {
|
||||
transpGroup = gTrue;
|
||||
if (!obj1.dictLookup(const_cast<char*>("CS"), &obj3)->isNull()) {
|
||||
-#if defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
+#if defined(POPPLER_EVEN_NEWER_NEW_COLOR_SPACE_API)
|
||||
+ blendingColorSpace = GfxColorSpace::parse(NULL, &obj3, NULL, NULL);
|
||||
+#elif defined(POPPLER_EVEN_NEWER_COLOR_SPACE_API)
|
||||
blendingColorSpace = GfxColorSpace::parse(&obj3, NULL, NULL);
|
||||
#elif defined(POPPLER_NEW_COLOR_SPACE_API) || defined(POPPLER_NEW_ERRORAPI)
|
||||
blendingColorSpace = GfxColorSpace::parse(&obj3, NULL);
|
@ -1,6 +1,6 @@
|
||||
Name: inkscape
|
||||
Version: 0.48.5
|
||||
Release: 5%{?dist}
|
||||
Release: 6%{?dist}
|
||||
Summary: Vector-based drawing program using SVG
|
||||
|
||||
Group: Applications/Productivity
|
||||
@ -20,6 +20,7 @@ Patch0: inkscape-0.48.2-types.patch
|
||||
#Patch12: inkscape-0.48.4-poppler-0.26.patch
|
||||
Patch13: inkscape-0.48.4-gc-7.4.patch
|
||||
Patch14: 0001-update-to-new-libwpg.patch
|
||||
Patch15: inkscape-0.48.5-poppler-0.29.0.patch
|
||||
|
||||
%if 0%{?fedora} && 0%{?fedora} < 18
|
||||
%define desktop_vendor fedora
|
||||
@ -142,6 +143,7 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
|
||||
#%patch12 -p1 -b .poppler
|
||||
%patch13 -p1 -b .gc
|
||||
%patch14 -p1 -b .libwpg
|
||||
%patch15 -p1 -b .poppler-0.29.0
|
||||
|
||||
# https://bugs.launchpad.net/inkscape/+bug/314381
|
||||
# A couple of files have executable bits set,
|
||||
@ -245,6 +247,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jan 23 2015 Marek Kasik <mkasik@redhat.com> - 0.48.5-6
|
||||
- Rebuild (poppler-0.30.0)
|
||||
- Backport commit "Fix build with poppler 0.29.0 (Bug #1399811)"
|
||||
|
||||
* Fri Jan 09 2015 Jon Ciesla <limburgher@gmail.com> - 0.48.5-5
|
||||
- Added aspell support, BZ 1171934.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user