Merge 0.46 from devel

This commit is contained in:
Lubomir Rintel 2008-04-06 13:51:37 +00:00
parent fc7768a6d2
commit 8abc7d35bb
10 changed files with 167 additions and 328 deletions

View File

@ -1 +1 @@
inkscape-0.45.1.tar.gz
inkscape-0.46.tar.bz2

View File

@ -1,42 +0,0 @@
--- inkscape-0.44.1/share/extensions/ps_input.inx.orig 2006-12-06 11:47:27.000000000 +0100
+++ inkscape-0.44.1/share/extensions/ps_input.inx 2006-12-06 11:46:40.000000000 +0100
@@ -1,7 +1,6 @@
<inkscape-extension>
<_name>Postscript Input</_name>
<id>org.inkscape.input.ps</id>
- <dependency type="extension">org.inkscape.input.sk</dependency>
<dependency type="executable">pstoedit</dependency>
<input>
<extension>.ps</extension>
@@ -11,7 +10,6 @@
<output_extension>org.inkscape.output.ps</output_extension>
</input>
<script>
- <command reldir="path">pstoedit -f sk</command>
- <helper_extension>org.inkscape.input.sk</helper_extension>
+ <command reldir="path">pstoedit -ndt -f plot-svg</command>
</script>
</inkscape-extension>
--- inkscape-0.44.1/share/extensions/eps_input.inx.orig 2006-12-06 12:19:56.000000000 +0100
+++ inkscape-0.44.1/share/extensions/eps_input.inx 2006-12-06 12:19:42.000000000 +0100
@@ -1,9 +1,8 @@
<inkscape-extension>
<_name>EPS Input</_name>
<id>org.inkscape.input.eps</id>
- <dependency type="extension">org.inkscape.input.ps</dependency>
- <dependency type="executable">gs</dependency>
- <input>
+ <dependency type="executable">pstoedit</dependency>
+ <input>
<extension>.eps</extension>
<mimetype>image/x-encapsulated-postscript</mimetype>
<_filetypename>Encapsulated Postscript (*.eps)</_filetypename>
@@ -11,7 +10,6 @@
<output_extension>org.inkscape.output.eps</output_extension>
</input>
<script>
- <command reldir="path">gs -q -sDEVICE=pswrite -sOutputFile=- -dNOPAUSE -dBATCH -dSAFER -dDEVICEWIDTH=250000 -dDEVICEHEIGHT=250000</command>
- <helper_extension>org.inkscape.input.ps</helper_extension>
+ <command reldir="path">pstoedit -ndt -f plot-svg</command>
</script>
</inkscape-extension>

View File

@ -1,36 +0,0 @@
--- inkscape-0.45/configure.orig 2007-02-07 12:08:44.000000000 -0800
+++ inkscape-0.45/configure 2007-02-07 12:22:34.000000000 -0800
@@ -10769,7 +10769,7 @@
if test "$?" -gt "0"; then
with_python="no"
else
- checkPYTHON_LIBS=`python -c "import distutils.sysconfig ; print '%s/%s %s' % (distutils.sysconfig.get_config_var('LIBPL'),distutils.sysconfig.get_config_var('LDLIBRARY'),distutils.sysconfig.get_config_var('LIBS'))" 2>/dev/null`
+ checkPYTHON_LIBS=`python -c "import distutils.sysconfig ; print '%s/%s %s' % (distutils.sysconfig.get_config_var('DBLIB'),distutils.sysconfig.get_config_var('LDLIBRARY'),distutils.sysconfig.get_config_var('LIBS'))" 2>/dev/null`
if test "$?" -gt "0"; then
with_python="no"
else
--- inkscape-0.45/src/extension/script/inkscape_py_wrap.cpp.orig 2007-02-07 17:11:42.000000000 -0800
+++ inkscape-0.45/src/extension/script/inkscape_py_wrap.cpp 2007-02-07 18:19:21.000000000 -0800
@@ -802,7 +802,7 @@
obj = pyobj;
if (PyCFunction_Check(obj)) {
/* here we get the method pointer for callbacks */
- char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
+ const char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
c = doc ? strstr(doc, "swig_ptr: ") : 0;
if (c) {
c += 10;
@@ -977,11 +977,11 @@
swig_type_info **types_initial) {
int i;
for (i = 0; methods[i].ml_name; ++i) {
- char *c = methods[i].ml_doc;
+ const char *c = methods[i].ml_doc;
if (c && (c = strstr(c, "swig_ptr: "))) {
int j;
swig_const_info *ci = 0;
- char *name = c + 10;
+ const char *name = c + 10;
for (j = 0; const_table[j].type; j++) {
if (strncmp(const_table[j].name, name,
strlen(const_table[j].name)) == 0) {

View File

@ -1,6 +1,8 @@
Make desktop-file-validate and rpmlint happy, handle compressed svgs (#245413)
and let it conform enough not to break the build in Rawhide.
(Lubomir Kundrak <lkundrak@redhat.com>)
https://bugs.launchpad.net/inkscape/+bug/190420
--- inkscape-0.45.1.orig/inkscape.desktop.in 2007-01-16 03:49:00.000000000 +0100
+++ inkscape-0.45.1/inkscape.desktop.in 2007-12-02 03:17:08.000000000 +0100

View File

@ -1,215 +0,0 @@
Patch from upstream SVN, by Kees Cook of Ubuntu
Index: src/extension/internal/ps.cpp
===================================================================
--- src/extension/internal/ps.cpp (revision 14039)
+++ src/extension/internal/ps.cpp (revision 14040)
@@ -43,6 +43,8 @@
#include <gtk/gtkentry.h>
#include <gtk/gtktooltips.h>
+#include <gtk/gtkprintunixdialog.h>
+
#include <glibmm/i18n.h>
#include "display/nr-arena-item.h"
#include "display/canvas-bpath.h"
@@ -102,6 +104,59 @@
return;
}
+static void
+unix_print_complete (GtkPrintJob *print_job,
+ gpointer user_data,
+ GError *error)
+{
+ fprintf(stderr,"job finished: %s\n",error ? error->message : "no error");
+}
+
+static void
+unix_print_dialog (const gchar * ps_file, const gchar * jobname)
+{
+ GtkWidget* dlg = gtk_print_unix_dialog_new(_("Print"), NULL);
+
+/*
+ gtk_print_unix_dialog_add_custom_tab (GtkPrintUnixDialog *dialog,
+ GtkWidget *child,
+ GtkWidget *tab_label);
+*/
+
+ int const response = gtk_dialog_run(GTK_DIALOG(dlg));
+
+ if (response == GTK_RESPONSE_OK) {
+ GtkPrinter* printer = gtk_print_unix_dialog_get_selected_printer(GTK_PRINT_UNIX_DIALOG(dlg));
+
+ fprintf(stderr,"Selected printer '%s'\n",gtk_printer_get_name (printer));
+
+ if (gtk_printer_accepts_ps (printer)) {
+ GtkPrintJob* job = gtk_print_job_new (jobname, printer,
+ gtk_print_unix_dialog_get_settings(GTK_PRINT_UNIX_DIALOG(dlg)),
+ gtk_print_unix_dialog_get_page_setup(GTK_PRINT_UNIX_DIALOG(dlg)));
+
+
+ GError * error = NULL;
+ if ( gtk_print_job_set_source_file (job, ps_file, &error)) {
+ fprintf(stderr,"sending...\n");
+ gtk_print_job_send (job, unix_print_complete, NULL, NULL);
+ }
+ else {
+ fprintf(stderr,"Could not set print source: %s\n",error ? error->message : "unknown error");
+ }
+ }
+ else {
+ fprintf(stderr,"Printer can't support PS output\n");
+ }
+ }
+ else if (response == GTK_RESPONSE_APPLY) {
+ fprintf(stderr,"preview not available\n");
+ }
+
+ gtk_widget_destroy(dlg);
+}
+
+
unsigned int
PrintPS::setup(Inkscape::Extension::Print * mod)
{
@@ -118,13 +173,21 @@
g_object_ref((GObject *) tt);
gtk_object_sink((GtkObject *) tt);
+#ifdef HAVE_GTK_UNIX_PRINT
+ GtkWidget *dlg = gtk_dialog_new_with_buttons(_("Print Configuration"),
+#else
GtkWidget *dlg = gtk_dialog_new_with_buttons(_("Print Destination"),
+#endif
// SP_DT_WIDGET(SP_ACTIVE_DESKTOP)->window,
NULL,
(GtkDialogFlags) (GTK_DIALOG_MODAL | GTK_DIALOG_NO_SEPARATOR | GTK_DIALOG_DESTROY_WITH_PARENT),
GTK_STOCK_CANCEL,
GTK_RESPONSE_CANCEL,
+#ifdef HAVE_GTK_UNIX_PRINT
+ GTK_STOCK_GO_FORWARD,
+#else
GTK_STOCK_PRINT,
+#endif
GTK_RESPONSE_OK,
NULL);
@@ -180,6 +243,7 @@
GtkWidget *l = gtk_label_new(_("Resolution:"));
gtk_box_pack_end(GTK_BOX(hb), l, FALSE, FALSE, 0);
+#ifndef HAVE_GTK_UNIX_PRINT
/* Print destination frame */
f = gtk_frame_new(_("Print destination"));
gtk_box_pack_start(GTK_BOX(vbox), f, FALSE, FALSE, 4);
@@ -204,6 +268,7 @@
// pressing enter in the destination field is the same as clicking Print:
gtk_entry_set_activates_default(GTK_ENTRY(e), TRUE);
+#endif
gtk_widget_show_all(vbox);
@@ -218,15 +283,26 @@
_bitmap = gtk_toggle_button_get_active((GtkToggleButton *) rb);
sstr = gtk_entry_get_text(GTK_ENTRY(GTK_COMBO(combo)->entry));
_dpi = (unsigned int) MAX((int)(atof(sstr)), 1);
+#ifndef HAVE_GTK_UNIX_PRINT
/* Arrgh, have to do something */
fn = gtk_entry_get_text(GTK_ENTRY(e));
/* skip leading whitespace, bug #1068483 */
while (fn && *fn==' ') { fn++; }
/* g_print("Printing to %s\n", fn); */
+ mod->set_param_string("destination", (gchar *)fn);
+#else
+ /* unix print dialog prints to a tempfile */
+ char * filename = strdup("/tmp/inkscape-ps-XXXXXX");
+ int tmpfd = mkstemp(filename);
+ close(tmpfd);
+ Glib::ustring dest = ">";
+ dest+=filename;
+ free(filename);
+ mod->set_param_string("destination", dest.c_str());
+#endif
mod->set_param_bool("bitmap", _bitmap);
mod->set_param_string("resolution", (gchar *)sstr);
- mod->set_param_string("destination", (gchar *)fn);
ret = TRUE;
}
@@ -283,6 +359,7 @@
epsexport = g_str_has_suffix(fn,".eps");
while (isspace(*fn)) fn += 1;
Inkscape::IO::dump_fopen_call(fn, "K");
+ _tmpfilename = fn;
osf = Inkscape::IO::fopen_utf8name(fn, "w+");
if (!osf) {
fprintf(stderr, "inkscape: fopen(%s): %s\n",
@@ -582,12 +659,23 @@
{
while((c = fgetc(_stream))!=EOF) fputc(c, _begin_stream);
}
- fclose(_begin_stream);
+ fclose(_stream);
+ _stream = _begin_stream;
}
+#ifdef HAVE_GTK_UNIX_PRINT
+ /* redirect output to new print dialog */
+ fseek(_stream, 0, SEEK_SET);
+ Glib::ustring output = _tmpfilename;
+ unix_print_dialog(output.c_str(),"job name");
+ unlink(output.c_str());
+ /* end redirected new print dialog */
+#endif
+
/* fixme: should really use pclose for popen'd streams */
fclose(_stream);
- _stream = 0;
+ _stream = NULL;
+
_latin1_encoded_fonts.clear();
g_tree_destroy(_fonts);
Index: src/extension/internal/ps.h
===================================================================
--- src/extension/internal/ps.h (revision 14039)
+++ src/extension/internal/ps.h (revision 14040)
@@ -36,6 +36,7 @@
float _height;
FILE * _begin_stream;//stream to print prolog and document setup of EPS, if font embedding
FILE * _stream;//(main) stream to print the (E)PS output, or only the script part following prolog/document setup, if font embedding
+ Glib::ustring _tmpfilename;
unsigned short _dpi;
bool _bitmap;
Index: src/Makefile.am
===================================================================
--- src/Makefile.am (revision 14039)
+++ src/Makefile.am (revision 14040)
@@ -20,6 +20,7 @@
$(GNOME_VFS_CFLAGS) \
$(INKBOARD_CFLAGS) \
$(XFT_CFLAGS) \
+ $(GTK_UNIX_PRINT_CFLAGS) \
-DPOTRACE=\"potrace\" \
$(INKSCAPE_CFLAGS) \
-I$(top_srcdir)/cxxtest
Index: configure.ac
===================================================================
--- configure.ac (revision 14039)
+++ configure.ac (revision 14040)
@@ -525,6 +525,11 @@
AC_DEFINE(HAVE_CAIRO_PDF, 1, [Whether the Cairo PDF backend is available])
fi
+PKG_CHECK_MODULES(GTK_UNIX_PRINT, gtk+-unix-print-2.0, gtk_unix_print=yes, gtk_unix_print=no)
+if test "x$gtk_unix_print" = "xyes"; then
+ AC_DEFINE(HAVE_GTK_UNIX_PRINT, 1, [Whether the GTK Unix printing backend is available])
+fi
+
dnl Shouldn't we test for libpng and libz?
INKSCAPE_LIBS="$INKSCAPE_LIBS -lpng -lz"

View File

@ -0,0 +1,42 @@
Patch to fix #441017: LaTeX rendering nonfunctional in Inkscape 0.46.
First hunk is from Stéphane Bonnet, thanks!
http://launchpadlibrarian.net/12978623/eqtexsvg.py.patch
Second hunk is from here, unlike Ubuntu we support -quiet though
https://bugs.launchpad.net/inkscape/+bug/195052/comments/1
--- inkscape-0.46/share/extensions/eqtexsvg.py.orig 2008-04-05 22:12:35.000000000 +0200
+++ inkscape-0.46/share/extensions/eqtexsvg.py 2008-04-05 22:14:04.000000000 +0200
@@ -49,16 +49,18 @@ def svg_open(self,filename):
doc_sizeW = max(doc_width,doc_height)
def clone_and_rewrite(self, node_in):
- if node_in.tag != 'svg':
- node_out = inkex.etree.Element(inkex.addNS(node_in.tag,'svg'))
+ in_tag = node_in.tag.rsplit('}',1)[-1]
+ if in_tag != 'svg':
+ node_out = inkex.etree.Element(inkex.addNS(in_tag,'svg'))
for name in node_in.attrib:
node_out.set(name, node_in.attrib[name])
else:
node_out = inkex.etree.Element(inkex.addNS('g','svg'))
for c in node_in.iterchildren():
- if c.tag in ('g', 'path', 'polyline', 'polygon'):
+ c_tag = c.tag.rsplit('}',1)[-1]
+ if c_tag in ('g', 'path', 'polyline', 'polygon'):
child = clone_and_rewrite(self, c)
- if c.tag == 'g':
+ if c_tag == 'g':
child.set('transform','matrix('+str(doc_sizeH/700.)+',0,0,'+str(-doc_sizeH/700.)+','+str(-doc_sizeH*0.25)+','+str(doc_sizeW*0.75)+')')
node_out.append(child)
@@ -110,7 +112,7 @@ class EQTEXSVG(inkex.Effect):
os.system('dvips -q -f -E -D 600 -y 5000 -o ' + ps_file + ' ' + dvi_file)
#os.system('cd ' + base_dir)
- os.system('pstoedit -f plot-svg -dt -ssp ' + ps_file + ' ' + svg_file + '> ' + out_file)
+ os.system('pstoedit -quiet -f plot-svg -dt -ssp ' + ps_file + ' ' + svg_file + '> ' + out_file)
svg_open(self, svg_file)
clean()

View File

@ -0,0 +1,23 @@
Default to small icons and Sans font.
diff -urp inkscape-0.45+0.46pre2.orig/src/preferences-skeleton.h inkscape-0.45+0.46pre2/src/preferences-skeleton.h
--- inkscape-0.45+0.46pre2.orig/src/preferences-skeleton.h 2008-02-17 05:24:14.000000000 +0100
+++ inkscape-0.45+0.46pre2/src/preferences-skeleton.h 2008-02-22 09:34:12.000000000 +0100
@@ -73,7 +73,7 @@ static char const preferences_skeleton[]
" tracebackground=\"0\" usepressure=\"1\" usetilt=\"0\" keep_selected=\"1\"/>\n"
" <eventcontext id=\"text\" usecurrent=\"0\" gradientdrag=\"1\"\n"
" font_sample=\"AaBbCcIiPpQq12369$\342\202\254\302\242?.;/()\"\n"
-" style=\"fill:black;fill-opacity:1;stroke:none;font-family:Bitstream Vera Sans;font-style:normal;font-weight:normal;font-size:40px;\" selcue=\"1\"/>\n"
+" style=\"fill:black;fill-opacity:1;stroke:none;font-family:Sans;font-style:normal;font-weight:normal;font-size:40px;-inkscape-font-specification:Sans;font-stretch:normal;font-variant:normal\" selcue=\"1\"/>\n"
" <eventcontext id=\"nodes\" selcue=\"1\" gradientdrag=\"1\" show_handles=\"1\" sculpting_profile=\"1\" />\n"
" <eventcontext id=\"tweak\" selcue=\"0\" gradientdrag=\"0\" show_handles=\"0\" width=\"0.2\" force=\"0.2\" fidelity=\"0.5\" usepressure=\"1\" style=\"fill:red;stroke:none;\" usecurrent=\"0\"/>\n"
" <eventcontext id=\"gradient\" selcue=\"1\"/>\n"
@@ -308,7 +308,7 @@ static char const preferences_skeleton[]
" <group\n"
" id=\"tools\"\n"
" icononly=\"1\"\n"
-" small=\"0\" />\n"
+" small=\"1\" />\n"
" </group>\n"
"\n"
" <group\n"

View File

@ -0,0 +1,12 @@
--- inkscape-16571/src/Makefile.in.orig 2007-11-29 13:38:13.000000000 +0100
+++ inkscape-16571/src/Makefile.in 2007-11-29 13:38:29.000000000 +0100
@@ -317,7 +317,8 @@
$(POPPLER_GLIB_CFLAGS) \
-DPOTRACE=\"potrace\" \
$(INKSCAPE_CFLAGS) \
- -I$(top_srcdir)/cxxtest
+ -I$(top_srcdir)/cxxtest \
+ -I$(top_srcdir)/src/extension/script
@PLATFORM_WIN32_TRUE@win32_sources = winmain.cpp registrytool.cpp registrytool.h

View File

@ -1,17 +1,17 @@
Name: inkscape
Version: 0.45.1
Version: 0.46
Release: 2%{?dist}
Summary: Vector-based drawing program using SVG
Group: Applications/Productivity
License: GPLv2+
URL: http://inkscape.sourceforge.net/
Source0: http://download.sourceforge.net/inkscape/inkscape-%{version}.tar.gz
Patch0: inkscape-0.44.1-psinput.patch
Patch1: inkscape-0.45-python.patch
Patch2: inkscape-0.45.1-gtkprint.patch
Patch3: inkscape-0.45.1-desktop.patch
Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
Patch0: inkscape-16571-cxxinclude.patch
Patch1: inkscape-0.45.1-desktop.patch
Patch2: inkscape-0.46pre2-icons.patch
Patch3: inkscape-0.46-fixlatex.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: atk-devel
@ -19,33 +19,34 @@ BuildRequires: desktop-file-utils
BuildRequires: freetype-devel
BuildRequires: gc-devel >= 6.4
BuildRequires: gettext
BuildRequires: gtkmm24-devel
BuildRequires: gtkmm24-devel >= 2.8.0
BuildRequires: gtkspell-devel
BuildRequires: gnome-vfs2-devel >= 2.0
BuildRequires: libpng-devel >= 1.2
BuildRequires: libsigc++20-devel >= 2.0.12
BuildRequires: libxml2-devel >= 2.6.11
BuildRequires: libxslt-devel >= 1.0.15
BuildRequires: pango-devel
BuildRequires: pkgconfig
BuildRequires: lcms-devel >= 1.13
BuildRequires: cairo-devel
BuildRequires: openssl-devel
BuildRequires: dos2unix
BuildRequires: perl-XML-Parser
BuildRequires: python-devel
BuildRequires: popt
# The following are needed due to gtkprint patch changing configure.ac
BuildRequires: autoconf automake17 intltool
BuildRequires: poppler-devel >= 0.5.9
BuildRequires: popt-devel
BuildRequires: loudmouth-devel >= 1.0
BuildRequires: boost-devel
Requires: pstoedit
Requires: perl(Image::Magick)
Requires: numpy
Requires: PyXML
Requires: python-lxml
Requires(post): desktop-file-utils
Requires(postun): desktop-file-utils
%description
Inkscape is a vector-based drawing program, like CorelDraw® or Adobe
Illustrator® from the proprietary software world, and Sketch or Karbon14 from
@ -62,19 +63,16 @@ C and C++, using the Gtk+ toolkit and optionally some Gnome libraries.
%prep
%setup -q
%patch0 -p1 -b .psinput
%patch1 -p1 -b .python
%patch2 -p0 -b .gtkprint
%patch3 -p1 -b .desktop
%patch0 -p1 -b .cxxinclude
%patch1 -p1 -b .desktop
%patch2 -p1 -b .icons
%patch3 -p1 -b .fixlatex
find -type f -regex '.*\.\(cpp\|h\)' -perm +111 -exec chmod -x {} ';'
find share/extensions/ -type f -regex '.*\.py' -perm +111 -exec chmod -x {} ';'
dos2unix share/extensions/*.py
dos2unix -k -q share/extensions/*.py
%build
intltoolize --force
autoconf
autoheader
%configure \
--disable-dependency-tracking \
--with-xinerama \
@ -84,14 +82,15 @@ autoheader
--with-gnome-vfs \
--with-inkjar \
--enable-inkboard \
--enable-lcms
--enable-lcms \
--enable-poppler-cairo
make %{?_smp_mflags}
%install
rm -rf ${RPM_BUILD_ROOT}
make install DESTDIR=${RPM_BUILD_ROOT}
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT
%find_lang %{name}
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
@ -99,12 +98,12 @@ rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions/outline2svg.*
rm -f $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions/txt2svg.*
desktop-file-install --vendor fedora --delete-original \
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
${RPM_BUILD_ROOT}/usr/share/applications/%{name}.desktop
--dir $RPM_BUILD_ROOT%{_datadir}/applications \
$RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
%clean
rm -rf ${RPM_BUILD_ROOT}
rm -rf $RPM_BUILD_ROOT
%post
@ -127,10 +126,64 @@ update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
%changelog
* Wed Dec 12 2007 <denis@localhost.localdomain> - 0.45.1-2
- Merging with F-8 spec
* Sat Apr 05 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-2
- Fix LaTeX rendering, #441017
* Tue Mar 20 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-1
* Tue Mar 25 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-1
- 0.46 released
* Sun Mar 23 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.3.pre3
- Rebuild for newer Poppler
* Wed Mar 12 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.2.pre3
- Probably last prerelease?
* Fri Feb 22 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.2.pre2
- Panel icon sizes
* Sun Feb 17 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.46-0.1.pre2
- 0.46pre2
- Dropping upstreamed patches
* Sat Feb 16 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-5
- Attempt to fix the font selector (#432892)
* Thu Feb 14 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-4
- Tolerate recoverable errors in OCAL feeds
- Fix OCAL insecure temporary file usage (#432807)
* Wed Feb 13 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-3
- Fix crash when adding text objects (#432220)
* Thu Feb 07 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-2
- Build with gcc-4.3
* Wed Feb 06 2008 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1+0.46pre1-1
- 0.46 prerelease
- Minor cosmetic changes to satisfy the QA script
- Dependency on Boost
- Inkboard is not optional
- Merge from Denis Leroy's svn16571 snapshot:
- Require specific gtkmm24-devel versions
- enable-poppler-cairo
- No longer BuildRequire libsigc++20-devel
* Wed Dec 5 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-5
- Rebuild with new openssl
* Sun Dec 02 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1-4
- Added missing dependencies for modules (#301881)
* Sun Dec 02 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1-3
- Satisfy desktop-file-validate, so that Rawhide build won't break
* Sat Dec 01 2007 Lubomir Kundrak <lkundrak@redhat.com> - 0.45.1-2
- Use GTK print dialog
- Added compressed SVG association (#245413)
- popt headers went into popt-devel, post Fedora 7
- Fix macro usage in changelog
* Wed Mar 21 2007 Denis Leroy <denis@poolshark.org> - 0.45.1-1
- Update to bugfix release 0.45.1
- Added R to ImageMagick-perl (#231563)
@ -141,7 +194,7 @@ update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
- LaTex patch integrated upstreamed, removed
- Some rpmlint cleanups
* Fri Dec 1 2006 Denis Leroy <denis@poolshark.org> - 0.44.1-2
* Wed Dec 6 2006 Denis Leroy <denis@poolshark.org> - 0.44.1-2
- Added patches to fix LaTex import (#217699)
- Added patch to base postscript import on pstoedit plot-svg
@ -255,9 +308,9 @@ update-desktop-database %{_datadir}/applications > /dev/null 2>&1 || :
* Tue Mar 16 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.6
- fix typo in provides
* Tue Mar 16 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.5
- add %{release} to provides perl(SpSVG) = %{epoch}:%{version}:%{release} only
- add %%{release} to provides perl(SpSVG) = %%{epoch}:%%{version}:%%{release} only
* Tue Mar 16 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.4
- add %{release} to provides
- add %%{release} to provides
* Sun Mar 14 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.3
- add arch dependent flags
* Thu Mar 11 2004 P Linnell <scribusdocs at atlantictechsolutions.com> 0:0.37.0.fdr.2

View File

@ -1 +1 @@
1ac63dfd5d78a676599bf5cf6d22e493 inkscape-0.45.1.tar.gz
59997096c3640b2601c2b4afba8a3d75 inkscape-0.46.tar.bz2