Rebuild for poppler 24.08.0
This commit is contained in:
parent
178115ad62
commit
6880239ec9
73
inkscape-1.3.2-c++20.patch
Normal file
73
inkscape-1.3.2-c++20.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From 1798e9c13b786f3d077ba0132592c4d5c1d1fb9b Mon Sep 17 00:00:00 2001
|
||||
From: Tavmjong Bah <tavmjong@free.fr>
|
||||
Date: Tue, 26 Sep 2023 19:23:27 +0000
|
||||
Subject: Up C++ version to C++20.
|
||||
|
||||
|
||||
--- inkscape-1.3.2_2023-11-25_091e20ef0f/CMakeLists.txt
|
||||
+++ inkscape-1.3.2_2023-11-25_091e20ef0f/CMakeLists.txt
|
||||
@@ -18,9 +18,9 @@ message("Binary Dir: ${CMAKE_CURRENT_BIN
|
||||
# -----------------------------------------------------------------------------
|
||||
# CMake Configuration
|
||||
# -----------------------------------------------------------------------------
|
||||
-set(CMAKE_CXX_STANDARD 17)
|
||||
+set(CMAKE_CXX_STANDARD 20)
|
||||
set(CMAKE_CXX_STANDARD_REQUIRED ON)
|
||||
-# set(CMAKE_CXX_EXTENSIONS OFF) # enforces -std=c++17 instead of -std=gnu++17
|
||||
+# set(CMAKE_CXX_EXTENSIONS OFF) # enforces -std=c++20 instead of -std=gnu++20
|
||||
# TODO: build currently fails with it as we actually depend on GNU compiler extensions...
|
||||
|
||||
list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/CMakeScripts/Modules")
|
||||
--- inkscape-1.3.2_2023-11-25_091e20ef0f/_clang-format
|
||||
+++ inkscape-1.3.2_2023-11-25_091e20ef0f/_clang-format
|
||||
@@ -103,7 +103,7 @@ SpacesInContainerLiterals: false
|
||||
SpacesInCStyleCastParentheses: false
|
||||
SpacesInParentheses: false
|
||||
SpacesInSquareBrackets: false
|
||||
-Standard: c++17
|
||||
+Standard: c++20
|
||||
StatementMacros: []
|
||||
TypenameMacros: []
|
||||
TabWidth: 4
|
||||
--- inkscape-1.3.2_2023-11-25_091e20ef0f/src/ui/knot/knot-holder-entity.cpp
|
||||
+++ inkscape-1.3.2_2023-11-25_091e20ef0f/src/ui/knot/knot-holder-entity.cpp
|
||||
@@ -329,7 +329,7 @@ PatternKnotHolderEntityScale::knot_set(G
|
||||
double scale_x = std::clamp(new_extent[X] / _cached_diagonal[X], _cached_min_scale, 1e9);
|
||||
double scale_y = std::clamp(new_extent[Y] / _cached_diagonal[Y], _cached_min_scale, 1e9);
|
||||
|
||||
- Affine new_transform = (state & GDK_CONTROL_MASK) ? Scale(lerp(0.5, scale_x, scale_y))
|
||||
+ Affine new_transform = (state & GDK_CONTROL_MASK) ? Scale((scale_x + scale_y) * 0.5)
|
||||
: Scale(scale_x, scale_y);
|
||||
|
||||
// 2. Calculate offset to keep pattern origin aligned
|
||||
--- inkscape-1.3.2_2023-11-25_091e20ef0f/src/ui/tools/pencil-tool.cpp
|
||||
+++ inkscape-1.3.2_2023-11-25_091e20ef0f/src/ui/tools/pencil-tool.cpp
|
||||
@@ -17,7 +17,10 @@
|
||||
* Released under GNU GPL v2+, read the file 'COPYING' for more information.
|
||||
*/
|
||||
|
||||
-#include <numeric> // For std::accumulate
|
||||
+#include "pencil-tool.h"
|
||||
+
|
||||
+#include <cmath> // std::lerp
|
||||
+#include <numeric> // std::accumulate
|
||||
#include <gdk/gdkkeysyms.h>
|
||||
#include <glibmm/i18n.h>
|
||||
|
||||
@@ -26,7 +29,6 @@
|
||||
#include <2geom/sbasis-to-bezier.h>
|
||||
#include <2geom/svg-path-parser.h>
|
||||
|
||||
-#include "pencil-tool.h"
|
||||
|
||||
#include "context-fns.h"
|
||||
#include "desktop.h"
|
||||
@@ -814,7 +816,7 @@ void PencilTool::_addFreehandPoint(Geom:
|
||||
min = max;
|
||||
}
|
||||
double dezoomify_factor = 0.05 * 1000 / _desktop->current_zoom();
|
||||
- double const pressure_shrunk = pressure * (max - min) + min; // C++20 -> use std::lerp()
|
||||
+ double const pressure_shrunk = std::lerp(min, max, pressure);
|
||||
double pressure_computed = std::abs(pressure_shrunk * dezoomify_factor);
|
||||
double pressure_computed_scaled = std::abs(pressure_computed * _desktop->getDocument()->getDocumentScale().inverse()[Geom::X]);
|
||||
if (p != this->p[this->_npoints - 1]) {
|
69
inkscape-1.3.2-gettype-enum.patch
Normal file
69
inkscape-1.3.2-gettype-enum.patch
Normal file
@ -0,0 +1,69 @@
|
||||
From f7e944575ea5247952d23f85dfa905cfa13f7b28 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Sturmlechner <asturm@gentoo.org>
|
||||
Date: Mon, 4 Mar 2024 22:59:40 +0100
|
||||
Subject: Fix build with >=poppler-24.03.0
|
||||
|
||||
Fixes build errors caused by:
|
||||
|
||||
"Use an enum for Function getType"
|
||||
Upstream commit 6e3824d45d42cb806a28a2df84e4ab6bb3587083
|
||||
|
||||
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
|
||||
|
||||
Fixes https://gitlab.com/inkscape/inkscape/-/issues/4787
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/poppler-transition-api.h b/src/extension/internal/pdfinput/poppler-transition-api.h
|
||||
index 66b15d705a..58aa1ec921 100644
|
||||
--- a/src/extension/internal/pdfinput/poppler-transition-api.h
|
||||
+++ b/src/extension/internal/pdfinput/poppler-transition-api.h
|
||||
@@ -14,6 +14,16 @@
|
||||
|
||||
#include <glib/poppler-features.h>
|
||||
|
||||
+#if POPPLER_CHECK_VERSION(24, 3, 0)
|
||||
+#define _POPPLER_FUNCTION_TYPE_SAMPLED Function::Type::Sampled
|
||||
+#define _POPPLER_FUNCTION_TYPE_EXPONENTIAL Function::Type::Exponential
|
||||
+#define _POPPLER_FUNCTION_TYPE_STITCHING Function::Type::Stitching
|
||||
+#else
|
||||
+#define _POPPLER_FUNCTION_TYPE_SAMPLED 0
|
||||
+#define _POPPLER_FUNCTION_TYPE_EXPONENTIAL 2
|
||||
+#define _POPPLER_FUNCTION_TYPE_STITCHING 3
|
||||
+#endif
|
||||
+
|
||||
#if POPPLER_CHECK_VERSION(22, 4, 0)
|
||||
#define _POPPLER_FONTPTR_TO_GFX8(font_ptr) ((Gfx8BitFont *)font_ptr.get())
|
||||
#else
|
||||
diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
index 525fbfec0a..f0a9c1ac69 100644
|
||||
--- a/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
+++ b/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
@@ -1175,9 +1175,9 @@ static bool svgGetShadingColor(GfxShading *shading, double offset, GfxColor *res
|
||||
#define INT_EPSILON 8
|
||||
bool SvgBuilder::_addGradientStops(Inkscape::XML::Node *gradient, GfxShading *shading,
|
||||
_POPPLER_CONST Function *func) {
|
||||
- int type = func->getType();
|
||||
+ auto type = func->getType();
|
||||
auto space = shading->getColorSpace();
|
||||
- if ( type == 0 || type == 2 ) { // Sampled or exponential function
|
||||
+ if (type == _POPPLER_FUNCTION_TYPE_SAMPLED || type == _POPPLER_FUNCTION_TYPE_EXPONENTIAL) {
|
||||
GfxColor stop1, stop2;
|
||||
if (!svgGetShadingColor(shading, 0.0, &stop1) || !svgGetShadingColor(shading, 1.0, &stop2)) {
|
||||
return false;
|
||||
@@ -1185,7 +1185,7 @@ bool SvgBuilder::_addGradientStops(Inkscape::XML::Node *gradient, GfxShading *sh
|
||||
_addStopToGradient(gradient, 0.0, &stop1, space, 1.0);
|
||||
_addStopToGradient(gradient, 1.0, &stop2, space, 1.0);
|
||||
}
|
||||
- } else if ( type == 3 ) { // Stitching
|
||||
+ } else if (type == _POPPLER_FUNCTION_TYPE_STITCHING) {
|
||||
auto stitchingFunc = static_cast<_POPPLER_CONST StitchingFunction*>(func);
|
||||
const double *bounds = stitchingFunc->getBounds();
|
||||
const double *encode = stitchingFunc->getEncode();
|
||||
@@ -1200,7 +1200,7 @@ bool SvgBuilder::_addGradientStops(Inkscape::XML::Node *gradient, GfxShading *sh
|
||||
for ( int i = 0 ; i < num_funcs ; i++ ) {
|
||||
svgGetShadingColor(shading, bounds[i + 1], &color);
|
||||
// Add stops
|
||||
- if (stitchingFunc->getFunc(i)->getType() == 2) { // process exponential fxn
|
||||
+ if (stitchingFunc->getFunc(i)->getType() == _POPPLER_FUNCTION_TYPE_EXPONENTIAL) {
|
||||
double expE = (static_cast<_POPPLER_CONST ExponentialFunction*>(stitchingFunc->getFunc(i)))->getE();
|
||||
if (expE > 1.0) {
|
||||
expE = (bounds[i + 1] - bounds[i])/expE; // approximate exponential as a single straight line at x=1
|
57
inkscape-1.3.2-unicode-marker.patch
Normal file
57
inkscape-1.3.2-unicode-marker.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From 96ca7a6c215aa14336b52753f56244dc8796ec43 Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Becker <mail@heiko-becker.de>
|
||||
Date: Fri, 3 May 2024 14:52:00 +0200
|
||||
Subject: Fix build with poppler >= 24.05.0
|
||||
|
||||
GooString::hasUnicodeMarkerLE and GooString::hasUnicodeMarker were
|
||||
rename and moved to UTF.h [1][2]
|
||||
|
||||
[1] https://gitlab.freedesktop.org/poppler/poppler/-/commit/98fabb298b0e8eaef9193bbce68c99c85473a314
|
||||
[2] https://gitlab.freedesktop.org/poppler/poppler/-/commit/1f06dca08c32ed18c3030530d98a0e30d41dd7a2
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/poppler-transition-api.h b/src/extension/internal/pdfinput/poppler-transition-api.h
|
||||
index 58aa1ec921..481aefadf4 100644
|
||||
--- a/src/extension/internal/pdfinput/poppler-transition-api.h
|
||||
+++ b/src/extension/internal/pdfinput/poppler-transition-api.h
|
||||
@@ -13,6 +13,15 @@
|
||||
#define SEEN_POPPLER_TRANSITION_API_H
|
||||
|
||||
#include <glib/poppler-features.h>
|
||||
+#include <poppler/UTF.h>
|
||||
+
|
||||
+#if POPPLER_CHECK_VERSION(24, 5, 0)
|
||||
+#define _POPPLER_HAS_UNICODE_BOM(value) (hasUnicodeByteOrderMark(value->toStr()))
|
||||
+#define _POPPLER_HAS_UNICODE_BOMLE(value) (hasUnicodeByteOrderMarkLE(value->toStr()))
|
||||
+#else
|
||||
+#define _POPPLER_HAS_UNICODE_BOM(value) (value->hasUnicodeMarker())
|
||||
+#define _POPPLER_HAS_UNICODE_BOMLE(value) (value->hasUnicodeMarkerLE())
|
||||
+#endif
|
||||
|
||||
#if POPPLER_CHECK_VERSION(24, 3, 0)
|
||||
#define _POPPLER_FUNCTION_TYPE_SAMPLED Function::Type::Sampled
|
||||
diff --git a/src/extension/internal/pdfinput/poppler-utils.cpp b/src/extension/internal/pdfinput/poppler-utils.cpp
|
||||
index 78d90c66c9..c02815f64b 100644
|
||||
--- a/src/extension/internal/pdfinput/poppler-utils.cpp
|
||||
+++ b/src/extension/internal/pdfinput/poppler-utils.cpp
|
||||
@@ -12,6 +12,8 @@
|
||||
|
||||
#include "poppler-utils.h"
|
||||
|
||||
+#include <poppler/UTF.h>
|
||||
+
|
||||
#include "2geom/affine.h"
|
||||
#include "GfxFont.h"
|
||||
#include "GfxState.h"
|
||||
@@ -563,10 +565,10 @@ std::string getDictString(Dict *dict, const char *key)
|
||||
*/
|
||||
std::string getString(const GooString *value)
|
||||
{
|
||||
- if (value->hasUnicodeMarker()) {
|
||||
+ if (_POPPLER_HAS_UNICODE_BOM(value)) {
|
||||
return g_convert(value->getCString () + 2, value->getLength () - 2,
|
||||
"UTF-8", "UTF-16BE", NULL, NULL, NULL);
|
||||
- } else if (value->hasUnicodeMarkerLE()) {
|
||||
+ } else if (_POPPLER_HAS_UNICODE_BOMLE(value)) {
|
||||
return g_convert(value->getCString () + 2, value->getLength () - 2,
|
||||
"UTF-8", "UTF-16LE", NULL, NULL, NULL);
|
||||
}
|
@ -43,6 +43,10 @@ Source10: https://inkscape.org/~MarcJeanmougin/gpg/#/MarcJeanmougin.gpg
|
||||
Source100: Fedora-Color-Palette.gpl
|
||||
|
||||
Patch0: 0001-add-xmlmemory-include.patch
|
||||
Patch1: inkscape-1.3.2-c++20.patch
|
||||
Patch2: inkscape-1.3.2-gettype-enum.patch
|
||||
Patch3: inkscape-1.3.2-unicode-marker.patch
|
||||
|
||||
|
||||
# Don't drop i686 until at least texlive no longer needs it -GC, 2023-08-10
|
||||
#%%if 0%%{?fedora} >= 39
|
||||
|
Loading…
x
Reference in New Issue
Block a user