0.48.5.
This commit is contained in:
parent
c2511d3990
commit
636c517184
1
.gitignore
vendored
1
.gitignore
vendored
@ -4,3 +4,4 @@ inkscape.tar.bz2
|
||||
/inkscape-0.48.2.tar.bz2
|
||||
/inkscape-0.48.3.1.tar.bz2
|
||||
/inkscape-0.48.4.tar.bz2
|
||||
/inkscape-0.48.5.tar.bz2
|
||||
|
@ -10,59 +10,3 @@ diff -rupN inkscape-0.48.4/configure.ac inkscape-0.48.4-new/configure.ac
|
||||
int main(void){
|
||||
unsigned min = ((6 << 16) | (4 << 8) | 0);
|
||||
printf("%d.%d.%d ",GC_version >> 16, (GC_version >> 8) & 0xFF, GC_version & 0xFF);
|
||||
diff -rupN inkscape-0.48.4/src/gc-core.h inkscape-0.48.4-new/src/gc-core.h
|
||||
--- inkscape-0.48.4/src/gc-core.h 2012-02-14 04:22:17.670697000 +0100
|
||||
+++ inkscape-0.48.4-new/src/gc-core.h 2014-05-15 00:28:40.838404308 +0200
|
||||
@@ -57,7 +57,7 @@ struct Ops {
|
||||
CleanupFunc *old_func,
|
||||
void **old_data);
|
||||
int (*general_register_disappearing_link)(void **p_ptr,
|
||||
- void *base);
|
||||
+ const void *base);
|
||||
int (*unregister_disappearing_link)(void **p_ptr);
|
||||
std::size_t (*get_heap_size)();
|
||||
std::size_t (*get_free_bytes)();
|
||||
diff -rupN inkscape-0.48.4/src/gc.cpp inkscape-0.48.4-new/src/gc.cpp
|
||||
--- inkscape-0.48.4/src/gc.cpp 2012-02-14 04:22:17.670697000 +0100
|
||||
+++ inkscape-0.48.4-new/src/gc.cpp 2014-05-15 00:28:40.839404331 +0200
|
||||
@@ -70,8 +70,8 @@ void *debug_base(void *ptr) {
|
||||
return base + debug_base_fixup();
|
||||
}
|
||||
|
||||
-int debug_general_register_disappearing_link(void **p_ptr, void *base) {
|
||||
- char *real_base=reinterpret_cast<char *>(base) - debug_base_fixup();
|
||||
+int debug_general_register_disappearing_link(void **p_ptr, const void *base) {
|
||||
+ char *real_base=const_cast<char *>(reinterpret_cast<const char *>(base)) - debug_base_fixup();
|
||||
return GC_general_register_disappearing_link(p_ptr, real_base);
|
||||
}
|
||||
|
||||
@@ -90,7 +90,7 @@ void dummy_register_finalizer(void *, Cl
|
||||
}
|
||||
}
|
||||
|
||||
-int dummy_general_register_disappearing_link(void **, void *) { return false; }
|
||||
+int dummy_general_register_disappearing_link(void **, const void *) { return false; }
|
||||
|
||||
int dummy_unregister_disappearing_link(void **/*link*/) { return false; }
|
||||
|
||||
@@ -112,7 +112,11 @@ Ops enabled_ops = {
|
||||
&GC_malloc_atomic_uncollectable,
|
||||
&GC_base,
|
||||
&GC_register_finalizer_ignore_self,
|
||||
+#if (GC_MAJOR_VERSION >= 7 && GC_MINOR_VERSION >= 4)
|
||||
&GC_general_register_disappearing_link,
|
||||
+#else
|
||||
+ (int (*)(void**, const void*))(&GC_general_register_disappearing_link),
|
||||
+#endif
|
||||
&GC_unregister_disappearing_link,
|
||||
&GC_get_heap_size,
|
||||
&GC_get_free_bytes,
|
||||
@@ -202,7 +206,7 @@ void stub_register_finalizer_ignore_self
|
||||
die_because_not_initialized();
|
||||
}
|
||||
|
||||
-int stub_general_register_disappearing_link(void **, void *) {
|
||||
+int stub_general_register_disappearing_link(void **, const void *) {
|
||||
die_because_not_initialized();
|
||||
return 0;
|
||||
}
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: inkscape
|
||||
Version: 0.48.4
|
||||
Release: 18%{?dist}
|
||||
Version: 0.48.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Vector-based drawing program using SVG
|
||||
|
||||
Group: Applications/Productivity
|
||||
@ -14,10 +14,10 @@ Patch0: inkscape-0.48.2-types.patch
|
||||
#Patch7: inkscape-0.48.2-gcc47.patch
|
||||
#Patch8: inkscape-0.48.2-poppler_020.patch
|
||||
#Patch9: inkscape-0.48.3.1-hugexml.patch
|
||||
Patch10: inkscape-0.48.4-spuriouscomma.h
|
||||
Patch11: inkscape-0.48.4-freetype.patch
|
||||
#Patch10: inkscape-0.48.4-spuriouscomma.h
|
||||
#Patch11: inkscape-0.48.4-freetype.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1097945
|
||||
Patch12: inkscape-0.48.4-poppler-0.26.patch
|
||||
#Patch12: inkscape-0.48.4-poppler-0.26.patch
|
||||
Patch13: inkscape-0.48.4-gc-7.4.patch
|
||||
Patch14: 0001-update-to-new-libwpg.patch
|
||||
|
||||
@ -136,9 +136,9 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
|
||||
#%patch7 -p0 -b .gcc47
|
||||
#%patch8 -p1 -b .poppler_020
|
||||
#%patch9 -p0 -b .hugexml
|
||||
%patch10 -p0 -b .spuriouscomma
|
||||
%patch11 -p0 -b .freetype
|
||||
%patch12 -p1 -b .poppler
|
||||
#%patch10 -p0 -b .spuriouscomma
|
||||
#%patch11 -p0 -b .freetype
|
||||
#%patch12 -p1 -b .poppler
|
||||
%patch13 -p1 -b .gc
|
||||
%patch14 -p1 -b .libwpg
|
||||
|
||||
@ -244,6 +244,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jul 21 2014 Jon Ciesla <limburgher@gmail.com> - 0.48.5-1
|
||||
- Latest bugfix release.
|
||||
- Spurious comma patch upstreamed.
|
||||
- Dropped Freetype, poppler, gc patches.
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.48.4-18
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user