Shuffle forgotten files around
This commit is contained in:
parent
9bea88ae1c
commit
2c212ac605
13
inkscape-0.46-cxxinclude.patch
Normal file
13
inkscape-0.46-cxxinclude.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up inkscape-0.46/src/Makefile.in.cxxinclude inkscape-0.46/src/Makefile.in
|
||||
--- inkscape-0.46/src/Makefile.in.cxxinclude 2008-03-11 05:47:10.000000000 +0100
|
||||
+++ inkscape-0.46/src/Makefile.in 2008-08-13 23:26:52.000000000 +0200
|
||||
@@ -1487,7 +1487,8 @@ INCLUDES = \
|
||||
$(POPPLER_GLIB_CFLAGS) \
|
||||
-DPOTRACE=\"potrace\" \
|
||||
$(INKSCAPE_CFLAGS) \
|
||||
- -I$(top_srcdir)/cxxtest
|
||||
+ -I$(top_srcdir)/cxxtest \
|
||||
+ -I$(top_srcdir)/src/extension/script
|
||||
|
||||
@PLATFORM_WIN32_TRUE@win32_sources = winmain.cpp registrytool.cpp registrytool.h
|
||||
@PLATFORM_WIN32_TRUE@win32ldflags = -lcomdlg32
|
54
inkscape-0.46-uniconv.patch
Normal file
54
inkscape-0.46-uniconv.patch
Normal file
@ -0,0 +1,54 @@
|
||||
See https://bugs.launchpad.net/inkscape/+bug/226383
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=458845
|
||||
|
||||
Lubomir Rintel <lkundrak@v3.sk>
|
||||
|
||||
diff -up inkscape-0.46/inkscape.desktop.in.uniconv inkscape-0.46/inkscape.desktop.in
|
||||
diff -up inkscape-0.46/inkscape.desktop.in.uniconv inkscape-0.46/inkscape.desktop.in
|
||||
--- inkscape-0.46/inkscape.desktop.in.uniconv 2008-08-13 23:31:17.000000000 +0200
|
||||
+++ inkscape-0.46/inkscape.desktop.in 2008-08-13 23:32:35.000000000 +0200
|
||||
@@ -7,7 +7,7 @@ Version=1.0
|
||||
Type=Application
|
||||
Categories=Graphics;VectorGraphics;GTK;
|
||||
|
||||
-MimeType=image/svg+xml;image/svg+xml-compressed;
|
||||
+MimeType=image/svg+xml;image/svg+xml-compressed;application/vnd.corel-draw;image/x-wmf;
|
||||
|
||||
Exec=inkscape %F
|
||||
TryExec=inkscape
|
||||
diff -up inkscape-0.46/share/extensions/cdr2svg.sh.uniconv inkscape-0.46/share/extensions/cdr2svg.sh
|
||||
--- inkscape-0.46/share/extensions/cdr2svg.sh.uniconv 2008-03-11 05:21:10.000000000 +0100
|
||||
+++ inkscape-0.46/share/extensions/cdr2svg.sh 2008-08-13 23:31:17.000000000 +0200
|
||||
@@ -4,7 +4,7 @@ TMPDIR="${TMPDIR-/tmp}"
|
||||
TEMPFILENAME=`mktemp 2>/dev/null || echo "$TMPDIR/$$"`
|
||||
TEMPFILENAME=${TEMPFILENAME}.svg
|
||||
|
||||
-uniconv "$1" "${TEMPFILENAME}" > /dev/null 2>&1 || rc=1
|
||||
+unviconvertor "$1" "${TEMPFILENAME}" > /dev/null 2>&1 || rc=1
|
||||
|
||||
cat < "${TEMPFILENAME}" || rc=1
|
||||
rm -f "${TEMPFILENAME}"
|
||||
diff -up inkscape-0.46/share/extensions/cdr_input.inx.uniconv inkscape-0.46/share/extensions/cdr_input.inx
|
||||
--- inkscape-0.46/share/extensions/cdr_input.inx.uniconv 2008-03-11 05:21:07.000000000 +0100
|
||||
+++ inkscape-0.46/share/extensions/cdr_input.inx 2008-08-13 23:31:17.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
<inkscape-extension>
|
||||
<_name>Corel DRAW Input</_name>
|
||||
<id>org.inkscape.input.cdr</id>
|
||||
- <dependency type="executable" location="path">uniconv</dependency>
|
||||
+ <dependency type="executable" location="path">unviconvertor</dependency>
|
||||
<dependency type="executable" location="extensions">cdr2svg.sh</dependency>
|
||||
<input>
|
||||
<extension>.cdr</extension>
|
||||
diff -up inkscape-0.46/share/extensions/wmf_input.inx.uniconv inkscape-0.46/share/extensions/wmf_input.inx
|
||||
--- inkscape-0.46/share/extensions/wmf_input.inx.uniconv 2008-03-11 05:21:10.000000000 +0100
|
||||
+++ inkscape-0.46/share/extensions/wmf_input.inx 2008-08-13 23:31:17.000000000 +0200
|
||||
@@ -1,7 +1,7 @@
|
||||
<inkscape-extension>
|
||||
<_name>Windows Metafile Input</_name>
|
||||
<id>org.inkscape.input.wmf</id>
|
||||
- <dependency type="executable" location="path">uniconv</dependency>
|
||||
+ <dependency type="executable" location="path">unviconvertor</dependency>
|
||||
<dependency type="executable" location="extensions">cdr2svg.sh</dependency>
|
||||
<input>
|
||||
<extension>.wmf</extension>
|
@ -1,12 +0,0 @@
|
||||
--- inkscape-16571/src/Makefile.in.orig 2007-11-29 13:38:13.000000000 +0100
|
||||
+++ inkscape-16571/src/Makefile.in 2007-11-29 13:38:29.000000000 +0100
|
||||
@@ -317,7 +317,8 @@
|
||||
$(POPPLER_GLIB_CFLAGS) \
|
||||
-DPOTRACE=\"potrace\" \
|
||||
$(INKSCAPE_CFLAGS) \
|
||||
- -I$(top_srcdir)/cxxtest
|
||||
+ -I$(top_srcdir)/cxxtest \
|
||||
+ -I$(top_srcdir)/src/extension/script
|
||||
|
||||
|
||||
@PLATFORM_WIN32_TRUE@win32_sources = winmain.cpp registrytool.cpp registrytool.h
|
Loading…
x
Reference in New Issue
Block a user