New upstream version
This commit is contained in:
parent
a70672d661
commit
1fca4194a5
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
inkscape.tar.bz2
|
||||
/inkscape-0.48.0.tar.bz2
|
||||
/inkscape-0.48.1.tar.bz2
|
||||
/inkscape-0.48.2.tar.bz2
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,45 +0,0 @@
|
||||
--- inkscape-0.48.0/configure.ac 2010-08-04 18:45:00.000000000 +0200
|
||||
+++ inkscape-0.48.0/configure.ac 2010-11-24 14:01:43.000000000 +0100
|
||||
@@ -678,7 +678,7 @@
|
||||
dnl Check for libwpg for extension
|
||||
dnl ******************************
|
||||
|
||||
-PKG_CHECK_MODULES(LIBWPG, libwpg-0.1 libwpg-stream-0.1, with_libwpg=yes, with_libwpg=no)
|
||||
+PKG_CHECK_MODULES(LIBWPG, libwpg-0.2 libwpd-0.9 libwpd-stream-0.9, with_libwpg=yes, with_libwpg=no)
|
||||
if test "x$with_libwpg" = "xyes"; then
|
||||
AC_DEFINE(WITH_LIBWPG,1,[Build in libwpg])
|
||||
fi
|
||||
--- inkscape-0.48.0/src/extension/internal/wpg-input.cpp 2010-07-13 05:48:40.000000000 +0200
|
||||
+++ inkscape-0.48.0/src/extension/internal/wpg-input.cpp 2010-11-24 14:58:08.000000000 +0100
|
||||
@@ -49,7 +49,7 @@
|
||||
#include "document.h"
|
||||
|
||||
#include "libwpg/libwpg.h"
|
||||
-#include "libwpg/WPGStreamImplementation.h"
|
||||
+#include "libwpd-stream/libwpd-stream.h"
|
||||
|
||||
|
||||
using namespace libwpg;
|
||||
@@ -61,9 +61,9 @@
|
||||
|
||||
SPDocument *
|
||||
WpgInput::open(Inkscape::Extension::Input * mod, const gchar * uri) {
|
||||
- WPXInputStream* input = new libwpg::WPGFileStream(uri);
|
||||
+ WPXInputStream* input = new WPXFileStream(uri);
|
||||
if (input->isOLEStream()) {
|
||||
- WPXInputStream* olestream = input->getDocumentOLEStream();
|
||||
+ WPXInputStream* olestream = input->getDocumentOLEStream("PerfectOffice_MAIN");
|
||||
if (olestream) {
|
||||
delete input;
|
||||
input = olestream;
|
||||
@@ -78,7 +78,7 @@
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- libwpg::WPGString output;
|
||||
+ WPXString output;
|
||||
if (!libwpg::WPGraphics::generateSVG(input, output)) {
|
||||
delete input;
|
||||
return NULL;
|
||||
|
||||
|
@ -1,26 +0,0 @@
|
||||
From d30b1aeacddd15c3870d0933b4ff5a33320894fd Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Thu, 26 Aug 2010 08:33:05 +0200
|
||||
Subject: [PATCH] Add more supported mime/types
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=458845
|
||||
---
|
||||
inkscape.desktop.in | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/inkscape.desktop.in b/inkscape.desktop.in
|
||||
index bd2478e..f663942 100644
|
||||
--- a/inkscape.desktop.in
|
||||
+++ b/inkscape.desktop.in
|
||||
@@ -6,7 +6,7 @@ _X-GNOME-FullName=Inkscape Vector Graphics Editor
|
||||
_Comment=Create and edit Scalable Vector Graphics images
|
||||
Type=Application
|
||||
Categories=Graphics;VectorGraphics;GTK;
|
||||
-MimeType=image/svg+xml;image/svg+xml-compressed;
|
||||
+MimeType=image/svg+xml;image/svg+xml-compressed;image/cgm;image/x-wmf;application/vnd.corel-draw;application/x-xccx;application/x-xcgm;application/x-xcdt;application/x-xsk1;application/x-xcmx;image/x-xcdr;
|
||||
Exec=inkscape %F
|
||||
TryExec=inkscape
|
||||
Terminal=false
|
||||
--
|
||||
1.7.2.1
|
||||
|
2445
inkscape-0.48.2-glib.patch
Normal file
2445
inkscape-0.48.2-glib.patch
Normal file
File diff suppressed because it is too large
Load Diff
31
inkscape-0.48.2-png-write.patch
Normal file
31
inkscape-0.48.2-png-write.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From: inkscape upstream
|
||||
Fix compilation against libpng-1.5
|
||||
|
||||
=== modified file 'src/extension/internal/pdfinput/svg-builder.cpp'
|
||||
--- src/extension/internal/pdfinput/svg-builder.cpp 2011-10-27 04:55:51 +0000
|
||||
+++ src/extension/internal/pdfinput/svg-builder.cpp 2011-10-29 20:34:00 +0000
|
||||
@@ -1481,7 +1481,7 @@
|
||||
return NULL;
|
||||
}
|
||||
// Set error handler
|
||||
- if (setjmp(png_ptr->jmpbuf)) {
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
png_destroy_write_struct(&png_ptr, &info_ptr);
|
||||
return NULL;
|
||||
}
|
||||
|
||||
=== modified file 'src/helper/png-write.cpp'
|
||||
--- src/helper/png-write.cpp 2011-08-07 10:53:12 +0000
|
||||
+++ src/helper/png-write.cpp 2011-10-29 20:34:00 +0000
|
||||
@@ -166,8 +166,8 @@
|
||||
/* Set error handling. REQUIRED if you aren't supplying your own
|
||||
* error hadnling functions in the png_create_write_struct() call.
|
||||
*/
|
||||
- if (setjmp(png_ptr->jmpbuf)) {
|
||||
- /* If we get here, we had a problem reading the file */
|
||||
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||
+ // If we get here, we had a problem reading the file
|
||||
fclose(fp);
|
||||
png_destroy_write_struct(&png_ptr, &info_ptr);
|
||||
return false;
|
||||
|
23
inkscape-0.48.2-png.patch
Normal file
23
inkscape-0.48.2-png.patch
Normal file
@ -0,0 +1,23 @@
|
||||
From: inkscape upstream
|
||||
Fix compilation against libpng-1.5
|
||||
|
||||
=== modified file 'src/sp-image.cpp'
|
||||
--- src/sp-image.cpp 2011-02-21 07:59:34 +0000
|
||||
+++ src/sp-image.cpp 2011-02-21 08:57:28 +0000
|
||||
@@ -387,9 +387,13 @@
|
||||
|
||||
#if defined(PNG_iCCP_SUPPORTED)
|
||||
{
|
||||
- char* name = 0;
|
||||
+ png_charp name = 0;
|
||||
int compression_type = 0;
|
||||
- char* profile = 0;
|
||||
+#if (PNG_LIBPNG_VER < 10500)
|
||||
+ png_charp profile = 0;
|
||||
+#else
|
||||
+ png_bytep profile = 0;
|
||||
+#endif
|
||||
png_uint_32 proflen = 0;
|
||||
if ( png_get_iCCP(pngPtr, infoPtr, &name, &compression_type, &profile, &proflen) ) {
|
||||
// g_message("Found an iCCP chunk named [%s] with %d bytes and comp %d", name, proflen, compression_type);
|
||||
|
17
inkscape-0.48.2-types.patch
Normal file
17
inkscape-0.48.2-types.patch
Normal file
@ -0,0 +1,17 @@
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=458845
|
||||
|
||||
Index: inkscape-0.48.2/inkscape.desktop.in
|
||||
===================================================================
|
||||
--- inkscape-0.48.2.orig/inkscape.desktop.in
|
||||
+++ inkscape-0.48.2/inkscape.desktop.in
|
||||
@@ -6,7 +6,7 @@ _X-GNOME-FullName=Inkscape Vector Graphi
|
||||
_Comment=Create and edit Scalable Vector Graphics images
|
||||
Type=Application
|
||||
Categories=Graphics;VectorGraphics;GTK;
|
||||
-MimeType=image/svg+xml;image/svg+xml-compressed;application/vnd.corel-draw;application/pdf;application/postscript;image/x-eps;application/illustrator;
|
||||
+MimeType=image/svg+xml;image/svg+xml-compressed;application/vnd.corel-draw;application/pdf;application/postscript;image/x-eps;application/illustrator;image/cgm;image/x-wmf;application/x-xccx;application/x-xcgm;application/x-xcdt;application/x-xsk1;application/x-xcmx;image/x-xcdr;
|
||||
Exec=inkscape %F
|
||||
TryExec=inkscape
|
||||
Terminal=false
|
@ -1,15 +1,16 @@
|
||||
Name: inkscape
|
||||
Version: 0.48.1
|
||||
Release: 10%{?dist}
|
||||
Version: 0.48.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Vector-based drawing program using SVG
|
||||
|
||||
Group: Applications/Productivity
|
||||
License: GPLv2+
|
||||
URL: http://inkscape.sourceforge.net/
|
||||
Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
|
||||
Patch0: inkscape-0.48.0-types.patch
|
||||
Patch2: inkscape-0.48.0-libwpd.patch
|
||||
Patch3: inkscape-0.48.0-gcc46.patch
|
||||
Patch0: inkscape-0.48.2-types.patch
|
||||
Patch4: inkscape-0.48.2-glib.patch
|
||||
Patch5: inkscape-0.48.2-png.patch
|
||||
Patch6: inkscape-0.48.2-png-write.patch
|
||||
|
||||
BuildRequires: atk-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -120,8 +121,9 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .types
|
||||
%patch2 -p1 -b .libwpd
|
||||
%patch3 -p1 -b .gcc46
|
||||
%patch4 -p1 -b .glib
|
||||
%patch5 -p0 -b .png
|
||||
%patch6 -p0 -b .png-write
|
||||
|
||||
# https://bugs.launchpad.net/inkscape/+bug/314381
|
||||
# A couple of files have executable bits set,
|
||||
@ -233,6 +235,11 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Nov 15 2011 German Ruiz <germanrs@fedoraproject.org> - 0.48.2-1
|
||||
- New upstream version
|
||||
- Fix glib include compile problem
|
||||
- Fix compilation against libpng-1.5
|
||||
|
||||
* Fri Oct 28 2011 Rex Dieter <rdieter@fedoraproject.org> - 0.48.1-10
|
||||
- rebuild(poppler)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user