rebuild for libwpd
This commit is contained in:
parent
5c449570a6
commit
144ce007a9
45
inkscape-0.48.0-libwpd.patch
Normal file
45
inkscape-0.48.0-libwpd.patch
Normal file
@ -0,0 +1,45 @@
|
||||
--- inkscape-0.48.0/configure.ac 2010-08-04 18:45:00.000000000 +0200
|
||||
+++ inkscape-0.48.0/configure.ac 2010-11-24 14:01:43.000000000 +0100
|
||||
@@ -678,7 +678,7 @@
|
||||
dnl Check for libwpg for extension
|
||||
dnl ******************************
|
||||
|
||||
-PKG_CHECK_MODULES(LIBWPG, libwpg-0.1 libwpg-stream-0.1, with_libwpg=yes, with_libwpg=no)
|
||||
+PKG_CHECK_MODULES(LIBWPG, libwpg-0.2 libwpd-0.9 libwpd-stream-0.9, with_libwpg=yes, with_libwpg=no)
|
||||
if test "x$with_libwpg" = "xyes"; then
|
||||
AC_DEFINE(WITH_LIBWPG,1,[Build in libwpg])
|
||||
fi
|
||||
--- inkscape-0.48.0/src/extension/internal/wpg-input.cpp 2010-07-13 05:48:40.000000000 +0200
|
||||
+++ inkscape-0.48.0/src/extension/internal/wpg-input.cpp 2010-11-24 14:58:08.000000000 +0100
|
||||
@@ -49,7 +49,7 @@
|
||||
#include "document.h"
|
||||
|
||||
#include "libwpg/libwpg.h"
|
||||
-#include "libwpg/WPGStreamImplementation.h"
|
||||
+#include "libwpd-stream/libwpd-stream.h"
|
||||
|
||||
|
||||
using namespace libwpg;
|
||||
@@ -61,9 +61,9 @@
|
||||
|
||||
SPDocument *
|
||||
WpgInput::open(Inkscape::Extension::Input * mod, const gchar * uri) {
|
||||
- WPXInputStream* input = new libwpg::WPGFileStream(uri);
|
||||
+ WPXInputStream* input = new WPXFileStream(uri);
|
||||
if (input->isOLEStream()) {
|
||||
- WPXInputStream* olestream = input->getDocumentOLEStream();
|
||||
+ WPXInputStream* olestream = input->getDocumentOLEStream("PerfectOffice_MAIN");
|
||||
if (olestream) {
|
||||
delete input;
|
||||
input = olestream;
|
||||
@@ -78,7 +78,7 @@
|
||||
return NULL;
|
||||
}
|
||||
|
||||
- libwpg::WPGString output;
|
||||
+ WPXString output;
|
||||
if (!libwpg::WPGraphics::generateSVG(input, output)) {
|
||||
delete input;
|
||||
return NULL;
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: inkscape
|
||||
Version: 0.48.0
|
||||
Release: 6%{?dist}
|
||||
Release: 7%{?dist}
|
||||
Summary: Vector-based drawing program using SVG
|
||||
|
||||
Group: Applications/Productivity
|
||||
@ -9,6 +9,7 @@ URL: http://inkscape.sourceforge.net/
|
||||
Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
|
||||
Patch0: inkscape-0.48.0-types.patch
|
||||
Patch1: inkscape-0.48.0-poppler.patch
|
||||
Patch2: inkscape-0.48.0-libwpd.patch
|
||||
|
||||
BuildRequires: atk-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -120,6 +121,7 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .types
|
||||
%patch1 -p1 -b .poppler
|
||||
%patch2 -p1 -b .libwpd
|
||||
|
||||
# https://bugs.launchpad.net/inkscape/+bug/314381
|
||||
# A couple of files have executable bits set,
|
||||
@ -231,6 +233,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Dec 08 2010 Caolán McNamara <caolanm@redhat.com> - 0.48.0-7
|
||||
- rebuilt (libwpd)
|
||||
|
||||
* Sun Nov 14 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.48.0-6
|
||||
- rebuilt (poppler)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user