- Move to later snapshot
- Drop uniconvertor patch
This commit is contained in:
parent
8749035ded
commit
06d9f8f975
@ -1,110 +0,0 @@
|
||||
Fix Rawhide build (more recent poppler)
|
||||
|
||||
Lubomir Rintel <lkundrak@v3.sk>
|
||||
|
||||
|
||||
Index: inkscape-svn/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
===================================================================
|
||||
--- inkscape-svn/src/extension/internal/pdfinput/pdf-parser.cpp (revision 22620)
|
||||
+++ inkscape-svn/src/extension/internal/pdfinput/pdf-parser.cpp (working copy)
|
||||
@@ -56,6 +56,13 @@
|
||||
#define M_PI 3.14159265358979323846
|
||||
#endif
|
||||
|
||||
+#include <glib/poppler-features.h>
|
||||
+#if POPPLER_CHECK_VERSION(0,12,2)
|
||||
+#define PGFX ,NULL
|
||||
+#else
|
||||
+#define PGFX
|
||||
+#endif
|
||||
+
|
||||
//------------------------------------------------------------------------
|
||||
// constants
|
||||
//------------------------------------------------------------------------
|
||||
@@ -809,7 +816,7 @@
|
||||
blendingColorSpace = NULL;
|
||||
isolated = knockout = gFalse;
|
||||
if (!obj4.dictLookup(const_cast<char*>("CS"), &obj5)->isNull()) {
|
||||
- blendingColorSpace = GfxColorSpace::parse(&obj5);
|
||||
+ blendingColorSpace = GfxColorSpace::parse(&obj5 PGFX);
|
||||
}
|
||||
obj5.free();
|
||||
if (obj4.dictLookup(const_cast<char*>("I"), &obj5)->isBool()) {
|
||||
@@ -1009,9 +1016,9 @@
|
||||
state->setFillPattern(NULL);
|
||||
res->lookupColorSpace(args[0].getName(), &obj);
|
||||
if (obj.isNull()) {
|
||||
- colorSpace = GfxColorSpace::parse(&args[0]);
|
||||
+ colorSpace = GfxColorSpace::parse(&args[0] PGFX);
|
||||
} else {
|
||||
- colorSpace = GfxColorSpace::parse(&obj);
|
||||
+ colorSpace = GfxColorSpace::parse(&obj PGFX);
|
||||
}
|
||||
obj.free();
|
||||
if (colorSpace) {
|
||||
@@ -1032,9 +1039,9 @@
|
||||
state->setStrokePattern(NULL);
|
||||
res->lookupColorSpace(args[0].getName(), &obj);
|
||||
if (obj.isNull()) {
|
||||
- colorSpace = GfxColorSpace::parse(&args[0]);
|
||||
+ colorSpace = GfxColorSpace::parse(&args[0] PGFX);
|
||||
} else {
|
||||
- colorSpace = GfxColorSpace::parse(&obj);
|
||||
+ colorSpace = GfxColorSpace::parse(&obj PGFX);
|
||||
}
|
||||
obj.free();
|
||||
if (colorSpace) {
|
||||
@@ -1101,7 +1108,7 @@
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
if (args[numArgs-1].isName() &&
|
||||
- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
|
||||
+ (pattern = res->lookupPattern(args[numArgs-1].getName() PGFX))) {
|
||||
state->setFillPattern(pattern);
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
@@ -1145,7 +1152,7 @@
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
if (args[numArgs-1].isName() &&
|
||||
- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
|
||||
+ (pattern = res->lookupPattern(args[numArgs-1].getName() PGFX))) {
|
||||
state->setStrokePattern(pattern);
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
@@ -1543,7 +1550,7 @@
|
||||
double *matrix = NULL;
|
||||
GBool savedState = gFalse;
|
||||
|
||||
- if (!(shading = res->lookupShading(args[0].getName()))) {
|
||||
+ if (!(shading = res->lookupShading(args[0].getName() PGFX))) {
|
||||
return;
|
||||
}
|
||||
|
||||
@@ -2507,7 +2514,7 @@
|
||||
}
|
||||
}
|
||||
if (!obj1.isNull()) {
|
||||
- colorSpace = GfxColorSpace::parse(&obj1);
|
||||
+ colorSpace = GfxColorSpace::parse(&obj1 PGFX);
|
||||
} else if (csMode == streamCSDeviceGray) {
|
||||
colorSpace = new GfxDeviceGrayColorSpace();
|
||||
} else if (csMode == streamCSDeviceRGB) {
|
||||
@@ -2592,7 +2599,7 @@
|
||||
obj2.free();
|
||||
}
|
||||
}
|
||||
- maskColorSpace = GfxColorSpace::parse(&obj1);
|
||||
+ maskColorSpace = GfxColorSpace::parse(&obj1 PGFX);
|
||||
obj1.free();
|
||||
if (!maskColorSpace || maskColorSpace->getMode() != csDeviceGray) {
|
||||
goto err1;
|
||||
@@ -2767,7 +2774,7 @@
|
||||
if (obj1.dictLookup(const_cast<char*>("S"), &obj2)->isName(const_cast<char*>("Transparency"))) {
|
||||
transpGroup = gTrue;
|
||||
if (!obj1.dictLookup(const_cast<char*>("CS"), &obj3)->isNull()) {
|
||||
- blendingColorSpace = GfxColorSpace::parse(&obj3);
|
||||
+ blendingColorSpace = GfxColorSpace::parse(&obj3 PGFX);
|
||||
}
|
||||
obj3.free();
|
||||
if (obj1.dictLookup(const_cast<char*>("I"), &obj3)->isBool()) {
|
@ -1,4 +1,4 @@
|
||||
From 61ef28dbb939d8a65c17e07834d7e31bae7955f2 Mon Sep 17 00:00:00 2001
|
||||
From e7a6bc54086917865a8accac50b185e72012ddb3 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Fri, 25 Sep 2009 15:15:56 +0200
|
||||
Subject: [PATCH] Make it possible to build Inkscape 0.47 on RHEL 5
|
||||
@ -21,19 +21,17 @@ gtk_entry_completion_set_inline_selection () function
|
||||
* GLib prior to version 2.15.1 did not provide mechanisms for parsing
|
||||
URIs.
|
||||
---
|
||||
autogen.sh | 10 +++++-----
|
||||
configure.ac | 2 +-
|
||||
src/Makefile.am | 5 +++++
|
||||
src/extension/internal/cairo-ps-out.cpp | 5 +++++
|
||||
src/widgets/toolbox.cpp | 2 ++
|
||||
src/xml/rebase-hrefs.cpp | 13 ++++++++++++-
|
||||
6 files changed, 30 insertions(+), 7 deletions(-)
|
||||
4 files changed, 23 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index fbfa2e5..32ff5a4 100644
|
||||
index a85c9c2..802f5fd 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -649,7 +649,7 @@ if test $cc_vers_major -gt 3; then
|
||||
@@ -719,7 +719,7 @@ if test $cc_vers_major -gt 3; then
|
||||
else
|
||||
min_sigc_version=2.0.11
|
||||
fi
|
||||
@ -43,10 +41,10 @@ index fbfa2e5..32ff5a4 100644
|
||||
# Check for Apple Mac OS X Carbon framework
|
||||
carbon_ok=no
|
||||
diff --git a/src/Makefile.am b/src/Makefile.am
|
||||
index 4d57de8..07339ad 100644
|
||||
index 03b58c6..deb284b 100644
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -284,3 +284,8 @@ dist-hook:
|
||||
@@ -275,3 +275,8 @@ dist-hook:
|
||||
|
||||
distclean-local:
|
||||
rm -f cxxtests.xml cxxtests.log
|
||||
@ -56,10 +54,10 @@ index 4d57de8..07339ad 100644
|
||||
+.S.o:
|
||||
+ $(CCASCOMPILE) -c -o $@ $<
|
||||
diff --git a/src/extension/internal/cairo-ps-out.cpp b/src/extension/internal/cairo-ps-out.cpp
|
||||
index 9ac1932..d3bda7f 100644
|
||||
index 61760e9..1ab3342 100644
|
||||
--- a/src/extension/internal/cairo-ps-out.cpp
|
||||
+++ b/src/extension/internal/cairo-ps-out.cpp
|
||||
@@ -38,6 +38,11 @@
|
||||
@@ -39,6 +39,11 @@
|
||||
|
||||
#include "io/sys.h"
|
||||
|
||||
@ -71,20 +69,6 @@ index 9ac1932..d3bda7f 100644
|
||||
namespace Inkscape {
|
||||
namespace Extension {
|
||||
namespace Internal {
|
||||
diff --git a/src/widgets/toolbox.cpp b/src/widgets/toolbox.cpp
|
||||
index 46ad082..5d3cdea 100644
|
||||
--- a/src/widgets/toolbox.cpp
|
||||
+++ b/src/widgets/toolbox.cpp
|
||||
@@ -6563,7 +6563,9 @@ cbe_add_completion (GtkComboBoxEntry *cbe, GObject *tbl){
|
||||
gtk_entry_completion_set_model(completion, model);
|
||||
gtk_entry_completion_set_text_column(completion, 0);
|
||||
gtk_entry_completion_set_inline_completion(completion, FALSE);
|
||||
+#if GTK_CHECK_VERSION(2,12,0)
|
||||
gtk_entry_completion_set_inline_selection(completion, FALSE);
|
||||
+#endif
|
||||
gtk_entry_completion_set_popup_completion(completion, TRUE);
|
||||
gtk_entry_set_completion(entry, completion);
|
||||
|
||||
diff --git a/src/xml/rebase-hrefs.cpp b/src/xml/rebase-hrefs.cpp
|
||||
index c387672..69b2c60 100644
|
||||
--- a/src/xml/rebase-hrefs.cpp
|
||||
@ -125,5 +109,5 @@ index c387672..69b2c60 100644
|
||||
/* If absolute then keep it as is.
|
||||
*
|
||||
--
|
||||
1.6.2.5
|
||||
1.7.0.1
|
||||
|
72
inkscape-0.48-newpoppler.patch
Normal file
72
inkscape-0.48-newpoppler.patch
Normal file
@ -0,0 +1,72 @@
|
||||
From d04983e353a3d3ca2d8cb14ca706eaccdcaff704 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Wed, 5 May 2010 08:48:37 +0200
|
||||
Subject: [PATCH] Fix build with more recent poppler
|
||||
|
||||
---
|
||||
src/extension/internal/pdfinput/pdf-parser.cpp | 19 +++++++++++++------
|
||||
1 files changed, 13 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
index b37cbb7..006e614 100644
|
||||
--- a/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
+++ b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
@@ -56,6 +56,13 @@ extern "C" {
|
||||
#define M_PI 3.14159265358979323846
|
||||
#endif
|
||||
|
||||
+#include <glib/poppler-features.h>
|
||||
+#if POPPLER_CHECK_VERSION(0,12,2)
|
||||
+#define PGFX ,NULL
|
||||
+#else
|
||||
+#define PGFX
|
||||
+#endif
|
||||
+
|
||||
//------------------------------------------------------------------------
|
||||
// constants
|
||||
//------------------------------------------------------------------------
|
||||
@@ -1020,9 +1027,9 @@ void PdfParser::opSetFillColorSpace(Object args[], int numArgs) {
|
||||
}
|
||||
#else
|
||||
if (obj.isNull()) {
|
||||
- colorSpace = GfxColorSpace::parse(&args[0]);
|
||||
+ colorSpace = GfxColorSpace::parse(&args[0] PGFX);
|
||||
} else {
|
||||
- colorSpace = GfxColorSpace::parse(&obj);
|
||||
+ colorSpace = GfxColorSpace::parse(&obj PGFX);
|
||||
}
|
||||
#endif
|
||||
obj.free();
|
||||
@@ -1051,9 +1058,9 @@ void PdfParser::opSetStrokeColorSpace(Object args[], int numArgs) {
|
||||
}
|
||||
#else
|
||||
if (obj.isNull()) {
|
||||
- colorSpace = GfxColorSpace::parse(&args[0]);
|
||||
+ colorSpace = GfxColorSpace::parse(&args[0] PGFX);
|
||||
} else {
|
||||
- colorSpace = GfxColorSpace::parse(&obj);
|
||||
+ colorSpace = GfxColorSpace::parse(&obj PGFX);
|
||||
}
|
||||
#endif
|
||||
obj.free();
|
||||
@@ -1128,7 +1135,7 @@ void PdfParser::opSetFillColorN(Object args[], int numArgs) {
|
||||
}
|
||||
#else
|
||||
if (args[numArgs-1].isName() &&
|
||||
- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
|
||||
+ (pattern = res->lookupPattern(args[numArgs-1].getName() PGFX))) {
|
||||
state->setFillPattern(pattern);
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
@@ -1180,7 +1187,7 @@ void PdfParser::opSetStrokeColorN(Object args[], int numArgs) {
|
||||
}
|
||||
#else
|
||||
if (args[numArgs-1].isName() &&
|
||||
- (pattern = res->lookupPattern(args[numArgs-1].getName()))) {
|
||||
+ (pattern = res->lookupPattern(args[numArgs-1].getName() PGFX))) {
|
||||
state->setStrokePattern(pattern);
|
||||
builder->updateStyle(state);
|
||||
}
|
||||
--
|
||||
1.7.0.1
|
||||
|
@ -1,38 +0,0 @@
|
||||
uniconvertor and uniconv are looked in in reversed order
|
||||
(therefore we can call uniconv that's different from the uniconvertor one)
|
||||
https://bugs.launchpad.net/inkscape/+bug/226383
|
||||
|
||||
Lubomir Rintel <lkundrak@v3.sk>
|
||||
|
||||
diff -up inkscape/share/extensions/uniconv-ext.py.uniconv inkscape/share/extensions/uniconv-ext.py
|
||||
--- inkscape/share/extensions/uniconv-ext.py.uniconv 2009-03-01 18:06:19.000000000 +0100
|
||||
+++ inkscape/share/extensions/uniconv-ext.py 2009-04-10 15:22:21.916579400 +0200
|
||||
@@ -28,19 +28,21 @@ cmd = None
|
||||
|
||||
try:
|
||||
from subprocess import Popen, PIPE
|
||||
- p = Popen('uniconv', shell=True, stdout=PIPE, stderr=PIPE).wait()
|
||||
+ p = Popen('uniconvertor', shell=True, stdout=PIPE, stderr=PIPE).wait()
|
||||
if p==0 :
|
||||
- cmd = 'uniconv'
|
||||
+ cmd = 'uniconvertor'
|
||||
else:
|
||||
- p = Popen('uniconvertor', shell=True, stdout=PIPE, stderr=PIPE).wait()
|
||||
+ p = Popen('uniconv', shell=True, stdout=PIPE, stderr=PIPE).wait()
|
||||
if p==0 :
|
||||
- cmd = 'uniconvertor'
|
||||
+ cmd = 'uniconv'
|
||||
except ImportError:
|
||||
from popen2 import Popen3
|
||||
- p = Popen3('uniconv', True).wait()
|
||||
- if p!=32512 : cmd = 'uniconv'
|
||||
p = Popen3('uniconvertor', True).wait()
|
||||
- if p!=32512 : cmd = 'uniconvertor'
|
||||
+ if p!=32512 :
|
||||
+ cmd = 'uniconvertor'
|
||||
+ else:
|
||||
+ p = Popen3('uniconv', True).wait()
|
||||
+ if p!=32512 : cmd = 'uniconv'
|
||||
|
||||
if cmd == None:
|
||||
# there's no succeffully-returning uniconv command; try to get the module directly (on Windows)
|
@ -8,15 +8,14 @@ License: GPLv2+
|
||||
URL: http://inkscape.sourceforge.net/
|
||||
# bzr branch lp:inkscape
|
||||
# cd inkscape
|
||||
# bzr export -r9206 ../inkscape.tar.bz2
|
||||
# bzr export -r9395 ../inkscape.tar.bz2
|
||||
Source0: inkscape.tar.bz2
|
||||
#Source0: http://download.sourceforge.net/inkscape/%{name}-%{version}.tar.bz2
|
||||
|
||||
Patch0: inkscape-20090410svn-uniconv.patch
|
||||
Patch4: inkscape-20090410svn-formats.patch
|
||||
Patch5: inkscape-20090925svn-el5.patch
|
||||
Patch5: inkscape-0.48-el5.patch
|
||||
Patch6: inkscape-20091101svn-icon.patch
|
||||
Patch7: inkscape-0.47-newpoppler.patch
|
||||
Patch7: inkscape-0.48-newpoppler.patch
|
||||
Patch8: inkscape-0.47-x11.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
@ -136,7 +135,6 @@ graphics in W3C standard Scalable Vector Graphics (SVG) file format.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
%patch0 -p1 -b .uniconv
|
||||
%patch4 -p1 -b .formats
|
||||
%patch5 -p1 -b .el5
|
||||
%patch6 -p0 -b .japierdole
|
||||
@ -255,6 +253,10 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed May 05 2010 Lubomir Rintel <lkundrak@v3.sk> - 0.48-0.1.20100505bzr
|
||||
- Move to later snapshot
|
||||
- Drop uniconvertor patch
|
||||
|
||||
* Tue Apr 06 2010 Caolán McNamara <caolanm@redhat.com> - 0.48-0.2.20100318bzr
|
||||
- Resolves: rhbz#565106 fix inkscape-0.47-x11.patch to not clobber INKSCAPE_LIBS
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user