- new upstream version 1.4.2
This commit is contained in:
parent
541ea7eb56
commit
f9baf611a9
@ -1 +1 @@
|
||||
imlib2-1.4.1.tar.gz
|
||||
imlib2-1.4.2.tar.bz2
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up imlib2-1.4.1/src/modules/loaders/loader_xpm.c~ imlib2-1.4.1/src/modules/loaders/loader_xpm.c
|
||||
--- imlib2-1.4.1/src/modules/loaders/loader_xpm.c~ 2008-06-12 20:45:41.000000000 +0200
|
||||
+++ imlib2-1.4.1/src/modules/loaders/loader_xpm.c 2008-06-12 20:45:41.000000000 +0200
|
||||
@@ -52,6 +52,8 @@ xpm_parse_color(char *color, int *r, int
|
||||
/* look in rgb txt database */
|
||||
if (!rgb_txt)
|
||||
#ifndef __EMX__
|
||||
+ rgb_txt = fopen("/usr/share/X11/rgb.txt", "r");
|
||||
+ if (!rgb_txt)
|
||||
rgb_txt = fopen("/usr/X11R6/lib/X11/rgb.txt", "r");
|
||||
if (!rgb_txt)
|
||||
rgb_txt = fopen("/usr/openwin/lib/X11/rgb.txt", "r");
|
@ -1,86 +0,0 @@
|
||||
diff -Nur imlib2-1.2.1/src/modules/loaders/loader_argb.c imlib2-1.2.1.new/src/modules/loaders/loader_argb.c
|
||||
--- imlib2-1.2.1/src/modules/loaders/loader_argb.c 2006-11-06 01:27:59.000000000 -0800
|
||||
+++ imlib2-1.2.1.new/src/modules/loaders/loader_argb.c 2006-11-06 01:30:41.000000000 -0800
|
||||
@@ -23,7 +23,7 @@
|
||||
load(ImlibImage * im, ImlibProgressFunction progress,
|
||||
char progress_granularity, char immediate_load)
|
||||
{
|
||||
- int w, h, alpha;
|
||||
+ int w=0, h=0, alpha=0;
|
||||
FILE *f;
|
||||
|
||||
if (im->data)
|
||||
@@ -36,6 +36,8 @@
|
||||
{
|
||||
char buf[256], buf2[256];
|
||||
|
||||
+ memset(buf, 0, sizeof(buf));
|
||||
+ memset(buf2, 0, sizeof(buf));
|
||||
if (!fgets(buf, 255, f))
|
||||
{
|
||||
fclose(f);
|
||||
diff -Nur imlib2-1.2.1/src/modules/loaders/loader_jpeg.c imlib2-1.2.1.new/src/modules/loaders/loader_jpeg.c
|
||||
--- imlib2-1.2.1/src/modules/loaders/loader_jpeg.c 2006-11-06 01:27:59.000000000 -0800
|
||||
+++ imlib2-1.2.1.new/src/modules/loaders/loader_jpeg.c 2006-11-06 01:33:01.000000000 -0800
|
||||
@@ -104,8 +104,9 @@
|
||||
im->w = w = cinfo.output_width;
|
||||
im->h = h = cinfo.output_height;
|
||||
|
||||
- if (cinfo.rec_outbuf_height > 16)
|
||||
+ if (cinfo.rec_outbuf_height > 16 || w < 1 || h < 1 || w > 16383 || h > 16383)
|
||||
{
|
||||
+ im->w = im->h = 0;
|
||||
jpeg_destroy_decompress(&cinfo);
|
||||
fclose(f);
|
||||
return 0;
|
||||
diff -Nur imlib2-1.2.1/src/modules/loaders/loader_lbm.c imlib2-1.2.1.new/src/modules/loaders/loader_lbm.c
|
||||
--- imlib2-1.2.1/src/modules/loaders/loader_lbm.c 2006-11-06 01:27:59.000000000 -0800
|
||||
+++ imlib2-1.2.1.new/src/modules/loaders/loader_lbm.c 2006-11-06 01:30:41.000000000 -0800
|
||||
@@ -453,6 +453,7 @@
|
||||
}
|
||||
}
|
||||
if (!full || !ok) {
|
||||
+ im->w = im->h = 0;
|
||||
freeilbm(&ilbm);
|
||||
return ok;
|
||||
}
|
||||
@@ -467,12 +468,13 @@
|
||||
cancel = 0;
|
||||
plane[0] = NULL;
|
||||
|
||||
+ n = ilbm.depth;
|
||||
+ if (ilbm.mask == 1) n++;
|
||||
+
|
||||
im->data = malloc(im->w * im->h * sizeof(DATA32));
|
||||
- if (im->data) {
|
||||
- n = ilbm.depth;
|
||||
- if (ilbm.mask == 1) n++;
|
||||
+ plane[0] = malloc(((im->w + 15) / 16) * 2 * n);
|
||||
+ if (im->data && plane[0]) {
|
||||
|
||||
- plane[0] = malloc(((im->w + 15) / 16) * 2 * n);
|
||||
for (i = 1; i < n; i++) plane[i] = plane[i - 1] + ((im->w + 15) / 16) * 2;
|
||||
|
||||
z = ((im->w + 15) / 16) * 2 * n;
|
||||
@@ -511,6 +513,7 @@
|
||||
* the memory for im->data.
|
||||
*----------*/
|
||||
if (!ok) {
|
||||
+ im->w = im->h = 0;
|
||||
if (im->data) free(im->data);
|
||||
im->data = NULL;
|
||||
}
|
||||
diff -Nur imlib2-1.2.1/src/modules/loaders/loader_tga.c imlib2-1.2.1.new/src/modules/loaders/loader_tga.c
|
||||
--- imlib2-1.2.1/src/modules/loaders/loader_tga.c 2006-11-06 01:27:59.000000000 -0800
|
||||
+++ imlib2-1.2.1.new/src/modules/loaders/loader_tga.c 2006-11-06 01:30:41.000000000 -0800
|
||||
@@ -365,7 +369,9 @@
|
||||
else
|
||||
dataptr = im->data + (y * im->w);
|
||||
|
||||
- for (x = 0; x < im->w; x++) /* for each pixel in the row */
|
||||
+ for (x = 0;
|
||||
+ x < im->w && bufptr+bpp/8 < bufend;
|
||||
+ x++) /* for each pixel in the row */
|
||||
{
|
||||
switch (bpp)
|
||||
{
|
17
imlib2.spec
17
imlib2.spec
@ -1,17 +1,13 @@
|
||||
Summary: Image loading, saving, rendering, and manipulation library
|
||||
Name: imlib2
|
||||
Version: 1.4.1
|
||||
Version: 1.4.2
|
||||
Release: 1%{?dist}
|
||||
License: Imlib2
|
||||
Group: System Environment/Libraries
|
||||
URL: http://docs.enlightenment.org/api/imlib2/html/
|
||||
Source0: http://downloads.sourceforge.net/enlightenment/%{name}-%{version}.tar.gz
|
||||
# submitted to enlightenment-devel@lists.sourceforge.net
|
||||
Patch0: imlib2-1.2.1-X11-path.patch
|
||||
Source0: http://downloads.sourceforge.net/enlightenment/%{name}-%{version}.tar.bz2
|
||||
# Fedora specific multilib hack, upstream should switch to pkgconfig one day
|
||||
Patch1: imlib2-1.3.0-multilib.patch
|
||||
# submitted to enlightenment-devel@lists.sourceforge.net
|
||||
Patch2: imlib2-1.3.0-loader_overflows.patch
|
||||
Patch0: imlib2-1.3.0-multilib.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libjpeg-devel libpng-devel libtiff-devel
|
||||
BuildRequires: giflib-devel freetype-devel >= 2.1.9-4 libtool bzip2-devel
|
||||
@ -60,9 +56,7 @@ conditions of the GPL version 2 (or at your option) any later version.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .x11-path
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1 -b .overflow
|
||||
%patch0 -p1 -b .multilib
|
||||
|
||||
|
||||
%build
|
||||
@ -127,6 +121,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Oct 21 2008 Tomas Smetana <tsmetana@redhat.com> 1.4.2-1
|
||||
- new upstream version 1.4.2
|
||||
|
||||
* Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.1-1
|
||||
- New upstream release 1.4.1
|
||||
- Stop shipping static lib in -devel
|
||||
|
Loading…
Reference in New Issue
Block a user