- New upstream release 1.4.1

- Stop shipping static lib in -devel
This commit is contained in:
Hans de Goede 2008-06-12 19:46:35 +00:00
parent 197d35e202
commit 541ea7eb56
7 changed files with 30 additions and 75 deletions

View File

@ -1 +1 @@
imlib2-1.4.0.tar.gz
imlib2-1.4.1.tar.gz

View File

@ -1,12 +1,12 @@
diff -Nur imlib2-1.2.1-orig/src/modules/loaders/loader_xpm.c imlib2-1.2.1/src/modules/loaders/loader_xpm.c
--- imlib2-1.2.1-orig/src/modules/loaders/loader_xpm.c 2005-05-18 07:26:16.000000000 +0200
+++ imlib2-1.2.1/src/modules/loaders/loader_xpm.c 2005-09-21 08:55:11.000000000 +0200
@@ -66,7 +66,7 @@
diff -up imlib2-1.4.1/src/modules/loaders/loader_xpm.c~ imlib2-1.4.1/src/modules/loaders/loader_xpm.c
--- imlib2-1.4.1/src/modules/loaders/loader_xpm.c~ 2008-06-12 20:45:41.000000000 +0200
+++ imlib2-1.4.1/src/modules/loaders/loader_xpm.c 2008-06-12 20:45:41.000000000 +0200
@@ -52,6 +52,8 @@ xpm_parse_color(char *color, int *r, int
/* look in rgb txt database */
if (!rgb_txt)
#ifndef __EMX__
- rgb_txt = fopen("/usr/X11R6/lib/X11/rgb.txt", "r");
+ rgb_txt = fopen("/usr/share/X11/rgb.txt", "r");
#else
rgb_txt = fopen(__XOS2RedirRoot("/XFree86/lib/X11/rgb.txt"), "rt");
#endif
+ rgb_txt = fopen("/usr/share/X11/rgb.txt", "r");
+ if (!rgb_txt)
rgb_txt = fopen("/usr/X11R6/lib/X11/rgb.txt", "r");
if (!rgb_txt)
rgb_txt = fopen("/usr/openwin/lib/X11/rgb.txt", "r");

View File

@ -70,18 +70,6 @@ diff -Nur imlib2-1.2.1/src/modules/loaders/loader_lbm.c imlib2-1.2.1.new/src/mod
if (im->data) free(im->data);
im->data = NULL;
}
diff -Nur imlib2-1.2.1/src/modules/loaders/loader_pnm.c imlib2-1.2.1.new/src/modules/loaders/loader_pnm.c
--- imlib2-1.2.1/src/modules/loaders/loader_pnm.c 2006-11-06 01:27:59.000000000 -0800
+++ imlib2-1.2.1.new/src/modules/loaders/loader_pnm.c 2006-11-06 01:30:41.000000000 -0800
@@ -80,7 +80,7 @@
int i = 0;
/* read numbers */
- while (c != EOF && !isspace(c))
+ while (c != EOF && i+1 < sizeof(buf) && !isspace(c))
{
buf[i++] = c;
c = fgetc(f);
diff -Nur imlib2-1.2.1/src/modules/loaders/loader_tga.c imlib2-1.2.1.new/src/modules/loaders/loader_tga.c
--- imlib2-1.2.1/src/modules/loaders/loader_tga.c 2006-11-06 01:27:59.000000000 -0800
+++ imlib2-1.2.1.new/src/modules/loaders/loader_tga.c 2006-11-06 01:30:41.000000000 -0800

View File

@ -1,25 +1,3 @@
--- imlib2-1.3.0/configure.in~ 2006-10-27 00:18:39.000000000 +0200
+++ imlib2-1.3.0/configure.in 2006-10-27 00:18:39.000000000 +0200
@@ -190,7 +190,7 @@
AC_PATH_XTRA
x_dir=${x_dir:-/usr/X11R6}
x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
+ x_libs="-lX11 -lXext"
AM_CONDITIONAL(BUILD_X11, true)
AC_DEFINE(BUILD_X11, 1, [enabling X11 support])
else
--- imlib2-1.3.0/configure~ 2006-10-27 00:18:25.000000000 +0200
+++ imlib2-1.3.0/configure 2006-10-27 00:18:25.000000000 +0200
@@ -23117,7 +23117,7 @@
x_dir=${x_dir:-/usr/X11R6}
x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
+ x_libs="-lX11 -lXext"
if true; then
--- imlib2-1.3.0/imlib2-config.in~ 2006-10-27 00:17:29.000000000 +0200
+++ imlib2-1.3.0/imlib2-config.in 2006-10-27 00:17:29.000000000 +0200
@@ -45,8 +45,7 @@

View File

@ -1,12 +0,0 @@
diff -up imlib2-1.4.0/src/modules/loaders/loader_xpm.c.CVE-2008-2426 imlib2-1.4.0/src/modules/loaders/loader_xpm.c
--- imlib2-1.4.0/src/modules/loaders/loader_xpm.c.CVE-2008-2426 2008-05-30 11:54:06.000000000 +0200
+++ imlib2-1.4.0/src/modules/loaders/loader_xpm.c 2008-05-30 11:54:40.000000000 +0200
@@ -284,7 +284,7 @@ load(ImlibImage * im, ImlibProgressFunct
if (line[k] != ' ')
{
s[0] = 0;
- sscanf(&line[k], "%65535s", s);
+ sscanf(&line[k], "%255s", s);
slen = strlen(s);
k += slen;
if (!strcmp(s, "c"))

View File

@ -1,15 +1,17 @@
Summary: Image loading, saving, rendering, and manipulation library
Name: imlib2
Version: 1.4.0
Release: 7%{?dist}
Version: 1.4.1
Release: 1%{?dist}
License: Imlib2
Group: System Environment/Libraries
URL: http://docs.enlightenment.org/api/imlib2/html/
Source0: http://downloads.sourceforge.net/enlightenment/%{name}-%{version}.tar.gz
# submitted to enlightenment-devel@lists.sourceforge.net
Patch0: imlib2-1.2.1-X11-path.patch
# Fedora specific multilib hack, upstream should switch to pkgconfig one day
Patch1: imlib2-1.3.0-multilib.patch
# submitted to enlightenment-devel@lists.sourceforge.net
Patch2: imlib2-1.3.0-loader_overflows.patch
Patch3: imlib2-1.4.0-CVE-2008-2426.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel libpng-devel libtiff-devel
BuildRequires: giflib-devel freetype-devel >= 2.1.9-4 libtool bzip2-devel
@ -44,7 +46,7 @@ flexible.
%package id3tag-loader
Summary: id3tag-loader for %{name}
Summary: Imlib2 id3tag-loader
License: GPLv2+
Group: System Environment/Libraries
Requires: %{name} = %{version}-%{release}
@ -61,12 +63,6 @@ conditions of the GPL version 2 (or at your option) any later version.
%patch0 -p1 -b .x11-path
%patch1 -p1 -b .multilib
%patch2 -p1 -b .overflow
%patch3 -p1 -b .CVE-2008-2426
# sigh stop autoxxx from rerunning because of our patches above.
touch aclocal.m4
touch configure
touch config.h.in
touch `find -name Makefile.in`
%build
@ -75,18 +71,19 @@ asmopts="--disable-mmx --disable-amd64"
asmopts="--enable-mmx --disable-amd64"
%endif
# Note: --disable-static doesn't work as of 1.2.1.
%configure --disable-dependency-tracking --with-pic $asmopts
make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
# stop -L/usr/lib[64] getting added to imlib2-config
export x_libs=" "
%configure --disable-static --with-pic $asmopts
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
make %{?_smp_mflags}
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
make install DESTDIR=$RPM_BUILD_ROOT
rm -f \
$RPM_BUILD_ROOT%{_libdir}/imlib2/{loaders,filters}/*.a \
$RPM_BUILD_ROOT%{_bindir}/imlib2_test
rm $RPM_BUILD_ROOT%{_bindir}/imlib2_test
# ship .la files due to a bug in kdelibs (bugzilla.fedora.us #2284):
# $RPM_BUILD_ROOT%{_libdir}/libImlib2.la \
@ -121,7 +118,6 @@ rm -rf $RPM_BUILD_ROOT
%doc doc/*.gif doc/*.html
%{_bindir}/imlib2-config
%{_includedir}/Imlib2.h
%{_libdir}/libImlib2.a
%{_libdir}/libImlib2.la
%{_libdir}/libImlib2.so
%{_libdir}/pkgconfig/imlib2.pc
@ -129,7 +125,12 @@ rm -rf $RPM_BUILD_ROOT
%files id3tag-loader
%{_libdir}/imlib2/loaders/id3.*
%changelog
* Thu Jun 12 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 1.4.1-1
- New upstream release 1.4.1
- Stop shipping static lib in -devel
* Fri May 30 2008 Tomas Smetana <tsmetana@redhat.com> 1.4.0-7
- patch for CVE-2008-2426

View File

@ -1 +1 @@
69f7ee996c943142332b4c98597b095c imlib2-1.4.0.tar.gz
16a3d885e523303be794282c0ed90841 imlib2-1.4.1.tar.gz