- 1.2.1, patches applied/obsoleted upstream.

- Improve summary and description, fix URL.
- Move HTML docs to -devel.
- Build with dependency tracking disabled.
- Drop x86_64 freetype rpath hack, require a fixed freetype-devel.
This commit is contained in:
Ville Skyttä 2005-09-20 19:09:39 +00:00
parent d36f8bba9e
commit 49ec3bf586
5 changed files with 43 additions and 99 deletions

View File

@ -1 +1 @@
imlib2-1.1.2.tar.gz imlib2-1.2.1.tar.gz

View File

@ -1,11 +0,0 @@
--- configure.old 2005-01-09 18:36:09.314185880 +0100
+++ configure 2005-01-09 18:37:15.840072408 +0100
@@ -20262,7 +20262,7 @@
if test "x$have_x" = "xyes"; then
x_dir="/usr/X11R6";
x_cflags="-I"$x_dir"/include"
- x_libs="-L"$x_dir"/lib -lX11 -lXext"
+ x_libs="-L"$x_dir"/lib64 -lX11 -lXext"
echo "$as_me:$LINENO: result: enabling X11 support" >&5
echo "${ECHO_T}enabling X11 support" >&6

View File

@ -1,40 +0,0 @@
diff -Nur imlib2-1.2.0-orig/src/modules/loaders/loader_xpm.c imlib2-1.2.0/src/modules/loaders/loader_xpm.c
--- imlib2-1.2.0-orig/src/modules/loaders/loader_xpm.c 2005-01-04 04:28:52.000000000 +0100
+++ imlib2-1.2.0/src/modules/loaders/loader_xpm.c 2005-05-09 21:19:22.000000000 +0200
@@ -108,7 +108,7 @@
FILE *f;
int pc, c, i, j, k, w, h, ncolors, cpp, comment, transp,
- quote, context, len, done, r, g, b;
+ quote, context, len, done, r, g, b, backslash;
char *line, s[256], tok[128], col[256];
int lsz = 256;
struct _cmap {
@@ -163,6 +163,7 @@
pixels = 0;
count = 0;
line = malloc(lsz);
+ backslash = 0;
memset(lookup, 0, sizeof(lookup));
while (!done)
{
@@ -645,7 +646,18 @@
c = 32;
else if (c > 127)
c = 127;
- line[i++] = c;
+ if ( c=='\\' ) {
+ if ( ++backslash<2 ) {
+ line[i++] = c;
+ }
+ else {
+ backslash = 0;
+ }
+ }
+ else {
+ backslash = 0;
+ line[i++] = c;
+ }
}
if (i >= lsz)
{

View File

@ -1,87 +1,74 @@
Summary: Graphic library for file loading, saving, rendering, and manipulation Summary: Image loading, saving, rendering, and manipulation library
Name: imlib2 Name: imlib2
Version: 1.2.0 Version: 1.2.1
Release: 8.fc4 Release: 2%{?dist}
License: BSD License: BSD
Group: System Environment/Libraries Group: System Environment/Libraries
URL: http://www.enlightenment.org/pages/imlib2.html URL: http://www.enlightenment.org/Libraries/Imlib2/
Source0: http://download.sf.net/enlightenment/%{name}-%{version}.tar.gz Source0: http://download.sf.net/enlightenment/%{name}-%{version}.tar.gz
Patch0: imlib2-1.2.0-configure-xlib64.patch
Patch1: imlib2-1.2.0-xpmcescape.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: XFree86-devel libjpeg-devel libpng-devel libtiff-devel BuildRequires: XFree86-devel libjpeg-devel libpng-devel libtiff-devel
BuildRequires: libungif-devel freetype-devel libtool bzip2-devel %{__perl} BuildRequires: libungif-devel freetype-devel >= 2.1.9-4 libtool bzip2-devel
%package devel %package devel
Summary: Development package for %{name} Summary: Development package for %{name}
Group: Development/Libraries Group: Development/Libraries
Requires: %{name} = %{version}-%{release} Requires: %{name} = %{version}-%{release}
Requires: XFree86-devel freetype-devel pkgconfig Requires: XFree86-devel freetype-devel >= 2.1.9-4 pkgconfig
%description %description
Imlib 2 is the successor to Imlib. It is NOT a newer version -- it is Imlib 2 is a library that does image file loading and saving as well
a completely new library. Imlib 2 can be installed alongside Imlib 1.x as rendering, manipulation, arbitrary polygon support, etc. It does
without any problems since they are effectively different libraries ALL of these operations FAST. Imlib2 also tries to be highly
which have very similar functionality. Please see the homepage for the intelligent about doing them, so writing naive programs can be done
long description of the differences. easily, without sacrificing speed. This is a complete rewrite over
the Imlib 1.x series. The architecture is more modular, simple, and
flexible.
%description devel %description devel
This package contains development files for %{name}. This package contains development files for %{name}.
Imlib 2 is the successor to Imlib. It is NOT a newer version -- it is Imlib 2 is a library that does image file loading and saving as well
a completely new library. Imlib 2 can be installed alongside Imlib 1.x as rendering, manipulation, arbitrary polygon support, etc. It does
without any problems since they are effectively different libraries ALL of these operations FAST. Imlib2 also tries to be highly
which have very similar functionality. Please see the homepage for the intelligent about doing them, so writing naive programs can be done
long description of the differences. easily, without sacrificing speed. This is a complete rewrite over
the Imlib 1.x series. The architecture is more modular, simple, and
flexible.
%prep %prep
%setup -q %setup -q
%ifarch x86_64
%patch0 -b .patch0
%endif
%patch1 -p1 -b .xpmcescape
# loaders need to link with the main lib
%{__perl} -pi -e \
's|^(\w+_la_LDFLAGS .*)|$1 -L\$(top_builddir)/src/lib| ;
s|^(\w+_la_LIBADD .*)|$1 -lImlib2|' src/modules/loaders/Makefile.*
%build %build
%configure \ asmopts="--disable-mmx --disable-amd64"
--x-libraries=%{_prefix}/X11R6/%{_lib} \
--with-pic \
%ifarch %{ix86} ia64 %ifarch %{ix86} ia64
--enable-mmx asmopts="--enable-mmx --disable-amd64"
%else
--disable-mmx
%endif %endif
%ifarch x86_64 %ifarch x86_64
# fix hardcoded rpath im Makefiles on x86_64 due to freetype-config --libs asmopts="--disable-mmx --enable-amd64"
# returning "-L/usr/lib64 -Wl,--rpath -Wl,/usr/lib64 -lfreetype -lz":
%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,/usr/lib64||g;' \
Makefile */Makefile */*/Makefile imlib2-config
%endif %endif
# Note: --disable-static doesn't work as of 1.2.1.
%configure --disable-dependency-tracking \
--x-libraries=%{_prefix}/X11R6/%{_lib} \
--with-pic \
$asmopts
make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool make %{?_smp_mflags} LIBTOOL=/usr/bin/libtool
%install %install
rm -rf $RPM_BUILD_ROOT __doc rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
cp -a doc __doc
rm -f __doc/Makefile*
# remove unexpanded variable in pkgconfig file
sed -i -e 's!@requirements@!!g' ${RPM_BUILD_ROOT}%{_libdir}/pkgconfig/imlib2.pc
rm -f \ rm -f \
$RPM_BUILD_ROOT%{_libdir}/imlib2/{loaders,filters}/*.a \ $RPM_BUILD_ROOT%{_libdir}/imlib2/{loaders,filters}/*.a \
$RPM_BUILD_ROOT%{_bindir}/{color_spaces,imlib2,*test} $RPM_BUILD_ROOT%{_bindir}/imlib2_test
# ship .la files due to a bug in kdelibs (see changelog): # ship .la files due to a bug in kdelibs (bugzilla.fedora.us #2284):
# $RPM_BUILD_ROOT%{_libdir}/libImlib2.la \ # $RPM_BUILD_ROOT%{_libdir}/libImlib2.la \
@ -95,7 +82,7 @@ rm -rf $RPM_BUILD_ROOT
%files %files
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc COPYING AUTHORS README ChangeLog TODO __doc/* %doc COPYING AUTHORS README ChangeLog TODO
%{_bindir}/imlib2_view %{_bindir}/imlib2_view
%{_bindir}/imlib2_bumpmap %{_bindir}/imlib2_bumpmap
%{_bindir}/imlib2_colorspace %{_bindir}/imlib2_colorspace
@ -115,6 +102,7 @@ rm -rf $RPM_BUILD_ROOT
%files devel %files devel
%defattr(-,root,root,-) %defattr(-,root,root,-)
%doc doc/*.gif doc/*.html
%{_bindir}/imlib2-config %{_bindir}/imlib2-config
%{_includedir}/Imlib2.h %{_includedir}/Imlib2.h
%{_libdir}/libImlib2.a %{_libdir}/libImlib2.a
@ -124,6 +112,13 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Sun Aug 28 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.2.1-2
- 1.2.1, patches applied/obsoleted upstream.
- Improve summary and description, fix URL.
- Move HTML docs to -devel.
- Build with dependency tracking disabled.
- Drop x86_64 freetype rpath hack, require a fixed freetype-devel.
* Mon May 9 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-8.fc4 * Mon May 9 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 1.2.0-8.fc4
- Fix segfault in XPM loader (#156058). - Fix segfault in XPM loader (#156058).

View File

@ -1 +1 @@
853fb77100ee3c3ca944f52c892ab49b imlib2-1.2.0.tar.gz e32970d03d8aee2885782312d0a7f15f imlib2-1.2.1.tar.gz