Update to 3.1.3.

This commit is contained in:
Richard Shaw 2021-11-02 07:40:41 -05:00
parent cc0f9fd416
commit fc4b7d74ec
2 changed files with 21 additions and 3 deletions

View File

@ -2,8 +2,25 @@ Index: Imath-3.1.3/docs/CMakeLists.txt
===================================================================
--- Imath-3.1.3.orig/docs/CMakeLists.txt
+++ Imath-3.1.3/docs/CMakeLists.txt
@@ -42,6 +42,8 @@ add_custom_command(OUTPUT ${SPHINX_INDEX
add_custom_target(Sphinx ALL DEPENDS ${SPHINX_INDEX_FILE})
@@ -23,11 +23,10 @@ file(MAKE_DIRECTORY ${DOXYGEN_OUTPUT_DIR
add_custom_command(OUTPUT ${DOXYGEN_INDEX_FILE}
COMMAND ${DOXYGEN_EXECUTABLE} ${DOXYFILE_OUT}
MAIN_DEPENDENCY ${DOXYFILE_OUT} ${DOXYFILE_IN}
+ DEPENDS ${DOXYGEN_OUTPUT_DIR}
COMMENT "Running doxygen"
VERBATIM)
-add_custom_target(Doxygen ALL DEPENDS ${DOXYGEN_INDEX_FILE})
-
add_custom_command(OUTPUT ${SPHINX_INDEX_FILE}
COMMAND
${SPHINX_EXECUTABLE} -b html
@@ -39,9 +38,11 @@ add_custom_command(OUTPUT ${SPHINX_INDEX
MAIN_DEPENDENCY conf.py
COMMENT "Generating documentation with Sphinx")
-add_custom_target(Sphinx ALL DEPENDS ${SPHINX_INDEX_FILE})
+add_custom_target(docs ALL DEPENDS ${SPHINX_INDEX_FILE} ${DOXYGEN_INDEX_FILE})
# Add an install target to install the docs
-include(GNUInstallDirs)

View File

@ -61,7 +61,8 @@ Requires: python3-devel
%cmake -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-DPYTHON=ON \
-DDOCS=ON \
-DINSTALL_DOCS=OFF
-DINSTALL_DOCS=OFF \
--trace-source=docs/CMakeLists.txt
%cmake_build