Fix build for cmake 3.14 #1690947

This commit is contained in:
Bruno Postle 2019-03-23 10:20:17 +00:00
parent f52d84b0bb
commit ae043e63c3
2 changed files with 26 additions and 1 deletions

View File

@ -1,9 +1,10 @@
Summary: A panoramic photo stitcher and more
Name: hugin
Version: 2018.0.0
Release: 9%{?dist}
Release: 10%{?dist}
License: GPLv2+
Source: http://downloads.sourceforge.net/hugin/%{name}-%{version}.tar.bz2
Patch0: wx_use_libs.patch
URL: http://hugin.sourceforge.net/
Requires: shared-mime-info
Requires: webclient
@ -42,6 +43,9 @@ src/hugin_script_interface/plugins/*.py
sed -i 's^exiv2/easyaccess.hpp^exiv2/exiv2.hpp^' \
src/hugin_base/panodata/Exiv2Helper.cpp
# Bugzilla #1690947
%patch0 -p1
%build
# hugin now forces build out of tree
[ ! -d "build" ] && mkdir build
@ -200,6 +204,9 @@ EOF
%{_mandir}/man1/hugin_lensdb.*
%changelog
* Sat Mar 23 2019 Bruno Postle <bruno@postle.net> - 2019.0.0-10
- upstream fix for cmake 3.14 changes
* Thu Jan 31 2019 Kalev Lember <klember@redhat.com> - 2018.0.0-9
- Rebuilt for Boost 1.69

18
wx_use_libs.patch Normal file
View File

@ -0,0 +1,18 @@
diff -r 05a55c15585c -r 2a4ddd1a0fed CMakeLists.txt
--- a/CMakeLists.txt Sat Mar 23 10:11:35 2019 +0100
+++ b/CMakeLists.txt Sat Mar 23 08:20:27 2019 +0100
@@ -159,12 +159,11 @@
# This must come before FINDs for tiff, jpeg, png, zlib to enable
# finding the wxWidgets distributions of those packages (Win32 only).
IF(WIN32)
- SET(wxWidgets_USE_LIBS base core aui xrc html xml adv gl qa)
+ FIND_PACKAGE(wxWidgets REQUIRED base core aui xrc html xml adv gl qa)
ELSE()
# Unix needs also wxWidgets net library
- SET(wxWidgets_USE_LIBS base core aui xrc html xml adv gl net qa)
+ FIND_PACKAGE(wxWidgets REQUIRED base core aui xrc html xml adv gl net qa)
ENDIF()
-FIND_PACKAGE(wxWidgets REQUIRED)
# hugin requires wxwidgets 3.0 or above
IF (UNIX)